All Questions

Tagged with
Filter by
Sorted by
Tagged with
0
votes
0answers
28 views

SXA Map throwing 400 Bad Request

Working with Sitecore 9 (Update 1), SXA 1.7.1 and Azure Search. Components added on the page: Map, Location Finder, Search Results (all components have the same search signature). Search Query: ...
0
votes
1answer
35 views

Need to access search keyword in a custom rendering controller in SXA

We are using SXA 1.8 with Sitecore 9. And, we have the requirement to access the search keyword passed in the search-box in one of the custom-renderings. But unfortunately, SXA is appending the search ...
0
votes
1answer
96 views

Is it possible to make custom computed index field searchable in SXA 1.8

I'm using Sitecore 9.0 with SXA 1.8. I've got a requirement to search PDF names and it's fields including custom fields (e.g. download title field). When I see the Solr index / Azure index, PDF names ...
1
vote
1answer
132 views

Search with dropdown filter based on parent item display name

I am using SXA's search results and dropdown filter to be able to filter items on the search scope by their parent item display name. I have it sort of working by first creating a Computed Index ...
1
vote
1answer
75 views

How to write a custom controller for Sitecore SXA Search Box component?

We are using Sitecore 9.0.2, SXA 1.8.1 and Azure search. The SXA component Search Box works perfectly fine. In our application, we need to show the search results from other application along with ...
0
votes
0answers
96 views

ERROR Year, Month, and Day parameters describe an un-representable DateTime

We are receiving below errors during Indexing. We are on Sitecore 9 update-2, SXA 1.7.1 and using Azure search. The errors below seems related to SXA fields. Has anyone come across this issue? 10752 ...
0
votes
0answers
26 views

How to index sxa tags in azure search and show them in rendering variant of search results [duplicate]

We are using SXA 1.8.1 , Sitecore 9.0.2 and azure search we want to show tags for each item in search results. I created tags under "Tag repository"(under system -> settings) item, the created ...
1
vote
0answers
51 views

SXA checklist filter doesnt return facets with count 0 when used with azure search

I am currently using Sitecore version 9.0.2 and SXA version 1.8.1 Requirement : - In checklist filter, I want to show all the facets irrespective of the results. If for a facet the result is not ...
5
votes
1answer
153 views

Using Geospatial Features Implemented in SXA with a Custom Search Index - Run-time Error

After manually implementing support for the Edm.GeographyPoint field type (per Is it possible to get Azure Search to support EDM.GeographyPoint?), I was happy to notice an answer on a related question ...
2
votes
1answer
161 views

Sitecore SXA Azure Search Facets Returning 400 Bad Request when there are more than 50 results

I have a search page that is working correctly on my local instance using SOLR, but when we move the page to our AZURE Instance it fails. The AZURE Instance is using AZURE Search instead SOLR. If I ...
2
votes
1answer
78 views

Not finding SXA Rich text rendering content in search results

In our SXA site we make use of the OOTB rich text renderings. I was hoping the content of these would be available in the search results - pointing to the containing page as the result. I notice ...
1
vote
3answers
98 views

Sitecore sxa checklist facets in search are not loading when using azure search

I am using SXA 1.8 with Sitecore 9.0.2. I wanted to add a checklist facet to my search, as I am using Azure Search, I added the field to be indexed like below in a custom config file. <include ...
1
vote
1answer
246 views

Sitecore 9.0.2 SXA 1.8 PaaS Azure Search Configuration

This is the first time we working on Azure Search and Sitecore SXA we are facing a problem related to Exception: Sitecore.ContentSearch.Azure.Http.Exceptions.AzureSearchServiceRESTCallException ...
0
votes
1answer
168 views

Azure search with SXA

Environment: SXA 1.8 in Azure PAAS + Azure search What I have: My client has multiple offices and each office has its individual page managed with SXA. The fields on this page include address and ...
4
votes
1answer
101 views

Azure Search duplicate results for multilingual countries in same site with different language versions

We have a multi-lingual site where the group of countries (say for example Asia Region) is hosted in one Site folder. Thus Home, Pages, Settings have different language versions (zh-HK, en-HK, en-AU)...
0
votes
0answers
97 views

SXA Custom index not used by Search Results component

Following the SXA documentation Configure SXA indexing, I have created my custom indexes : Then I have created a patch config file for the corresponding index definitions. On a page I use a ...
0
votes
1answer
191 views

Where to check the index that is configured from SXA Search API?

When I request the url https://mydomain/sxa/search/results?q=test, below is the response {"TotalTime":259,"CountTime":211,"QueryTime":38,"Signature":null,"Index":"sitecore_sxa_web_index","Count":0,"...
2
votes
1answer
82 views

Do we need to trigger SXA indexes after cloning a new site?

This is the first time working on SXA Search. We have an SXA site with search in working condition. We cloned a new site from the existing one and using master database for now but the search page is ...
3
votes
0answers
82 views

SXA 1.8 Sitecore 9.1 Azure Search field limit reached on default install [duplicate]

In an Azure PaaS XP Single installation of Sitecore 9.1 using Azure Search, I have installed SXA 1.8. This has pushed the Sitecore Master index field count to just over the 1000 field limit in Azure ...
3
votes
1answer
202 views

My index on Content Delivery does not match with CM and is not updating anymore on Azure PAAS - Sitecore 9.0.2

We noticed that our CD environment gave different results from the index compared to the CM environment. We did some more checks and found that the index on CD was also not updating anymore. It did ...
1
vote
1answer
56 views

SXA scope not working with one specific field in PAAS

I have a SXA search scope which is working, but as soon as I try to extend it with our "Company" field, it fails to find any results. Company is a multilist field. Our steps: Create a search scope ...
0
votes
1answer
138 views

Fetching the data from Sitecore Azure having multiple indexes

We are using Sitecore Commerce 9.0.1 update 1. We are creating multiple indexes to avoid Azure field limit ( 1000).My question is , how the Azure search to get the results from multiple indexes? We ...
1
vote
1answer
137 views

Index queries not working with DateTime and ID on SXA and PAAS

I had some custom code performing queries on a Sitecore index that worked perfectly on my local environment with Solr. But when deploying the code to Azure PAAS with Azure search they don't work. The ...