Questions tagged [azure-search]

Anything related to Azure Search: querying, configuring, maintaining, ... Azure (PaaS) replacement for Solr and Lucene.

Filter by
Sorted by
Tagged with
0
votes
0answers
15 views

Overriding the Aggregated.cs file in Sitecore.XA.Foundation.Search.ComputedFields.AggregatedContent

I have arranged all my content based on country which a folder template and has a field for country name. All my content specific to that country are placed under it. For SXA search I want the English ...
1
vote
1answer
707 views

Could not create instance of type: Sitecore.ContentSearch.Azure.CloudSearchProviderIndex. No matching constructor was found

Currently in progress of upgrading from Sitecore 8.1 to 8.2 update 7. So I'm currently converting existing indexes from luecene to Azure search, I have done all the basic steps like, disabling all the ...
1
vote
1answer
143 views

Custom Sitecore index not updated on publish after item delete

We are using Sitecore 8.2 with Azure search. When I delete an item and publish the parent folder, the item goes away from sitecore_web_index, however, it doesnt go away from the custom_web_index. (I ...
0
votes
0answers
45 views

Browser is unable to load pdf documents from Azure CDN

we are getting an error when the browser is trying to download pdf documents. we are getting an error i.e. Failed to load the document. This error we are getting for pdf files that are greater than ...
1
vote
1answer
699 views

Custom index field not showing in Azure search

I am trying to use KamSars approach to indexing subcontent (pagecomponents) in my Sitecore 9.2.0 solution. It works fine in my Solr index locally, but when I try to add the two new computed index ...
1
vote
3answers
545 views

Azure Search not working for other language

Using Sitecore 8.2 update 3. I'm new to search & Azure Search and followed this approach to implement the site search functionality on our multi-lingual site. https://kamsar.net/index.php/2014/...
1
vote
1answer
490 views

Could not compute value for ComputedIndexField - Service Host URI is not a Valid URI

We have a sitecore 9.1.1 CM instance configured to use Azure Cloud. We have the relevant configurations enabled & disabled for each instance. However we are seeing the following: 16784 22:55:11 ...
1
vote
1answer
78 views

How to create a custom facet for a Time range for an SXA search filter

I have a search result component showing all the events. The requirement is to add a CheckList filter to filter the events that have their event date before 9AM and after 9AM. How can I create a ...
8
votes
0answers
177 views

Virtual field not working with Azure

Currently, I'm using facet to filter the search result. The result works perfectly fine with SOLR but when I switch to Azure it doesn't work anymore. The result shows all although I added filter ...
1
vote
1answer
429 views

How to write a custom controller for Sitecore SXA Search Box component?

We are using Sitecore 9.0.2, SXA 1.8.1 and Azure search. The SXA component Search Box works perfectly fine. In our application, we need to show the search results from other application along with ...
6
votes
2answers
732 views

Migrating Solr Core indexes to Azure Search indexes

I am midst of migrating a Sitecore project to Azure Paas offering. I've completed the deployment of the files (ie. dlls, configs, css, js, etc) and were able to do a complete unicorn sync. That looks ...
2
votes
1answer
146 views

Getting extra results in content search result with Azure Search

Using Azure search in Sitecore 9.1.1. We are getting extra results in Azure search only, with Solr results are showing correctly. Scenario: Fetching result from the below structure : When we try to ...
0
votes
2answers
66 views

Where to get Azure search query logs to check a query?

We are using Azure search to get the Sitecore items based on some filter conditions passed as predicate. This condition is not working with Azure Search in our dev environment. We have to check the ...
1
vote
1answer
43 views

How to index Catalog Generated Template Field's in Azure search

In Azure Search Index configuration, there is an option to include Fields that need to be indexed. But the catalog generated Templates Field may be having different id's in different environments (Dev,...
0
votes
0answers
19 views

Ensure Azure Content Search Provider uses a filter for a query

We have a number of searches on our site that should be possible through a pure filtered search - we're searching across a few fields, some of which are mutli-selects, others are booleans and one's a ...
0
votes
1answer
45 views

New field for Azure index

I have Sitecore 9.3 with Azure PAAS and are using Azure search. I added one 'shared' field to the media templates of the checkbox type with name IsOptimized. I added the following entry to the config. ...
0
votes
3answers
558 views

Sitecore 9.1.1 Azure Search custom index not updating when running rebuild

I'm trying to port an application to Azure Search from Solr. I've got the sitecore indexes working and rebuilding. The documents are being added to the azure search index. However for any custom ...
0
votes
1answer
55 views

GroupBy clause for both search providers (Solr, Azure)

Would like to use groupby clause in Sitecore 9.1.1 for both search provide (Azure, Solr) in content search API. However, Sitecore does not support this clause. Kindly let us know how we can group ...
0
votes
0answers
25 views

Boosting rule on checkbox field not working in Azure

I have a checkbox field (IsImportant). I have added the boosting rule to my search scope "Where the IsImportant field is equal to true adjust boost by 100". It is giving no result in azure ...
0
votes
0answers
171 views

How to build Sitecore SXA Scope Search query with comoperations

I have requirement to show the query results based on the logged-in user-profile details, I was able to pass the query token field value dynamical by following the code. How to write a SXA search ...
1
vote
0answers
62 views

Exact search in Azure search in Sitecore SXA

Using azure search in Sitecore SXA 1.7 and it is not fetching exact result likewise if we are using "Test data" in search box then it is showing result based which match "Test data ...
0
votes
1answer
65 views

Sitecore doesn't add the indexed field with Traditional Chinese & Simplified Chinese postfix on the Azure custom index

I am doing a POC in Sitecore.Net 9.2 vanilla setup for enabling the Traditional Chinese and Simplified Chinese in the CMS and looking for how can I perform the Azure search for the content in zh-HK ...
3
votes
0answers
69 views

Not able to fetch search result in Content search API with Solr and Azure

I am using content search API in Sitecore 9.1.1. However, it is not fetching result if i am using search with any of the template field. The below code fetching result based on template id but when we ...
3
votes
3answers
317 views

How to rename Azure Search index

I tried to index master, web indexes using the Azure Search service. Indexing works fine, but we have a requirement to have the index names unique in Azure as we are using single search services for ...
2
votes
1answer
55 views

Automated index document merge complains about invalid index name but index names are valid

I get thousands of the following error in the minions log: 00007 09:21:07 ERROR AzureContextCommand.MergeOrUploadDocuments.Error: Message=Index name must only contain lowercase letters, digits or ...
2
votes
1answer
78 views

Custom index was not found error in in Azure Paas Content Delivery

My custom index "custom_index" was not found error is coming in Sitecore 8.2 on the Azure Paas CD environment. But the same custom_index is accessible in the CM environment. I'm using the Azure ...
2
votes
1answer
384 views

Index has not been initialized error on Sitecore 8.2 with Azure Search

I have Sitecore 8.2 update 5 in Azure PaaS using Azure Search. When I am trying to open the content editor, it is throwing exception Index has not been initialized with stack trace info mentioning ...
0
votes
0answers
52 views

How can I solve Server Error in '/' Application Index has not been initialized? [duplicate]

If I access my home page, show error like this : Server Error in '/' Application. Index has not been initialized. Description: An unhandled exception occurred. Exception Details: System....
3
votes
1answer
1k views

ContentSearch predicates for filtering on a multilist field

I'm trying to figure out why certain code is needed in order for a content search query to work with Azure search. I have a multilist field which is indexed by the default indexer in Sitecore, meaning ...
1
vote
0answers
122 views

Azure search Synonyms implementation using SXA 1.9 and Sitecore 9.2 using postman API

I have requirement to work with the synonyms for the similar group of words in search. I did load the synonyms using Postman API to SXA web index and able to see them on the index. For example: home,...
1
vote
3answers
444 views

Techniques and Rules to Eliminating Template fields from Indexing

I am investigating my site's indexing and looking at working around the Azure Search index 1000 field limit (see here Rebuilding Sitecore Core Index on Azure search throwing exceeding index limitation ...
0
votes
2answers
240 views

Enabling full text search on a single line text field

Locally I successfully enabled full text search on a field in the sitecore_web_index by implementing the following logic in my Sitecore solution: 1) Added this xml to a patch configuration file: &...
1
vote
0answers
164 views

Sitecore Azure search suggesting index rebuild error

I have implemented Sitecore Suggesting search on Sitecore 9.2. based on https://sitecore.namics.com/2018/06/15/sitecore-9-azure-search-suggestions/ but when I rebuild indexes, I am getting error: ...
3
votes
2answers
3k views

Index has not been initialized on content delivery server

I'm using Sitecore on Azure, and I followed the wizard to create a project with a CD and a CM. I have a custom index SinglePageUrl on both of them with a web and a master version to Rewrite some ...
4
votes
1answer
393 views

How to get the page of a rendering used in a page in search

I have to implement Azure search but would like to try with Lucene first in the local setup. I am following this example by @kamsar 1.Created the SubcontentField class 2.Created the patch config and ...
1
vote
0answers
191 views

How can create new score profiling into Sitecore?

I am indexing Sitecore items into Azure and performing the Azure search via Azure functions. I want to create a new Scoring Profile into Sitecore and use it during the search. I am not getting much ...
2
votes
0answers
41 views

Safe to delete Sitecore master/web old index after rebuild/swap?

We're using the Swap and Rebuild feature of Sitecore 9.1 when we need to rebuild our indexes for Azure Search. Occasionally, after the rebuild and swap is complete; Sitecore won't delete the old ...
3
votes
1answer
179 views

How to replace `CertificateHttpClientHandlerModifier` to `X509Certificate2`

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on azure app service connects to XConnect which is also on Azure, am following this link ...
5
votes
1answer
388 views

Using Geospatial Features Implemented in SXA with a Custom Search Index - Run-time Error

After manually implementing support for the Edm.GeographyPoint field type (per Is it possible to get Azure Search to support EDM.GeographyPoint?), I was happy to notice an answer on a related question ...
3
votes
1answer
150 views

Connecting two Azure services to access XConnect

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on app service azure connects to XConnect which is also on Azure, am following this link ...
1
vote
0answers
110 views

Custom Azure Index doesn't update on CD Servers after rebuild

We have a custom Azure Index which we have enabled switch on rebuild for. The works fine on the CM servers but. However on CD we get no data showing until we restart the Azure App Service for the CD....
4
votes
0answers
80 views

Azure Deployment Slot Processing Events and Updating Indexes

We have a deployment slot that we deploy to, which we then warm up, and then swap with the live slot so that we can achieve zero downtime deployment on PaaS. This works very well in general. However, ...
1
vote
1answer
274 views

IS there a simple way to get the current Azure Search index name programatically?

I need to get the current active index name for Sitecore search for logging purposes. Because of the swap on rebuild functionality, I can't simply use the name field of the index, since on alternating ...
10
votes
2answers
2k views

Sitecore Azure Search vs. Solr Provider

I've used both Solr and Lucene. The majority of our sites now use SOLR. Heard Azure Search provider will be introduced on 8.2.1 release. Has anyone played with Azure Search? Does Azure Search use ...
1
vote
1answer
133 views

Azure search random behavior running for Sitecore 9.0.2

I am having issue with the Azure Search where I am not getting results from the search index (it is random issue). I’ve verified the configurations of Azure search and computed index fields. Below is ...
2
votes
2answers
949 views

Sitecore Azure Rebuild index error : sending too many requests

I am using Sitecore 8.2 update 3 with Azure search service(Basic) in our application. While rebuilding the index,we get below error. 7980 08:34:38 INFO Schema synchronization failed Exception: ...
0
votes
0answers
58 views

SXA Map throwing 400 Bad Request

Working with Sitecore 9 (Update 1), SXA 1.7.1 and Azure Search. Components added on the page: Map, Location Finder, Search Results (all components have the same search signature). Search Query: ...
0
votes
1answer
61 views

Need to access search keyword in a custom rendering controller in SXA

We are using SXA 1.8 with Sitecore 9. And, we have the requirement to access the search keyword passed in the search-box in one of the custom-renderings. But unfortunately, SXA is appending the search ...
0
votes
1answer
81 views

Azure Search queries including too many results due to extra wildcard in fullpath_1 query with space

We are using Azure Search to find items by path. We apply the following search code: var filterPredicate = PredicateBuilder.True<SearchResultItem>(); filterPredicate.And(x => x.Path....
0
votes
2answers
241 views

Rebuilding sitecore_master_index: The property 'property_id_s_t_de' does not exist on type 'search.documentFields'

When we rebuild our sitecore_master_index index, we usually get an error during the rebuild process and the logs show several instances of the below stack trace:  692 12:50:11 ERROR [Index=...