Questions tagged [azure-search]

Anything related to Azure Search: querying, configuring, maintaining, ... Azure (PaaS) replacement for Solr and Lucene.

Filter by
Sorted by
Tagged with
1
vote
1answer
42 views

Could not compute value for ComputedIndexField - Service Host URI is not a Valid URI

We have a sitecore 9.1.1 CM instance configured to use Azure Cloud. We have the relevant configurations enabled & disabled. However we are seeing the following:- 16784 22:55:11 WARN Could not ...
0
votes
0answers
11 views

How to index Catalog Generated Template Field's in Azure search

In Azure Search Index configuration, there is an option to include Fields that need to be indexed. But the catalog generated Templates Field may be having different id's in different environments (Dev,...
0
votes
1answer
41 views

Custom Sitecore index not updated on publish after item delete

We are using Sitecore 8.2 with Azure search. When I delete an item and publish the parent folder, the item goes away from sitecore_web_index, however, it doesnt go away from the custom_web_index. (I ...
1
vote
1answer
31 views

Automated index document merge complains about invalid index name but index names are valid

I get thousands of the following error in the minions log: 00007 09:21:07 ERROR AzureContextCommand.MergeOrUploadDocuments.Error: Message=Index name must only contain lowercase letters, digits or ...
1
vote
1answer
36 views

Custom index was not found error in in Azure Paas Content Delivery

My custom index "custom_index" was not found error is coming in Sitecore 8.2 on the Azure Paas CD environment. But the same custom_index is accessible in the CM environment. I'm using the Azure ...
0
votes
0answers
33 views

Initialization is failed for index sitecore-analytics-index

I'm currently working on Sitecore 8.2 update 7. with azure search. I got the complete db/code back up from QA environment (perfectly working environment) and restored in local. The only change I made ...
0
votes
0answers
38 views

How can I solve Server Error in '/' Application Index has not been initialized? [duplicate]

If I access my home page, show error like this : Server Error in '/' Application. Index has not been initialized. Description: An unhandled exception occurred. Exception Details: System....
1
vote
1answer
153 views

Index has not been initialized error on Sitecore 8.2 with Azure Search

I have Sitecore 8.2 update 5 in Azure PaaS using Azure Search. When I am trying to open the content editor, it is throwing exception Index has not been initialized with stack trace info mentioning ...
0
votes
1answer
117 views

Index has not been initialized on content management server

We are getting an issue "index has not been initialized" if clicks any of the Sitecore content tree items in the content editor, Does anyone know how to solve this. Thanks, Suresh
0
votes
0answers
21 views

Azure search, using SwitchOnRebuild, master index is not showing in indexes

We are using Sitecore 9.3 with SwitchOnRebuild Option enabled by default, within Sitecore Azure Search Service, under indexes am not able to see sitecore-master-index, instead it creates sitecore-...
0
votes
0answers
32 views

Sitecore Forms Disappearing Repeatedly [duplicate]

The forms in Sitecore Forms application are Disappearing Repeatedly, when i re-index the master they appear, but after re-index is completed they again disappear. We enabled SwitchOnRebuild, We are ...
1
vote
0answers
62 views

Azure search Synonyms implementation using SXA 1.9 and Sitecore 9.2 using postman API

I have requirement to work with the synonyms for the similar group of words in search. I did load the synonyms using Postman API to SXA web index and able to see them on the index. For example: home,...
0
votes
0answers
26 views

Overlay with Search box and Location finder does work in preview mode but not in normal mode + SXA 1.9 + Sitecore 9.2

I have overlay with search box which will need show predictions and on click redirect to search page where all the results displayed. The overlay search box is showing predictions and can see the ...
2
votes
3answers
140 views

How to rename Azure Search index

I tried to index master, web indexes using the Azure Search service. Indexing works fine, but we have a requirement to have the index names unique in Azure as we are using single search services for ...
1
vote
0answers
71 views

Sitecore Azure search suggesting index rebuild error

I have implemented Sitecore Suggesting search on Sitecore 9.2. based on https://sitecore.namics.com/2018/06/15/sitecore-9-azure-search-suggestions/ but when I rebuild indexes, I am getting error: ...
2
votes
0answers
38 views

Safe to delete Sitecore master/web old index after rebuild/swap?

We're using the Swap and Rebuild feature of Sitecore 9.1 when we need to rebuild our indexes for Azure Search. Occasionally, after the rebuild and swap is complete; Sitecore won't delete the old ...
1
vote
0answers
113 views

How can create new score profiling into Sitecore?

I am indexing Sitecore items into Azure and performing the Azure search via Azure functions. I want to create a new Scoring Profile into Sitecore and use it during the search. I am not getting much ...
3
votes
1answer
111 views

How to replace `CertificateHttpClientHandlerModifier` to `X509Certificate2`

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on azure app service connects to XConnect which is also on Azure, am following this link ...
3
votes
1answer
102 views

Connecting two Azure services to access XConnect

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on app service azure connects to XConnect which is also on Azure, am following this link ...
0
votes
0answers
38 views

Index values loss after smart publish, returns after an Index Rebuild or Republish

In the image below you can see how the search index for a sitecore item looks like before and after a Smart Publish. On the left is what I get when I recently did a Rebuild or a Republish and on the ...
0
votes
0answers
25 views

Issue - A tag scoring function must have tag parameters specified

I am trying to add new custom score profile into Sitecore for Azure Search as given below Added in the Sitecore.ContentSearch.Azure.DefaultIndexConfiguration.config file. <scoringProfile ...
0
votes
2answers
120 views

Enabling full text search on a single line text field

Locally I successfully enabled full text search on a field in the sitecore_web_index by implementing the following logic in my Sitecore solution: 1) Added this xml to a patch configuration file: &...
1
vote
0answers
67 views

Custom Azure Index doesn't update on CD Servers after rebuild

We have a custom Azure Index which we have enabled switch on rebuild for. The works fine on the CM servers but. However on CD we get no data showing until we restart the Azure App Service for the CD....
4
votes
0answers
49 views

Azure Deployment Slot Processing Events and Updating Indexes

We have a deployment slot that we deploy to, which we then warm up, and then swap with the live slot so that we can achieve zero downtime deployment on PaaS. This works very well in general. However, ...
1
vote
1answer
334 views

Could not create instance of type: Sitecore.ContentSearch.Azure.CloudSearchProviderIndex. No matching constructor was found

Currently in progress of upgrading from Sitecore 8.1 to 8.2 update 7. So I'm currently converting existing indexes from luecene to Azure search, I have done all the basic steps like, disabling all the ...
1
vote
1answer
139 views

IS there a simple way to get the current Azure Search index name programatically?

I need to get the current active index name for Sitecore search for logging purposes. Because of the swap on rebuild functionality, I can't simply use the name field of the index, since on alternating ...
0
votes
3answers
287 views

Sitecore 9.1.1 Azure Search custom index not updating when running rebuild

I'm trying to port an application to Azure Search from Solr. I've got the sitecore indexes working and rebuilding. The documents are being added to the azure search index. However for any custom ...
0
votes
1answer
372 views

Custom index field not showing in Azure search

I am trying to use KamSars approach to indexing subcontent (pagecomponents) in my Sitecore 9.2.0 solution. It works fine in my Solr index locally, but when I try to add the two new computed index ...
0
votes
0answers
38 views

SXA Map throwing 400 Bad Request

Working with Sitecore 9 (Update 1), SXA 1.7.1 and Azure Search. Components added on the page: Map, Location Finder, Search Results (all components have the same search signature). Search Query: ...
0
votes
1answer
45 views

Need to access search keyword in a custom rendering controller in SXA

We are using SXA 1.8 with Sitecore 9. And, we have the requirement to access the search keyword passed in the search-box in one of the custom-renderings. But unfortunately, SXA is appending the search ...
0
votes
1answer
39 views

Azure Search queries including too many results due to extra wildcard in fullpath_1 query with space

We are using Azure Search to find items by path. We apply the following search code: var filterPredicate = PredicateBuilder.True<SearchResultItem>(); filterPredicate.And(x => x.Path....
0
votes
1answer
288 views

Azure search not adding documents from custom index unless renamed

I am having some odd issues with Azure Search in Sitecore 9.2.0, not indexing any documents from my custom index. Locally, when indexing to SOLR there are no problems at all. Background: We use ...
0
votes
2answers
107 views

Rebuilding sitecore_master_index: The property 'property_id_s_t_de' does not exist on type 'search.documentFields'

When we rebuild our sitecore_master_index index, we usually get an error during the rebuild process and the logs show several instances of the below stack trace:  692 12:50:11 ERROR [Index=...
0
votes
1answer
51 views

Warning message: 'GUID' field of 'GUID' item is skipped: field name is missed

In all of our environments, any time there is an index update to our Azure Search indexes, we see the following WARN message logged repeatedly (many thousands of times): 06:11:06 WARN [Index=...
1
vote
2answers
114 views

Azure searches on one Azure CD server are sent as “&search=This_Is_Equal_ConstNode_Return_Nothing”

On one of three CD servers every search we execute is sent to Azure Search like the following: 19660 02:11:05 INFO AzureSearch Query [sitecore_web_index]: &search=...
0
votes
1answer
257 views

Is it possible to make custom computed index field searchable in SXA 1.8

I'm using Sitecore 9.0 with SXA 1.8. I've got a requirement to search PDF names and it's fields including custom fields (e.g. download title field). When I see the Solr index / Azure index, PDF names ...
1
vote
1answer
305 views

Search with dropdown filter based on parent item display name

I am using SXA's search results and dropdown filter to be able to filter items on the search scope by their parent item display name. I have it sort of working by first creating a Computed Index ...
1
vote
1answer
201 views

How to write a custom controller for Sitecore SXA Search Box component?

We are using Sitecore 9.0.2, SXA 1.8.1 and Azure search. The SXA component Search Box works perfectly fine. In our application, we need to show the search results from other application along with ...
0
votes
1answer
98 views

Index names get a number appended

I switched from Solr to Azure search and followed all the steps listed in the blog. I Also renamed the Solr core to lower case with dashes. When I run the xConnectSearchIndexer -rr service the ...
0
votes
0answers
451 views

ERROR Year, Month, and Day parameters describe an un-representable DateTime

We are receiving below errors during Indexing. We are on Sitecore 9 update-2, SXA 1.7.1 and using Azure search. The errors below seems related to SXA fields. Has anyone come across this issue? 10752 ...
1
vote
0answers
52 views

How can the Sitecore search API be extended to support Azure search traffic analytics?

I'm experimenting with adding support for conditionally returning SearchId for Azure search traffic analytics purposes (https://docs.microsoft.com/en-us/azure/search/search-traffic-analytics) as part ...
0
votes
0answers
36 views

How to index sxa tags in azure search and show them in rendering variant of search results [duplicate]

We are using SXA 1.8.1 , Sitecore 9.0.2 and azure search we want to show tags for each item in search results. I created tags under "Tag repository"(under system -> settings) item, the created ...
0
votes
1answer
601 views

Creating a new index in Azure Search for Sitecore 9 Helix structured

Background: I am completely new to Azure Search in general. New to SOLR, Lucene the whole thing. I have a good bit of experience in SQL design for indexes and such, but this seems completely different....
1
vote
1answer
90 views

Date field not showing in Azure Search results

I have a regular date field defined like this: <field type="System.DateTime" fieldName="entry_date" cloudFieldName="entry_date" searchable="NO" retrievable="YES" facetable="YES" filterable="YES" ...
0
votes
1answer
164 views

Resolve PostFailedForSomeDocumentsException exception during indexing

During (manually triggered) indexing of the master database, I get the following exception (stack trace below). Using Sitecore 8.2u7 with SXA 1.7. 27608 10:43:03 ERROR [Index=sitecore_master_index] ...
1
vote
0answers
74 views

SXA checklist filter doesnt return facets with count 0 when used with azure search

I am currently using Sitecore version 9.0.2 and SXA version 1.8.1 Requirement : - In checklist filter, I want to show all the facets irrespective of the results. If for a facet the result is not ...
2
votes
1answer
140 views

Excluding template fields from indexing - difference between documentOptions exclusion vs regular exclusion

I reducing the number of fields which get indexed in my site. I looked at App_Config\Include\Sitecore.ContentSearch.Azure.DefaultIndexConfiguration.config and see the section <configuration <...
5
votes
1answer
251 views

Using Geospatial Features Implemented in SXA with a Custom Search Index - Run-time Error

After manually implementing support for the Edm.GeographyPoint field type (per Is it possible to get Azure Search to support EDM.GeographyPoint?), I was happy to notice an answer on a related question ...
1
vote
3answers
218 views

Techniques and Rules to Eliminating Template fields from Indexing

I am investigating my site's indexing and looking at working around the Azure Search index 1000 field limit (see here Rebuilding Sitecore Core Index on Azure search throwing exceeding index limitation ...
2
votes
1answer
223 views

Sitecore SXA Azure Search Facets Returning 400 Bad Request when there are more than 50 results

I have a search page that is working correctly on my local instance using SOLR, but when we move the page to our AZURE Instance it fails. The AZURE Instance is using AZURE Search instead SOLR. If I ...