People who code: we want your input. Take the Survey

Questions tagged [azure-search]

Anything related to Azure Search: querying, configuring, maintaining, ... Azure (PaaS) replacement for Solr and Lucene.

36 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
8
votes
0answers
176 views

Virtual field not working with Azure

Currently, I'm using facet to filter the search result. The result works perfectly fine with SOLR but when I switch to Azure it doesn't work anymore. The result shows all although I added filter ...
5
votes
0answers
239 views

Check if boost rule has been applied to an item

I am implementing functionality to push certain items in my content tree down in search results depending on a "discontinued" checkbox field. I have created a rule item under /sitecore/system/Settings/...
5
votes
0answers
517 views

Index errors on start up on Azure environment

When starting our application we are seeing lots of these entries: 2017-06-29T08:38:59 PID[60944] Error 8168 08:38:59 ERROR Custodian.UpdateIndexTimestampTimerTick. Update index last updated ...
4
votes
0answers
76 views

Azure Deployment Slot Processing Events and Updating Indexes

We have a deployment slot that we deploy to, which we then warm up, and then swap with the live slot so that we can achieve zero downtime deployment on PaaS. This works very well in general. However, ...
3
votes
0answers
59 views

Not able to fetch search result in Content search API with Solr and Azure

I am using content search API in Sitecore 9.1.1. However, it is not fetching result if i am using search with any of the template field. The below code fetching result based on template id but when we ...
3
votes
0answers
341 views

Configuring the Analyzers (LowerCaseKeywordAnalyzer, Synonym) for Azure search in Sitecore 8.2.1

I had used Lucene and sometimes SOLR for Older Sitecore versions. Now the latest trend seems to be Azure search with Sitecore 8.2.1. https://doc.sitecore.net/sitecore_experience_platform/...
2
votes
0answers
41 views

Safe to delete Sitecore master/web old index after rebuild/swap?

We're using the Swap and Rebuild feature of Sitecore 9.1 when we need to rebuild our indexes for Azure Search. Occasionally, after the rebuild and swap is complete; Sitecore won't delete the old ...
2
votes
0answers
57 views

Azure Search FilterOn Linq Not Working

I am running Sitecore 9 update 2 on Azure Web App, with Azure Search. I am trying to use the Sitecore Facet Support, that works completely fine with Solr, but having no luck at all with Azure. So my ...
2
votes
0answers
335 views

Sitecore-Core-Index rebuild at Azure Search for Sitecore 9.0.1 PaaS fails

I have deployed Sitecore 9.0.1 XP Scaled in Azure PaaS (default, no customization). It is used self-signed certificate and configured with allowInvalidClientCertificates="true" in azuredeploy....
2
votes
0answers
315 views

A binary operator with incompatible types was detected error in Azure Search with Helix

I'm getting the below error after deploying on Azure. We're using Azure Search with Helix pattern reusing Habitat's Foundation.Indexing style (indexing providers). {"error":{"code":"","message":"...
1
vote
1answer
62 views

How to create a custom facet for a Time range for an SXA search filter

I have a search result component showing all the events. The requirement is to add a CheckList filter to filter the events that have their event date before 9AM and after 9AM. How can I create a ...
1
vote
0answers
60 views

Exact search in Azure search in Sitecore SXA

Using azure search in Sitecore SXA 1.7 and it is not fetching exact result likewise if we are using "Test data" in search box then it is showing result based which match "Test data ...
1
vote
1answer
422 views

Could not compute value for ComputedIndexField - Service Host URI is not a Valid URI

We have a sitecore 9.1.1 CM instance configured to use Azure Cloud. We have the relevant configurations enabled & disabled for each instance. However we are seeing the following: 16784 22:55:11 ...
1
vote
1answer
131 views

Custom Sitecore index not updated on publish after item delete

We are using Sitecore 8.2 with Azure search. When I delete an item and publish the parent folder, the item goes away from sitecore_web_index, however, it doesnt go away from the custom_web_index. (I ...
1
vote
0answers
114 views

Azure search Synonyms implementation using SXA 1.9 and Sitecore 9.2 using postman API

I have requirement to work with the synonyms for the similar group of words in search. I did load the synonyms using Postman API to SXA web index and able to see them on the index. For example: home,...
1
vote
0answers
150 views

Sitecore Azure search suggesting index rebuild error

I have implemented Sitecore Suggesting search on Sitecore 9.2. based on https://sitecore.namics.com/2018/06/15/sitecore-9-azure-search-suggestions/ but when I rebuild indexes, I am getting error: ...
1
vote
0answers
186 views

How can create new score profiling into Sitecore?

I am indexing Sitecore items into Azure and performing the Azure search via Azure functions. I want to create a new Scoring Profile into Sitecore and use it during the search. I am not getting much ...
1
vote
0answers
106 views

Custom Azure Index doesn't update on CD Servers after rebuild

We have a custom Azure Index which we have enabled switch on rebuild for. The works fine on the CM servers but. However on CD we get no data showing until we restart the Azure App Service for the CD....
1
vote
1answer
668 views

Could not create instance of type: Sitecore.ContentSearch.Azure.CloudSearchProviderIndex. No matching constructor was found

Currently in progress of upgrading from Sitecore 8.1 to 8.2 update 7. So I'm currently converting existing indexes from luecene to Azure search, I have done all the basic steps like, disabling all the ...
1
vote
1answer
669 views

Custom index field not showing in Azure search

I am trying to use KamSars approach to indexing subcontent (pagecomponents) in my Sitecore 9.2.0 solution. It works fine in my Solr index locally, but when I try to add the two new computed index ...
1
vote
1answer
403 views

How to write a custom controller for Sitecore SXA Search Box component?

We are using Sitecore 9.0.2, SXA 1.8.1 and Azure search. The SXA component Search Box works perfectly fine. In our application, we need to show the search results from other application along with ...
1
vote
0answers
74 views

How can the Sitecore search API be extended to support Azure search traffic analytics?

I'm experimenting with adding support for conditionally returning SearchId for Azure search traffic analytics purposes (https://docs.microsoft.com/en-us/azure/search/search-traffic-analytics) as part ...
1
vote
0answers
92 views

SXA checklist filter doesnt return facets with count 0 when used with azure search

I am currently using Sitecore version 9.0.2 and SXA version 1.8.1 Requirement : - In checklist filter, I want to show all the facets irrespective of the results. If for a facet the result is not ...
1
vote
0answers
45 views

Response from azure search in portal and on Sitecore UI is different

Environment: Sitecore 9.0.2 XP0 + SXA 1.8.0 + Azure search What I have done: My data is indexed in the index of Azure Search. I have added the search box and search result with custom scope '...
1
vote
0answers
82 views

Search not working for spaces, exclamation mark, slashes

When I search for a sentence like adoption of an animal, I don't get any results. Looking at the generated query, I have &search=content_1:(/.\*adoption of an animal.\*/)&queryType=full&...
1
vote
0answers
66 views

Azure Search doesn't work with query more than five letters

I've implemented simple search by query in my sitecore application. Locally it works perfectly with solr, but when solution is deployed to an Azure environment that is using Azure Search it doesn't ...
1
vote
0answers
255 views

rebuild the xDB index in Azure Search didn't finished

I followed this article to rebuild the xDB index in Azure Search. About 2 hours after the rebuild index process started, i noticed that the rebuild process seemed to stopped (document of xdb-...
1
vote
0answers
94 views

Content Search - How to choose boost values

I'm updating some of our search code to utilise boosting of different fields. We have been given a specification of the boosting values to be applied to different fields. We are covering 15 fields in ...
1
vote
3answers
534 views

Azure Search not working for other language

Using Sitecore 8.2 update 3. I'm new to search & Azure Search and followed this approach to implement the site search functionality on our multi-lingual site. https://kamsar.net/index.php/2014/...
0
votes
0answers
19 views

Ensure Azure Content Search Provider uses a filter for a query

We have a number of searches on our site that should be possible through a pure filtered search - we're searching across a few fields, some of which are mutli-selects, others are booleans and one's a ...
0
votes
0answers
22 views

Boosting rule on checkbox field not working in Azure

I have a checkbox field (IsImportant). I have added the boosting rule to my search scope "Where the IsImportant field is equal to true adjust boost by 100". It is giving no result in azure ...
0
votes
0answers
138 views

How to build Sitecore SXA Scope Search query with comoperations

I have requirement to show the query results based on the logged-in user-profile details, I was able to pass the query token field value dynamical by following the code. How to write a SXA search ...
0
votes
0answers
55 views

SXA Map throwing 400 Bad Request

Working with Sitecore 9 (Update 1), SXA 1.7.1 and Azure Search. Components added on the page: Map, Location Finder, Search Results (all components have the same search signature). Search Query: ...
0
votes
0answers
732 views

ERROR Year, Month, and Day parameters describe an un-representable DateTime

We are receiving below errors during Indexing. We are on Sitecore 9 update-2, SXA 1.7.1 and using Azure search. The errors below seems related to SXA fields. Has anyone come across this issue? 10752 ...
0
votes
0answers
209 views

SXA Custom index not used by Search Results component

Following the SXA documentation Configure SXA indexing, I have created my custom indexes : Then I have created a patch config file for the corresponding index definitions. On a page I use a ...
0
votes
1answer
801 views

Content not added to computed field using Azure Search

There is a custom code which triggers on rebuilding indexes. The method will extract all content from each page rendering's datasources and store in the content field. When I debug, I see that the ...