Questions tagged [azure-search]

Anything related to Azure Search: querying, configuring, maintaining, ... Azure (PaaS) replacement for Solr and Lucene.

Filter by
Sorted by
Tagged with
3
votes
1answer
179 views

How to replace `CertificateHttpClientHandlerModifier` to `X509Certificate2`

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on azure app service connects to XConnect which is also on Azure, am following this link ...
3
votes
1answer
274 views

Resolve PostFailedForSomeDocumentsException exception during indexing

During (manually triggered) indexing of the master database, I get the following exception (stack trace below). Using Sitecore 8.2u7 with SXA 1.7. 27608 10:43:03 ERROR [Index=sitecore_master_index] ...
3
votes
3answers
317 views

How to rename Azure Search index

I tried to index master, web indexes using the Azure Search service. Indexing works fine, but we have a requirement to have the index names unique in Azure as we are using single search services for ...
3
votes
1answer
150 views

Connecting two Azure services to access XConnect

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on app service azure connects to XConnect which is also on Azure, am following this link ...
3
votes
0answers
69 views

Not able to fetch search result in Content search API with Solr and Azure

I am using content search API in Sitecore 9.1.1. However, it is not fetching result if i am using search with any of the template field. The below code fetching result based on template id but when we ...
3
votes
0answers
87 views

SXA 1.8 Sitecore 9.1 Azure Search field limit reached on default install [duplicate]

In an Azure PaaS XP Single installation of Sitecore 9.1 using Azure Search, I have installed SXA 1.8. This has pushed the Sitecore Master index field count to just over the 1000 field limit in Azure ...
3
votes
0answers
343 views

Configuring the Analyzers (LowerCaseKeywordAnalyzer, Synonym) for Azure search in Sitecore 8.2.1

I had used Lucene and sometimes SOLR for Older Sitecore versions. Now the latest trend seems to be Azure search with Sitecore 8.2.1. https://doc.sitecore.net/sitecore_experience_platform/...
2
votes
1answer
478 views

Configure Azure search for Sitecore xConnect

Is there any document for configuring Azure search for xConnect. I could see a link here : https://doc.sitecore.net/developers/server-role-configuration-reference/search/configure-xconnect-search-...
2
votes
1answer
146 views

Getting extra results in content search result with Azure Search

Using Azure search in Sitecore 9.1.1. We are getting extra results in Azure search only, with Solr results are showing correctly. Scenario: Fetching result from the below structure : When we try to ...
2
votes
1answer
384 views

Index has not been initialized error on Sitecore 8.2 with Azure Search

I have Sitecore 8.2 update 5 in Azure PaaS using Azure Search. When I am trying to open the content editor, it is throwing exception Index has not been initialized with stack trace info mentioning ...
2
votes
1answer
783 views

Custom Azure Search Index returns '&search=This_Is_Equal_ConstNode_Return_Nothing' for searches

I have setup an custom Azure Search index in Sitecore 8.2 u7 and was getting no results returned even though I have data in it (I can see the data in the Azure console). Looking in the Sitecore Search ...
2
votes
2answers
81 views

Unable to install JSS Server Package on Azure Web Apps

Installed SC9 update 1 using sitecore market place. I've been trying to setup JSS on Web Apps but not having any luck. When I try to install JSS Server package the installation process keeps spinning ...
2
votes
1answer
130 views

Do we need to trigger SXA indexes after cloning a new site?

This is the first time working on SXA Search. We have an SXA site with search in working condition. We cloned a new site from the existing one and using master database for now but the search page is ...
2
votes
2answers
949 views

Sitecore Azure Rebuild index error : sending too many requests

I am using Sitecore 8.2 update 3 with Azure search service(Basic) in our application. While rebuilding the index,we get below error. 7980 08:34:38 INFO Schema synchronization failed Exception: ...
2
votes
1answer
592 views

Sitecore 9.0 update 1 Azure search is not stable

Using Sitecore 9 update 1. followed Sitecore documentation to implement the site search in Azure PaaS https://doc.sitecore.net/sitecore_experience_platform/setting_up_and_maintaining/...
2
votes
2answers
773 views

How to add a suggester / enable autocomplete in Sitecore configuration for an Azure search index?

Has anyone here implemented autocomplete feature of azure search with Sitecore? I see documentation on how to add a suggester while creating an index in azure, but Sitecore documentation (https://...
2
votes
1answer
730 views

How do I search for a value in a parent item field?

I have several items (news stories) that are contained within a section (like a category) that span multiple issues and publications. The sections are mostly repeated in every issue and many times ...
2
votes
1answer
255 views

Excluding template fields from indexing - difference between documentOptions exclusion vs regular exclusion

I reducing the number of fields which get indexed in my site. I looked at App_Config\Include\Sitecore.ContentSearch.Azure.DefaultIndexConfiguration.config and see the section <configuration <...
2
votes
1answer
176 views

Not finding SXA Rich text rendering content in search results

In our SXA site we make use of the OOTB rich text renderings. I was hoping the content of these would be available in the search results - pointing to the containing page as the result. I notice ...
2
votes
1answer
515 views

Search not working in multi-language site

We are using Azure search. This is a website search. End user enters the keyword and the pages where it is present in the content, are returned as search results. The functionality works fine when ...
2
votes
1answer
695 views

Rebuilding custom Index on Sitecore Azure WebApp doesn't work

I'm new to Azure deployments. We have installed Sitecore 8.2 webapp and deployed and everything works fine except that our custom indices have not been created. Pages that use indices crash. ...
2
votes
1answer
78 views

Custom index was not found error in in Azure Paas Content Delivery

My custom index "custom_index" was not found error is coming in Sitecore 8.2 on the Azure Paas CD environment. But the same custom_index is accessible in the CM environment. I'm using the Azure ...
2
votes
1answer
170 views

Azure Search Indexes are not being added/populated

I am trying to configure azure search in Sitecore. I followed this article to configure it. But when I try to rebuild the indexes, the number of units processed is empty and the indexes are not ...
2
votes
1answer
147 views

Azure Search returns extra results

So I've got certain items indexed. Each item has a tags field, which is used in search. Tags field example: "tags": "{62AEFBF6-2580-4C80-A4E2-D9E82055DCE0} |{5A3775E0-8D9F-42FA-B34D-5E93EAA56D4C} |{...
2
votes
2answers
115 views

Can Azure Search be used outside a Sitecore PaaS solution?

This article mentions that Azure Search can be used if you use Sitecore Azure Paas. But I don't see any reason why you couldn't use Azure Search with a standalone Sitecore solution. Do you really need ...
2
votes
3answers
1k views

SearchResultItem POCO not populated

I have a class (SBJSearchItem) that inherits SearchResultItem that I'm using with the ContentSearchManager. The problem is that some of my SBJSearchItem properties are not populating. I'm using Azure ...
2
votes
1answer
55 views

Automated index document merge complains about invalid index name but index names are valid

I get thousands of the following error in the minions log: 00007 09:21:07 ERROR AzureContextCommand.MergeOrUploadDocuments.Error: Message=Index name must only contain lowercase letters, digits or ...
2
votes
0answers
41 views

Safe to delete Sitecore master/web old index after rebuild/swap?

We're using the Swap and Rebuild feature of Sitecore 9.1 when we need to rebuild our indexes for Azure Search. Occasionally, after the rebuild and swap is complete; Sitecore won't delete the old ...
2
votes
1answer
278 views

Sitecore SXA Azure Search Facets Returning 400 Bad Request when there are more than 50 results

I have a search page that is working correctly on my local instance using SOLR, but when we move the page to our AZURE Instance it fails. The AZURE Instance is using AZURE Search instead SOLR. If I ...
2
votes
0answers
58 views

Azure Search FilterOn Linq Not Working

I am running Sitecore 9 update 2 on Azure Web App, with Azure Search. I am trying to use the Sitecore Facet Support, that works completely fine with Solr, but having no luck at all with Azure. So my ...
2
votes
1answer
52 views

Set up field copy rules

I need to add custom field to Azure search schema and set up copy field rules to get the values of some other fields and set them as the values of this custom field. I can do it in Solr with Schema ...
2
votes
0answers
340 views

Sitecore-Core-Index rebuild at Azure Search for Sitecore 9.0.1 PaaS fails

I have deployed Sitecore 9.0.1 XP Scaled in Azure PaaS (default, no customization). It is used self-signed certificate and configured with allowInvalidClientCertificates="true" in azuredeploy....
2
votes
0answers
322 views

A binary operator with incompatible types was detected error in Azure Search with Helix

I'm getting the below error after deploying on Azure. We're using Azure Search with Helix pattern reusing Habitat's Foundation.Indexing style (indexing providers). {"error":{"code":"","message":"...
2
votes
0answers
71 views

When will the sitecore azure search provider be released? [closed]

I saw there was a Roadmap from earlier this year saying Azure Search Provider would be included in 8.2 update 1 to be released this year. Along with Azure session redis cache. Has anyone got any ...
1
vote
1answer
885 views

Creating a new index in Azure Search for Sitecore 9 Helix structured

Background: I am completely new to Azure Search in general. New to SOLR, Lucene the whole thing. I have a good bit of experience in SQL design for indexes and such, but this seems completely different....
1
vote
3answers
197 views

Sitecore sxa checklist facets in search are not loading when using azure search

I am using SXA 1.8 with Sitecore 9.0.2. I wanted to add a checklist facet to my search, as I am using Azure Search, I added the field to be indexed like below in a custom config file. <include ...
1
vote
2answers
196 views

Any guide to implement Azure Search with Sitecore 8.1x?

Is there a way to implement Azure Search with Sitecore 8.1x? Currently I can see only one option to update current Sitecore instance to 8.2x.
1
vote
1answer
139 views

Date field not showing in Azure Search results

I have a regular date field defined like this: <field type="System.DateTime" fieldName="entry_date" cloudFieldName="entry_date" searchable="NO" retrievable="YES" facetable="YES" filterable="YES" ...
1
vote
1answer
81 views

integrating the Azure Search Service with Sitecore 8.1 Update 3

We are integrating the Azure Search Service with Sitecore 8.1 Update 3. However, could not find any thorough documentation for the same and are having difficulty performing the steps mentioned in here ...
1
vote
1answer
274 views

IS there a simple way to get the current Azure Search index name programatically?

I need to get the current active index name for Sitecore search for logging purposes. Because of the swap on rebuild functionality, I can't simply use the name field of the index, since on alternating ...
1
vote
2answers
266 views

Azure searches on one Azure CD server are sent as “&search=This_Is_Equal_ConstNode_Return_Nothing”

On one of three CD servers every search we execute is sent to Azure Search like the following: 19660 02:11:05 INFO AzureSearch Query [sitecore_web_index]: &search=...
1
vote
3answers
444 views

Techniques and Rules to Eliminating Template fields from Indexing

I am investigating my site's indexing and looking at working around the Azure Search index 1000 field limit (see here Rebuilding Sitecore Core Index on Azure search throwing exceeding index limitation ...
1
vote
1answer
197 views

Patching Azure Search config files and deploy on Sitecore Azure PaaS

Our application (Sitecore 9.0.2 SXA 1.8) is currently running on Azure PaaS with Azure Search as Search service Recently we ran into this problem of master index exceeding 1000 field Limit we ...
1
vote
1answer
422 views

Data template not found for item in web database

Found the below error in log while indexing sitecore azure indexes.Once we get this error indexing gets stuck and there will be multiple errors in log and none of the items get indexed. ERROR Data ...
1
vote
1answer
101 views

How do you check if your configuration for Azure Search is working on Sitecore 8.2.7?

According to this official guide "Configure Azure Search"(https://doc.sitecore.net/sitecore_experience_platform/82/setting_up_and_maintaining/search_and_indexing/configure_azure_search#...
1
vote
2answers
218 views

Sitecore 8.2 and Azure search indexes have different names

I have an inherited an instance of Sitecore 8 deployed to azure PaaS. Sitecore has been set up to use Azure search, however when I look in Sitecore the names of the indexes are slightly different from ...
1
vote
1answer
292 views

Multiple language items in search results

We have couple of sites configured under one Sitecore instance for different languages, for example one for "Australia(en-AU)" and one for "Korea(KR)" We are using Azure search and observing when we ...
1
vote
1answer
557 views

Is it possible to make custom computed index field searchable in SXA 1.8

I'm using Sitecore 9.0 with SXA 1.8. I've got a requirement to search PDF names and it's fields including custom fields (e.g. download title field). When I see the Solr index / Azure index, PDF names ...
1
vote
1answer
202 views

Index the content for some of the languages - Sitecore Azure index

I am using Sitecore 9 Update 1 with Sitecore Azure search. We have many different language content in the site. I want to index the content which are belongs to 2 languages. Is there any change to be ...
1
vote
1answer
236 views

Index queries not working with DateTime and ID on SXA and PAAS

I had some custom code performing queries on a Sitecore index that worked perfectly on my local environment with Solr. But when deploying the code to Azure PAAS with Azure search they don't work. The ...