Questions tagged [azure-search]

Anything related to Azure Search: querying, configuring, maintaining, ... Azure (PaaS) replacement for Solr and Lucene.

Filter by
Sorted by
Tagged with
0
votes
0answers
25 views

Boosting rule on checkbox field not working in Azure

I have a checkbox field (IsImportant). I have added the boosting rule to my search scope "Where the IsImportant field is equal to true adjust boost by 100". It is giving no result in azure ...
0
votes
0answers
171 views

How to build Sitecore SXA Scope Search query with comoperations

I have requirement to show the query results based on the logged-in user-profile details, I was able to pass the query token field value dynamical by following the code. How to write a SXA search ...
0
votes
0answers
52 views

How can I solve Server Error in '/' Application Index has not been initialized? [duplicate]

If I access my home page, show error like this : Server Error in '/' Application. Index has not been initialized. Description: An unhandled exception occurred. Exception Details: System....
0
votes
3answers
558 views

Sitecore 9.1.1 Azure Search custom index not updating when running rebuild

I'm trying to port an application to Azure Search from Solr. I've got the sitecore indexes working and rebuilding. The documents are being added to the azure search index. However for any custom ...
0
votes
0answers
58 views

SXA Map throwing 400 Bad Request

Working with Sitecore 9 (Update 1), SXA 1.7.1 and Azure Search. Components added on the page: Map, Location Finder, Search Results (all components have the same search signature). Search Query: ...
0
votes
1answer
61 views

Need to access search keyword in a custom rendering controller in SXA

We are using SXA 1.8 with Sitecore 9. And, we have the requirement to access the search keyword passed in the search-box in one of the custom-renderings. But unfortunately, SXA is appending the search ...
0
votes
1answer
94 views

Warning message: 'GUID' field of 'GUID' item is skipped: field name is missed

In all of our environments, any time there is an index update to our Azure Search indexes, we see the following WARN message logged repeatedly (many thousands of times): 06:11:06 WARN [Index=...
0
votes
0answers
794 views

ERROR Year, Month, and Day parameters describe an un-representable DateTime

We are receiving below errors during Indexing. We are on Sitecore 9 update-2, SXA 1.7.1 and using Azure search. The errors below seems related to SXA fields. Has anyone come across this issue? 10752 ...
0
votes
0answers
224 views

SXA Custom index not used by Search Results component

Following the SXA documentation Configure SXA indexing, I have created my custom indexes : Then I have created a patch config file for the corresponding index definitions. On a page I use a ...
0
votes
1answer
407 views

Sitecore Azure rebuild index:The request is invalid. Details: index.fields[0].name

I am using Sitecore 8.2 update 3 and Azure search service in our application. I am able to rebuild the master index successfully but when i am rebuilding web index, it will get stuck in middle and ...
0
votes
1answer
811 views

Content not added to computed field using Azure Search

There is a custom code which triggers on rebuilding indexes. The method will extract all content from each page rendering's datasources and store in the content field. When I debug, I see that the ...
-1
votes
1answer
144 views

Azure Search SwitchOnRebuild returns no results

I have created a separate publishing target (Production). I have created a separate index for this database (sitecore_prod_index). I rebuild my index, and it returns results. I rebuild again, no ...
-1
votes
1answer
277 views

Product ID or name is not searchable

I am working on Sitecore commerce 9 update-1. Many customizations are already done till now. For searching I'm using the default Search component. Issue :- Product is not searchable by Product ID/...

1 2 3
4