Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

Filter by
Sorted by
Tagged with
0
votes
0answers
17 views

How to setup one common CMS and two CD server in different region in Azure Pass Architecture?

Currently we have scaled environment setup on Azure Pass i:e one CM and one CD server in common region. Now we have created one more site but its for another region and due to compliance policy we can'...
1
vote
0answers
10 views

Sitecore media library - unable to load large files ( > 8MB) via Azure Front Door

We've run into an issue in Sitecore 9.3 where it's not serving media items properly via Azure FrontDoor with caching enabled. (Front Door works exceptionally well for 99.95% of the website). But a ...
0
votes
2answers
246 views

Identity Server not redirecting to Azure Frontdoor URL

We are implementing URL hardening in Azure PaaS. We have added Azure front door urls to CM app. We have updated Sitecore.Owin.Authentication.IdentityServer.config on CM server with new url for ...
0
votes
1answer
23 views

Issue when trying to enable Azure Blob storage to sitecore 9.3

I tried to enable Azure blob storage to sitecore 9.3. I configured as per the doc(https://doc.sitecore.com/developers/93/sitecore-experience-manager/en/enable-the-azure-blob-storage-module-for-...
0
votes
3answers
309 views

Sitecore 9.1.1 Azure Search custom index not updating when running rebuild

I'm trying to port an application to Azure Search from Solr. I've got the sitecore indexes working and rebuilding. The documents are being added to the azure search index. However for any custom ...
0
votes
0answers
37 views

Node version issue in Multisite Sitecore jss application in Azure

I have 2 jss apps deployed to azure. Both are built on node 12.15.0 and I have WEBSITE_NODE_DEFAULT_VERSION as 12.15.0 in azure app settings but Only one of the apps is getting loaded at a time. For ...
0
votes
0answers
28 views

Package installation error - Find corrupted items [duplicate]

I'm experiencing this problem when installing packages in an instance hosted on Azure. The package installation fails and the dialog just says - Retry installation. There are also no related logs. On ...
0
votes
1answer
250 views

Azure Search &search=This_Is_Equal_ConstNode_Return_Nothing

I have a site that I have recently been upgrading from 8.2 to 9.1 and everything is looking good EXCEPT anything that relies on search funcionality. Any Azure search has in the info log: 2019-02-...
1
vote
2answers
51 views

Azure Deploy of CM + Reporting

I'd like to build a deployment of CM and Reporting in a single App Service. Is the best approach to take the XP0 files and try to remove what isn't needed ? Or try and combine The CM and Reporting ...
6
votes
1answer
588 views

Migrating Solr Core indexes to Azure Search indexes

I am midst of migrating a Sitecore project to Azure Paas offering. I've completed the deployment of the files (ie. dlls, configs, css, js, etc) and were able to do a complete unicorn sync. That looks ...
0
votes
0answers
23 views

Sitecore SaaS Migration to Sitecore PaaS on Azure

I would like to move my current Sitecore SaaS to Sitecore PaaS on Azure. If anyone can provide guidelines or documents on the steps process that will be really helpful.
0
votes
0answers
45 views

Sitecore TDS Webdeploy in Azure PAAS

I am facing issues in Deploying TDS Webdeploy Package to Azure PAAS. I'm using Sitecore 9.3, TDS.6.0.0.14 We are getting an error on TDS service Msg From Kudu --> "WARN Request is ...
0
votes
2answers
276 views

After deploying Habitat to Azure I am getting rendering error

While opening the item in the Experience editor I am getting a lot of errors like the below: Error Rendering View: /Views/MediaFeature/LightboxVideo.cshtml: Error while rendering view: '/Views/...
0
votes
0answers
14 views

Has anyone gotten “Replicating the Web database using Azure active geo-replication” working

I'm trying to set 2 CD sites (SC 9.3 XM) on Azure (1 in west region, 1 in east region). I've tried following the steps in this article: https://doc.sitecore.com/developers/93/platform-administration-...
1
vote
1answer
191 views

Sitecore setup using Azure VM Scale sets

Has anyone implemented CD server on Azure VM Scale sets? Looking at below information: The CD Image process as per the VM Scale set process When the Image is used to scale VMs using Azure approach, ...
0
votes
2answers
31 views

Base Templates are deployed without any language version

We have very bizare issue with our deployment. Project contains of multiple templates and we recently (couple of months ago) introduced couple of base templates. We have prefixed them with underscore,...
1
vote
2answers
62 views

Incorrect URLs when behind proxy

I have a Sitecore 9.3 xp1 scaled application hosted in Azure PaaS. The CD App Service sits behind an F5 and Azure Gateway, with DNS of https://mysite.com routing through these 2 proxies (F5 -> ...
2
votes
1answer
44 views

Load balancing with Azure PaaS on CD

We have a Sitecore 9.2 setup using the S3 profile for the CD with 3 instances scaled out manually. I'm pretty new to managing the PaaS environment, and I'm trying to figure out if the traffic is load-...
1
vote
1answer
97 views

Where to download Azure SDK 2.7.1 needed to deploy Sitecore Azure 8.1?

We are building a development environment for Sitecore 8.1 Update 1 with Sitecore Azure 8.1. Since Sitecore Azure requires Azure SDK 2.7.1 to be deployed, I am having such a bad day trying to figure ...
2
votes
1answer
313 views

Multi-Site Domain is not resolving Using Azure WAF

I am facing domain resolving issue in Sitecore Multi-Site Solution using Azure PaaS with Azure WAF setup, however, it's working fine if I add the custom domain on Content delivery(Web Apps) level. ...
0
votes
0answers
19 views

Install Sitecore 9.3 XM on Azure VM with Azure SQL

Has anyone had success installing Sitecore 9.3 (XM) on a Azure VM + Azure SQL? When running the SC setup.exe program, I'm seeing this error:
1
vote
1answer
219 views

Sitecore 8.2 Update 4 in Azure SQL

Sitecore 8.2 Update 4 I am looking to run Sitecore in IaaS. Azure VMs for web and Azure SQL for database. Not the new Azure service stack. Its great that Sitecore comes with dacpac files in all ...
9
votes
4answers
5k views

How to Copy complete site from Production Slot to Staging slot in Azure PaaS?

Azure Deployment Slot is Awesome functionality for regular(Full) production deployment build process using Deployment Slot Swap functionality. But sometimes we need to deploy the hotfix on production,...
2
votes
2answers
257 views

Getting IDX20803 when trying to log in via IdentityServer on my CD instance

I have a functioning login flow for my site via IdentityServer. When I test the flow on the CM server (but the frontend site) everything works ok. When I try the same thing on my CD server, I get: ...
1
vote
1answer
144 views

Error when installing WDP in on-premises Sitecore 9.1 XP setup

I followed the steps described in this SSE question/answer to create my WDP. Everything works like a charm when deploying this WDP into a Sitecore Azure Paas instance. However, when I try to install ...
15
votes
2answers
418 views

Excessive SQL Server DTU consumption after deployment to Azure (messaging_db)

After an initial Sitecore 9.1 deployment with Sitecore Managed cloud (Default installation, x-small no custom code and configuration). We notice an excessive DTU consumption on the messaging database....
2
votes
1answer
65 views

Enabling Local Cache on Sitecore Azure App Services

I've read the following article https://blog.baslijten.com/increase-your-sitecore-performance-by-enabling-the-local-cache-on-azure-app-services/ that says how to enable Local Cache option in the Azure ...
0
votes
0answers
21 views

unable to integrate Sitecore rocks 4.0.291 with VS 2019 [duplicate]

Trying to integrate Sitecore rocks 4.0.291 with VS 2019 but getting below error while i have applied web.config changes as per here Visual studio version is Microsoft Visual Studio Professional 2019 ...
0
votes
1answer
251 views

ERROR Could not run the 'getMediaStream' pipeline for '/sitecore/media library/Images/test '. Original media data will be used

I’ve extended SqlServerDataProvider to use the azure blob storage account for storing the media library assests. I’ve taken reference from below GitHub project: https://github.com/aweber1/Sitecore....
0
votes
1answer
37 views

Sitecore.IO.FileWatcher Error

I have an issue with the test site which broke after I had done a deployment with VSTS. The test environment is hosted on Azure in a webservice app. I know it has to do something with the files in the ...
2
votes
2answers
353 views

Secure Azure SQL database connection using a managed identity

We are currently hosting our Sitecore 9.1 initial release on premises, but want to move the complete solution into Azure. We want to use public services and not put our solution in an ASE. To secure ...
8
votes
4answers
2k views

502 - Web server received an invalid response while acting as a gateway or proxy server

I've noticed the 502 error after deployment to Azure question, but it appears to be related to a failed deployment and rollback of databases - not what we're seeing here. I am getting the above ...
0
votes
2answers
190 views

Login failed for user 'masteruser'

I was moving my Sitecore 9.2 QA database in UAT in Azure PaaS. I have moved the web & master database and renamed the databases to UAT's database name. In connectionString.config we have changed ...
2
votes
3answers
217 views

Unable to install Sitecore Horizon 9.3 on Azure

I have installed Sitecore 9.3 XP Single on Azure using Sitecore Experience Cloud (Azure Marketplace). Now I want to install Sitecore Horizon 9.3 on existing Azure Sitecore 9.3 instance. While ...
0
votes
1answer
101 views

Sitecore Azure PaaS Client Certificate on ASE

I deployed Sitecore 9.2 on Azure PaaS and facing the issue with Client Certificate Authentication. The Azure hosting is on ASE with Isolated App Service Plan. It seems like CM server is not able to ...
1
vote
1answer
52 views

Most cost effective way to add custom SQL server tables/database to Sitecore 9.1.1 PaaS installation

I'm looking for some guidance please, we have a small (~500Mb) custom SQL server database that we need to run alongside the standard Sitecore 9.1.1 databases. I'm also new to Azure so I apologies if ...
1
vote
1answer
103 views

Publishing Service error message: Could not persist PublisherOperations in the service

In my CM logs, I'm seeing the following warning repeatedly. WARN Could not persist PublisherOperations in the service Exception: Polly.CircuitBreaker.BrokenCircuitException Message: The circuit is ...
18
votes
2answers
3k views

Experience Analytics are not showing Online Interactions

I have a Sitecore solution (Sitecore 9.0.1 revision 171219 on Azure in xP1 topology) that as far as I can tell all roles are working as expected and communicating. I am able to fire goals, create ...
2
votes
1answer
177 views

Index has not been initialized error on Sitecore 8.2 with Azure Search

I have Sitecore 8.2 update 5 in Azure PaaS using Azure Search. When I am trying to open the content editor, it is throwing exception Index has not been initialized with stack trace info mentioning ...
0
votes
0answers
38 views

How can I solve Server Error in '/' Application Index has not been initialized? [duplicate]

If I access my home page, show error like this : Server Error in '/' Application. Index has not been initialized. Description: An unhandled exception occurred. Exception Details: System....
0
votes
0answers
29 views

Where can I find Serialized item in Azure portal in Sitecore 9.0.2?

We are using the Azure portal for Sitecore 9.0.2 instance and using Unicorn along with it. Where can I find the serialized items in the Sitecore instance? I checked the path \\App_Data folder but ...
-1
votes
1answer
38 views

Script to automatically recycle Azure app every day at a certain time?

We're dealing with what appears to be a memory leak issue, and we're still trying to find the root cause. In the meantime, Azure is auto-healing every time the memory gets high, which is happening ...
12
votes
2answers
2k views

WAF support with Sitecore Experience Platform

We are looking for a Web Application Firewall (WAF) solution for our Sitecore CMS implementation, because we are an Azure shop we specifically wanted to use the WAF feature on the Azure AppGateway ...
1
vote
1answer
54 views

What is the recommended approach to handle blue/green deployments with Commerce on Azure

Is there a recommended/standard approach to handling blue/green deployments for Sitecore Commerce services? Our Sitecore app services are hosted on Azure and we are able to do zero-downtime ...
3
votes
2answers
265 views

Azure database refdata high intermittent load

We've been running a SC9.1 solution on PAAS for a while now, but have recently noticed intermittent slow response times, both on the CD and the CM. We've correlated it to high load on the refdata-db: ...
1
vote
1answer
284 views

Sitecore redirects for login page using hostname

We have a sitecore instance (xp0 for now) with an identity server. They are deployed to azure and belong to a private vnet. Access to nodes is done through the application gateway. But because of ...
10
votes
3answers
3k views

Azure Web App Redis timeout exceptions when under load

We are performance testing our Sitecore hosted in azure web apps (2 CD S3) which uses Premium Redis. There are no error during normal UAT and SIT. However, on performance testing there are quiet a ...
0
votes
0answers
26 views

Using Seq with Sitecore PaaS

We are running 9.3 in an app service in Azure. We have found a number of articles stating different things about logging in SC. Some say it's log4net, others say Serilog... Since we cannot get to ...
-1
votes
1answer
178 views

How does the gulp build transform Sitecore config files?

I'm migrating Sitecore 9.1.0 to Azure. During the process of build on Azure DevOps, I have a gulp tasks, which builds the solution and transforms the configuration files. On certain configuration ...
1
vote
2answers
57 views

Sitecore 9.2 Query not returning all matching items on Azure production

We have multiple environments for a website including local, UAT (single Azure instance), CM (Azure production for authoring) and CD (content delivery). The following code is on all instances and ...

1
2 3 4 5 6