Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

Filter by
Sorted by
Tagged with
0
votes
0answers
19 views

Lighthouse demo code deployment to azure

Is it possible to deploy the lighthouse demo code to azure app services? We would like do a POC to play around before we plan for our upgrade. We would need to install the below to azure instead of ...
1
vote
1answer
58 views

Does Sitecore 10.0.1 support SAML with Okta?

I am using Sitecore 10.0.1 on the Azure App Services platform. I would like to implement federated authentication using saml. I was only able to find documentation using open id connect. Does ...
1
vote
1answer
445 views

Sitecore.XConnect.XdbSearchUnavailableException [closed]

Hi I was installing Sitecore in Azure Web App. It has been installed without SOLR cores in SOLR server (in this case I have a separate SORL VM along with Web apps for Sitecore PaaS). Once I have ...
0
votes
2answers
573 views

Identity Server not redirecting to Azure Frontdoor URL

We are implementing URL hardening in Azure PaaS. We have added Azure front door urls to CM app. We have updated Sitecore.Owin.Authentication.IdentityServer.config on CM server with new url for ...
0
votes
2answers
35 views

Sitecore CD app service connection string is being ignored

I am trying to setup Sitecore CD to work with Blue/Green deployments. As part of this configuration, I am tying to get our database to stay sticky to the staging and production deployment slots This ...
1
vote
1answer
144 views

IDX10500 error when calling Sitecore with JWT token from Postman after updating identity server certificate

I am using Sitecore 9.1 and have recently updated my .pfx identity server certificates in Azure, due to the old ones expiring. After updating the Sitecore.IdentityServer.Host.xml configuration, the ...
1
vote
1answer
52 views

I've trying to install Sitecore, getting error: Missing source parameter

I am trying to install Sitecore 9 update 2 on Azure. I am getting this error: Package deployment failed ARM-MSDeploy Deploy Failed: 'Microsoft.Web.Deployment.DeploymentClientServerException: Missing ...
2
votes
2answers
92 views

JSS: Azure deployment

In our case, both test and prod environments are Azure app services. So currently when we deploy to test: I replace the layoutServiceHost and deployUrl in scjssconfig.json to be the address of QA ...
4
votes
1answer
78 views

SQL Replication doesn't clear CD caches on remote target

We have a multi-cd publishing situation I can use some help with. We are in an Azure PAAS situation, with the CM and 1 CD server located in the US. We also have a CD Server and SQL database in China (...
3
votes
1answer
241 views

Sitecore setup using Azure VM Scale sets

Has anyone implemented CD server on Azure VM Scale sets? Looking at below information: The CD Image process as per the VM Scale set process When the Image is used to scale VMs using Azure approach, ...
0
votes
0answers
36 views

Unable to install Mssql init job in azure AKS [duplicate]

I was trying to install sitecore on my azure AKS engine. When I run the mssql-init file the jobs fail to create with the following error: Start publishing dacpacs Sqlcmd: Error: Microsoft ODBC ...
3
votes
2answers
317 views

Hard time installing Sitecore 10 external resources in Kubernetes AKS in Azure

I'm trying to install Sitecore 10 on AKS so I was following the steps in Installation_Guide_for_Production_Deployments_with_Kubernetes_XP10.0.0.pdf Installed azureCli & helm on my local pc az ...
1
vote
2answers
62 views

Azure Deploy of CM + Reporting

I'd like to build a deployment of CM and Reporting in a single App Service. Is the best approach to take the XP0 files and try to remove what isn't needed ? Or try and combine The CM and Reporting ...
2
votes
3answers
854 views

Login failed for user 'masteruser'

I was moving my Sitecore 9.2 QA database in UAT in Azure PaaS. I have moved the web & master database and renamed the databases to UAT's database name. In connectionString.config we have changed ...
1
vote
0answers
47 views

Sitecore login redirects to website and not Launchpad

We are using azure alias URL "https://abc.com/sitecore/login" to access our prod CM site "https://abc-1001-cm.azurewebsites.net/sitecore/login". Earlier we had Sitecore 9.0.1 ...
6
votes
2answers
682 views

Migrating Solr Core indexes to Azure Search indexes

I am midst of migrating a Sitecore project to Azure Paas offering. I've completed the deployment of the files (ie. dlls, configs, css, js, etc) and were able to do a complete unicorn sync. That looks ...
1
vote
2answers
330 views

After deploying Habitat to Azure I am getting rendering error

While opening the item in the Experience editor I am getting a lot of errors like the below: Error Rendering View: /Views/MediaFeature/LightboxVideo.cshtml: Error while rendering view: '/Views/...
1
vote
2answers
42 views

Base Templates are deployed without any language version

We have very bizare issue with our deployment. Project contains of multiple templates and we recently (couple of months ago) introduced couple of base templates. We have prefixed them with underscore,...
2
votes
1answer
230 views

Where to download Azure SDK 2.7.1 needed to deploy Sitecore Azure 8.1?

We are building a development environment for Sitecore 8.1 Update 1 with Sitecore Azure 8.1. Since Sitecore Azure requires Azure SDK 2.7.1 to be deployed, I am having such a bad day trying to figure ...
1
vote
1answer
320 views

SolrCloud on Azure PaaS

I am setting up a Sitecore 9.2 Production instance and ideally would like to Setup SolrCloud in Azure PaaS Web Apps. In test environments i have setup Solr on a single PaaS App Service and it is ...
1
vote
1answer
243 views

Sitecore 8.2 Update 4 in Azure SQL

Sitecore 8.2 Update 4 I am looking to run Sitecore in IaaS. Azure VMs for web and Azure SQL for database. Not the new Azure service stack. Its great that Sitecore comes with dacpac files in all ...
1
vote
1answer
40 views

We have Sitecore 9.0 web apps on Azure App Services, Is it safe to change the time zone of the App Services?

We have Sitecore 9.0 web apps hosted on Azure App Services. These App Services are in a different timezone that where our content authors are located. We want all the times displayed in Content Editor ...
1
vote
1answer
99 views

Clean Deployment to Azure VM Server

For automated deployment to CM and CD Azure VM Servers, I am using Azure DevOps. I need to deploy artifacts over clean environment everytime. That means each time before deployment, I need to delete ...
10
votes
4answers
3k views

Azure Web App Redis timeout exceptions when under load

We are performance testing our Sitecore hosted in azure web apps (2 CD S3) which uses Premium Redis. There are no error during normal UAT and SIT. However, on performance testing there are quiet a ...
16
votes
2answers
564 views

Excessive SQL Server DTU consumption after deployment to Azure (messaging_db)

After an initial Sitecore 9.1 deployment with Sitecore Managed cloud (Default installation, x-small no custom code and configuration). We notice an excessive DTU consumption on the messaging database....
1
vote
1answer
95 views

How to setup Application Insights for a Solr service hosted on Azure PaaS

We have an Azure PaaS environment for Sitecore 9.3 and Solr App services created. Is there any way to connect Application Insights for the Solr App service? For CM and CD services we have setup the ...
0
votes
1answer
64 views

Node version issue in Multisite Sitecore jss application in Azure

I have 2 jss apps deployed to azure. Both are built on node 12.15.0 and I have WEBSITE_NODE_DEFAULT_VERSION as 12.15.0 in azure app settings but Only one of the apps is getting loaded at a time. For ...
0
votes
0answers
22 views

Azure blob storage: still save some blobs to SQL

Sitecore 9.3 We switched to Azure blob storage to store the media items. We installed Azure Blob Storage module,turned it on, migrated all the existing media library items to Azure, and everything ...
0
votes
1answer
387 views

ERROR Could not run the 'getMediaStream' pipeline for '/sitecore/media library/Images/test '. Original media data will be used

I’ve extended SqlServerDataProvider to use the azure blob storage account for storing the media library assests. I’ve taken reference from below GitHub project: https://github.com/aweber1/Sitecore....
0
votes
0answers
17 views

Ensure Azure Content Search Provider uses a filter for a query

We have a number of searches on our site that should be possible through a pure filtered search - we're searching across a few fields, some of which are mutli-selects, others are booleans and one's a ...
0
votes
1answer
39 views

Sitecore PaaS Web DB spikes

We’ve just migrated from Sitecore 8.2.5 on-prem to 9.3 Azure PaaS. Performance seems ok most of the time, but we’re seeing regular spikes to 100% DTU on the web db. The db is standard S2 50 DTU and we’...
0
votes
0answers
19 views

Redirect on authorization path exposes azure domain

We are using Sitecore 9.3 hosting in azure environment and we have an issue on the CD site, when the user enters the url e.g, https://customdomaincdurl/ap_config it is expected to redirect the user ...
0
votes
2answers
48 views

Using Seq with Sitecore PaaS

We are running 9.3 in an app service in Azure. We have found a number of articles stating different things about logging in SC. Some say it's log4net, others say Serilog... Since we cannot get to ...
0
votes
3answers
486 views

Sitecore 9.1.1 Azure Search custom index not updating when running rebuild

I'm trying to port an application to Azure Search from Solr. I've got the sitecore indexes working and rebuilding. The documents are being added to the azure search index. However for any custom ...
9
votes
2answers
1k views

How to Create Web Deploy Package for Sitecore Modules

We are currently using Sitecore PaaS implementation for Sitecore 9 Update 1 and would like to know if it is possible to create a Web Deploy Package for other Sitecore Modules like Data Exchange ...
2
votes
2answers
394 views

Incorrect URLs when behind proxy

I have a Sitecore 9.3 xp1 scaled application hosted in Azure PaaS. The CD App Service sits behind an F5 and Azure Gateway, with DNS of https://mysite.com routing through these 2 proxies (F5 -> ...
0
votes
2answers
168 views

Sitecore TDS Webdeploy in Azure PAAS

I am facing issues in Deploying TDS Webdeploy Package to Azure PAAS. I'm using Sitecore 9.3, TDS.6.0.0.14 We are getting an error on TDS service Msg From Kudu --> "WARN Request is ...
0
votes
0answers
148 views

.aspnet.cookie is not set after Azure AD B2C successful authentication

We have an ASP.NET webforms application with Sitecore 9.0.0 Initial release, and we want to use Azure B2C as an external identity provider for our external users. We created the new authentication ...
2
votes
1answer
108 views

Load balancing with Azure PaaS on CD

We have a Sitecore 9.2 setup using the S3 profile for the CD with 3 instances scaled out manually. I'm pretty new to managing the PaaS environment, and I'm trying to figure out if the traffic is load-...
6
votes
1answer
252 views

Can you use Azure DevOps with Sitecore Managed Cloud

When implementing Sitecore Managed Cloud, what deployment or technical considerations need to be thought about? As an example: in modern deployments, using Azure DevOps is a viable deployment ...
1
vote
1answer
38 views

unicorn deployment failure - can't sync when deployed to real environments

I am sure I am missing something simple about using Unicorn in environments above the local dev environments the source folder is correct out of Azure Paas, out on my App Service I am in Sitecore 9.3....
0
votes
0answers
25 views

Sitecore 9 Analytics - added user agent in the <excludedUserAgents> not working

We have Sitecore 9.0.2 based UAT and Live website in Azure PaaS environment. Before some time we have configured Sitecore analytics tracking in UAT and Live both. Now what happened is in both ...
0
votes
1answer
56 views

Does Sitecore Azure paas support sticky session?

I want to enable Sticky session on Azure Pass Sitecore CD instances(multiple app services). Is this possible? If not, what are other options that I have?
1
vote
1answer
166 views

What does “Keyword not supported: 'endpoint'” mean and how does it relate to the “messaging” connectionstring?

I'm encountering the following issue but can't find any documentation to troubleshoot this issue. Any tips? 51324 09:55:20 ERROR Messaging : IMessageBus failed to start 'Sitecore.Marketing.Automation....
0
votes
0answers
19 views

We are working on Azure Search and we want to limit the search results to certain fields in Sitecore [duplicate]

We are working on Azure Search and we want to limit the search results to certain fields in Sitecore. I have created a patch file where we have mention the limit fields. But, still the search is ...
0
votes
1answer
33 views

Opening HTML microsite from Sitecore Media Library v9.1.1

looking for settings to open microsite uploaded to media library in browser. In the past we would take an Adobe Captivate html export load it into a folder in the media library and run the .html from ...
1
vote
1answer
42 views

Sitecore Indexing GetLocalDatasourceDependencies

Sitecore 8.2 update 5 on Azure App Services. Anyone knows what could be the reason <pipelines> <indexing.getDependencies> <processor type="Custom....
2
votes
2answers
74 views

Outage on your sitecore website during an azure platform upgrade

Our website becomes unresponsive and we get Pingdom alerts whenever there is either an azure platform or infrastructure upgrade on our website. This happens once a month. We have an app gateway and ...
0
votes
0answers
84 views

Issue when trying to enable Azure Blob storage to sitecore 9.3

I tried to enable Azure blob storage to sitecore 9.3. I configured as per the doc(https://doc.sitecore.com/developers/93/sitecore-experience-manager/en/enable-the-azure-blob-storage-module-for-...
0
votes
1answer
125 views

Invalid identity provider: sitecoreidentityserver when attempting to login

Attempted to simply login to two different sitecore CM ( test and prod ) Azure PaaS servers and go the following error : Invalid identity provider: sitecoreidentityserver I suspect it has to do with ...

1
2 3 4 5
7