Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

Filter by
Sorted by
Tagged with
10
votes
4answers
3k views

Azure Web App Redis timeout exceptions when under load

We are performance testing our Sitecore hosted in azure web apps (2 CD S3) which uses Premium Redis. There are no error during normal UAT and SIT. However, on performance testing there are quiet a ...
10
votes
2answers
2k views

How to configure Solr for Sitecore PaaS setup

We are currently trying to upgrade our Sitecore 8.1 Environment to Sitecore 9. We are also doing this implementation to Sitecore 9 PaaS and succesfully had several components work, however we are ...
5
votes
1answer
3k views

xConnect WebApps on Azure PaaS not working

I installed the vanilla Sitecore 9.0 version from Marketplace on Azure PaaS with XP and extra small configuration and select the option self signed certificate for xConnect client certificate, but ...
5
votes
3answers
583 views

PaaS compatibility for WFFM and EXM?

Are the current versions of WFFM and/or EXM supported on Azure PaaS?
4
votes
1answer
292 views

Provisioning to Azure failure on deploying CM

I am trying to setup a new Sitecore 9.2 instance on PAAS using ARM templates. I used these templates a few months ago on the same subscription to setup our development environment and that worked fine....
19
votes
2answers
4k views

Experience Analytics are not showing Online Interactions

I have a Sitecore solution (Sitecore 9.0.1 revision 171219 on Azure in xP1 topology) that as far as I can tell all roles are working as expected and communicating. I am able to fire goals, create ...
9
votes
4answers
3k views

502 - Web server received an invalid response while acting as a gateway or proxy server

I've noticed the 502 error after deployment to Azure question, but it appears to be related to a failed deployment and rollback of databases - not what we're seeing here. I am getting the above ...
15
votes
2answers
2k views

Slow cshtml compilation on Azure WebApps

We are having serious issues in the startup (boot) time of our application. After carefull investigation we have discovered that the most time is consumed by first-time-visit compilation of the ...
3
votes
3answers
517 views

Sitecore 9 Infrastructure (roles and services required) Design in Azure

We need to setup infrastructure for Sitecore 9 update 2 in azure PaaS. To achieve this we first need to identify which one is must/optional for costing. Have been reading all Sitecore documentations ...
2
votes
1answer
323 views

Index has not been initialized error on Sitecore 8.2 with Azure Search

I have Sitecore 8.2 update 5 in Azure PaaS using Azure Search. When I am trying to open the content editor, it is throwing exception Index has not been initialized with stack trace info mentioning ...
3
votes
1answer
2k views

Accessing log files in application insights for Sitecore 9 in Azure app service

I've been reading several blog posts about application insights and Sitecore logs, and I've not been able to get the proper configuration working. This is using Sitecore 9 ARM templates on Azure app ...
3
votes
1answer
163 views

How to replace `CertificateHttpClientHandlerModifier` to `X509Certificate2`

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on azure app service connects to XConnect which is also on Azure, am following this link ...
2
votes
1answer
352 views

EXM - reports email campaign sent successfully - zero emails actually sent

We have an instance of Sitecore 8.2 update 5 using XDB cloud and EXM hosted in Azure using PaaS AppServices. I am testing EXM and trying to send test email campaigns from our CM instance. However ...
13
votes
2answers
3k views

WAF support with Sitecore Experience Platform

We are looking for a Web Application Firewall (WAF) solution for our Sitecore CMS implementation, because we are an Azure shop we specifically wanted to use the WAF feature on the Azure AppGateway ...
10
votes
4answers
6k views

How to Copy complete site from Production Slot to Staging slot in Azure PaaS?

Azure Deployment Slot is Awesome functionality for regular(Full) production deployment build process using Deployment Slot Swap functionality. But sometimes we need to deploy the hotfix on production,...
12
votes
4answers
2k views

FileWatcher Error, Internal buffer overflow

After a deploy, my Sitecore Azure instance is heavily slowed down and I get the following error on and on, 2017-06-29T08:22:15 PID[42864] Error 54964 08:22:15 ERROR Error in FileWatcher. ...
10
votes
2answers
506 views

How to convert a Sitecore package into a WDP package?

How can I convert a given Sitecore Package previously created using the Package Designer into a WDP package, so that I can create a script to deploy it on my Azure instances?
10
votes
1answer
2k views

Sitecore PaaS Log files missing

Currently, We are on Sitecore PaaS. There are some issues and we are not able to find out the root cause of those issues. We tried to find out some clues in Sitecore log file but We noticed that there ...
9
votes
3answers
2k views

Azure Application Insights not working on Sitecore 9.1 PaaS

I've provisioned a Sitecore 9.1 PaaS, and for some odd reason the Application Insights is not loading graphics except in Live Metrics Stream for Process CPU data I went through the existing post ...
8
votes
1answer
1k views

Where is the location of local sitecore media cache folder in Azure Web Apps?

I am unable to find the local media cache folder in azure apps, as per the configuration in the Sitecore.config it supposed to be in the Media cache folder under App_data: I checked in the Temp ...
3
votes
2answers
1k views

Web API 404 on content delivery server

I am using Sitecore on azure and have a CD and a CM server. The Web API works fine on CM but throws a 404 error (and no more information in logs). I have deleted the following dll files from server ...
3
votes
2answers
322 views

Hard time installing Sitecore 10 external resources in Kubernetes AKS in Azure

I'm trying to install Sitecore 10 on AKS so I was following the steps in Installation_Guide_for_Production_Deployments_with_Kubernetes_XP10.0.0.pdf Installed azureCli & helm on my local pc az ...
11
votes
3answers
1k views

How to add custom language to Sitecore on Azure PaaS Web Apps?

I want to create custom new languages. On-premise or IaaS I can use https://marketplace.sitecore.net/en/Modules/Custom_Language_Registration.aspx to register a new language. Does anyone have some ...
6
votes
1answer
264 views

How to force Sitecore to use &$filter not &search in Azure Content Search Provider

A query built using the Sitecore Azure Content Search Provider doesn't produce the query that I was expecting. The result is that far too many results are returned. The purpose of the code is to find ...
4
votes
1answer
245 views

DTU shooting up after application start in Azure PAAS Sitecore 9.0.2

We are observing that DTUs are shooting up while the application startsup in Azure PAAS environment, however the frequency is not consistent- sometime we restart the webapp explicitly and sometime it'...
1
vote
1answer
555 views

Sitecore redirects for login page using hostname

We have a sitecore instance (xp0 for now) with an identity server. They are deployed to azure and belong to a private vnet. Access to nodes is done through the application gateway. But because of ...
10
votes
3answers
699 views

SQL user creation is setting password of 12345, fails deployment

Using the updated Sitecore Azure Toolkit 2.0.1 rev. 171218, which has resources for 9.0.1, I'm hitting an error on the xc-collect\MSDeploy stage where it's attempting to apply the default sql user ...
7
votes
1answer
528 views

Using TDS sync with Azure PaaS and Sitecore 9

We're setting up a QA environment in Azure PaaS and we're working to figure out the best way to publish things. The code seems to be easy with VS 2017, but we're trying to figure out how to get TDS ...
6
votes
1answer
526 views

Send email with Segmented List - Skipped during message delivery

I have a Sitecore v9.0u1 solution that runs in the Azure.The Sitecore instance and the EXM, Marketing Automation and IndexWorker are all hosted on the same web server for this POC project, and the ...
5
votes
2answers
585 views

Update the sitecore.configs at runtime possible?

We have a requirement to store all the secrets on to azure key-vault. This requires us to update the configurations at Runtime. One challenge we are facing at the moment is to store the password for ...
3
votes
3answers
793 views

New-SCWebDeployPackage is not recognized

I'm trying to package a Sitecore solution and followed the instructions mentioned in the following URLs. https://doc.sitecore.net/cloud/working_with_sitecore_azure/configuring_sitecore_azure/...
3
votes
1answer
138 views

Connecting two Azure services to access XConnect

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on app service azure connects to XConnect which is also on Azure, am following this link ...
3
votes
0answers
990 views

502 error after deployment to Azure [closed]

We have had an automated deployment process that has been working well for ages deploying our Sitecore 8.2 Update 5 site to Azure. Yesterday, a deployment failed to our test environment with the CD ...
3
votes
2answers
1k views

Can't bootstrap/initialize a new Sitecore Commerce 9 instance on Azure App Service

Just starting messing with Sitecore Experience Platform/Commerce 9.0 update 1 on Azure's App Service, managed to deploy it fairly easily, but now I'm stuck during the bootstrap/initialization part. ...
2
votes
2answers
399 views

Incorrect URLs when behind proxy

I have a Sitecore 9.3 xp1 scaled application hosted in Azure PaaS. The CD App Service sits behind an F5 and Azure Gateway, with DNS of https://mysite.com routing through these 2 proxies (F5 -> ...
1
vote
1answer
629 views

Sitecore fails when memory > maxmemory in Redis

If you don't switch to another tier in time; Sitecore returns an Application error and is not available anymore. Monitoring Redis can be one solution, but are there any other options available? See ...
1
vote
3answers
582 views

EXM report is empty (data is not being captured) in scaled environment

I am working with Sitecore 9.0 update 2 on Azure. Server is scale out : 1CM and 3CD. After email campaign is run, we can receive email but reporting is not working. It doesn't have any data is as ...
0
votes
1answer
387 views

ERROR Could not run the 'getMediaStream' pipeline for '/sitecore/media library/Images/test '. Original media data will be used

I’ve extended SqlServerDataProvider to use the azure blob storage account for storing the media library assests. I’ve taken reference from below GitHub project: https://github.com/aweber1/Sitecore....