Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

62 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
5
votes
0answers
268 views

Log Sitecore errors as exceptions instead of trace in application insights

By default, Sitecore application insights config logs Sitecore errors as traces instead of exceptions this means application insights dashboard and alerts are unaware of the exception occurring in a ...
5
votes
0answers
519 views

Index errors on start up on Azure environment

When starting our application we are seeing lots of these entries: 2017-06-29T08:38:59 PID[60944] Error 8168 08:38:59 ERROR Custodian.UpdateIndexTimestampTimerTick. Update index last updated ...
4
votes
1answer
97 views

SQL Replication doesn't clear CD caches on remote target

We have a multi-cd publishing situation I can use some help with. We are in an Azure PAAS situation, with the CM and 1 CD server located in the US. We also have a CD Server and SQL database in China (...
4
votes
0answers
80 views

Azure Deployment Slot Processing Events and Updating Indexes

We have a deployment slot that we deploy to, which we then warm up, and then swap with the live slot so that we can achieve zero downtime deployment on PaaS. This works very well in general. However, ...
3
votes
0answers
49 views

Accessing Azure B2C Access Token with Sitecore ID Server

In Sitecore 9.1 we have integrated Azure B2C with Sitecore Identity Server. We now need to get access to the Azure B2C Access Token on the Sitecore CD server, which was based to Sitecore Identity ...
3
votes
0answers
160 views

Installation issue on migration 9.1.1

I am trying to migrate a Sitecore 9.0.2 to 9.1.1. Following the upgrade guide https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform/91/Sitecore_Experience_Platform_91_Update1.aspx, I have to ...
2
votes
0answers
31 views

How to replace/register 'ResizeImageStream' method of class 'Sitecore.Resources.Media.ImageEffectsResize' from Sitecore.kernel dll

I’ve extended SqlServerDataProvider to use the azure blob storage account for storing the media library assests.Everything works fine but Sitecore.Resources.Media.ThumbnailProcessor throws error in ...
2
votes
0answers
97 views

Losing Session Value in Sitecore 9.0.2

I have a Sitecore 9.0.2 portal in Azure PaaS from where we are making some transactions. I am posting form to the payment gateway using form post method and gateway is returning the response to a ...
2
votes
0answers
187 views

Integration with AD B2C: Trigger Owin challenges by policy name

We're using Sitecore.NET 9.1.0. We're trying to trigger register, login and forgot password flows from Sitecore that will be used by end users of our website. After a successful login we want to ...
2
votes
0answers
528 views

Sitecore schedule task not running on the XP scaled environment (CM server)

We’ve configured Sitecore schedule task, which runs at every 1 hour. The schedule task is running fine after deployment/web app restart but after sometime it’s not working as expected. We’ve verified ...
2
votes
0answers
141 views

How to create a Sitecore Module WDP packge **WITH** Sitecore items?

I was following the official documentation on the subject here https://doc.sitecore.com/developers/sat/20/sitecore-azure-toolkit/en/web-deploy-packages-for-a-module.html and realized that it looks ...
2
votes
1answer
332 views

Where to download Azure SDK 2.7.1 needed to deploy Sitecore Azure 8.1?

We are building a development environment for Sitecore 8.1 Update 1 with Sitecore Azure 8.1. Since Sitecore Azure requires Azure SDK 2.7.1 to be deployed, I am having such a bad day trying to figure ...
2
votes
0answers
340 views

Sitecore-Core-Index rebuild at Azure Search for Sitecore 9.0.1 PaaS fails

I have deployed Sitecore 9.0.1 XP Scaled in Azure PaaS (default, no customization). It is used self-signed certificate and configured with allowInvalidClientCertificates="true" in azuredeploy....
1
vote
0answers
50 views

Files not found on Azure Paas

We have a solution installed on Azure Paas. In the logs we have next errors: Exception: System.IO.FileNotFoundException Message: Could not find file 'D:\home\site\wwwroot\sitecore\shell\client\...
1
vote
0answers
96 views

Sitecore login redirects to website and not Launchpad

We are using azure alias URL "https://abc.com/sitecore/login" to access our prod CM site "https://abc-1001-cm.azurewebsites.net/sitecore/login". Earlier we had Sitecore 9.0.1 ...
1
vote
0answers
38 views

Is there a connector to Azure AppInsights for VM Sitecore Instances

We are currently running Sitecore 9.0 on AWS instances but will be moving to 9.3 on Azure. We have 4 production CD servers, so tracking down issues in the log files is tedious to say the least, as we ...
1
vote
1answer
57 views

We have Sitecore 9.0 web apps on Azure App Services, Is it safe to change the time zone of the App Services?

We have Sitecore 9.0 web apps hosted on Azure App Services. These App Services are in a different timezone that where our content authors are located. We want all the times displayed in Content Editor ...
1
vote
0answers
34 views

Has anyone gotten “Replicating the Web database using Azure active geo-replication” working

I'm trying to set 2 CD sites (SC 9.3 XM) on Azure (1 in west region, 1 in east region). I've tried following the steps in this article: https://doc.sitecore.com/developers/93/platform-administration-...
1
vote
0answers
113 views

Sitecore Paas installation failure - AppGallery Deploy Failed: The declared parameter 'Application Path' is not recognized

We are trying to create Sitecore 9.2 instance in azure PaaS using ARM templates. The ARM templates worked fine. Now we have modified the ARM templates to install the JSS module with Sitecore while ...
1
vote
0answers
165 views

Sitecore Azure search suggesting index rebuild error

I have implemented Sitecore Suggesting search on Sitecore 9.2. based on https://sitecore.namics.com/2018/06/15/sitecore-9-azure-search-suggestions/ but when I rebuild indexes, I am getting error: ...
1
vote
1answer
424 views

SolrCloud on Azure PaaS

I am setting up a Sitecore 9.2 Production instance and ideally would like to Setup SolrCloud in Azure PaaS Web Apps. In test environments i have setup Solr on a single PaaS App Service and it is ...
1
vote
0answers
310 views

Clean install on Azure SQL Managed instance

I am trying to install Sitecore 9.2 vanilla on Azure with SQL Managed Instance but I am getting the following error { "status": "failed", "error": { "code": "ResourceDeploymentFailure", "...
1
vote
0answers
66 views

How can I add a new QA environment to existing Sitecore Azure Paas setup?

We have an existing Sitecore 9 setup in Azure Paas. It includes one CD and one CM server with no xDB. Now we're looking to add a new QA environment which will effectively be a copy of CM with its own ...
1
vote
0answers
282 views

NullReferenceException while setting up ApplicationInsights with Sitecore 9.1 PaaS

We are following post below for the steps to configure ApplicationInsights and also have applied the patch as specified in the article. After setting things we are getting a NullReferenceException (...
1
vote
0answers
33 views

How to get current browser url with Azure AD authentication (OWIN) : <owin.identityProviders>

Currently we have the requirement like we want set redirect url as per current browser url So for that we trying to set redirect url custom implementation of IdentityProvidersProcessor , but its ...
1
vote
0answers
65 views

Sitecore 8.2 Azure Web App / Solr VMs

We are running Sitecore 8.2 as a WebApp on Azure, with this we using Solr on VMs , using along with Zookeeper [3 nodes]. There is odd behavior we are seeing, if we make any configurations on Solr as ...
1
vote
0answers
263 views

rebuild the xDB index in Azure Search didn't finished

I followed this article to rebuild the xDB index in Azure Search. About 2 hours after the rebuild index process started, i noticed that the rebuild process seemed to stopped (document of xdb-...
1
vote
0answers
143 views

Powershell script fails on trying to start website when installing the Sitecore 9.0.1

My powershell script fails when I try to run it on the Azure VM. The local installation passes successfully. Any help is appreciated :) > [-------------------------------------------- ...
1
vote
0answers
226 views

Redis session provider not working on Azure PaaS webapp

I am working on a Sitecore 9 solution which is hosted on Azure PaaS. I have a simple piece of code that is meant to store an object in session which works fine on my local machine but once deployed ...
1
vote
0answers
231 views

Page test in Experience Optimization on Azure Fails

Sitecore Experience Optimization Page Testing. On Sitecore 9, I am trying to test created simple page in Experience Optimization. Locally everything working fine. When i tried same steps in Azure ...
1
vote
0answers
58 views

Browsing individual delivery server in Azure scaling environment

We are on Sitecore 8.1 rev. 151207 (Update-1) When we scale an existing Azure Delivery Farm, using Sitecore Azure module, we are seeing the additional server, but we are not seeing anything deployed ...
1
vote
1answer
252 views

Sitecore 8.2 Update 4 in Azure SQL

Sitecore 8.2 Update 4 I am looking to run Sitecore in IaaS. Azure VMs for web and Azure SQL for database. Not the new Azure service stack. Its great that Sitecore comes with dacpac files in all ...
0
votes
0answers
31 views

Upload file more than 200 mb in content hub

I am trying to upload files more than 200 MB in Sitecore Content Hub using Blob Storage URLs. For file size 700 MB it is working fine. But for more than 1 GB files, the Azure Blob SAAS URL is getting ...
0
votes
0answers
55 views

Powershell script fail with 'Access to the cloud file is denied' error when trying to install SitecoreAzure.Binder module

PackageManagement\Install-Package : Access to the cloud file is denied At C:\Program Files\WindowsPowerShell\Modules\PowerShellGet\2.2.5\PSModule.psm1:9711 char:34 + ... talledPackages = ...
0
votes
1answer
21 views

Using vhost for JSS Multi-site setup on Azure App Service

I have a headless proxy multisite setup locally using JSS. I have two sites, SiteA and SiteB. I'm using vhost in node to serve as a middleware to resolve the hostname. http://expressjs.com/en/...
0
votes
0answers
54 views

Redis cache issue of sitecore 9.3 hosted with azure app services

We are using sitecore 9.3 on azure PAAS, and trying to check the feasibility of number of users who can access application at a time. On load test with 250 users we are getting the following error on ...
0
votes
0answers
35 views

Sitecore 10.0 use Sitecore Azure Toolkit to add SXA to an existing instance of Sitecore

For Sitecore 10.0 (sitecore hosted) installed on Azure App Services what is the commandlet in Sitecore Azure Toolkit to add SXA the existing instance? I have the file Sitecore Experience Accelerator ...
0
votes
0answers
37 views

Lighthouse demo code deployment to azure

Is it possible to deploy the lighthouse demo code to azure app services? We would like do a POC to play around before we plan for our upgrade. We would need to install the below to azure instead of ...
0
votes
2answers
60 views

Sitecore CD app service connection string is being ignored

I am trying to setup Sitecore CD to work with Blue/Green deployments. As part of this configuration, I am tying to get our database to stay sticky to the staging and production deployment slots This ...
0
votes
0answers
24 views

Azure blob storage: still save some blobs to SQL

Sitecore 9.3 We switched to Azure blob storage to store the media items. We installed Azure Blob Storage module,turned it on, migrated all the existing media library items to Azure, and everything ...
0
votes
0answers
19 views

Ensure Azure Content Search Provider uses a filter for a query

We have a number of searches on our site that should be possible through a pure filtered search - we're searching across a few fields, some of which are mutli-selects, others are booleans and one's a ...
0
votes
0answers
21 views

Redirect on authorization path exposes azure domain

We are using Sitecore 9.3 hosting in azure environment and we have an issue on the CD site, when the user enters the url e.g, https://customdomaincdurl/ap_config it is expected to redirect the user ...
0
votes
1answer
53 views

Sitecore PaaS Web DB spikes

We’ve just migrated from Sitecore 8.2.5 on-prem to 9.3 Azure PaaS. Performance seems ok most of the time, but we’re seeing regular spikes to 100% DTU on the web db. The db is standard S2 50 DTU and we’...
0
votes
0answers
265 views

.aspnet.cookie is not set after Azure AD B2C successful authentication

We have an ASP.NET webforms application with Sitecore 9.0.0 Initial release, and we want to use Azure B2C as an external identity provider for our external users. We created the new authentication ...
0
votes
0answers
30 views

Sitecore 9 Analytics - added user agent in the <excludedUserAgents> not working

We have Sitecore 9.0.2 based UAT and Live website in Azure PaaS environment. Before some time we have configured Sitecore analytics tracking in UAT and Live both. Now what happened is in both ...
0
votes
0answers
56 views

Problem Installing to Azure China

Sitecore 9.2 I am trying to run an ARM Template to install Sitecore to Azure China. I set the location parameter to "China East 2". When I run Start-SitecoreAzureDeployment, it creates the ...
0
votes
0answers
317 views

“XdbContextLoggingPlugin” XdbContext Batch Execution Exception

I am getting an SQL exception in the XConnect application. Error: ["XdbContextLoggingPlugin"] XdbContext Batch Execution Exception XdbContextLoggingPlugin MessageTemplate: [{0}] XdbContext ...
0
votes
0answers
50 views

How to setup one common CMS and two CD server in different region in Azure Pass Architecture?

Currently we have scaled environment setup on Azure Pass i:e one CM and one CD server in common region. Now we have created one more site but its for another region and due to compliance policy we can'...
0
votes
1answer
70 views

Node version issue in Multisite Sitecore jss application in Azure

I have 2 jss apps deployed to azure. Both are built on node 12.15.0 and I have WEBSITE_NODE_DEFAULT_VERSION as 12.15.0 in azure app settings but Only one of the apps is getting loaded at a time. For ...
0
votes
0answers
128 views

Issue when trying to enable Azure Blob storage to sitecore 9.3

I tried to enable Azure blob storage to sitecore 9.3. I configured as per the doc(https://doc.sitecore.com/developers/93/sitecore-experience-manager/en/enable-the-azure-blob-storage-module-for-...