Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

Filter by
Sorted by
Tagged with
0
votes
1answer
28 views

Sitecore.IO.FileWatcher Error

I have an issue with the test site which broke after I had done a deployment with VSTS. The test environment is hosted on Azure in a webservice app. I know it has to do something with the files in the ...
0
votes
1answer
163 views

ERROR Could not run the 'getMediaStream' pipeline for '/sitecore/media library/Images/test '. Original media data will be used

I’ve extended SqlServerDataProvider to use the azure blob storage account for storing the media library assests. I’ve taken reference from below GitHub project: https://github.com/aweber1/Sitecore....
3
votes
0answers
17 views

Accessing Azure B2C Access Token with Sitecore ID Server

In Sitecore 9.1 we have integrated Azure B2C with Sitecore Identity Server. We now need to get access to the Azure B2C Access Token on the Sitecore CD server, which was based to Sitecore Identity ...
1
vote
0answers
34 views

SolrCloud on Azure PaaS

I am setting up a Sitecore 9.2 Production instance and ideally would like to Setup SolrCloud in Azure PaaS Web Apps. In test environments i have setup Solr on a single PaaS App Service and it is ...
1
vote
0answers
58 views

Clean install on Azure SQL Managed instance

I am trying to install Sitecore 9.2 vanilla on Azure with SQL Managed Instance but I am getting the following error { "status": "failed", "error": { "code": "ResourceDeploymentFailure", "...
14
votes
2answers
277 views

Excessive SQL Server DTU consumption after deployment to Azure (messaging_db)

After an initial Sitecore 9.1 deployment with Sitecore Managed cloud (Default installation, x-small no custom code and configuration). We notice an excessive DTU consumption on the messaging database....
4
votes
1answer
553 views

Getting Required license is missing: Runtime

I am setting up Sitecore on Azure Web app PaaS. I am using the official Sitecore packages to deploy a CD and CM role to azure. These have been deployed as vanilla Sitecore instances with no ...
0
votes
2answers
39 views

How to bind multiple custom domains and redirect to azure web app

I'm going to deploy my web app which hosted in IIS (Window VM) to Azure app service as the following current behavior: Note: mhksite.com is primary domain "*:80:mhksite.com" => redirect to home ...
3
votes
2answers
2k views

Index has not been initialized on content delivery server

I'm using Sitecore on Azure, and I followed the wizard to create a project with a CD and a CM. I have a custom index SinglePageUrl on both of them with a web and a master version to Rewrite some ...
4
votes
1answer
55 views

XConnect `The HTTP response was not successful: Forbidden` on Azure

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make .Net core 2.2 projects published on azure app service, not on the same instance of Sitecore azure connects to XConnect, I was ...
7
votes
2answers
399 views

Package installation wizard slow on our servers

We have problems deploying Sitecore update packages to our servers. Using Sitecore Update package wizard in a local machine to deploy master update package takes about 70-90 seconds, but in the ...
4
votes
1answer
105 views

Provisioning to Azure failure on deploying CM

I am trying to setup a new Sitecore 9.2 instance on PAAS using ARM templates. I used these templates a few months ago on the same subscription to setup our development environment and that worked fine....
0
votes
1answer
68 views

Sitecore Azure PaaS Client Certificate on ASE

I deployed Sitecore 9.2 on Azure PaaS and facing the issue with Client Certificate Authentication. The Azure hosting is on ASE with Isolated App Service Plan. It seems like CM server is not able to ...
1
vote
0answers
49 views

How can I add a new QA environment to existing Sitecore Azure Paas setup?

We have an existing Sitecore 9 setup in Azure Paas. It includes one CD and one CM server with no xDB. Now we're looking to add a new QA environment which will effectively be a copy of CM with its own ...
2
votes
1answer
188 views

Does Sitecore support Azure Web App for Containers?

Windows Server Containers in Web App are now available in public preview, and I wonder if Sitecore provides any sort of support to run an environment in containers, specifically to Web App for ...
1
vote
1answer
36 views

Migrate Content to Azure

I have installed a baseline 8.2.7 Sitecore to Azure using the XP templates in the Azure ToolKit. How to I get my existing content into the databases ? If I try to import a bacpac file I get a new ...
2
votes
2answers
83 views

How to host custom Sitecore solution in Azure PaaS

I am using Azure PaaS as an environment of Sitecore 9.2.0 (XP + XC) with one custom solution. Can anyone please tell me how to deploy that custom solution into Azure Paas, as there are 17 web apps. ...
1
vote
1answer
35 views

Maintenance Page in Sitecore Azure PaaS

I have a Sitecore 9.0.2 environment in Azure PaaS. It is connecting to different third party services to get and data. Whenever third party update their system or make any new release our portal goes ...
1
vote
2answers
95 views

Azure WebApp XDB apps cannot find service 'KeyStoreProviders'

I'm upgrading from 9.0.2 (XM) to 9.2 (XP), so I got a fresh install of the XDB enviroments (Azure WebApps), but my xcollect, ma-ops, xc-search (Solr), and maybe other webapps give me the You do not ...
1
vote
2answers
119 views

Unable to install Sitecore Horizon 9.3 on Azure

I have installed Sitecore 9.3 XP Single on Azure using Sitecore Experience Cloud (Azure Marketplace). Now I want to install Sitecore Horizon 9.3 on existing Azure Sitecore 9.3 instance. While ...
1
vote
1answer
49 views

Sitecore.XConnect.XdbSearchUnavailableException

Hi I was installing Sitecore in Azure Web App. It has been installed without SOLR cores in SOLR server (in this case I have a separate SORL VM along with Web apps for Sitecore PaaS). Once I have ...
3
votes
1answer
74 views

How to replace `CertificateHttpClientHandlerModifier` to `X509Certificate2`

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on azure app service connects to XConnect which is also on Azure, am following this link ...
3
votes
1answer
53 views

Connecting two Azure services to access XConnect

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on app service azure connects to XConnect which is also on Azure, am following this link ...
4
votes
1answer
103 views

DTU shooting up after application start in Azure PAAS Sitecore 9.0.2

We are observing that DTUs are shooting up while the application startsup in Azure PAAS environment, however the frequency is not consistent- sometime we restart the webapp explicitly and sometime it'...
6
votes
1answer
94 views

Log stream on Azure Paas

I have an environment running Sitecore 9.2 on Azure PAAS. It's an upgraded codebase (from 9.0.2) but on a clean setup. I had an issue with logging. Application Insights is working fine - I can see my ...
0
votes
1answer
156 views

Azure Search &search=This_Is_Equal_ConstNode_Return_Nothing

I have a site that I have recently been upgrading from 8.2 to 9.1 and everything is looking good EXCEPT anything that relies on search funcionality. Any Azure search has in the info log: 2019-02-...
0
votes
1answer
117 views

Azure DevOps - Release Pipeline for TDS Project

I have created Azure DevOps CI in `Azure DevOps. That CI is generating a TDS WebDeploy Package as an artifact. Now I need to create a release pipeline to Deploy and install the items in TDS to Azure ...
1
vote
2answers
40 views

Azure Deploy of CM + Reporting

I'd like to build a deployment of CM and Reporting in a single App Service. Is the best approach to take the XP0 files and try to remove what isn't needed ? Or try and combine The CM and Reporting ...
6
votes
1answer
93 views

Azure Traffic Manager and Sitecore 9.2.0 PaaS

Background We are trying to create a "lightweight" failover setup, consisting of a failover CD instance with the core + web database being replicated (Azure SQL failovergroup). Additionally, that ...
1
vote
0answers
48 views

Integration with AD B2C: Trigger Owin challenges by policy name

We're using Sitecore.NET 9.1.0. We're trying to trigger register, login and forgot password flows from Sitecore that will be used by end users of our website. After a successful login we want to ...
0
votes
0answers
43 views

Azure DevOps tds project build not creating web deploy package

I have added a task to build my tds project. The TDS Project contains configurations to create web deploy package. When I build it manually in Visual Studio, it creates a package and .ps1 file in ...
4
votes
0answers
39 views

Azure Deployment Slot Processing Events and Updating Indexes

We have a deployment slot that we deploy to, which we then warm up, and then swap with the live slot so that we can achieve zero downtime deployment on PaaS. This works very well in general. However, ...
12
votes
2answers
2k views

WAF support with Sitecore Experience Platform

We are looking for a Web Application Firewall (WAF) solution for our Sitecore CMS implementation, because we are an Azure shop we specifically wanted to use the WAF feature on the Azure AppGateway ...
3
votes
1answer
94 views

HTTP Error 502.5 - Process Failure

I was installed Sitecore XC 9.2.0 Scaled using the ARM template. After successful installation, when I am trying to open theBizFX web app, getting this error. Most probably getting this error ...
0
votes
2answers
204 views

After deploying Habitat to Azure I am getting rendering error

While opening the item in the Experience editor I am getting a lot of errors like the below: Error Rendering View: /Views/MediaFeature/LightboxVideo.cshtml: Error while rendering view: '/Views/...
1
vote
1answer
242 views

Secure Azure SQL database connection using a managed identity

We are currently hosting our Sitecore 9.1 initial release on premises, but want to move the complete solution into Azure. We want to use public services and not put our solution in an ASE. To secure ...
0
votes
2answers
134 views

Sitecore 9.1.1 Azure Search custom index not updating when running rebuild

I'm trying to port an application to Azure Search from Solr. I've got the sitecore indexes working and rebuilding. The documents are being added to the azure search index. However for any custom ...
7
votes
1answer
74 views

How to filter application insights logs based on log file type

In a regular Sitecore deployment, the logs are written to files such as Crawling.log.yyyyMMdd.txt Search.log.yyyyMMdd.txt log.yyyyMMdd.txt and Publishing.log.yyyyMMdd.txt. When viewing logs in Azure ...
2
votes
0answers
101 views

How to create a Sitecore Module WDP packge **WITH** Sitecore items?

I was following the official documentation on the subject here https://doc.sitecore.com/developers/sat/20/sitecore-azure-toolkit/en/web-deploy-packages-for-a-module.html and realized that it looks ...
1
vote
1answer
43 views

URL rewrite from www to naked domain

We've got a Sitecore 9 Azure app service instance We've got redirects set up as follows: <rule name="Root Hit Force HTTPS Redirection" enabled="true" stopProcessing="true"> <match url="...
2
votes
1answer
53 views

Can Sitecore be configured to automatically recover after restarting the Solr service?

We are hosting Sitecore 9 on Azure App Services using Solr as the search provider. Microsoft will occasionally restart the server that is hosting Solr (due to ... updates made by Microsoft to the ...
0
votes
2answers
28 views

Base Templates are deployed without any language version

We have very bizare issue with our deployment. Project contains of multiple templates and we recently (couple of months ago) introduced couple of base templates. We have prefixed them with underscore,...
1
vote
1answer
144 views

Sitecore setup using Azure VM Scale sets

Has anyone implemented CD server on Azure VM Scale sets? Looking at below information: The CD Image process as per the VM Scale set process When the Image is used to scale VMs using Azure approach, ...
1
vote
2answers
140 views

How to link Sitecore 9.2 and SOLR running on Azure App service

I have installed SOLR 7.5 on Azure App service and this SOLR instance is running fine. Now I have installed Sitecore 9.2 through Azure Sitecore marketplace and mentioned this SOLR url as a search ...
1
vote
1answer
70 views

Where to download Azure SDK 2.7.1 needed to deploy Sitecore Azure 8.1?

We are building a development environment for Sitecore 8.1 Update 1 with Sitecore Azure 8.1. Since Sitecore Azure requires Azure SDK 2.7.1 to be deployed, I am having such a bad day trying to figure ...
0
votes
1answer
160 views

Multi-Site Domain is not resolving Using Azure WAF

I am facing domain resolving issue in Sitecore Multi-Site Solution using Azure PaaS with Azure WAF setup, however, it's working fine if I add the custom domain on Content delivery(Web Apps) level. ...
0
votes
1answer
129 views

How does the gulp build transform Sitecore config files?

I'm migrating Sitecore 9.1.0 to Azure. During the process of build on Azure DevOps, I have a gulp tasks, which builds the solution and transforms the configuration files. On certain configuration ...
1
vote
1answer
72 views

Location of Redis cache connection String in XC 9.2.0 PaaS Scaled

I have installed Sitecore 9.2.0 XC Scaled in Azure PasS. Hence there are two Redis cache has been created in azure portal, one for XC and one for XP. I was able to find out where the Redis cache ...
2
votes
2answers
94 views

CORS Error while downloading the fonts from the Azure CDN using Sitecore PaaS

We have configured the Azure CDN for Sitecore Web Apps website, everything is working fine except the Fonts rendering from CDN, and we are getting below error: Any suggestion?
3
votes
1answer
83 views

'Aspnetcoreruntime' not found in scaled ARM template

I was trying to install Sitecore 9.2.0 XP Scaled in Azure using ARM template. But I am getting an error named 'AspNetCoreRuntime' not found. { "id": "/subscriptions/72a1bd21-63be-430d-b8a9-...