Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

Filter by
Sorted by
Tagged with
0 votes
1 answer
32 views

Does anyone know how to delete the Log files FOLDERS

Ok so I have a patch that looks like below, it does a good job of deleting 2 day and older logs but however it just leaves the folder itself. I tried adding the section above which is bolded but it ...
user avatar
0 votes
1 answer
27 views

How to run a long user process on a background thread instead of the request thread?

I have an export tool that scans content in Sitecore and generates a CSV. When exporting the entire content tree or a very large folder, it tends to time out on Azure apps which have a hard limit of ...
user avatar
1 vote
0 answers
23 views

Experience editor ribbon disappear

When I open a site in experience editor mode, I see the editor ribbon, but after I navigate on the site, the ribbon disappears. Everything is fine in the local environment, but the error occurs in ...
user avatar
0 votes
0 answers
31 views

Signing out of Sitecore with Azure AD

We are working on an upgrade from Sitecore 8.2 to 10.2 with an Azure AD sign-in/sign-out component. Right now, when a user is logged in with Azure AD in Sitecore and clicks the logout button it is ...
user avatar
0 votes
0 answers
38 views

Failed to start service 'Sitecore Marketing Automation Engine [duplicate]

I am getting error "Failed to start service 'Sitecore Marketing Automation Engine - gettingStartedxconnect.dev.local-MarketingAutomationService (gettingStartedxconnect.dev.local-...
user avatar
  • 1
0 votes
1 answer
49 views

Intermittent "Unable to connect remote server" on Azure hosted sitecore 10.2 site

We have a Sitecore 10.2 site hosted on Azure App services. Very often site is getting down with the blank page throwing error Unable to connect remote server. If we refresh multiple times, then site ...
user avatar
  • 25
0 votes
1 answer
63 views

Sitecore 10.2 on Azure Virtual machine

I am new to Sitecore and trying to create a Sitecore development environment. I was planning to build an Azure Virtual machine with Windows 11 Pro N, 16 GB RAM. Just wanted to confirm that If we can ...
user avatar
  • 1
0 votes
0 answers
33 views

While rebuilding sitecore index getting java.nio.file.NoSuchFileException

We have deployed Sitecore instance in Azure.When we try to rebuild master index getting below exception. We are using Sitecore 9.0.1 version. java.nio.file.NoSuchFileException: D:\home\site\wwwroot\...
user avatar
  • 29
0 votes
1 answer
41 views

When this URL(/sitecore/shell/Applications/Buckets/Services/Search.ashx) gets called

We have deployed Sitecore into the Azure cloud. We often see Sitecore CM instance getting down, to fix this slowness check the http5xxx error on the azure web APP. As part of troubleshooting noticed ...
user avatar
  • 29
0 votes
1 answer
79 views

After Login on Sitecore CMS does not redirect to Content Editor and throws error 500 - The request timed out

I have deployed our Application on PROD CM and CD instance on the Azure PAAS and the instance is working fine. When I try to log in to the CM instance, I can log in, but instead of redirecting me to ...
user avatar
2 votes
1 answer
23 views

PowerShell Remoting not working with an Azure VM

I'm trying to connect to a VM hosted in Azure and for some reason the remoting connection never established like you would typically see while on a corporate network. Things I've checked: Enabled PS ...
user avatar
  • 16.6k
0 votes
3 answers
155 views

Webp Image not generating when azure CDN enabled

With Dianoga.WebP.config enabled, I replaced JSS media handler in web.config: with custom one: using MediaRequestHandler = Sitecore.JavaScriptServices.Media.MediaRequestHandler; public class ...
user avatar
0 votes
0 answers
63 views

Reset Admin password in Sitecore 10.2 using SQL in Azure CM instance

I am working on the Sitecore 10.2 version and the solution is deployed on Azure PAAS, Now I trying to reset the admin password to log in on the CM instance. I have gone through with the below question ...
user avatar
0 votes
0 answers
39 views

OAuth2.0 Federated authentication with Sitecore 9.3

We are upgrading our existing site from Sitecore 8.2 to Sitecore 9.3. We are using federated authentication for our CD site with OAuth2.0. The login to the site is working as expected but in the ...
user avatar
0 votes
2 answers
122 views

Is there a way to access Azure keyvault secrets from sitecore site

I have some secrets stored in azure keyvault. Using the following code, I was able to get the secret values via a console application. using System.Management.Automation; Collection<PSObject> ...
user avatar
  • 317
0 votes
2 answers
52 views

Provision new Azure PaaS staging environment as a copy of Production

Our current production environment is XP 9.1.1 scaled on Azure App Services PaaS. We need to quickly provision a new staging environment as an exact replica of current production one. As you are aware,...
user avatar
  • 33
0 votes
0 answers
27 views

sitecore managed cloud HttpRequstBegin patch config

I have a patch config for HttpRequstBegin... On my local dev it is working as expected. When deployed to sitecore managed cloud it's not getting added before "Sitecore.Pipelines.HttpRequest....
user avatar
0 votes
0 answers
24 views

Static ile like Base theme js and css files returning with HTTP error code 403 - forbidden

We have enabled optimizations for JS and CSS files and the optimized files come from azure CDN but we are getting 403 requests for base theme files in Application Insights. GET /-/media/Base-Themes/...
user avatar
1 vote
0 answers
196 views

Hard Time Creating mssql-init image with Multiple Modules on XP1

I'm trying to create an mssql-init image for XP1 that will install the following components: SPE module CH connector SXA module Coveo Coveo SXA I'll be using this to deploy to an Azure SQL server. I ...
user avatar
0 votes
1 answer
57 views

Unable to find any CM login information in Sitecore 10.1

I cannot find any login messages in my Azure application insights. Only found a logout message like this: AUDIT (sitecore\foo.bar): Logout: sitecore\foo.bar. Does anyone know where to find the login ...
user avatar
2 votes
1 answer
90 views

Sitecore Scheduled task runs on startup

I'm using Sitecore 9.3, I have a custom scheduled task for rebuilding the Sitecore search index at night. My project is hosted on Azure environment, I noticed that if I restart the CM app service then ...
user avatar
0 votes
0 answers
35 views

running unit tests in azure build pipeline for a helix project

We are trying to update our Azure build pipeline to run our Unit tests for our SC 8.2 instance. Our project is structured using helix and our build / publish is done using Gulp. It looks to me like ...
user avatar
1 vote
1 answer
170 views

Not Able to Sync Azure Key Vault Secrets Into Sitecore Pods

I'm following this Microsoft document to integrate AKS with KeyVault: https://docs.microsoft.com/en-us/azure/aks/csi-secrets-store-driver I'm using Sitecore 10.1.0 that uses AKS, my idea is to sync ...
user avatar
0 votes
0 answers
140 views

Login failure for collection user after migrating to Azure SQL

"login failed for collectionuser" errors appear after migrating our Sitecore 10.1.1 databases from self-hosted SQL Server on VM to Azure SQL Database. The site itself is working, but ...
user avatar
0 votes
0 answers
13 views

BlobProviderException - Can't publish media items from Master to Web database [duplicate]

When I am publishing many media items from the master to the web database, it crashes at some point in the process with the following exception: Job started: Publish to 'web'|#Exception: System....
user avatar
1 vote
1 answer
64 views

Sitecore SQL Migration to Azure is Blocked

We have an on premises instance of Sitecore 10.1.1 and want to move the databases from SQL Server on VM to Azure SQL Database. We are leaving the Sitecore sites on VM for now. A migration blocker in ...
user avatar
2 votes
1 answer
278 views

Application Insights on Sitecore 10.1 not logging custom errros from the application

I tried to install Application Insights on Sitecore 10.1 project in Azure PaaS. After installing the AI SDK and configuring the instrumentation key the app insights started to pick up Sitecore logs e....
user avatar
  • 77
0 votes
2 answers
569 views

Upgrade Sitecore 9.1 to Version 10.1.1

We have Sitecore 9.1.1 currently deployed on production environment. Our topology is scaled on Azure App services. It's required to upgrade current version (9.1.1) to the latest Sitecore version (10.1....
user avatar
  • 33
0 votes
1 answer
74 views

Resolve Sitecore.XConnect.Operations.FacetOperationException - should CDs share common redis cache?

The logs of my site are getting full with Sitecore.XConnect.Operations.FacetOperationException. The site uses Sitecore 9.2 in a load-balanced setup on azure with CD1 in UK South and CD2 in UK West ...
user avatar
1 vote
1 answer
111 views

Solr suspicious behavior

I've Sitecore instance hosted on Azure according to below breakdown : Sitecore 9.1 (each component as standalone App Service) Solr 7.2.1 (standalone App Service) App insights configured and connected ...
user avatar
  • 33
0 votes
1 answer
1k views

AzureRM.Profile already loaded when deploying to Azure

I am trying to deploy vanila sitecore 9.1.1 (XM single) to Azure Paas. For this I am using Sitecore Azure Toolkit and Sitecore ARM templates. Below is the Powershell script I am using. $SCTemplates=&...
user avatar
  • 572
1 vote
0 answers
74 views

Files not found on Azure Paas

We have a solution installed on Azure Paas. In the logs we have next errors: Exception: System.IO.FileNotFoundException Message: Could not find file 'D:\home\site\wwwroot\sitecore\shell\client\...
user avatar
  • 17.8k
0 votes
0 answers
111 views

Upload file more than 200 mb in content hub

I am trying to upload files more than 200 MB in Sitecore Content Hub using Blob Storage URLs. For file size 700 MB it is working fine. But for more than 1 GB files, the Azure Blob SAAS URL is getting ...
user avatar
  • 421
2 votes
1 answer
89 views

How to profile Sitecore startup time in Azure

It is quite easy to profile Sitecore startup time on-premise, e.g. using JetBrains dotTrace. However, I can't find any good tools to do the same with Sitecore in Azure. JetBrains dotTrace simply does ...
user avatar
  • 342
0 votes
0 answers
988 views

Powershell script fail with 'Access to the cloud file is denied' error when trying to install SitecoreAzure.Binder module

PackageManagement\Install-Package : Access to the cloud file is denied At C:\Program Files\WindowsPowerShell\Modules\PowerShellGet\2.2.5\PSModule.psm1:9711 char:34 + ... talledPackages = ...
user avatar
  • 1
0 votes
1 answer
191 views

How can I show static page during a deployment to Sitecore Manage Cloud?

We are using Sitecore Managed Cloud and we have just one CD web app. Obviously when we deploy the website goes down and we would like to show a static page to the users during this time. Is there an ...
user avatar
  • 77
0 votes
1 answer
77 views

Using vhost for JSS Multi-site setup on Azure App Service

I have a headless proxy multisite setup locally using JSS. I have two sites, SiteA and SiteB. I'm using vhost in node to serve as a middleware to resolve the hostname. http://expressjs.com/en/...
user avatar
  • 353
0 votes
1 answer
71 views

Sitecore 10.0 use Sitecore Azure Toolkit to add SXA to an existing instance of Sitecore

For Sitecore 10.0 (sitecore hosted) installed on Azure App Services what is the commandlet in Sitecore Azure Toolkit to add SXA the existing instance? I have the file Sitecore Experience Accelerator ...
user avatar
3 votes
1 answer
187 views

How do the xConnect Docker containers correspond to the Azure xConnect app services?

I've tried to find documentation on the various xConnect roles that exist and their names and map them to the names of the xConnect containers in an XP1 container setup and an Azure PaaS configuration,...
user avatar
  • 5,085
3 votes
2 answers
373 views

Does Sitecore 10.0.1 support SAML with Okta?

I am using Sitecore 10.0.1 on the Azure App Services platform. I would like to implement federated authentication using saml. I was only able to find documentation using open id connect. Does ...
user avatar
0 votes
2 answers
223 views

Sitecore CD app service connection string is being ignored

I am trying to setup Sitecore CD to work with Blue/Green deployments. As part of this configuration, I am tying to get our database to stay sticky to the staging and production deployment slots This ...
user avatar
0 votes
0 answers
66 views

Unable to install Mssql init job in azure AKS [duplicate]

I was trying to install sitecore on my azure AKS engine. When I run the mssql-init file the jobs fail to create with the following error: Start publishing dacpacs Sqlcmd: Error: Microsoft ODBC ...
user avatar
1 vote
0 answers
375 views

Sitecore login redirects to website and not Launchpad

We are using azure alias URL "https://abc.com/sitecore/login" to access our prod CM site "https://abc-1001-cm.azurewebsites.net/sitecore/login". Earlier we had Sitecore 9.0.1 ...
user avatar
1 vote
1 answer
412 views

How to setup Application Insights for a Solr service hosted on Azure PaaS

We have an Azure PaaS environment for Sitecore 9.3 and Solr App services created. Is there any way to connect Application Insights for the Solr App service? For CM and CD services we have setup the ...
user avatar
2 votes
2 answers
225 views

JSS: Azure deployment

In our case, both test and prod environments are Azure app services. So currently when we deploy to test: I replace the layoutServiceHost and deployUrl in scjssconfig.json to be the address of QA ...
user avatar
  • 554
0 votes
1 answer
121 views

Sitecore PaaS Web DB spikes

We’ve just migrated from Sitecore 8.2.5 on-prem to 9.3 Azure PaaS. Performance seems ok most of the time, but we’re seeing regular spikes to 100% DTU on the web db. The db is standard S2 50 DTU and we’...
user avatar
3 votes
2 answers
805 views

Hard time installing Sitecore 10 external resources in Kubernetes AKS in Azure

I'm trying to install Sitecore 10 on AKS so I was following the steps in Installation_Guide_for_Production_Deployments_with_Kubernetes_XP10.0.0.pdf Installed azureCli & helm on my local pc az ...
user avatar
1 vote
0 answers
491 views

.aspnet.cookie is not set after Azure AD B2C successful authentication

We have an ASP.NET webforms application with Sitecore 9.0.0 Initial release, and we want to use Azure B2C as an external identity provider for our external users. We created the new authentication ...
user avatar
  • 11
1 vote
1 answer
120 views

I've trying to install Sitecore, getting error: Missing source parameter

I am trying to install Sitecore 9 update 2 on Azure. I am getting this error: Package deployment failed ARM-MSDeploy Deploy Failed: 'Microsoft.Web.Deployment.DeploymentClientServerException: Missing ...
user avatar
  • 11
1 vote
1 answer
117 views

unicorn deployment failure - can't sync when deployed to real environments

I am sure I am missing something simple about using Unicorn in environments above the local dev environments the source folder is correct out of Azure Paas, out on my App Service I am in Sitecore 9.3....
user avatar

1
2 3 4 5
8