Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

51 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
14
votes
2answers
314 views

Excessive SQL Server DTU consumption after deployment to Azure (messaging_db)

After an initial Sitecore 9.1 deployment with Sitecore Managed cloud (Default installation, x-small no custom code and configuration). We notice an excessive DTU consumption on the messaging database....
8
votes
0answers
148 views

Virtual field not working with Azure

Currently I'm using facet to filter the search result. The result works perfectly with SOLR but when I switch to Azure it doesn't work anymore. The result shows all although I added filter criteria. ...
6
votes
1answer
516 views

Migrating Solr Core indexes to Azure Search indexes

I am midst of migrating a Sitecore project to Azure Paas offering. I've completed the deployment of the files (ie. dlls, configs, css, js, etc) and were able to do a complete unicorn sync. That looks ...
4
votes
0answers
41 views

Azure Deployment Slot Processing Events and Updating Indexes

We have a deployment slot that we deploy to, which we then warm up, and then swap with the live slot so that we can achieve zero downtime deployment on PaaS. This works very well in general. However, ...
4
votes
0answers
92 views

Log Sitecore errors as exceptions instead of trace in application insights

By default, Sitecore application insights config logs Sitecore errors as traces instead of exceptions this means application insights dashboard and alerts are unaware of the exception occurring in a ...
4
votes
0answers
440 views

Index errors on start up on Azure environment

When starting our application we are seeing lots of these entries: 2017-06-29T08:38:59 PID[60944] Error 8168 08:38:59 ERROR Custodian.UpdateIndexTimestampTimerTick. Update index last updated ...
3
votes
0answers
21 views

Accessing Azure B2C Access Token with Sitecore ID Server

In Sitecore 9.1 we have integrated Azure B2C with Sitecore Identity Server. We now need to get access to the Azure B2C Access Token on the Sitecore CD server, which was based to Sitecore Identity ...
3
votes
0answers
131 views

Installation issue on migration 9.1.1

I am trying to migrate a Sitecore 9.0.2 to 9.1.1. Following the upgrade guide https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform/91/Sitecore_Experience_Platform_91_Update1.aspx, I have to ...
2
votes
0answers
35 views

Losing Session Value in Sitecore 9.0.2

I have a Sitecore 9.0.2 portal in Azure PaaS from where we are making some transactions. I am posting form to the payment gateway using form post method and gateway is returning the response to a ...
2
votes
0answers
181 views

Sitecore schedule task not running on the XP scaled environment (CM server)

We’ve configured Sitecore schedule task, which runs at every 1 hour. The schedule task is running fine after deployment/web app restart but after sometime it’s not working as expected. We’ve verified ...
2
votes
0answers
105 views

How to create a Sitecore Module WDP packge **WITH** Sitecore items?

I was following the official documentation on the subject here https://doc.sitecore.com/developers/sat/20/sitecore-azure-toolkit/en/web-deploy-packages-for-a-module.html and realized that it looks ...
2
votes
0answers
301 views

Sitecore-Core-Index rebuild at Azure Search for Sitecore 9.0.1 PaaS fails

I have deployed Sitecore 9.0.1 XP Scaled in Azure PaaS (default, no customization). It is used self-signed certificate and configured with allowInvalidClientCertificates="true" in azuredeploy....
1
vote
0answers
38 views

Sitecore Paas installation failure - AppGallery Deploy Failed: The declared parameter 'Application Path' is not recognized

We are trying to create Sitecore 9.2 instance in azure PaaS using ARM templates. The ARM templates worked fine. Now we have modified the ARM templates to install the JSS module with Sitecore while ...
1
vote
0answers
39 views

Sitecore Azure search suggesting index rebuild error

I have implemented Sitecore Suggesting search on Sitecore 9.2. based on https://sitecore.namics.com/2018/06/15/sitecore-9-azure-search-suggestions/ but when I rebuild indexes, I am getting error: ...
1
vote
0answers
46 views

SolrCloud on Azure PaaS

I am setting up a Sitecore 9.2 Production instance and ideally would like to Setup SolrCloud in Azure PaaS Web Apps. In test environments i have setup Solr on a single PaaS App Service and it is ...
1
vote
0answers
72 views

Clean install on Azure SQL Managed instance

I am trying to install Sitecore 9.2 vanilla on Azure with SQL Managed Instance but I am getting the following error { "status": "failed", "error": { "code": "ResourceDeploymentFailure", "...
1
vote
0answers
51 views

How can I add a new QA environment to existing Sitecore Azure Paas setup?

We have an existing Sitecore 9 setup in Azure Paas. It includes one CD and one CM server with no xDB. Now we're looking to add a new QA environment which will effectively be a copy of CM with its own ...
1
vote
0answers
62 views

Integration with AD B2C: Trigger Owin challenges by policy name

We're using Sitecore.NET 9.1.0. We're trying to trigger register, login and forgot password flows from Sitecore that will be used by end users of our website. After a successful login we want to ...
1
vote
2answers
40 views

Azure Deploy of CM + Reporting

I'd like to build a deployment of CM and Reporting in a single App Service. Is the best approach to take the XP0 files and try to remove what isn't needed ? Or try and combine The CM and Reporting ...
1
vote
0answers
30 views

How to get current browser url with Azure AD authentication (OWIN) : <owin.identityProviders>

Currently we have the requirement like we want set redirect url as per current browser url So for that we trying to set redirect url custom implementation of IdentityProvidersProcessor , but its ...
1
vote
0answers
53 views

Sitecore 8.2 Azure Web App / Solr VMs

We are running Sitecore 8.2 as a WebApp on Azure, with this we using Solr on VMs , using along with Zookeeper [3 nodes]. There is odd behavior we are seeing, if we make any configurations on Solr as ...
1
vote
1answer
147 views

Sitecore setup using Azure VM Scale sets

Has anyone implemented CD server on Azure VM Scale sets? Looking at below information: The CD Image process as per the VM Scale set process When the Image is used to scale VMs using Azure approach, ...
1
vote
1answer
73 views

Where to download Azure SDK 2.7.1 needed to deploy Sitecore Azure 8.1?

We are building a development environment for Sitecore 8.1 Update 1 with Sitecore Azure 8.1. Since Sitecore Azure requires Azure SDK 2.7.1 to be deployed, I am having such a bad day trying to figure ...
1
vote
0answers
170 views

rebuild the xDB index in Azure Search didn't finished

I followed this article to rebuild the xDB index in Azure Search. About 2 hours after the rebuild index process started, i noticed that the rebuild process seemed to stopped (document of xdb-...
1
vote
0answers
111 views

Powershell script fails on trying to start website when installing the Sitecore 9.0.1

My powershell script fails when I try to run it on the Azure VM. The local installation passes successfully. Any help is appreciated :) > [-------------------------------------------- ...
1
vote
0answers
182 views

Redis session provider not working on Azure PaaS webapp

I am working on a Sitecore 9 solution which is hosted on Azure PaaS. I have a simple piece of code that is meant to store an object in session which works fine on my local machine but once deployed ...
1
vote
0answers
192 views

Page test in Experience Optimization on Azure Fails

Sitecore Experience Optimization Page Testing. On Sitecore 9, I am trying to test created simple page in Experience Optimization. Locally everything working fine. When i tried same steps in Azure ...
1
vote
0answers
55 views

Browsing individual delivery server in Azure scaling environment

We are on Sitecore 8.1 rev. 151207 (Update-1) When we scale an existing Azure Delivery Farm, using Sitecore Azure module, we are seeing the additional server, but we are not seeing anything deployed ...
1
vote
1answer
194 views

Sitecore 8.2 Update 4 in Azure SQL

Sitecore 8.2 Update 4 I am looking to run Sitecore in IaaS. Azure VMs for web and Azure SQL for database. Not the new Azure service stack. Its great that Sitecore comes with dacpac files in all ...
0
votes
0answers
15 views

Using Seq with Sitecore PaaS

We are running 9.3 in an app service in Azure. We have found a number of articles stating different things about logging in SC. Some say it's log4net, others say Serilog... Since we cannot get to ...
0
votes
1answer
132 views

Sitecore redirects for login page using hostname

We have a sitecore instance (xp0 for now) with an identity server. They are deployed to azure and belong to a private vnet. Access to nodes is done through the application gateway. But because of ...
0
votes
0answers
14 views

Sitecore Azure PaaS ARM templates doesnt support template idempotence

We are using ARM templates to install Sitecore 9.2.0 XP Scaled topology for our infrastructure. While using these templates, we observed that these templates are not idempotent in nature. We needed to ...
0
votes
1answer
30 views

Sitecore.IO.FileWatcher Error

I have an issue with the test site which broke after I had done a deployment with VSTS. The test environment is hosted on Azure in a webservice app. I know it has to do something with the files in the ...
0
votes
0answers
54 views

Azure DevOps tds project build not creating web deploy package

I have added a task to build my tds project. The TDS Project contains configurations to create web deploy package. When I build it manually in Visual Studio, it creates a package and .ps1 file in ...
0
votes
1answer
80 views

Sitecore Azure PaaS Client Certificate on ASE

I deployed Sitecore 9.2 on Azure PaaS and facing the issue with Client Certificate Authentication. The Azure hosting is on ASE with Isolated App Service Plan. It seems like CM server is not able to ...
0
votes
1answer
200 views

Multi-Site Domain is not resolving Using Azure WAF

I am facing domain resolving issue in Sitecore Multi-Site Solution using Azure PaaS with Azure WAF setup, however, it's working fine if I add the custom domain on Content delivery(Web Apps) level. ...
0
votes
2answers
30 views

Base Templates are deployed without any language version

We have very bizare issue with our deployment. Project contains of multiple templates and we recently (couple of months ago) introduced couple of base templates. We have prefixed them with underscore,...
0
votes
0answers
52 views

Post Condition failed on Migration between Azure Servers

We are trying to migrate our application from Azure US servers to EU Servers. We just copied all the files of Website folder (or wwwroot folder) from US server to EU server. Our Production CM ...
0
votes
0answers
86 views

How to log requests, fail requests on WAF Azure

I'm working with azure WAF solution. I cannot log the WAF gateway requests that are blocked or not how to do it? I tried to do this: https://docs.microsoft.com/en-us/azure/application-gateway/...
0
votes
0answers
96 views

NullReferenceException while setting up ApplicationInsights with Sitecore 9.1 PaaS

We are following post below for the steps to configure ApplicationInsights and also have applied the patch as specified in the article. After setting things we are getting a NullReferenceException (...
0
votes
0answers
17 views

Sitecore Azure Paas Media files not appearing

I have installed fresh new Sitecore Azure Paas (Sitecore 9 update 2). Created a Sitecore packages from my local to the new instance to migrate all the content, media, system and templates. Everything ...
0
votes
0answers
221 views

How am I supposed to configure an Azure Hosted Agent VS2017 build for 9.1?

I'm trying to deploy my Sitecore 9.1 solution to Azure DevOps. I'm using a Hosted VS2017 Agent pool to do that. When it compiles my *.sln solution, an error shows up, explaining that WebApplication....
0
votes
1answer
179 views

ERROR Could not run the 'getMediaStream' pipeline for '/sitecore/media library/Images/test '. Original media data will be used

I’ve extended SqlServerDataProvider to use the azure blob storage account for storing the media library assests. I’ve taken reference from below GitHub project: https://github.com/aweber1/Sitecore....
0
votes
1answer
178 views

Azure Search &search=This_Is_Equal_ConstNode_Return_Nothing

I have a site that I have recently been upgrading from 8.2 to 9.1 and everything is looking good EXCEPT anything that relies on search funcionality. Any Azure search has in the info log: 2019-02-...
0
votes
0answers
54 views

Download Package in Package Designer does not work

When I try to download generated package into Sitecore Package designer, nothing is happened. Just only an error, that I can observe in Chrome Dev Tool (sitecore.js, line 1058): In additional, the ...
0
votes
0answers
344 views

Are there specific configuration requirements for Redis in Azure?

We're attempting to configure Azure Redis cache, I'm confident the connection string is correct as the logs suggests it's been able to make a connection. However my knowledge of using Redis with ...
0
votes
2answers
223 views

After deploying Habitat to Azure I am getting rendering error

While opening the item in the Experience editor I am getting a lot of errors like the below: Error Rendering View: /Views/MediaFeature/LightboxVideo.cshtml: Error while rendering view: '/Views/...
0
votes
0answers
316 views

System.Data.SqlClient.SqlException: Invalid object name 'AccessControl'

We have the sitecore azure module installed, and everything seems to be fine. However, when we attempt to spin up an editing or a delivery farm, we get the following error message: 4‎/‎11‎/‎‎2017 ‎...
0
votes
2answers
149 views

Sitecore 9.1.1 Azure Search custom index not updating when running rebuild

I'm trying to port an application to Azure Search from Solr. I've got the sitecore indexes working and rebuilding. The documents are being added to the azure search index. However for any custom ...
-1
votes
1answer
137 views

Cache cleared message every second in Azure Logs

We are trying to figure our an issue where our LIVE sites are getting down for 10 minutes everyday. While going through the Azure logs I am getting the following Warning: WARN web[standardValues] ...