Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

Filter by
Sorted by
Tagged with
-1
votes
1answer
54 views

Can we deploy helix structure on azure appservice without using teamcity

My team is deploying Sitecore 9.0.2 application to azure appservice for the first time since we got the project. So while reading the ways to deploy the helix website we found that we will need to ...
2
votes
1answer
99 views

Getting IDX20803 when trying to log in via IdentityServer on my CD instance

I have a functioning login flow for my site via IdentityServer. When I test the flow on the CM server (but the frontend site) everything works ok. When I try the same thing on my CD server, I get: ...
0
votes
0answers
42 views

Post Condition failed on Migration between Azure Servers

We are trying to migrate our application from Azure US servers to EU Servers. We just copied all the files of Website folder (or wwwroot folder) from US server to EU server. Our Production CM ...
4
votes
0answers
416 views

Index errors on start up on Azure environment

When starting our application we are seeing lots of these entries: 2017-06-29T08:38:59 PID[60944] Error 8168 08:38:59 ERROR Custodian.UpdateIndexTimestampTimerTick. Update index last updated ...
3
votes
1answer
274 views

Sitecore 8.2 Update 1 folder and files gone missing

Noticed that after standing up 8.2 updates 1 on Web App, the following folders and files are not there anymore. Folder: Media Cache Submit Queue MediaIndexing Files: Log files are missing ( I'm ...
4
votes
2answers
385 views

Sitecore Azure Cachingservices Sizing on Prod Based on number of CD servers

Is there any rule of thumb on the number of caching services to have with Content delivery servers. Like 2 Cache services with 1 CD in Azure PAAS. Asking this question, because one of our clients ...
2
votes
1answer
40 views

Sitecore Azure SQL DB Advisor recommendation - Drop unused indexes

As part of Sitecore 9.1 Azure hosting setup, I'm seeing few SQL DB Advisor recommendations in Azure to drop unused indexes on certain Sitecore tables that were created by Web deploy packages. Since ...
9
votes
2answers
1k views

How to configure Solr for Sitecore PaaS setup

We are currently trying to upgrade our Sitecore 8.1 Environment to Sitecore 9. We are also doing this implementation to Sitecore 9 PaaS and succesfully had several components work, however we are ...
2
votes
1answer
112 views

Azure database refdata high intermittent load

We've been running a SC9.1 solution on PAAS for a while now, but have recently noticed intermittent slow response times, both on the CD and the CM. We've correlated it to high load on the refdata-db: ...
3
votes
1answer
147 views

Sitecore Identity Server on Azure App Service

I need some help to configure the KeyVault connection string for Azure App Service and Sitecore Identity Service. Sitecore Identity Server is based on aspnet core and the connection string settings ...
1
vote
1answer
36 views

Does Sitecore provide tool to Migrate Analytics DB to Azure SQL

We are migrating from Sitecore v7.2 to v9.1. We would like to migrate customer xDB data on Azure. Can we automate using xDB Data Migration Tool?
1
vote
1answer
49 views

Why are Sitecore roles not persisting quick enough when using a scaled CD?

User scenario is as follows: Anonymous user navigates to website home page Automatically redirected to /login, which detects user is not authenticated & redirects to ADFS User authenticates on ...
7
votes
2answers
809 views

Azure Search indexes are not created

We are seeing a lot of Depenendy Failures in Application Insights because some non exisiting Azure Search indexes are queried. The following indexes on Azure search return a 404: sitecore-marketing-...
0
votes
0answers
62 views

How to log requests, fail requests on WAF Azure

I'm working with azure WAF solution. I cannot log the WAF gateway requests that are blocked or not how to do it? I tried to do this: https://docs.microsoft.com/en-us/azure/application-gateway/...
2
votes
1answer
87 views

Installing Packages in Sitecore PaaS/WebApp

Sitecore Support has stated that I can’t install packages like PowerShell Extensions and SXA if my PaaS environment is already deployed. They stated I need to redeploy and add these to the ARM ...
1
vote
1answer
39 views

Programmatically uploaded media files are not showing in CD Server

Sitecore Version : 9.0.2 Environment: Azure PaaS CD If upload any media file manually in Content editor, it uploads the media and the filepath field is empty. In program, I need to upload the media ...
6
votes
3answers
923 views

Azure Application Insights not working on Sitecore 9.1 PaaS

I've provisioned a Sitecore 9.1 PaaS, and for some odd reason the Application Insights is not loading graphics except in Live Metrics Stream for Process CPU data I went through the existing post ...
-1
votes
1answer
95 views

Cache cleared message every second in Azure Logs

We are trying to figure our an issue where our LIVE sites are getting down for 10 minutes everyday. While going through the Azure logs I am getting the following Warning: WARN web[standardValues] ...
2
votes
0answers
155 views

Sitecore schedule task not running on the XP scaled environment (CM server)

We’ve configured Sitecore schedule task, which runs at every 1 hour. The schedule task is running fine after deployment/web app restart but after sometime it’s not working as expected. We’ve verified ...
2
votes
1answer
114 views

Azure Search Indexes are not being added/populated

I am trying to configure azure search in Sitecore. I followed this article to configure it. But when I try to rebuild the indexes, the number of units processed is empty and the indexes are not ...
6
votes
3answers
921 views

502 - Web server received an invalid response while acting as a gateway or proxy server

I've noticed the 502 error after deployment to Azure question, but it appears to be related to a failed deployment and rollback of databases - not what we're seeing here. I am getting the above ...
0
votes
0answers
68 views

NullReferenceException while setting up ApplicationInsights with Sitecore 9.1 PaaS

We are following post below for the steps to configure ApplicationInsights and also have applied the patch as specified in the article. After setting things we are getting a NullReferenceException (...
2
votes
1answer
286 views

How to deploy Sitecore to a new deployment slot on an existing environment?

I have DTAP environments up and running for this client I'm working for and want to improve the deployment of releases by reducing the downtime / first loadtime. I have read up on blue/green ...
2
votes
1answer
44 views

No SXA 1.7 ARM Template for Sitecore 9.0.1

I have an existing Sitecore 9.0.1 installation on Azure PaaS. I am looking to install SXA 1.7 on this specific version of Sitecore as Sitecore has outlined this version to be compatible in the SXA 1.7 ...
1
vote
1answer
75 views

Error when installing WDP in on-premises Sitecore 9.1 XP setup

I followed the steps described in this SSE question/answer to create my WDP. Everything works like a charm when deploying this WDP into a Sitecore Azure Paas instance. However, when I try to install ...
1
vote
1answer
115 views

Provisioning Sitecore environment using Solr connection string

We are using Sitecore 9 Update 2 and SXA 1.7.1. We are provisioning Sitecore environment using Solr connection string through ARM template in Azure PaaS environment. We need ...
4
votes
1answer
322 views

PostFailedForSomeDocumentsException: Partial success for insert or update. Some documents succeeded

It looks similar to this post, but it's not Sitecore Azure Search - Invalid field name In Azure Paas, Sitecore control panel, I am trying to index my custom search index 'generic_search_master' and ...
2
votes
1answer
44 views

Contacts not enrolling in Automation Plan in XP Scaled topology

I am using events to enrol contacts in a Marketing Automation plan, and it works fine in XP Single topology, but in an XP Scaled topology (Azure PaaS) the contacts are not being enrolled. The plan is ...
2
votes
1answer
161 views

Sitecore SXA Azure Search Facets Returning 400 Bad Request when there are more than 50 results

I have a search page that is working correctly on my local instance using SOLR, but when we move the page to our AZURE Instance it fails. The AZURE Instance is using AZURE Search instead SOLR. If I ...
1
vote
2answers
157 views

AuthenticationException on Azure with Solr and self-signed certificates

looking for Azure experts advice! I have about 1M AuthenticationExceptions while connecting to solr in the last few hours for almost non-active Sitecore instance... I checked all the apps, they all ...
2
votes
1answer
307 views

Is it possible to add Custom 403 Error page in Azure Web Apps

We have built our Sitecore 9.1 solution in Azure Web Apps. We have added custom 403 and 400 error pages by making use of the Error Manager module from Sitecore https://marketplace.sitecore.net/en/...
1
vote
2answers
62 views

Where do the UpdateInstallationWizard.aspx logs get saved in Azure PaaS?

Sitecore 9.0.2. In my experience, the logs should be saved into the temp folder. Our environment is configured like so: <sc.variable name="tempFolder" value="d:\local\temp"/> I've looked ...
0
votes
0answers
16 views

Sitecore Azure Paas Media files not appearing

I have installed fresh new Sitecore Azure Paas (Sitecore 9 update 2). Created a Sitecore packages from my local to the new instance to migrate all the content, media, system and templates. Everything ...
1
vote
2answers
781 views

CD server throws “Unknown connection string. Name: 'master'”

I think I'm completely missing some step in my CD server deployment as I'm setting up my first XP Scaled environment in Azure and I'm facing the following issue with my CD server: Unknown ...
9
votes
2answers
213 views

How to convert a Sitecore package into a WDP package?

How can I convert a given Sitecore Package previously created using the Package Designer into a WDP package, so that I can create a script to deploy it on my Azure instances?
1
vote
2answers
283 views

How to add a suggester / enable autocomplete in Sitecore configuration for an Azure search index?

Has anyone here implemented autocomplete feature of azure search with Sitecore? I see documentation on how to add a suggester while creating an index in azure, but Sitecore documentation (https://...
5
votes
1answer
67 views

Error while creating a WDP package using AzureToolkit

I'm trying to create a WDP from an existing Sitecore package but I'm facing the following error even after installing DacFX: Microsoft.Web.Deployment.DeploymentDetailedFatalException: The SQL ...
0
votes
0answers
154 views

How am I supposed to configure an Azure Hosted Agent VS2017 build for 9.1?

I'm trying to deploy my Sitecore 9.1 solution to Azure DevOps. I'm using a Hosted VS2017 Agent pool to do that. When it compiles my *.sln solution, an error shows up, explaining that WebApplication....
0
votes
1answer
73 views

Proper troubleshooting approach if Sitecore PaaS couldn't pass data to Application Insights

Our Sitecore is 9.0 update 2 with SXA. We have 3 environments on Azure all using Azure Web App: BUILD(standalone), UAT(standalone) and Production(CM and CD). All of them have exactly the same ...
2
votes
1answer
111 views

Error when Installing Sitecore 9.1 on Azure PaaS

When trying to install Sitecore 9.1 on Azure PaaS, I face the following error: Add-AzureRMAccount : The term 'Add-AzureRMAccount' is not recognized as the name of a cmdlet, function, script file, or ...
3
votes
0answers
119 views

Installation issue on migration 9.1.1

I am trying to migrate a Sitecore 9.0.2 to 9.1.1. Following the upgrade guide https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform/91/Sitecore_Experience_Platform_91_Update1.aspx, I have to ...
8
votes
1answer
92 views

Customising the Sitecore Azure Marketplace Install

I installed Sitecore 9 on Azure using the Azure Marketplace. This creates a highly souped up instance of Sitecore. Id like to strip things out I don't need, to reduce the cost, but I am not entirely ...
1
vote
1answer
447 views

Azure PaaS Publishing Performance

One of the Sitecore projects is running on Azure PaaS. I use Sitecore 9 update 1 medium size (1 cm, 1 cd). The publishing speed is very slow after exceeding 10k items or more (I have around 200k items,...
2
votes
2answers
67 views

Should TransientRetryer be enabled for SQL Azure?

In Sitecore.config for Sitecore 9.0.2 I see the following comment: <!-- RETRYER Example transient retryer: <retryer disabled="false" type="Sitecore.Data.DataProviders....
1
vote
1answer
85 views

Missing VisitorIndentification.js script randomly when loading with Azure CDN

I am running 2 Sitecore CD servers, the servers are load balanced on Azure and we have Azure CDN as well. The strange thing is that 2 lines of codes are randomly missing from the page response we ...
0
votes
1answer
180 views

Sitecore Azure federated authentication username mappings and Roles not working

I've created a azure login like discriped here: https://labs.tadigital.com/index.php/2018/02/16/integrating-federated-authentication-for-sitecore-9-with-azure-ad/ I am using Sitecore 9 Update 2. the ...
1
vote
2answers
385 views

Sitecore PAAS Redis Exception [duplicate]

We are using Sitecore 9.0.2 deployed in PAAS and CD app service is showing below error and logs are full of this kind of exceptions: ERROR ProcessExpiredItems => System.TimeoutException: Timeout ...
6
votes
1answer
153 views

Can you use Azure DevOps with Sitecore Managed Cloud

When implementing Sitecore Managed Cloud, what deployment or technical considerations need to be thought about? As an example: in modern deployments, using Azure DevOps is a viable deployment ...
1
vote
3answers
293 views

EXM report is empty (data is not being captured) in scaled environment

I am working with Sitecore 9.0 update 2 on Azure. Server is scale out : 1CM and 3CD. After email campaign is run, we can receive email but reporting is not working. It doesn't have any data is as ...
4
votes
1answer
110 views

Image Editor actions throws “Parameter not valid.”

Image editor doesn't function after deploying to the azure environments. This seems to be the case for our Dev, Test and Acceptance environments. When using Crop or Rotate or Flip: Server Error in '/...