Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

Filter by
Sorted by
Tagged with
5
votes
2answers
1k views

Optionally Overriding Sitecore Settings with AppSettings (from Azure)

Background So long story short. We all know and use (right?) the established Sitecore Best Practice for not modifying vanilla configuration files. We use config patches (or config overrides, as some ...
2
votes
1answer
626 views

SwitchOnRebuild with SolrCloud not working

We are running Sitecore 9.0.0 (Initial Release) on Azure with SolrCloud (6.6.2) and getting close to go-live. We are using Sitecore's SwitchOnRebuild functionality for indexing so that the indexes ...
3
votes
2answers
641 views

Can't bootstrap/initialize a new Sitecore Commerce 9 instance on Azure App Service

Just starting messing with Sitecore Experience Platform/Commerce 9.0 update 1 on Azure's App Service, managed to deploy it fairly easily, but now I'm stuck during the bootstrap/initialization part. ...
4
votes
2answers
1k views

Max concurrent workers/Max concurrent sessions

We have 11 client Sites hosted on Azure PAAS setup with SQL on standard S2 tier. We also have planned to remove Inrole cache and Implement SQLSession Cache on these Production servers. For all 11 ...
2
votes
1answer
1k views

The `style` prop expects a mapping from style properties to values, not a string

Created Sitecore 9 update 1 on Azure Web App using the Azure Marketplace. JSS packages have been installed successfully and also JSS deploy command successfully: jss deploy package --includeContent --...
7
votes
1answer
428 views

Using TDS sync with Azure PaaS and Sitecore 9

We're setting up a QA environment in Azure PaaS and we're working to figure out the best way to publish things. The code seems to be easy with VS 2017, but we're trying to figure out how to get TDS ...
2
votes
1answer
97 views

Sitecore Azure vs Sitecore WebApp vs Sitecore on Azure PaaS

What is the difference between Sitecore Azure and Sitecore deployed on Azure PaaS. i.e. if I have Sitecore license and I procure an Azure PaaS server and install Sitecore on it, is it something ...
12
votes
1answer
109 views

Copy of the certificate that the Azure Marketplace wizard generates?

I have used the Azure Marketplace to create a new deployment of Sitecore Experience Cloud (XP). During the wizard I selected Autogenerate self-signed certificate. Can I download the certificate after ...
1
vote
1answer
125 views

Azure Sitecore 9.0.1 XP1 Paas XConnect 500 errors after DNS CNAME and SSL cert added to Site

I have a Pass Powershell Arm installed Sitecore 9.0.1 XP1 install. Verified that analytics were working (Collecting and reporting visits in the Experience Analytics Dashboard. We installed DNS CNAME ...
6
votes
1answer
740 views

How can I improve startup times content management in Azure PaaS?

On our Sitecore 9.0.1 in Azure PaaS, we notice that the first load of pages in the sitecore backend (login, desktop, experience editor, content editor) takes a lot of time. For now we implemented some ...
1
vote
0answers
103 views

Powershell script fails on trying to start website when installing the Sitecore 9.0.1

My powershell script fails when I try to run it on the Azure VM. The local installation passes successfully. Any help is appreciated :) > [-------------------------------------------- ...
5
votes
1answer
399 views

How to share Sitecore caches (item, data, prefetch,etc NOT session state) on Azure PaaS between Web Apps

I can't find any docs on this so I assume it's not possible, but... If you run Sitecore in Azure PaaS and have scale-out enabled (e.g. you're running 2x S3 instances) then can you have a shared/...
2
votes
3answers
3k views

Custom index field returning “Server Error in '/' Application. Could not find add method: AddComputedIndexField”

I am trying to create a commuted index field in sitecore 9 but can't get the configuration to work. I have a local environment which is running Solr and also environment is Azure. I have added the ...
2
votes
1answer
226 views

Sitecore 9.0.1 Custom ARM template for XP1 with combined roles

I want to create an ARM template to setup 9.0.1 PaaS with the following configuration: 1 appservice with CM, Reporting and Processing 1 appservice with CD xDB fully scaled I'm trying to determine ...
6
votes
3answers
427 views

'Microsoft.Web.Deployment.DeploymentException: The path '' is not valid for the 'dbFullSql' provider

I'm attempting to use the 9.0.0 ARM template to deploy a Siteocre 9.0.1 instance. I've hit a bit of a wall with this error: Package deployment failed AppGallery Deploy Failed: 'Microsoft.Web....
3
votes
1answer
388 views

Sitecore Azure Continuous Delivery

I'm new to this topic - Continuous Delivery, We already have Azure Web App Site is Deployed to Production and Running,and We do have the license for TDS and currently Using Sitecore 8.2 Update 3 We ...
2
votes
1answer
155 views

Why Sitecore 9 Azure installation having 5 different database ? Not able to connect to these database using local SQL MS (Sitecore PaaS)

When sitecore 9 using new Azure setup has been installed there are 5 different database servers. I want to know why we have different database for Forms and individual database servers. Also I am ...
3
votes
1answer
239 views

Install jss package (layout service) on content delivery server

I'm developing a Sitecore ssr with jss on azure using two app instances. One for content management and one for content delivery. I installed all the jss packages on content management and it works. ...
3
votes
3answers
219 views

How to create new layout on Sitecore CM server and sync it to Sitecore CD server in Azure Cloud

I'm a newbie on Sitecore. I'm studying the "Get Started" tutorial from Sitecore e-learning website. I have configured Sitecore 9 on Azure, from Azure marketplace, using extra-small sizing having 2 ...
2
votes
0answers
286 views

Sitecore-Core-Index rebuild at Azure Search for Sitecore 9.0.1 PaaS fails

I have deployed Sitecore 9.0.1 XP Scaled in Azure PaaS (default, no customization). It is used self-signed certificate and configured with allowInvalidClientCertificates="true" in azuredeploy....
1
vote
1answer
278 views

Sitecore Azure WebApp and TLS 1.2

I want to use the most secure TLS 1.2 on Sitecore Azure Web apps for all 4 roles - CD, CM, PRC and REP. I did not do any changes in Analytics processing and reporting - so, I do not deploy my code to ...
6
votes
1answer
524 views

Sitecore hosting on cloud with consumption based pricing includes Sitecore license cost?

I am aware of the consumption based pricing model of Sitecore Licensed based on the amount of visits your site receives No large up-front purchase, but you don’t “own” a license Can be paid for as-...
1
vote
0answers
167 views

Redis session provider not working on Azure PaaS webapp

I am working on a Sitecore 9 solution which is hosted on Azure PaaS. I have a simple piece of code that is meant to store an object in session which works fine on my local machine but once deployed ...
3
votes
1answer
1k views

Certificate not found error while using xConnect on Azure from Visual Studio Application

I have created a Sitecore 9.0 PaaS in Azure. I am trying to work with xConnect by following this article - https://doc.sitecore.net/developers/xp/getting-started/, tutorial 1. The certificate I used ...
2
votes
1answer
626 views

No Indexes showing in Index Manager on Azure CM AppService

We have created our Sitecore production environment (Sitrecore 8.2 Update 5, EXM + XDB Cloud) using ARM templates. This means we have CM, CD, Reporting, Processing and DDS (Data Distribution Server) ...
6
votes
1answer
359 views

Send email with Segmented List - Skipped during message delivery

I have a Sitecore v9.0u1 solution that runs in the Azure.The Sitecore instance and the EXM, Marketing Automation and IndexWorker are all hosted on the same web server for this POC project, and the ...
2
votes
1answer
283 views

EXM - reports email campaign sent successfully - zero emails actually sent

We have an instance of Sitecore 8.2 update 5 using XDB cloud and EXM hosted in Azure using PaaS AppServices. I am testing EXM and trying to send test email campaigns from our CM instance. However ...
0
votes
1answer
179 views

How does licencing work in Azure and local

Very much a newbie question. We have a client that would like us to embed our product in a Sitecore website. They have the licence including a number of NonProd instances. Can I use a non-prod ...
9
votes
1answer
646 views

How to Create Web Deploy Package for Sitecore Modules

We are currently using Sitecore PaaS implementation for Sitecore 9 Update 1 and would like to know if it is possible to create a Web Deploy Package for other Sitecore Modules like Data Exchange ...
3
votes
2answers
1k views

Web API 404 on content delivery server

I am using Sitecore on azure and have a CD and a CM server. The Web API works fine on CM but throws a 404 error (and no more information in logs). I have deleted the following dll files from server ...
6
votes
2answers
425 views

How to obtain a certificate from a certified authority for Sitecore 9 Installation?

I am planning to deployed Sitecore 9 Update 1 on Azure PaaS using Sitecore Marketplace template. I have created the non-production environment like SIT,QA,UAT using self signed certificate option and ...
1
vote
0answers
183 views

Page test in Experience Optimization on Azure Fails

Sitecore Experience Optimization Page Testing. On Sitecore 9, I am trying to test created simple page in Experience Optimization. Locally everything working fine. When i tried same steps in Azure ...
1
vote
0answers
165 views

Sitecore 9.0 Update 1 in PaaS: Error in Experience Profile [duplicate]

I have deployed my Sitecore 9.0.1 solution in Azure PaaS with Self Signed Certificate.I can't add contacts in List Manager and when I view the Experience Profile, I always get "An error has occurred." ...
3
votes
0answers
581 views

502 error after deployment to Azure [closed]

We have had an automated deployment process that has been working well for ages deploying our Sitecore 8.2 Update 5 site to Azure. Yesterday, a deployment failed to our test environment with the CD ...
15
votes
1answer
2k views

Experience Analytics are not showing Online Interactions

I have a Sitecore solution (Sitecore 9.0.1 revision 171219 on Azure in xP1 topology) that as far as I can tell all roles are working as expected and communicating. I am able to fire goals, create ...
1
vote
1answer
489 views

Unable to access Launchpad following Sitecore 8.2 Install [closed]

I'm trying to debug a 8.2 install. The databases have been deployed to Azure using the DACPAC files and the client installed using the EXE. I can see the vanilla website homepage and I can see the ...
1
vote
0answers
52 views

Browsing individual delivery server in Azure scaling environment

We are on Sitecore 8.1 rev. 151207 (Update-1) When we scale an existing Azure Delivery Farm, using Sitecore Azure module, we are seeing the additional server, but we are not seeing anything deployed ...
10
votes
3answers
598 views

SQL user creation is setting password of 12345, fails deployment

Using the updated Sitecore Azure Toolkit 2.0.1 rev. 171218, which has resources for 9.0.1, I'm hitting an error on the xc-collect\MSDeploy stage where it's attempting to apply the default sql user ...
10
votes
1answer
1k views

Sitecore PaaS Log files missing

Currently, We are on Sitecore PaaS. There are some issues and we are not able to find out the root cause of those issues. We tried to find out some clues in Sitecore log file but We noticed that there ...
5
votes
1answer
309 views

Log in with Azure Active Directory

Our client needs to pre-authenticate with AD before common Sitecore built-in authentication (they don't need the AD users in Sitecore). We switched on "Log in with Azure Active Directory" at our CM ...
3
votes
1answer
207 views

Two CD instances, one is missing content, the second is working as expected

When we deploy our site to our staging slot using the Sitecore Azure module we're running into odd behavior. The second web role instance, SitecoreWebRole_IN_1 is displaying all of the expected ...
3
votes
1answer
249 views

Error when deploying Sitecore and SXA module to Azure through Visual Studio Team Services release

We are trying to deploy Sitecore and the SXA module to our Azure Web App through VSTS with ARM templates instead of using the powershell script from the Sitecore Azure Toolkit. The initial Sitecore ...
2
votes
1answer
203 views

The path '' is not valid for the 'dbDacFx' provider with ARM templates SAT Sitecore Deployment

im trying to deploy "vanilla" Sitecore using the topology "XM" to create in Azure CD and CM PaaS servers ive encountered many issues while trying to get this working, but the most recent deployment ...
3
votes
3answers
552 views

New-SCWebDeployPackage is not recognized

I'm trying to package a Sitecore solution and followed the instructions mentioned in the following URLs. https://doc.sitecore.net/cloud/working_with_sitecore_azure/configuring_sitecore_azure/...
8
votes
0answers
143 views

Virtual field not working with Azure

Currently I'm using facet to filter the search result. The result works perfectly with SOLR but when I switch to Azure it doesn't work anymore. The result shows all although I added filter criteria. ...
0
votes
0answers
305 views

System.Data.SqlClient.SqlException: Invalid object name 'AccessControl'

We have the sitecore azure module installed, and everything seems to be fine. However, when we attempt to spin up an editing or a delivery farm, we get the following error message: 4‎/‎11‎/‎‎2017 ‎...
4
votes
1answer
208 views

Need to have different IIS Rewrite rule on CD and CM while using Sitecore Azure Module

We are using the Sitecore Azure Module to deploy to CD delivery farms. We want to use an IIS Rewrite Rule to redirect all traffic on CD to SSL - however, we do not want the same rule applied on CM (...
4
votes
1answer
501 views

Azure, Quickstart templates, xp config error: Microsoft.Insights/Components/CurrentBillingFeatures failed with message code:BadRequest

I am currently using the Azure Quickstart templates found on Sitecore's Github page. https://github.com/Sitecore/Sitecore-Azure-Quickstart-Templates/ I've successfully used these before, with both ...
3
votes
1answer
2k views

When attempting to deploy, I get “Restricted from provisioning in this region”

When trying to deploy a basic Sitecore 9 XM (Single) Instance via the Azure Portal, I am getting a deployment failure. After looking at the logs, it seems it is related to the West US region I'm ...
2
votes
2answers
155 views

Install EXM on Azure

I am trying to install Sitecore on Azure using marketplace XP1 template also I need to install EXM, in installation wizard I select Sitecore 8.2 update 5 and EXM module, when I try to open content ...