Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

Filter by
Sorted by
Tagged with
1 vote
0 answers
493 views

.aspnet.cookie is not set after Azure AD B2C successful authentication

We have an ASP.NET webforms application with Sitecore 9.0.0 Initial release, and we want to use Azure B2C as an external identity provider for our external users. We created the new authentication ...
user avatar
  • 11
1 vote
1 answer
121 views

I've trying to install Sitecore, getting error: Missing source parameter

I am trying to install Sitecore 9 update 2 on Azure. I am getting this error: Package deployment failed ARM-MSDeploy Deploy Failed: 'Microsoft.Web.Deployment.DeploymentClientServerException: Missing ...
user avatar
  • 11
1 vote
1 answer
117 views

unicorn deployment failure - can't sync when deployed to real environments

I am sure I am missing something simple about using Unicorn in environments above the local dev environments the source folder is correct out of Azure Paas, out on my App Service I am in Sitecore 9.3....
user avatar
4 votes
1 answer
139 views

SQL Replication doesn't clear CD caches on remote target

We have a multi-cd publishing situation I can use some help with. We are in an Azure PAAS situation, with the CM and 1 CD server located in the US. We also have a CD Server and SQL database in China (...
user avatar
0 votes
1 answer
154 views

Does Sitecore Azure paas support sticky session?

I want to enable Sticky session on Azure Pass Sitecore CD instances(multiple app services). Is this possible? If not, what are other options that I have?
user avatar
1 vote
1 answer
484 views

What does "Keyword not supported: 'endpoint'" mean and how does it relate to the "messaging" connectionstring?

I'm encountering the following issue but can't find any documentation to troubleshoot this issue. Any tips? 51324 09:55:20 ERROR Messaging : IMessageBus failed to start 'Sitecore.Marketing.Automation....
user avatar
  • 16.7k
1 vote
1 answer
670 views

IDX10500 error when calling Sitecore with JWT token from Postman after updating identity server certificate

I am using Sitecore 9.1 and have recently updated my .pfx identity server certificates in Azure, due to the old ones expiring. After updating the Sitecore.IdentityServer.Host.xml configuration, the ...
user avatar
  • 11
0 votes
1 answer
77 views

Opening HTML microsite from Sitecore Media Library v9.1.1

Looking for settings to open microsite uploaded to the media library in the browser. In the past, we would take an Adobe Captivate HTML export load it into a folder in the media library, and run the ....
user avatar
1 vote
1 answer
119 views

Sitecore Indexing GetLocalDatasourceDependencies

Sitecore 8.2 update 5 on Azure App Services. Anyone knows what could be the reason <pipelines> <indexing.getDependencies> <processor type="Custom....
user avatar
  • 1,603
2 votes
2 answers
129 views

Outage on your sitecore website during an azure platform upgrade

Our website becomes unresponsive and we get Pingdom alerts whenever there is either an azure platform or infrastructure upgrade on our website. This happens once a month. We have an app gateway and ...
user avatar
  • 187
0 votes
2 answers
379 views

Invalid identity provider: sitecoreidentityserver when attempting to login

Attempted to simply login to two different sitecore CM ( test and prod ) Azure PaaS servers and go the following error : Invalid identity provider: sitecoreidentityserver I suspect it has to do with ...
user avatar
0 votes
0 answers
96 views

Problem Installing to Azure China

Sitecore 9.2 I am trying to run an ARM Template to install Sitecore to Azure China. I set the location parameter to "China East 2". When I run Start-SitecoreAzureDeployment, it creates the ...
user avatar
0 votes
0 answers
575 views

"XdbContextLoggingPlugin" XdbContext Batch Execution Exception

I am getting an SQL exception in the XConnect application. Error: ["XdbContextLoggingPlugin"] XdbContext Batch Execution Exception XdbContextLoggingPlugin MessageTemplate: [{0}] XdbContext ...
user avatar
  • 421
1 vote
0 answers
49 views

Is there a connector to Azure AppInsights for VM Sitecore Instances

We are currently running Sitecore 9.0 on AWS instances but will be moving to 9.3 on Azure. We have 4 production CD servers, so tracking down issues in the log files is tedious to say the least, as we ...
user avatar
2 votes
0 answers
43 views

How to replace/register 'ResizeImageStream' method of class 'Sitecore.Resources.Media.ImageEffectsResize' from Sitecore.kernel dll

I’ve extended SqlServerDataProvider to use the azure blob storage account for storing the media library assests.Everything works fine but Sitecore.Resources.Media.ThumbnailProcessor throws an error in ...
user avatar
0 votes
0 answers
69 views

How to setup one common CMS and two CD server in different region in Azure Pass Architecture?

Currently we have scaled environment setup on Azure Pass i:e one CM and one CD server in common region. Now we have created one more site but its for another region and due to compliance policy we can'...
user avatar
  • 501
4 votes
1 answer
872 views

Sitecore media library - unable to load large files ( > 8MB) via Azure Front Door

We've run into an issue in Sitecore 9.3 where it's not serving media items properly via Azure FrontDoor with caching enabled. (Front Door works exceptionally well for 99.95% of the website). But a ...
user avatar
1 vote
1 answer
92 views

We have Sitecore 9.0 web apps on Azure App Services, Is it safe to change the time zone of the App Services?

We have Sitecore 9.0 web apps hosted on Azure App Services. These App Services are in a different timezone that where our content authors are located. We want all the times displayed in Content Editor ...
user avatar
  • 111
0 votes
1 answer
113 views

Node version issue in Multisite Sitecore jss application in Azure

I have 2 jss apps deployed to azure. Both are built on node 12.15.0 and I have WEBSITE_NODE_DEFAULT_VERSION as 12.15.0 in azure app settings but Only one of the apps is getting loaded at a time. For ...
user avatar
0 votes
0 answers
30 views

Package installation error - Find corrupted items [duplicate]

I'm experiencing this problem when installing packages in an instance hosted on Azure. The package installation fails and the dialog just says - Retry installation. There are also no related logs. On ...
user avatar
  • 2,547
0 votes
2 answers
462 views

Sitecore TDS Webdeploy in Azure PAAS

I am facing issues in Deploying TDS Webdeploy Package to Azure PAAS. I'm using Sitecore 9.3, TDS.6.0.0.14 We are getting an error on TDS service Msg From Kudu --> "WARN Request is ...
user avatar
  • 31
1 vote
0 answers
48 views

Has anyone gotten "Replicating the Web database using Azure active geo-replication" working

I'm trying to set 2 CD sites (SC 9.3 XM) on Azure (1 in west region, 1 in east region). I've tried following the steps in this article: https://doc.sitecore.com/developers/93/platform-administration-...
user avatar
  • 51
2 votes
2 answers
973 views

Incorrect URLs when behind proxy

I have a Sitecore 9.3 xp1 scaled application hosted in Azure PaaS. The CD App Service sits behind an F5 and Azure Gateway, with DNS of https://mysite.com routing through these 2 proxies (F5 -> ...
user avatar
  • 1,462
4 votes
1 answer
394 views

Enabling Local Cache on Sitecore Azure App Services

I've read the following article https://blog.baslijten.com/increase-your-sitecore-performance-by-enabling-the-local-cache-on-azure-app-services/ that says how to enable Local Cache option in the Azure ...
user avatar
2 votes
1 answer
211 views

Load balancing with Azure PaaS on CD

We have a Sitecore 9.2 setup using the S3 profile for the CD with 3 instances scaled out manually. I'm pretty new to managing the PaaS environment, and I'm trying to figure out if the traffic is load-...
user avatar
  • 5,052
3 votes
3 answers
3k views

Login failed for user 'masteruser'

I was moving my Sitecore 9.2 QA database in UAT in Azure PaaS. I have moved the web & master database and renamed the databases to UAT's database name. In connectionString.config we have changed ...
user avatar
  • 421
2 votes
1 answer
123 views

Most cost effective way to add custom SQL server tables/database to Sitecore 9.1.1 PaaS installation

I'm looking for some guidance please, we have a small (~500Mb) custom SQL server database that we need to run alongside the standard Sitecore 9.1.1 databases. I'm also new to Azure so I apologies if ...
user avatar
  • 123
0 votes
0 answers
69 views

How can I solve Server Error in '/' Application Index has not been initialized? [duplicate]

If I access my home page, show error like this : Server Error in '/' Application. Index has not been initialized. Description: An unhandled exception occurred. Exception Details: System....
user avatar
2 votes
1 answer
515 views

Index has not been initialized error on Sitecore 8.2 with Azure Search

I have Sitecore 8.2 update 5 in Azure PaaS using Azure Search. When I am trying to open the content editor, it is throwing exception Index has not been initialized with stack trace info mentioning ...
user avatar
3 votes
1 answer
639 views

Publishing Service error message: Could not persist PublisherOperations in the service

In my CM logs, I'm seeing the following warning repeatedly. WARN Could not persist PublisherOperations in the service Exception: Polly.CircuitBreaker.BrokenCircuitException Message: The circuit is ...
user avatar
  • 5,085
0 votes
0 answers
36 views

Where can I find Serialized item in Azure portal in Sitecore 9.0.2?

We are using the Azure portal for Sitecore 9.0.2 instance and using Unicorn along with it. Where can I find the serialized items in the Sitecore instance? I checked the path \\App_Data folder but ...
user avatar
  • 35
-1 votes
1 answer
684 views

Script to automatically recycle Azure app every day at a certain time?

We're dealing with what appears to be a memory leak issue, and we're still trying to find the root cause. In the meantime, Azure is auto-healing every time the memory gets high, which is happening ...
user avatar
1 vote
1 answer
115 views

What is the recommended approach to handle blue/green deployments with Commerce on Azure

Is there a recommended/standard approach to handling blue/green deployments for Sitecore Commerce services? Our Sitecore app services are hosted on Azure and we are able to do zero-downtime ...
user avatar
0 votes
1 answer
1k views

Identity Server not redirecting to Azure Frontdoor URL

We are implementing URL hardening in Azure PaaS. We have added Azure front door urls to CM app. We have updated Sitecore.Owin.Authentication.IdentityServer.config on CM server with new url for ...
user avatar
  • 442
0 votes
2 answers
65 views

Using Seq with Sitecore PaaS

We are running 9.3 in an app service in Azure. We have found a number of articles stating different things about logging in SC. Some say it's log4net, others say Serilog... Since we cannot get to ...
user avatar
2 votes
1 answer
1k views

Sitecore redirects for login page using hostname

We have a sitecore instance (xp0 for now) with an identity server. They are deployed to azure and belong to a private vnet. Access to nodes is done through the application gateway. But because of ...
user avatar
0 votes
0 answers
55 views

Sitecore Azure PaaS ARM templates doesnt support template idempotence

We are using ARM templates to install Sitecore 9.2.0 XP Scaled topology for our infrastructure. While using these templates, we observed that these templates are not idempotent in nature. We needed to ...
user avatar
  • 442
1 vote
2 answers
382 views

Sitecore 9.2 Query not returning all matching items on Azure production

We have multiple environments for a website including local, UAT (single Azure instance), CM (Azure production for authoring) and CD (content delivery). The following code is on all instances and ...
user avatar
  • 860
2 votes
0 answers
110 views

Losing Session Value in Sitecore 9.0.2

I have a Sitecore 9.0.2 portal in Azure PaaS from where we are making some transactions. I am posting form to the payment gateway using form post method and gateway is returning the response to a ...
user avatar
1 vote
0 answers
129 views

Sitecore Paas installation failure - AppGallery Deploy Failed: The declared parameter 'Application Path' is not recognized

We are trying to create Sitecore 9.2 instance in azure PaaS using ARM templates. The ARM templates worked fine. Now we have modified the ARM templates to install the JSS module with Sitecore while ...
user avatar
  • 442
1 vote
1 answer
72 views

CD with 2 separate Azure web apps or 1 web app scaled out to 2 instances?

For a new project (Sitecore PaaS) I'm wondering if it would be better to Run the CD with two separate web apps (both single instance) implementing the zero-downtime deployment myself in the ...
user avatar
1 vote
0 answers
206 views

Sitecore Azure search suggesting index rebuild error

I have implemented Sitecore Suggesting search on Sitecore 9.2. based on https://sitecore.namics.com/2018/06/15/sitecore-9-azure-search-suggestions/ but when I rebuild indexes, I am getting error: ...
user avatar
3 votes
0 answers
70 views

Accessing Azure B2C Access Token with Sitecore ID Server

In Sitecore 9.1 we have integrated Azure B2C with Sitecore Identity Server. We now need to get access to the Azure B2C Access Token on the Sitecore CD server, which was based to Sitecore Identity ...
user avatar
1 vote
1 answer
614 views

SolrCloud on Azure PaaS

I am setting up a Sitecore 9.2 Production instance and ideally would like to Setup SolrCloud in Azure PaaS Web Apps. In test environments i have setup Solr on a single PaaS App Service and it is ...
user avatar
  • 121
0 votes
2 answers
2k views

How to bind multiple custom domains and redirect to azure web app

I'm going to deploy my web app which hosted in IIS (Window VM) to Azure app service as the following current behavior: Note: mhksite.com is primary domain "*:80:mhksite.com" => redirect to home ...
user avatar
1 vote
0 answers
398 views

Clean install on Azure SQL Managed instance

I am trying to install Sitecore 9.2 vanilla on Azure with SQL Managed Instance but I am getting the following error { "status": "failed", "error": { "code": "ResourceDeploymentFailure", "...
user avatar
5 votes
1 answer
389 views

Provisioning to Azure failure on deploying CM

I am trying to setup a new Sitecore 9.2 instance on PAAS using ARM templates. I used these templates a few months ago on the same subscription to setup our development environment and that worked fine....
user avatar
  • 19.2k
1 vote
1 answer
170 views

Maintenance Page in Sitecore Azure PaaS

I have a Sitecore 9.0.2 environment in Azure PaaS. It is connecting to different third party services to get and data. Whenever third party update their system or make any new release our portal goes ...
user avatar
1 vote
0 answers
73 views

How can I add a new QA environment to existing Sitecore Azure Paas setup?

We have an existing Sitecore 9 setup in Azure Paas. It includes one CD and one CM server with no xDB. Now we're looking to add a new QA environment which will effectively be a copy of CM with its own ...
user avatar
  • 13
4 votes
3 answers
426 views

Unable to install Sitecore Horizon 9.3 on Azure

I have installed Sitecore 9.3 XP Single on Azure using Sitecore Experience Cloud (Azure Marketplace). Now I want to install Sitecore Horizon 9.3 on existing Azure Sitecore 9.3 instance. While ...
user avatar
  • 369

1
2
3 4 5
8