Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

Filter by
Sorted by
Tagged with
3 votes
1 answer
246 views

How to replace `CertificateHttpClientHandlerModifier` to `X509Certificate2`

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on azure app service connects to XConnect which is also on Azure, am following this link ...
user avatar
2 votes
2 answers
215 views

How to host custom Sitecore solution in Azure PaaS

I am using Azure PaaS as an environment of Sitecore 9.2.0 (XP + XC) with one custom solution. Can anyone please tell me how to deploy that custom solution into Azure Paas, as there are 17 web apps. ...
user avatar
  • 421
3 votes
1 answer
222 views

Connecting two Azure services to access XConnect

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on app service azure connects to XConnect which is also on Azure, am following this link ...
user avatar
4 votes
1 answer
387 views

DTU shooting up after application start in Azure PAAS Sitecore 9.0.2

We are observing that DTUs are shooting up while the application startsup in Azure PAAS environment, however the frequency is not consistent- sometime we restart the webapp explicitly and sometime it'...
user avatar
6 votes
1 answer
260 views

Azure Traffic Manager and Sitecore 9.2.0 PaaS

Background We are trying to create a "lightweight" failover setup, consisting of a failover CD instance with the core + web database being replicated (Azure SQL failovergroup). Additionally, that ...
user avatar
  • 844
2 votes
0 answers
251 views

Integration with AD B2C: Trigger Owin challenges by policy name

We're using Sitecore.NET 9.1.0. We're trying to trigger register, login and forgot password flows from Sitecore that will be used by end users of our website. After a successful login we want to ...
user avatar
  • 43
0 votes
1 answer
721 views

Azure DevOps - Release Pipeline for TDS Project

I have created Azure DevOps CI in `Azure DevOps. That CI is generating a TDS WebDeploy Package as an artifact. Now I need to create a release pipeline to Deploy and install the items in TDS to Azure ...
user avatar
4 votes
0 answers
98 views

Azure Deployment Slot Processing Events and Updating Indexes

We have a deployment slot that we deploy to, which we then warm up, and then swap with the live slot so that we can achieve zero downtime deployment on PaaS. This works very well in general. However, ...
user avatar
1 vote
1 answer
55 views

Migrate Content to Azure

I have installed a baseline 8.2.7 Sitecore to Azure using the XP templates in the Azure ToolKit. How to I get my existing content into the databases ? If I try to import a bacpac file I get a new ...
user avatar
  • 21
1 vote
1 answer
131 views

URL rewrite from www to naked domain

We've got a Sitecore 9 Azure app service instance We've got redirects set up as follows: <rule name="Root Hit Force HTTPS Redirection" enabled="true" stopProcessing="true"> <match url="...
user avatar
2 votes
1 answer
170 views

Can Sitecore be configured to automatically recover after restarting the Solr service?

We are hosting Sitecore 9 on Azure App Services using Solr as the search provider. Microsoft will occasionally restart the server that is hosting Solr (due to ... updates made by Microsoft to the ...
user avatar
2 votes
2 answers
756 views

How to link Sitecore 9.2 and SOLR running on Azure App service

I have installed SOLR 7.5 on Azure App service and this SOLR instance is running fine. Now I have installed Sitecore 9.2 through Azure Sitecore marketplace and mentioned this SOLR url as a search ...
user avatar
1 vote
1 answer
161 views

Sitecore Azure PaaS Client Certificate on ASE

I deployed Sitecore 9.2 on Azure PaaS and facing the issue with Client Certificate Authentication. The Azure hosting is on ASE with Isolated App Service Plan. It seems like CM server is not able to ...
user avatar
1 vote
2 answers
75 views

Azure Deploy of CM + Reporting

I'd like to build a deployment of CM and Reporting in a single App Service. Is the best approach to take the XP0 files and try to remove what isn't needed ? Or try and combine The CM and Reporting ...
user avatar
  • 21
1 vote
1 answer
277 views

Location of Redis cache connection String in XC 9.2.0 PaaS Scaled

I have installed Sitecore 9.2.0 XC Scaled in Azure PasS. Hence there are two Redis cache has been created in azure portal, one for XC and one for XP. I was able to find out where the Redis cache ...
user avatar
  • 421
6 votes
1 answer
515 views

Log stream on Azure Paas

I have an environment running Sitecore 9.2 on Azure PAAS. It's an upgraded codebase (from 9.0.2) but on a clean setup. I had an issue with logging. Application Insights is working fine - I can see my ...
user avatar
  • 19.2k
3 votes
1 answer
498 views

HTTP Error 502.5 - Process Failure

I was installed Sitecore XC 9.2.0 Scaled using the ARM template. After successful installation, when I am trying to open theBizFX web app, getting this error. Most probably getting this error ...
user avatar
  • 421
0 votes
3 answers
723 views

Sitecore 9.1.1 Azure Search custom index not updating when running rebuild

I'm trying to port an application to Azure Search from Solr. I've got the sitecore indexes working and rebuilding. The documents are being added to the azure search index. However for any custom ...
user avatar
3 votes
2 answers
900 views

CORS Error while downloading the fonts from the Azure CDN using Sitecore PaaS

We have configured the Azure CDN for Sitecore Web Apps website, everything is working fine except the Fonts rendering from CDN, and we are getting below error: Any suggestion?
user avatar
3 votes
1 answer
125 views

'Aspnetcoreruntime' not found in scaled ARM template

I was trying to install Sitecore 9.2.0 XP Scaled in Azure using ARM template. But I am getting an error named 'AspNetCoreRuntime' not found. { "id": "/subscriptions/72a1bd21-63be-430d-b8a9-...
user avatar
  • 421
4 votes
1 answer
666 views

Multi-Site Domain is not resolving Using Azure WAF

I am facing domain resolving issue in Sitecore Multi-Site Solution using Azure PaaS with Azure WAF setup, however, it's working fine if I add the custom domain on Content delivery(Web Apps) level. ...
user avatar
3 votes
1 answer
704 views

Sitecore 9.1 Azure AD infinite redirect on /admin

I have an XP Single instance deployed to Azure PAAS that has been configured to use Azure AD by following this blog post: https://sitecore.derekc.net/setting-up-azure-active-directory-integration-...
user avatar
1 vote
2 answers
52 views

Base Templates are deployed without any language version

We have very bizare issue with our deployment. Project contains of multiple templates and we recently (couple of months ago) introduced couple of base templates. We have prefixed them with underscore,...
user avatar
0 votes
1 answer
90 views

Azure Search queries including too many results due to extra wildcard in fullpath_1 query with space

We are using Azure Search to find items by path. We apply the following search code: var filterPredicate = PredicateBuilder.True<SearchResultItem>(); filterPredicate.And(x => x.Path....
user avatar
  • 5,085
0 votes
2 answers
297 views

Rebuilding sitecore_master_index: The property 'property_id_s_t_de' does not exist on type 'search.documentFields'

When we rebuild our sitecore_master_index index, we usually get an error during the rebuild process and the logs show several instances of the below stack trace:  692 12:50:11 ERROR [Index=...
user avatar
  • 5,085
1 vote
1 answer
106 views

Warning message: 'GUID' field of 'GUID' item is skipped: field name is missed

In all of our environments, any time there is an index update to our Azure Search indexes, we see the following WARN message logged repeatedly (many thousands of times): 06:11:06 WARN [Index=...
user avatar
  • 5,085
1 vote
2 answers
306 views

Azure searches on one Azure CD server are sent as "&search=This_Is_Equal_ConstNode_Return_Nothing"

On one of three CD servers every search we execute is sent to Azure Search like the following: 19660 02:11:05 INFO AzureSearch Query [sitecore_web_index]: &search=...
user avatar
  • 5,085
0 votes
1 answer
268 views

Sitecore Identity Service in the Azure App Service is empty

On the IdentityServer I need to access the Sitecore.IdentityServer.Host.xml file to update the values of AllowedCorsOriginsGroup1 and PasswordRecoveryUrl to be the new DNS for the CM instance. This ...
user avatar
3 votes
2 answers
1k views

Getting IDX20803 when trying to log in via IdentityServer on my CD instance

I have a functioning login flow for my site via IdentityServer. When I test the flow on the CM server (but the frontend site) everything works ok. When I try the same thing on my CD server, I get: ...
user avatar
  • 24.4k
0 votes
0 answers
109 views

Post Condition failed on Migration between Azure Servers

We are trying to migrate our application from Azure US servers to EU Servers. We just copied all the files of Website folder (or wwwroot folder) from US server to EU server. Our Production CM ...
user avatar
-1 votes
1 answer
123 views

Can we deploy helix structure on azure appservice without using teamcity

My team is deploying Sitecore 9.0.2 application to azure appservice for the first time since we got the project. So while reading the ways to deploy the helix website we found that we will need to ...
user avatar
2 votes
1 answer
136 views

Sitecore Azure SQL DB Advisor recommendation - Drop unused indexes

As part of Sitecore 9.1 Azure hosting setup, I'm seeing few SQL DB Advisor recommendations in Azure to drop unused indexes on certain Sitecore tables that were created by Web deploy packages. Since ...
user avatar
-2 votes
1 answer
270 views

How can I restore my deleted web.config file

I'm using Sitecore 9.1.1 on Azure environment, I'm facing a pretty big problem the Web.config has been replaced and I don't know where can I get the file from? Can someone please give me this file ...
user avatar
4 votes
2 answers
465 views

Azure database refdata high intermittent load

We've been running a SC9.1 solution on PAAS for a while now, but have recently noticed intermittent slow response times, both on the CD and the CM. We've correlated it to high load on the refdata-db: ...
user avatar
1 vote
1 answer
120 views

Does Sitecore provide tool to Migrate Analytics DB to Azure SQL

We are migrating from Sitecore v7.2 to v9.1. We would like to migrate customer xDB data on Azure. Can we automate using xDB Data Migration Tool?
user avatar
1 vote
1 answer
212 views

Why are Sitecore roles not persisting quick enough when using a scaled CD?

User scenario is as follows: Anonymous user navigates to website home page Automatically redirected to /login, which detects user is not authenticated & redirects to ADFS User authenticates on ...
user avatar
7 votes
1 answer
318 views

How to filter application insights logs based on log file type

In a regular Sitecore deployment, the logs are written to files such as Crawling.log.yyyyMMdd.txt Search.log.yyyyMMdd.txt log.yyyyMMdd.txt and Publishing.log.yyyyMMdd.txt. When viewing logs in Azure ...
user avatar
2 votes
1 answer
212 views

Installing Packages in Sitecore PaaS/WebApp

Sitecore Support has stated that I can’t install packages like PowerShell Extensions and SXA if my PaaS environment is already deployed. They stated I need to redeploy and add these to the ARM ...
user avatar
  • 227
1 vote
1 answer
268 views

Programmatically uploaded media files are not showing in CD Server

Sitecore Version : 9.0.2 Environment: Azure PaaS CD If upload any media file manually in Content editor, it uploads the media and the filepath field is empty. In program, I need to upload the media ...
user avatar
4 votes
1 answer
471 views

Checklist for Sitecore Security Hardening using Azure PaaS

I am Using Sitecore version 9 on Azure PaaS, Is there any official Sitecore security hardening guide for Azure PaaS ?, I can see some documentation as below link - https://doc.sitecore.com/...
user avatar
1 vote
0 answers
406 views

NullReferenceException while setting up ApplicationInsights with Sitecore 9.1 PaaS

We are following post below for the steps to configure ApplicationInsights and also have applied the patch as specified in the article. After setting things we are getting a NullReferenceException (...
user avatar
  • 111
9 votes
4 answers
5k views

502 - Web server received an invalid response while acting as a gateway or proxy server

I've noticed the 502 error after deployment to Azure question, but it appears to be related to a failed deployment and rollback of databases - not what we're seeing here. I am getting the above ...
user avatar
  • 24.4k
2 votes
1 answer
56 views

No SXA 1.7 ARM Template for Sitecore 9.0.1

I have an existing Sitecore 9.0.1 installation on Azure PaaS. I am looking to install SXA 1.7 on this specific version of Sitecore as Sitecore has outlined this version to be compatible in the SXA 1.7 ...
user avatar
2 votes
1 answer
177 views

Contacts not enrolling in Automation Plan in XP Scaled topology

I am using events to enrol contacts in a Marketing Automation plan, and it works fine in XP Single topology, but in an XP Scaled topology (Azure PaaS) the contacts are not being enrolled. The plan is ...
user avatar
  • 863
5 votes
1 answer
466 views

Sitecore Identity Server on Azure App Service

I need some help to configure the KeyVault connection string for Azure App Service and Sitecore Identity Service. Sitecore Identity Server is based on aspnet core and the connection string settings ...
user avatar
2 votes
1 answer
300 views

Sitecore SXA Azure Search Facets Returning 400 Bad Request when there are more than 50 results

I have a search page that is working correctly on my local instance using SOLR, but when we move the page to our AZURE Instance it fails. The AZURE Instance is using AZURE Search instead SOLR. If I ...
user avatar
  • 41
-1 votes
1 answer
563 views

Cache cleared message every second in Azure Logs

We are trying to figure our an issue where our LIVE sites are getting down for 10 minutes everyday. While going through the Azure logs I am getting the following Warning: WARN web[standardValues] ...
user avatar
2 votes
1 answer
3k views

Is it possible to add Custom 403 Error page in Azure Web Apps

We have built our Sitecore 9.1 solution in Azure Web Apps. We have added custom 403 and 400 error pages by making use of the Error Manager module from Sitecore https://marketplace.sitecore.net/en/...
user avatar
1 vote
2 answers
167 views

Where do the UpdateInstallationWizard.aspx logs get saved in Azure PaaS?

Sitecore 9.0.2. In my experience, the logs should be saved into the temp folder. Our environment is configured like so: <sc.variable name="tempFolder" value="d:\local\temp"/> I've looked ...
user avatar
  • 5,085
0 votes
0 answers
34 views

Sitecore Azure Paas Media files not appearing

I have installed fresh new Sitecore Azure Paas (Sitecore 9 update 2). Created a Sitecore packages from my local to the new instance to migrate all the content, media, system and templates. Everything ...
user avatar

1 2
3
4 5
8