Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

Filter by
Sorted by
Tagged with
17 votes
2 answers
2k views

Slow cshtml compilation on Azure WebApps

We are having serious issues in the startup (boot) time of our application. After carefull investigation we have discovered that the most time is consumed by first-time-visit compilation of the ...
user avatar
2 votes
1 answer
983 views

Change volume of performance counters in Application Insights PaaS

Default Sitecore logs performance counters every 5 second from each of the 4 roles. This is a bit much for our needs. Is it possible to reduce the sampling intervall of performance counters without ...
user avatar
  • 409
1 vote
1 answer
2k views

URL rewrite for naked domain to www domain in Azure app service

We've got a Sitecore 9 Azure app service instance that we're having a singular issue with. We've got redirects set up as follows: <rule name="Redirect to www" stopProcessing="true"> <...
user avatar
  • 5,052
2 votes
1 answer
418 views

Sitecore 9 Update 2 - Azure Database Type and Sizes

We are in process of designing the infrastructure architecture to host sitecore 9 update 2 in azure. This requires us to appropriately size all the databases for Sitecore 9. Also I can't find any ...
user avatar
  • 2,253
1 vote
0 answers
325 views

rebuild the xDB index in Azure Search didn't finished

I followed this article to rebuild the xDB index in Azure Search. About 2 hours after the rebuild index process started, i noticed that the rebuild process seemed to stopped (document of xdb-...
user avatar
  • 181
3 votes
2 answers
720 views

Azure Sitecore WebApp 500 errors after config change

I'm currenlty experiencing some problems with a basic Sitecore setup on Azure. I deployed a simple XP0 environment with Powershell. Then I made a change in the connectionstrings.config (Kudo) for ...
user avatar
  • 1,591
3 votes
3 answers
539 views

Sitecore 9 Infrastructure (roles and services required) Design in Azure

We need to setup infrastructure for Sitecore 9 update 2 in azure PaaS. To achieve this we first need to identify which one is must/optional for costing. Have been reading all Sitecore documentations ...
user avatar
  • 2,253
3 votes
1 answer
3k views

Accessing log files in application insights for Sitecore 9 in Azure app service

I've been reading several blog posts about application insights and Sitecore logs, and I've not been able to get the proper configuration working. This is using Sitecore 9 ARM templates on Azure app ...
user avatar
  • 5,052
3 votes
1 answer
166 views

CM server Sitecore 9 Update 1 is hosted on the Azure with XP Scaled didn't see the owin.initialize pipeline

I have used the pipeline profile and found the owin.initialize pipeline isn't available on the CM server which is hosted on the Azure App service. I have used the Sitecore 9 Update 1 - XP Scaled. ...
user avatar
  • 151
3 votes
1 answer
223 views

XConnectClientConfiguration.InitializeAsync() hangs on Azure Web App

When I try to initialize my XConnectClientConfiguration when running on an Azure App Service, the call to cfg.InitializeAsync() simply hangs. The controller trying to connect to XConnect eventually ...
user avatar
9 votes
1 answer
473 views

All Sitecore 8.2.x Azure Topologies seem to be effected because of TLS issues

In any Sitecore 8.2.x when using Experience Analytics when opening up chrome debugging there appears to be an error around TLS, there would be the same error when .Net code will be calling another ...
user avatar
1 vote
2 answers
410 views

After deploying Habitat to Azure I am getting rendering error

While opening the item in the Experience editor I am getting a lot of errors like the below: Error Rendering View: /Views/MediaFeature/LightboxVideo.cshtml: Error while rendering view: '/Views/...
user avatar
1 vote
2 answers
167 views

How to add Custom Databases to Sitecore Azure Deployment?

I am using Sitecore Azure Toolkit for packaging and deployment. I was wondering if there is a way to add custom databases (databases created by myself, other than core, master, web, etc.) to the ...
user avatar
  • 11
1 vote
1 answer
684 views

Azure PaaS ARM template installation error - "Invalid URI: The URI is empty"

Could anybody please help on below. I'm getting below error after 1 hour of execution in powershell script while installing sitecore on Azure PaaS using ARM template but I can access CM and CD server ...
user avatar
1 vote
1 answer
656 views

Could not find configuration node: contentSearch/indexConfigurations/indexUpdateStrategies/syncMaster

So, we're running Sitecore 9 on Azure. For some reason, on our CD, we're seeing the above error. You can see the full error message below. I haven't been able to find a lot of helpful information ...
user avatar
  • 113
2 votes
2 answers
483 views

Sitecore 9.01 Azure PaaS XP Scaled XP The certificate was not found

I have deployed our Sitecore 9 application to an Azure Scaled PaaS XP environment. i have used the marketplace and selected a 9.01 infrastructure. Our automated deployment has succeeded and our code ...
user avatar
1 vote
1 answer
163 views

How to Stop a Sitecore resource group in Azure PaaS

Is there any way to disable or stop the whole resource group temporary? We can stop the individual’s WebApps within the resource group. The whole idea is to save the cost of the services if I am not ...
user avatar
1 vote
0 answers
389 views

Sitecore Azure deployment failed : The password does not meet policy requirements [duplicate]

I am trying to install Sitecore 9.0 Update-2 on Azure PaaS using MarketPlace but I am getting the below error during deployment: {"code":"c","message":"At least one resource deployment operation ...
user avatar
3 votes
3 answers
1k views

Setting up SSL for Solr behind a Load Balancer on Azure

I have an Azure Load Balancer in front of two Solr servers in a Master/Slave configuration. This is a Sitecore 9 Update 1 build, so Solr is running SSL. For the CD Servers that will be pointed to ...
user avatar
  • 227
0 votes
1 answer
381 views

Dianoga implementation issue on the Azure Paas

I have implemented the Dianoga in my dev environment, while the final solution is deployed on azure paas. Could not resolve type name: Dianoga.Invokers.MediaCacheAsync.Pipelines.Initialize....
user avatar
  • 1,154
3 votes
2 answers
926 views

How to add a suggester / enable autocomplete in Sitecore configuration for an Azure search index?

Has anyone here implemented autocomplete feature of azure search with Sitecore? I see documentation on how to add a suggester while creating an index in azure, but Sitecore documentation (https://...
user avatar
4 votes
0 answers
653 views

When deploying Sitecore in Azure, how do you fix (or prevent) a slot lock? [closed]

We are deploying a Sitecore web application via CI/CD in Octopus to an Azure Staging slot. The deployment randomly fails with the following error: New-AzureRMWebAppSlot : Cannot acquire exclusive ...
user avatar
  • 1,059
5 votes
1 answer
2k views

SwitchOnRebuild with SolrCloud not working

We are running Sitecore 9.0.0 (Initial Release) on Azure with SolrCloud (6.6.2) and getting close to go-live. We are using Sitecore's SwitchOnRebuild functionality for indexing so that the indexes ...
user avatar
5 votes
1 answer
366 views

Migrate SQL DB to Azure SQL

We are facing issues while moving an existing Sitecore master db from an on premise SQL Server instance to an Azure SQL Server. The BACPAC file is almost 5 GB. The above error appears on - Enabling ...
user avatar
12 votes
1 answer
117 views

Copy of the certificate that the Azure Marketplace wizard generates?

I have used the Azure Marketplace to create a new deployment of Sitecore Experience Cloud (XP). During the wizard I selected Autogenerate self-signed certificate. Can I download the certificate after ...
user avatar
1 vote
1 answer
164 views

Azure Sitecore 9.0.1 XP1 Paas XConnect 500 errors after DNS CNAME and SSL cert added to Site

I have a Pass Powershell Arm installed Sitecore 9.0.1 XP1 install. Verified that analytics were working (Collecting and reporting visits in the Experience Analytics Dashboard. We installed DNS CNAME ...
user avatar
  • 13
1 vote
0 answers
160 views

Powershell script fails on trying to start website when installing the Sitecore 9.0.1

My powershell script fails when I try to run it on the Azure VM. The local installation passes successfully. Any help is appreciated :) > [-------------------------------------------- ...
user avatar
5 votes
1 answer
628 views

How to share Sitecore caches (item, data, prefetch,etc NOT session state) on Azure PaaS between Web Apps

I can't find any docs on this so I assume it's not possible, but... If you run Sitecore in Azure PaaS and have scale-out enabled (e.g. you're running 2x S3 instances) then can you have a shared/...
user avatar
6 votes
1 answer
1k views

How can I improve startup times content management in Azure PaaS?

On our Sitecore 9.0.1 in Azure PaaS, we notice that the first load of pages in the sitecore backend (login, desktop, experience editor, content editor) takes a lot of time. For now we implemented some ...
user avatar
2 votes
1 answer
8k views

The `style` prop expects a mapping from style properties to values, not a string

Created Sitecore 9 update 1 on Azure Web App using the Azure Marketplace. JSS packages have been installed successfully and also JSS deploy command successfully: jss deploy package --includeContent --...
user avatar
  • 2,253
2 votes
1 answer
301 views

Sitecore 9.0.1 Custom ARM template for XP1 with combined roles

I want to create an ARM template to setup 9.0.1 PaaS with the following configuration: 1 appservice with CM, Reporting and Processing 1 appservice with CD xDB fully scaled I'm trying to determine ...
user avatar
  • 1,307
2 votes
1 answer
180 views

Why Sitecore 9 Azure installation having 5 different database ? Not able to connect to these database using local SQL MS (Sitecore PaaS)

When sitecore 9 using new Azure setup has been installed there are 5 different database servers. I want to know why we have different database for Forms and individual database servers. Also I am ...
user avatar
4 votes
1 answer
499 views

Install jss package (layout service) on content delivery server

I'm developing a Sitecore ssr with jss on azure using two app instances. One for content management and one for content delivery. I installed all the jss packages on content management and it works. ...
user avatar
3 votes
3 answers
373 views

How to create new layout on Sitecore CM server and sync it to Sitecore CD server in Azure Cloud

I'm a newbie on Sitecore. I'm studying the "Get Started" tutorial from Sitecore e-learning website. I have configured Sitecore 9 on Azure, from Azure marketplace, using extra-small sizing having 2 ...
user avatar
2 votes
1 answer
149 views

Sitecore Azure vs Sitecore WebApp vs Sitecore on Azure PaaS

What is the difference between Sitecore Azure and Sitecore deployed on Azure PaaS. i.e. if I have Sitecore license and I procure an Azure PaaS server and install Sitecore on it, is it something ...
user avatar
2 votes
0 answers
348 views

Sitecore-Core-Index rebuild at Azure Search for Sitecore 9.0.1 PaaS fails

I have deployed Sitecore 9.0.1 XP Scaled in Azure PaaS (default, no customization). It is used self-signed certificate and configured with allowInvalidClientCertificates="true" in azuredeploy....
user avatar
  • 148
3 votes
2 answers
1k views

Can't bootstrap/initialize a new Sitecore Commerce 9 instance on Azure App Service

Just starting messing with Sitecore Experience Platform/Commerce 9.0 update 1 on Azure's App Service, managed to deploy it fairly easily, but now I'm stuck during the bootstrap/initialization part. ...
user avatar
1 vote
2 answers
156 views

Automatic Deployment Azure .update Package Error, 'Sitecore.Install.Serialization.IOUtils' threw an exception

We are doing automatic Azure deployments (blue/green) with .update package installations. We are using Octopus deploy to Azure, with remote Powershell script to install the .update package and do a ...
user avatar
  • 695
2 votes
1 answer
420 views

Sitecore Azure WebApp and TLS 1.2

I want to use the most secure TLS 1.2 on Sitecore Azure Web apps for all 4 roles - CD, CM, PRC and REP. I did not do any changes in Analytics processing and reporting - so, I do not deploy my code to ...
user avatar
2 votes
3 answers
446 views

Packaging a Sitecore 9 solution with the Sitecore Azure Toolkit

I have a Sitecore 9 instance that I'd like to deploy on Azure PaaS. I'm following the instructions here: https://doc.sitecore.net/cloud/working_with_sitecore_azure_toolkit/overview/...
user avatar
  • 21
1 vote
0 answers
248 views

Redis session provider not working on Azure PaaS webapp

I am working on a Sitecore 9 solution which is hosted on Azure PaaS. I have a simple piece of code that is meant to store an object in session which works fine on my local machine but once deployed ...
user avatar
  • 51
6 votes
2 answers
820 views

Using ASE (App Service Environment) to Secure Endpoints in Azure PaaS

I have found Azure Sitecore PaaS has security limitations where you cannot secure the internet facing endpoints of the PaaS Apps. The only way to totally secure App endpoints in Azure is to put them ...
user avatar
  • 695
6 votes
1 answer
640 views

Sitecore hosting on cloud with consumption based pricing includes Sitecore license cost?

I am aware of the consumption based pricing model of Sitecore Licensed based on the amount of visits your site receives No large up-front purchase, but you don’t “own” a license Can be paid for as-...
user avatar
2 votes
1 answer
1k views

No Indexes showing in Index Manager on Azure CM AppService

We have created our Sitecore production environment (Sitrecore 8.2 Update 5, EXM + XDB Cloud) using ARM templates. This means we have CM, CD, Reporting, Processing and DDS (Data Distribution Server) ...
user avatar
13 votes
2 answers
3k views

WAF support with Sitecore Experience Platform

We are looking for a Web Application Firewall (WAF) solution for our Sitecore CMS implementation, because we are an Azure shop we specifically wanted to use the WAF feature on the Azure AppGateway ...
user avatar
6 votes
1 answer
625 views

Send email with Segmented List - Skipped during message delivery

I have a Sitecore v9.0u1 solution that runs in the Azure.The Sitecore instance and the EXM, Marketing Automation and IndexWorker are all hosted on the same web server for this POC project, and the ...
user avatar
7 votes
1 answer
565 views

Using TDS sync with Azure PaaS and Sitecore 9

We're setting up a QA environment in Azure PaaS and we're working to figure out the best way to publish things. The code seems to be easy with VS 2017, but we're trying to figure out how to get TDS ...
user avatar
  • 5,052
0 votes
1 answer
249 views

How does licencing work in Azure and local

Very much a newbie question. We have a client that would like us to embed our product in a Sitecore website. They have the licence including a number of NonProd instances. Can I use a non-prod ...
user avatar
  • 101
2 votes
1 answer
417 views

EXM - reports email campaign sent successfully - zero emails actually sent

We have an instance of Sitecore 8.2 update 5 using XDB cloud and EXM hosted in Azure using PaaS AppServices. I am testing EXM and trying to send test email campaigns from our CM instance. However ...
user avatar
9 votes
2 answers
1k views

How to Create Web Deploy Package for Sitecore Modules

We are currently using Sitecore PaaS implementation for Sitecore 9 Update 1 and would like to know if it is possible to create a Web Deploy Package for other Sitecore Modules like Data Exchange ...
user avatar

1
4
5
6 7 8