Episode #125 of the Stack Overflow podcast is here. We talk Tilde Club and mechanical keyboards. Listen now

Questions tagged [configuration]

Questions about the ways Sitecore is configured, including .config files, patching, available settings, etc.

Filter by
Sorted by
Tagged with
0
votes
3answers
33 views

Should ConnectionStrings.config be in source control/VS?

Or alternatively should ConnectionStrings.config just be left up to the server environment and never part of your VS publish?
1
vote
1answer
34 views

Sitecore 9.2 Virtual User Authentication and SessionId Cookie

On the project I'm working on, we have chosen to use Sitecore 9.2 XM with Identity Server disabled. Where in the pipeline should I expect to see the ASP.NET_SessionId cookie get generated to be sent ...
0
votes
2answers
40 views

Sitecore 9.1.1 Azure Search custom index not updating when running rebuild

I'm trying to port an application to Azure Search from Solr. I've got the sitecore indexes working and rebuilding. The documents are being added to the azure search index. However for any custom ...
2
votes
1answer
39 views

How to specify custom CD Server URL for Language (.co.in instead of /en-in)

Im currently trying to set the publish url for a specific language on the CD server. On the CM server the URL is mysite.com/en-in I want the CD servers URL to be mysite.co.in. How do I specify the CD ...
1
vote
1answer
27 views

Change value of SC_ANALYTICS_GLOBAL_COOKIE to false

Can we override SC_ANALYTICS_GLOBAL_COOKIE through code? Meaning, in my configuration file I set to true, through code I want to set it to false for a particular user. Is it possible?
1
vote
1answer
52 views

Ip hashing in Sitecore

Following the Sitecore documentation, if Sitecore.Analytics.Lookups.IpHashProvider is set then the IP addresses will be in hashed. My configuration file contains value as below: <add name="default"...
1
vote
1answer
26 views

What is the equivalent of the “DataProviderTimeout” setting in Sitecore 9

I want to temporarily increase the timeout settings in a Sitecore 9 environment while I run the tool for removing broken links (https://stackoverflow.com/questions/28725537/how-to-remove-broken-links-...
1
vote
2answers
58 views

Patching an attribute using non-patching syntax

In Sitecore config patch files, both of the following will give the same result: <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:role="http://www.sitecore.net/...
1
vote
2answers
55 views

Sitecore Context null in web.config handler

I'm trying to create a handler to intercept index.cfm files, as we're migrating from an old ColdFusion system to Sitecore. I've designated the handler like this: <system.webServer> <...
2
votes
0answers
39 views

WebDAV disabled but still getting PROPFIND error

I have a Sitecore 8.2 site. WebDav is disabled on the CD as per https://doc.sitecore.com/developers/82/sitecore-experience-platform/en/disable-webdav.html# by disabling the Sitecore.WebDAV.config. ...
0
votes
0answers
27 views

Does runAllManagedModulesForAllRequests need to be set to “true”

I want to prevent the Session module (and other unnecessary modules) from running for static resources (.js, .css, etc..)
5
votes
2answers
149 views

Can I use Sitecore's Configuration patching mechanics for my Identity Server configuration?

Fairly sure I can guess the answer, but getting this question on record is still useful. Long story short: Can I use config patch files to manage configuration settings on my Sitecore IS web ...
2
votes
1answer
42 views

Sitecore Desktop database selection shows non-existent database

On my instance of Sitecore 8.2 Update 7, the database selection list in the lower right hand corner show two webs: There is only one web in publishing targets: And my connection strings only have ...
1
vote
0answers
33 views

What would cause a rendering to not show in preview mode for non-admins?

I have a rendering that shows fine for admin users but doesn't display for non-admins in preview mode. This happens on our production server but on our development server the rendering displays fine ...
0
votes
1answer
79 views

Sitecore patch files not overriding the value in Rainbow.config

I am using Sitecore 9.1.1 and I am trying to override the value of Rainbow.SFS.SerializationFolderPathMaxLength in the foundation.serialization.settings.config. But sitecore is taking the value from ...
2
votes
1answer
61 views

Excluding template fields from indexing - difference between documentOptions exclusion vs regular exclusion

I reducing the number of fields which get indexed in my site. I looked at App_Config\Include\Sitecore.ContentSearch.Azure.DefaultIndexConfiguration.config and see the section <configuration <...
1
vote
1answer
114 views

System.InvalidOperationException: geoIpServiceUri

I am troubleshooting why GeoIP information is not being resolved in my Sitecore 9.1.1 instance on Azure PaaS To try and ascertain whether the Sitecore GeoIP services has been subscribed to correctly, ...
0
votes
0answers
44 views

Need to know the configuration files to be modified in CD server

I have installed Sitecore 9.1 XP scaled(XP1) topology using PowerShell script shared in installation guide. I have sitecore.cm, sitecore.cd and other app process installed (REP,PRC,etc). When i ...
5
votes
2answers
116 views

Sitecore populating date field with yesterday's date via $date token

I have a date field in one of my templates who's default value is $date. When I create an item using that template, the raw value is 20190522Z, but when I view it not raw I see it as yesterday's date ...
2
votes
1answer
56 views

How does Sitecore read .jssconfig and .sxaconfig files?

So we know that Sitecore.Configuration.Factory reads through all files ending in *.config in the App_Config/Include folder of your website root. But I've seen with SXA and JSS, that additional config ...
1
vote
1answer
97 views

Boosting in solr vs lucene

I am changing the search engine from lucene to solr , and i want to make config changes in my custom indexes , i am using the search_keywords field for the predictive search , and the field is also ...
2
votes
1answer
68 views

Logged user is always sitecore\Anonymous during processor in SC 9.1

I'm using Sitecore 9.1, thus an identity provider. I have a custom domain named aba and I'm logged in Sitecore Administration Console using an aba\hsantos user. Then I have this processor which is ...
1
vote
1answer
74 views

Is there any need to use patch:after with Unicorn configuration files

I'm working in a Helix solution and have noticed things like: <configuration name="Feature.MyModuleName" dependencies="Foundation.SomethingElse" patch:after="...
1
vote
0answers
263 views

How to find reason for warning 'Could not load device from the device dictionary'

I've setup a separate CD environment for Sitecore 9.0.1 and upon starting the website, I see 1 exception in the log files that is logged as a warning. I've made sure that the client xConnect ...
4
votes
0answers
47 views

Breaking connection string causing a 500 not captured by HttpError

SC9.1 but tested in 8.2 also. I have been using my tried and true httpError config for capturing 500 errors to a static file. I was setting it up for a new client and I thought changing the ...
-1
votes
2answers
265 views

Error: The type or namespace name 'MVC' does not exist in the namespace 'Sitecore' [closed]

I'm facing this issue in one of my testing instances: Sitecore 9.1.0 Inner Exception: c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\84f876eb\34615233\App_Web_events....
8
votes
1answer
84 views

Customising the Sitecore Azure Marketplace Install

I installed Sitecore 9 on Azure using the Azure Marketplace. This creates a highly souped up instance of Sitecore. Id like to strip things out I don't need, to reduce the cost, but I am not entirely ...
5
votes
3answers
198 views

Patch forceDownload in Sitecore media types for PDF files

I want to patch only the ForceDownload attribute in below config: <mediaLibrary> <mediaTypes> <mediaType name="PDF file" extensions="pdf"> <mimeType>...
0
votes
1answer
55 views

URL rewrite doesn't seem to be working

We have the following rewrite rules in our config: <encodeNameReplacements> <replace mode="on" find="&amp;" replaceWith=",-a-," /> <replace mode="on" find="?" replaceWith=",...
2
votes
1answer
161 views

How to solve ambiguous constructors when trying to start Sitecore

We have a local Sitecore 9.0.2 installation that is relatively vanilla. It is currently failing to load the Configuration Manager because of the following error message. Server Error in '/' ...
2
votes
2answers
60 views

Should TransientRetryer be enabled for SQL Azure?

In Sitecore.config for Sitecore 9.0.2 I see the following comment: <!-- RETRYER Example transient retryer: <retryer disabled="false" type="Sitecore.Data.DataProviders....
1
vote
0answers
24 views

How do I interpret the results of the config changes for the Sitecore Express Migration Tool?

I have run the Sitecore Express Migration Tool 3.1 to migrate a 7.2 instance to 9.0 and I am very confused by the different diff and disabled migrated config files. I have read the EMT guide (...
2
votes
1answer
187 views

Popup dialog when saving an item to alert user to a required field

I'm trying to implement a popup when trying to implement a popup to alert users to a required field, but running into an error with even loading the CMS after trying to create the code: Could not ...
0
votes
1answer
167 views

Instance name in multi-CD setup

Sitecore 8.1 rev 160302. I've inherited a website that I'm having issues with the indexes. There is 1xCM server and 3xCD servers. We're using Lucene so have separate versions of the indexes on all 3 ...
5
votes
1answer
334 views

CM to Identity Server redirection issue

I'm running the Content Management (CM) and Sitecore Identity Server (SIS) roles on a single AWS EC2 instance. This is behind an AWS application load balancer, which accepts traffic on port 443 only ...
1
vote
1answer
171 views

How can I access the Sitecore 9 configuration values programmatically?

I'm trying to get this given node value from the Sitecore configuration (Sitecore 9 instance). My first approach was to read the configuration file on which this value is defined. Pretty standard... ...
0
votes
1answer
83 views

ConfigurationException: Expected: Sitecore.ExperienceAnalytics.Core.Diagnostics.ILogger. Got: Sitecore.ExperienceAnalytics.Core.Diagnostics.Logger

I am migrating from Sitecore 8.1 to Sitecore 9.1 and I'm getting this weird error: Unexpected object type created from configuration node. Expected: Sitecore.ExperienceAnalytics.Core.Diagnostics....
1
vote
1answer
146 views

contentStartItem site setting in Sitecore 9.1

This seems like a very simple config. Set the contentStartItem path that is below the rootPath. In this case it is the home item below the /sitecore/content/Sites/Client path. When I log in as an ...
1
vote
1answer
217 views

Use Seq for logging with log4net instead of text file

Using Sitecore 8.2. I want to log to SEQ instead of a standard file for the Sitecore log. Since Sitecore uses log4net, I've been looking at this documentation: https://docs.getseq.net/docs/using-...
4
votes
1answer
112 views

Conditionally patch config attribute

I want to patch an attribute when a certain node is present. In my concrete example below I would to change the lowercaseUrls attribute for the commerce provider, but only when the commerce provider ...
1
vote
0answers
41 views

Why there is no OOTB LanguageDefinition for a Language which name is “en”?

I'm using a vanilla Sitecore 82u6. When checking the .showconfig.aspx page I realized that the default language name is: <setting name="ClientLanguage" value="en" patch:source="Sitecore....
0
votes
2answers
320 views

xConnect The HTTP response was not successful: Unauthorized on Azure PaaS

Very similar to this question: xConnect The HTTP response was not successful: Unauthorized But in this case, it's in Azure PaaS so a lot of the answers are not applicable. How can I make sure the ...
2
votes
1answer
349 views

Sitecore 9 and custom solr indexes

I'm working with Sitecore 9 and solr 6.2.2. I am trying to create a custom index and in this index I'm only including a few fields. One of the fields is called OfficeLocation and it's a string. When ...
3
votes
1answer
796 views

Sitecore 9.1 and Active Directory compatibility question

I was looking into installing Sitecore 9.1 and was reviewing the modules compatibility table for XP (https://kb.sitecore.net/articles/541788) and was surprised to see no support for Active Directory ...
2
votes
1answer
262 views

Solr log: Multiple values encountered for non multiValued field _basetemplates_s

I'm on Solr 4.10.4, Sitecore 8.1 160519. The configuration of the custom index is <field fieldName="_basetemplates" returnType="string" multiValued="true" storageType="yes" indexType="untokenized"...
0
votes
1answer
65 views

Manage handlers in web.config for different environments

I removed some of the handlers on root web.config and place it on the subfolder sitecore/web.config but it looks like the handlers on subfolder is not working. Here's the content of sitecore/web....
0
votes
0answers
240 views

Sitecore 9 Forms - SimpleInjector conflicting with FormBuilderController

Sitecore 9.0.1 (rev. 171219) SimpleInjector v.4.3.0 Glass.Mapper v.4.5.0.4 Steps To Reproduce: In the Sitecore dashboard I click on the Forms button Click the Create button and select Blank Form On ...
1
vote
1answer
203 views

Is it possible to remove prefetch cache settings from sitecore version 8.X?

I want to disable the prefetch cache settings. Is there any way to disable them? I tried deleting the files from prefetch folder but site throws exception.
1
vote
1answer
62 views

Where to download Azure SDK 2.7.1 needed to deploy Sitecore Azure 8.1?

We are building a development environment for Sitecore 8.1 Update 1 with Sitecore Azure 8.1. Since Sitecore Azure requires Azure SDK 2.7.1 to be deployed, I am having such a bad day trying to figure ...
1
vote
2answers
689 views

CD server throws “Unknown connection string. Name: 'master'”

I think I'm completely missing some step in my CD server deployment as I'm setting up my first XP Scaled environment in Azure and I'm facing the following issue with my CD server: Unknown ...