Questions tagged [configuration]

Questions about the ways Sitecore is configured, including .config files, patching, available settings, etc.

Filter by
Sorted by
Tagged with
3
votes
2answers
38 views

Can I use Sitecore's Configuration patching mechanics for my Identity Server configuration?

Fairly sure I can guess the answer, but getting this question on record is still useful. Long story short: Can I use config patch files to manage configuration settings on my Sitecore IS web ...
2
votes
1answer
34 views

Sitecore Desktop database selection shows non-existent database

On my instance of Sitecore 8.2 Update 7, the database selection list in the lower right hand corner show two webs: There is only one web in publishing targets: And my connection strings only have ...
1
vote
0answers
27 views

What would cause a rendering to not show in preview mode for non-admins?

I have a rendering that shows fine for admin users but doesn't display for non-admins in preview mode. This happens on our production server but on our development server the rendering displays fine ...
0
votes
1answer
48 views

Sitecore patch files not overriding the value in Rainbow.config

I am using Sitecore 9.1.1 and I am trying to override the value of Rainbow.SFS.SerializationFolderPathMaxLength in the foundation.serialization.settings.config. But sitecore is taking the value from ...
2
votes
1answer
39 views

Excluding template fields from indexing - difference between documentOptions exclusion vs regular exclusion

I reducing the number of fields which get indexed in my site. I looked at App_Config\Include\Sitecore.ContentSearch.Azure.DefaultIndexConfiguration.config and see the section <configuration <...
1
vote
1answer
54 views

System.InvalidOperationException: geoIpServiceUri

I am troubleshooting why GeoIP information is not being resolved in my Sitecore 9.1.1 instance on Azure PaaS To try and ascertain whether the Sitecore GeoIP services has been subscribed to correctly, ...
0
votes
0answers
38 views

Need to know the configuration files to be modified in CD server

I have installed Sitecore 9.1 XP scaled(XP1) topology using PowerShell script shared in installation guide. I have sitecore.cm, sitecore.cd and other app process installed (REP,PRC,etc). When i ...
4
votes
2answers
57 views

Sitecore populating date field with yesterday's date via $date token

I have a date field in one of my templates who's default value is $date. When I create an item using that template, the raw value is 20190522Z, but when I view it not raw I see it as yesterday's date ...
2
votes
1answer
45 views

How does Sitecore read .jssconfig and .sxaconfig files?

So we know that Sitecore.Configuration.Factory reads through all files ending in *.config in the App_Config/Include folder of your website root. But I've seen with SXA and JSS, that additional config ...
1
vote
1answer
68 views

Boosting in solr vs lucene

I am changing the search engine from lucene to solr , and i want to make config changes in my custom indexes , i am using the search_keywords field for the predictive search , and the field is also ...
2
votes
1answer
34 views

Logged user is always sitecore\Anonymous during processor in SC 9.1

I'm using Sitecore 9.1, thus an identity provider. I have a custom domain named aba and I'm logged in Sitecore Administration Console using an aba\hsantos user. Then I have this processor which is ...
1
vote
1answer
64 views

Is there any need to use patch:after with Unicorn configuration files

I'm working in a Helix solution and have noticed things like: <configuration name="Feature.MyModuleName" dependencies="Foundation.SomethingElse" patch:after="...
0
votes
0answers
135 views

How to find reason for warning 'Could not load device from the device dictionary'

I've setup a separate CD environment for Sitecore 9.0.1 and upon starting the website, I see 1 exception in the log files that is logged as a warning. I've made sure that the client xConnect ...
4
votes
0answers
41 views

Breaking connection string causing a 500 not captured by HttpError

SC9.1 but tested in 8.2 also. I have been using my tried and true httpError config for capturing 500 errors to a static file. I was setting it up for a new client and I thought changing the ...
-1
votes
2answers
115 views

Error: The type or namespace name 'MVC' does not exist in the namespace 'Sitecore' [closed]

I'm facing this issue in one of my testing instances: Sitecore 9.1.0 Inner Exception: c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\84f876eb\34615233\App_Web_events....
7
votes
1answer
69 views

Customising the Sitecore Azure Marketplace Install

I installed Sitecore 9 on Azure using the Azure Marketplace. This creates a highly souped up instance of Sitecore. Id like to strip things out I don't need, to reduce the cost, but I am not entirely ...
5
votes
2answers
115 views

Patch forceDownload in Sitecore media types for PDF files

I want to patch only the ForceDownload attribute in below config: <mediaLibrary> <mediaTypes> <mediaType name="PDF file" extensions="pdf"> <mimeType>...
0
votes
1answer
41 views

URL rewrite doesn't seem to be working

We have the following rewrite rules in our config: <encodeNameReplacements> <replace mode="on" find="&amp;" replaceWith=",-a-," /> <replace mode="on" find="?" replaceWith=",...
2
votes
1answer
98 views

How to solve ambiguous constructors when trying to start Sitecore

We have a local Sitecore 9.0.2 installation that is relatively vanilla. It is currently failing to load the Configuration Manager because of the following error message. Server Error in '/' ...
2
votes
2answers
50 views

Should TransientRetryer be enabled for SQL Azure?

In Sitecore.config for Sitecore 9.0.2 I see the following comment: <!-- RETRYER Example transient retryer: <retryer disabled="false" type="Sitecore.Data.DataProviders....
1
vote
0answers
21 views

How do I interpret the results of the config changes for the Sitecore Express Migration Tool?

I have run the Sitecore Express Migration Tool 3.1 to migrate a 7.2 instance to 9.0 and I am very confused by the different diff and disabled migrated config files. I have read the EMT guide (...
2
votes
1answer
99 views

Popup dialog when saving an item to alert user to a required field

I'm trying to implement a popup when trying to implement a popup to alert users to a required field, but running into an error with even loading the CMS after trying to create the code: Could not ...
0
votes
1answer
102 views

Instance name in multi-CD setup

Sitecore 8.1 rev 160302. I've inherited a website that I'm having issues with the indexes. There is 1xCM server and 3xCD servers. We're using Lucene so have separate versions of the indexes on all 3 ...
5
votes
1answer
188 views

CM to Identity Server redirection issue

I'm running the Content Management (CM) and Sitecore Identity Server (SIS) roles on a single AWS EC2 instance. This is behind an AWS application load balancer, which accepts traffic on port 443 only ...
1
vote
1answer
84 views

How can I access the Sitecore 9 configuration values programmatically?

I'm trying to get this given node value from the Sitecore configuration (Sitecore 9 instance). My first approach was to read the configuration file on which this value is defined. Pretty standard... ...
0
votes
1answer
47 views

ConfigurationException: Expected: Sitecore.ExperienceAnalytics.Core.Diagnostics.ILogger. Got: Sitecore.ExperienceAnalytics.Core.Diagnostics.Logger

I am migrating from Sitecore 8.1 to Sitecore 9.1 and I'm getting this weird error: Unexpected object type created from configuration node. Expected: Sitecore.ExperienceAnalytics.Core.Diagnostics....
1
vote
1answer
86 views

contentStartItem site setting in Sitecore 9.1

This seems like a very simple config. Set the contentStartItem path that is below the rootPath. In this case it is the home item below the /sitecore/content/Sites/Client path. When I log in as an ...
1
vote
1answer
134 views

Use Seq for logging with log4net instead of text file

Using Sitecore 8.2. I want to log to SEQ instead of a standard file for the Sitecore log. Since Sitecore uses log4net, I've been looking at this documentation: https://docs.getseq.net/docs/using-...
4
votes
1answer
88 views

Conditionally patch config attribute

I want to patch an attribute when a certain node is present. In my concrete example below I would to change the lowercaseUrls attribute for the commerce provider, but only when the commerce provider ...
1
vote
0answers
33 views

Why there is no OOTB LanguageDefinition for a Language which name is “en”?

I'm using a vanilla Sitecore 82u6. When checking the .showconfig.aspx page I realized that the default language name is: <setting name="ClientLanguage" value="en" patch:source="Sitecore....
0
votes
2answers
227 views

xConnect The HTTP response was not successful: Unauthorized on Azure PaaS

Very similar to this question: xConnect The HTTP response was not successful: Unauthorized But in this case, it's in Azure PaaS so a lot of the answers are not applicable. How can I make sure the ...
2
votes
1answer
292 views

Sitecore 9 and custom solr indexes

I'm working with Sitecore 9 and solr 6.2.2. I am trying to create a custom index and in this index I'm only including a few fields. One of the fields is called OfficeLocation and it's a string. When ...
2
votes
1answer
540 views

Sitecore 9.1 and Active Directory compatibility question

I was looking into installing Sitecore 9.1 and was reviewing the modules compatibility table for XP (https://kb.sitecore.net/articles/541788) and was surprised to see no support for Active Directory ...
1
vote
1answer
143 views

Solr log: Multiple values encountered for non multiValued field _basetemplates_s

I'm on Solr 4.10.4, Sitecore 8.1 160519. The configuration of the custom index is <field fieldName="_basetemplates" returnType="string" multiValued="true" storageType="yes" indexType="untokenized"...
0
votes
1answer
52 views

Manage handlers in web.config for different environments

I removed some of the handlers on root web.config and place it on the subfolder sitecore/web.config but it looks like the handlers on subfolder is not working. Here's the content of sitecore/web....
0
votes
1answer
169 views

Sitecore 9 Forms - SimpleInjector conflicting with FormBuilderController

Sitecore 9.0.1 (rev. 171219) SimpleInjector v.4.3.0 Glass.Mapper v.4.5.0.4 Steps To Reproduce: In the Sitecore dashboard I click on the Forms button Click the Create button and select Blank Form On ...
1
vote
1answer
141 views

Is it possible to remove prefetch cache settings from sitecore version 8.X?

I want to disable the prefetch cache settings. Is there any way to disable them? I tried deleting the files from prefetch folder but site throws exception.
1
vote
1answer
51 views

Where to download Azure SDK 2.7.1 needed to deploy Sitecore Azure 8.1?

We are building a development environment for Sitecore 8.1 Update 1 with Sitecore Azure 8.1. Since Sitecore Azure requires Azure SDK 2.7.1 to be deployed, I am having such a bad day trying to figure ...
1
vote
2answers
418 views

CD server throws “Unknown connection string. Name: 'master'”

I think I'm completely missing some step in my CD server deployment as I'm setting up my first XP Scaled environment in Azure and I'm facing the following issue with my CD server: Unknown ...
7
votes
1answer
82 views

Sitecore 9.1 + PHP 7.2 = all form fields being removed by Sitecore on POST events

Mixing Sitecore and PHP has worked for all versions up till 9.1. Now PHP pages render fine, but when you post to a page, the $_POST collection is empty now. I took a vanilla Sitecore 9.1 instance ...
1
vote
1answer
210 views

Custom Azure Search Index returns '&search=This_Is_Equal_ConstNode_Return_Nothing' for searches

I have setup an custom Azure Search index in Sitecore 8.2 u7 and was getting no results returned even though I have data in it (I can see the data in the Azure console). Looking in the Sitecore Search ...
4
votes
2answers
140 views

Is Website\App_Config\Include\Sitecore.Upgrade82.config required after upgrading to Sitecore 9.x?

On our Sitecore 9.0.x environments we have a file at Website\App_Config\Include\Sitecore.Upgrade82.config with the following contents. <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/...
6
votes
3answers
672 views

Why use Patch Files to update configuration?

Some Sitecore documentation I found says.. Do not make changes directly to the configuration files. Instead, you must create a patch file that performs the required changes during run time. But it ...
9
votes
4answers
2k views

Install-SitecoreConfiguration xconnect-solr.json - Error Invoke-ManageSolrCoreTask : Missing required parameter: name

What: I am trying to install sitecore XP1 architecture. I already have a signed certificate. My issue comes when I try to configure sitecore on my solr. Sitecore 9.0.1 rev. 171219. SOLR 6.6.4. ...
1
vote
1answer
183 views

Opening Content Editor taking too long time to load

I have configured an environment for Sitecore XP 8.2.7 and it seems it is not somehow using cache properly when opening Content Editor since it takes just too long time for the initial loading. What ...
2
votes
1answer
113 views

Multiple websites hosted in the same app pool

Is it possible to have two or more Sitecore instances with different code bases running in the same (single) application pool?
22
votes
1answer
303 views

Can I encrypt the Sitecore Publishing Service connection strings?

Is there a way to encrypt the connection strings of the Sitecore Publishing Service? I don't want the connection strings to stay in clear text on the server, nor leave the system in Sitecore support ...
2
votes
1answer
136 views

Can we remove default.aspx page from deploy location?

What is the use of default.aspx page(present in deploy location) which comes with Sitecore installation? If we remove, will it have any impact? Sitecore: 8.2 update 3
-1
votes
2answers
73 views

Locate web.config to implement 404 page

I'm really new with Sitecore and I'm not sure where to perform this change. So far I only know the CMS web interface which is very limited. How can I locate the web.config file? What tool should I use?...
2
votes
1answer
28 views

What does this “Domain User” mean in Sitecore 8.2.7 Installation Guide?

I have installed Sitecore 8.2.7 couple of times. But recently I figured out that I might have missed the step in the following section, "Windows Authentication for Sitecore". I am not sure what the "...