Questions tagged [configuration]

Questions about the ways Sitecore is configured, including .config files, patching, available settings, etc.

Filter by
Sorted by
Tagged with
1
vote
1answer
43 views

Making config settings configurable for user

I am using Sitecore 9.3, SXA. I want to make some of the current config settings configurable from within Sitecore. I have created a template with all of the fields (e.g. MediaResponse single text ...
0
votes
3answers
309 views

Sitecore 9.1.1 Azure Search custom index not updating when running rebuild

I'm trying to port an application to Azure Search from Solr. I've got the sitecore indexes working and rebuilding. The documents are being added to the azure search index. However for any custom ...
13
votes
4answers
4k views

Install-SitecoreConfiguration xconnect-solr.json - Error Invoke-ManageSolrCoreTask : Missing required parameter: name

What: I am trying to install sitecore XP1 architecture. I already have a signed certificate. My issue comes when I try to configure sitecore on my solr. Sitecore 9.0.1 rev. 171219. SOLR 6.6.4. ...
1
vote
1answer
52 views

Could not compute value for ComputedIndexField - Service Host URI is not a Valid URI

We have a sitecore 9.1.1 CM instance configured to use Azure Cloud. We have the relevant configurations enabled & disabled. However we are seeing the following:- 16784 22:55:11 WARN Could not ...
1
vote
1answer
180 views

Sitecore 9.2 Virtual User Authentication and SessionId Cookie [closed]

On the project I'm working on, we have chosen to use Sitecore 9.2 XM with Identity Server disabled. Where in the pipeline should I expect to see the ASP.NET_SessionId cookie get generated to be sent ...
1
vote
1answer
97 views

Where to download Azure SDK 2.7.1 needed to deploy Sitecore Azure 8.1?

We are building a development environment for Sitecore 8.1 Update 1 with Sitecore Azure 8.1. Since Sitecore Azure requires Azure SDK 2.7.1 to be deployed, I am having such a bad day trying to figure ...
1
vote
0answers
50 views

Sitecore website as a subsite of an existing non-Sitecore website

We have two websites: the first one is non-Sitecore website (e.g. 'www.non-sitecore-site.com') the second one is Sitecore website (e.g. 'www.sitecore-site.com') My task is to make the second one (...
0
votes
0answers
22 views

Explore mode GeoIP data not available

In Sitecore Experience Editor Explore view I am facing one issue in which I am not getting any country list in GeoIP section under Visitor information. Below is the screenshot of my page. Please ...
1
vote
1answer
244 views

Sitecore 9.3 with solr - Computed field is not showing up in index, nor is ComputeFieldValue executed

I think I may be missing an important piece of information, but I am currently trying to get a computed field to show up in my Solr index. I did not have any issues doing this in Sitecore 7.5 with ...
0
votes
3answers
321 views

Why am I receiving a message Could not find configuration node: databases/database @id=master?

Here is what I am hoping to do: I would like to upload a media item to the Media Library. Here is my Code: Here is my App.config <?xml version="1.0" encoding="utf-8"?> <configuration>...
1
vote
2answers
106 views

Apply patch to web.config in sitecore

I am little new to sitecore and I got a work thats bugging me. I was given a task to applying sitecore patches to the project and deploy to Dev. There were 3 patches. I completed the first two as it ...
9
votes
2answers
449 views

EnforceVersionPresence not working on home/start item of site when using “/”

Situation We have a Sitecore 8.1 Initial install with a site that has enforceVersionPresence="true" in the site definition. We have a _BasePage template for which in the advanced section we have now ...
0
votes
1answer
60 views

Web Config Tranformation Namespace Issue

I need to transform web.config file for Prod CM and CD. To transform the assembly bindings for dependent assembly, I added below transform snippet on web.config.Prod.CM - <dependentAssembly ...
5
votes
1answer
1k views

NullReferenceException when executing pathAnalyzer/newMapAgent

I'm a new maintainer for an instance of Sitecore 8.2. I'm seeing this error a lot in the logs: 1664 16:28:00 WARN Could not find constructor in ReflectionUtil.CreateObject: Sitecore.PathAnalyzer....
0
votes
2answers
52 views

is there a way to merge web config entries during sitecore upgrade?

we are upgrading our site from sitecore 8.1 to 9.1. hence like to know how the 9.1 instance web config file can be merged with existing 8.1 web config entries. is this has to be manual or is there any ...
0
votes
0answers
20 views

How to configure Solr to treat European English language the same as international English

I'm configuring a few sites within my solution to use "European English" (en-150 yes, it's weird, but it is a valid culture!). Does Solr treat all en- languages the same, or will I need to set up ...
0
votes
0answers
21 views

Modifying base RichText field styling

Still new to Sitecore and .NET, so I apologize if this is common but haven't come across a solution yet. I am trying to modify the body of our rich text template and create a new one that doesn't have ...
4
votes
1answer
571 views

How to find reason for warning 'Could not load device from the device dictionary'

I've setup a separate CD environment for Sitecore 9.0.1 and upon starting the website, I see 1 exception in the log files that is logged as a warning. I've made sure that the client xConnect ...
0
votes
0answers
54 views

PDF files downloading rather than opening in a tab

We recently upgraded to Sitecore 9 and noticed that our PDF links are now downloading rather than opening in a new tab. I have tried changing the forceDownload in the the Sitecore.config to false, ...
1
vote
0answers
29 views

How do you disable rel='noreferrer' for external links?

Our ProtectExternalLinksWithBlankTarget is set to true so all our external links have the rel='noopener noreferrer' attribute, but we need to be able to allow some external links to be recognized as ...
0
votes
1answer
59 views

Allow public access to Staging website, but block access to CMS by IP

I'm looking to limit access to Staging CMS by IP. At the same time, the Staging website should be accessible to anyone irrespective of the IP. The website is hosted on Azure App Service. I ...
22
votes
2answers
407 views

Can I encrypt the Sitecore Publishing Service connection strings?

Is there a way to encrypt the connection strings of the Sitecore Publishing Service? I don't want the connection strings to stay in clear text on the server, nor leave the system in Sitecore support ...
1
vote
1answer
76 views

“Index sitecore_suggested_test_index was not found” on CM 8.2 after changing the default Solr index name

I am running: 8.2 Update 7 Solr xDB and Tracking enabled The Solr instance is shared across DEV and QA, so I need to prefix the index names for all of the indexes so that they do not conflict. I ...
66
votes
7answers
37k views

How do you setup a 404 and 500 error page for missing files and media items?

When navigating to a url such as www.website.com/missing.pdf and www.website.com/-/media/missing.pdf you will either receive the IIS 404 Server Error message or a Sitecore document not found page. ...
21
votes
4answers
5k views

How can I disable xDB?

If I don't have a working connection to MongoDB and I don't want to use xDB functionality. Currently, my logs are being filled with errors. What is the configuration needed to disable xDB?
2
votes
2answers
2k views

Adding new connection into ConnectionStrings.config gives “exceptions occurred while processing the subscribers to the 'property:changed' event”

After I added new connection string into ConnectionStrings.config file, I cannot log into Sitecore and getting this exception: Exception textually: > Server Error in '/' Application. > One or more ...
6
votes
2answers
2k views

Handling 500 errors in sitecore multi site multi language environment [duplicate]

I found a similar question, but could not find out what I need from there I am trying to achieve a language-specific, content manageable, friendly error message page for 500 status code. What I ...
0
votes
0answers
35 views

Custom Processing Engine Service Not Working

I'm trying to implement a test Processing Engine service to get started with Sitecore Cortex and ML.NET -> https://www.brimit.com/blog/dive-sitecore-cortex-machine-learning-introduction. Issue: I've ...
3
votes
1answer
146 views

Sitecore Password setting configuration

We are on 6.3.1 rev. 110112 and We have some specific requirements for setting up the password in Sitecore from the client side. For Example, we have the following requirements for the password ...
5
votes
2answers
328 views

Filter pages from Path Analyzer

In our site we have some Ajax calls for performance measurements and cookie management. These calls show up in the path analyzer and distort the statistics. They are reported as most visited and most ...
4
votes
1answer
608 views

Getting Required license is missing: Runtime

I am setting up Sitecore on Azure Web app PaaS. I am using the official Sitecore packages to deploy a CD and CM role to azure. These have been deployed as vanilla Sitecore instances with no ...
1
vote
0answers
48 views

What permissions does Sitecore need to manage Solr?

Solr 6.1.0 + Zookeeper + Basic Authentication Sitecore 8.0 Update-5 What are the minimum permissions required for Sitecore to manage Solr? The official documentation says nothing about this AFAICT ...
4
votes
2answers
82 views

Setting up “Hot reload” for frontend assets

We would like to improve the frontend development experience in our Sitecore 9.2 solution and provide something like "hot reload", i.e. the frontend is built auto-magically and published to wwwroot, ...
0
votes
1answer
33 views

Coveo Config based on Environment [closed]

I am new to coveo and our dev environment is not working as expected, I am trying to duplicate the QA Environment and set up dev environment When i do this what are all the changes i should keep in ...
1
vote
0answers
52 views

Index core names and rebuild core

I've noticed in Sitecore 9 (at least through 9.1.1) that the value of <param desc="core> is based on the prefix you use during installation (IE, if you chose "local" as a prefix, the core is ...
1
vote
0answers
44 views

LINQPad DirectoryNotFoundException: “Could not find a part of the path”

With Sitecore 8.0 update 5 and LINQPad Sitecore Driver 1.9.0.2 I am receiving the following error when attempting to run a vanilla query: It's strange that this isn't utilizing the specified web root ...
13
votes
3answers
7k views

Viewing the compiled Sitecore config on Content Delivery?

On Content Authoring servers, you can go to the control panel and view this page to see the compiled Sitecore config: /sitecore/admin/ShowConfig.aspx. It's also possible to do this via Sitecore Rocks....
3
votes
1answer
125 views

Is it possible to create a patch config file for log level?

I've created this patch file for a Sitecore 9 instance, but looking at showconfig.aspx it has had no effect. The config file name begins with a 'z' to try to ensure it's processed last. <?xml ...
1
vote
0answers
19 views

Does this error MediaRequestProtection: An invalid/missing hash value was encountered show only in logs or a Yellow Page? [duplicate]

We are seeing this logs in our Sitecore application, we already saw some of the fixes and we are just wandering if this error makes the page in exception(yellow) page? or this has nothing to do in the ...
2
votes
1answer
98 views

Ip hashing in Sitecore

Following the Sitecore documentation, if Sitecore.Analytics.Lookups.IpHashProvider is set then the IP addresses will be in hashed. My configuration file contains value as below: <add name="default"...
14
votes
1answer
593 views

How is the FXM bundle beacon constructed?

I am trying to implement FXM for a customer, with the purpose of collecting data from a bunch of WordPress based sites into a single repository. An example of such a site is http://dev.verum.se/test/...
0
votes
3answers
119 views

Should ConnectionStrings.config be in source control/VS?

Or alternatively should ConnectionStrings.config just be left up to the server environment and never part of your VS publish?
2
votes
3answers
1k views

Patch attribute does not replace patch:source

This is not exactly a problem, more of an irritating itch... I have replaced the InitializeGlobalFilters with a patchfile called InitializeGlobalFilters.config: <configuration xmlns:patch="http://...
2
votes
1answer
52 views

How to specify custom CD Server URL for Language (.co.in instead of /en-in)

Im currently trying to set the publish url for a specific language on the CD server. On the CM server the URL is mysite.com/en-in I want the CD servers URL to be mysite.co.in. How do I specify the CD ...
0
votes
0answers
555 views

Sitecore images served as ashx when Media.RequestionExtension setting is blank

We've just deployed to a new environment and expected images from the Media library to be referenced with their original file extensions e.g. .jpg as Media.RequestionExtension setting is "". They are ...
1
vote
1answer
334 views

Change value of SC_ANALYTICS_GLOBAL_COOKIE to false

Can we override SC_ANALYTICS_GLOBAL_COOKIE through code? Meaning, in my configuration file I set to true, through code I want to set it to false for a particular user. Is it possible?
2
votes
1answer
77 views

What is the equivalent of the “DataProviderTimeout” setting in Sitecore 9

I want to temporarily increase the timeout settings in a Sitecore 9 environment while I run the tool for removing broken links (https://stackoverflow.com/questions/28725537/how-to-remove-broken-links-...
1
vote
2answers
186 views

Patching an attribute using non-patching syntax

In Sitecore config patch files, both of the following will give the same result: <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:role="http://www.sitecore.net/...
1
vote
2answers
173 views

Sitecore Context null in web.config handler

I'm trying to create a handler to intercept index.cfm files, as we're migrating from an old ColdFusion system to Sitecore. I've designated the handler like this: <system.webServer> <...
2
votes
0answers
118 views

WebDAV disabled but still getting PROPFIND error

I have a Sitecore 8.2 site. WebDav is disabled on the CD as per https://doc.sitecore.com/developers/82/sitecore-experience-platform/en/disable-webdav.html# by disabling the Sitecore.WebDAV.config. ...

1
2 3 4 5 6