Questions tagged [configuration]

Questions about the ways Sitecore is configured, including .config files, patching, available settings, etc.

Filter by
Sorted by
Tagged with
1
vote
0answers
16 views

LINQPad DirectoryNotFoundException: “Could not find a part of the path”

With Sitecore 8.0 update 5 and LINQPad Sitecore Driver 1.9.0.2 I am receiving the following error when attempting to run a vanilla query: It's strange that this isn't utilizing the specified web root ...
11
votes
3answers
6k views

Viewing the compiled Sitecore config on Content Delivery?

On Content Authoring servers, you can go to the control panel and view this page to see the compiled Sitecore config: /sitecore/admin/ShowConfig.aspx. It's also possible to do this via Sitecore Rocks....
3
votes
1answer
52 views

Is it possible to create a patch config file for log level?

I've created this patch file for a Sitecore 9 instance, but looking at showconfig.aspx it has had no effect. The config file name begins with a 'z' to try to ensure it's processed last. <?xml ...
0
votes
2answers
76 views

Sitecore 9.1.1 Azure Search custom index not updating when running rebuild

I'm trying to port an application to Azure Search from Solr. I've got the sitecore indexes working and rebuilding. The documents are being added to the azure search index. However for any custom ...
1
vote
1answer
44 views

Sitecore 9.2 Virtual User Authentication and SessionId Cookie

On the project I'm working on, we have chosen to use Sitecore 9.2 XM with Identity Server disabled. Where in the pipeline should I expect to see the ASP.NET_SessionId cookie get generated to be sent ...
0
votes
0answers
13 views

Does this error MediaRequestProtection: An invalid/missing hash value was encountered show only in logs or a Yellow Page? [duplicate]

We are seeing this logs in our Sitecore application, we already saw some of the fixes and we are just wandering if this error makes the page in exception(yellow) page? or this has nothing to do in the ...
1
vote
1answer
57 views

Ip hashing in Sitecore

Following the Sitecore documentation, if Sitecore.Analytics.Lookups.IpHashProvider is set then the IP addresses will be in hashed. My configuration file contains value as below: <add name="default"...
1
vote
1answer
63 views

Where to download Azure SDK 2.7.1 needed to deploy Sitecore Azure 8.1?

We are building a development environment for Sitecore 8.1 Update 1 with Sitecore Azure 8.1. Since Sitecore Azure requires Azure SDK 2.7.1 to be deployed, I am having such a bad day trying to figure ...
2
votes
1answer
296 views

How to find reason for warning 'Could not load device from the device dictionary'

I've setup a separate CD environment for Sitecore 9.0.1 and upon starting the website, I see 1 exception in the log files that is logged as a warning. I've made sure that the client xConnect ...
14
votes
1answer
540 views

How is the FXM bundle beacon constructed?

I am trying to implement FXM for a customer, with the purpose of collecting data from a bunch of WordPress based sites into a single repository. An example of such a site is http://dev.verum.se/test/...
0
votes
3answers
56 views

Should ConnectionStrings.config be in source control/VS?

Or alternatively should ConnectionStrings.config just be left up to the server environment and never part of your VS publish?
2
votes
3answers
1k views

Patch attribute does not replace patch:source

This is not exactly a problem, more of an irritating itch... I have replaced the InitializeGlobalFilters with a patchfile called InitializeGlobalFilters.config: <configuration xmlns:patch="http://...
2
votes
1answer
45 views

How to specify custom CD Server URL for Language (.co.in instead of /en-in)

Im currently trying to set the publish url for a specific language on the CD server. On the CM server the URL is mysite.com/en-in I want the CD servers URL to be mysite.co.in. How do I specify the CD ...
0
votes
0answers
450 views

Sitecore images served as ashx when Media.RequestionExtension setting is blank

We've just deployed to a new environment and expected images from the Media library to be referenced with their original file extensions e.g. .jpg as Media.RequestionExtension setting is "". They are ...
1
vote
1answer
45 views

Change value of SC_ANALYTICS_GLOBAL_COOKIE to false

Can we override SC_ANALYTICS_GLOBAL_COOKIE through code? Meaning, in my configuration file I set to true, through code I want to set it to false for a particular user. Is it possible?
11
votes
4answers
3k views

Install-SitecoreConfiguration xconnect-solr.json - Error Invoke-ManageSolrCoreTask : Missing required parameter: name

What: I am trying to install sitecore XP1 architecture. I already have a signed certificate. My issue comes when I try to configure sitecore on my solr. Sitecore 9.0.1 rev. 171219. SOLR 6.6.4. ...
1
vote
1answer
29 views

What is the equivalent of the “DataProviderTimeout” setting in Sitecore 9

I want to temporarily increase the timeout settings in a Sitecore 9 environment while I run the tool for removing broken links (https://stackoverflow.com/questions/28725537/how-to-remove-broken-links-...
1
vote
2answers
67 views

Patching an attribute using non-patching syntax

In Sitecore config patch files, both of the following will give the same result: <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:role="http://www.sitecore.net/...
7
votes
2answers
367 views

EnforceVersionPresence not working on home/start item of site when using “/”

Situation We have a Sitecore 8.1 Initial install with a site that has enforceVersionPresence="true" in the site definition. We have a _BasePage template for which in the advanced section we have now ...
5
votes
1answer
1k views

NullReferenceException when executing pathAnalyzer/newMapAgent

I'm a new maintainer for an instance of Sitecore 8.2. I'm seeing this error a lot in the logs: 1664 16:28:00 WARN Could not find constructor in ReflectionUtil.CreateObject: Sitecore.PathAnalyzer....
1
vote
2answers
61 views

Sitecore Context null in web.config handler

I'm trying to create a handler to intercept index.cfm files, as we're migrating from an old ColdFusion system to Sitecore. I've designated the handler like this: <system.webServer> <...
2
votes
0answers
40 views

WebDAV disabled but still getting PROPFIND error

I have a Sitecore 8.2 site. WebDav is disabled on the CD as per https://doc.sitecore.com/developers/82/sitecore-experience-platform/en/disable-webdav.html# by disabling the Sitecore.WebDAV.config. ...
4
votes
2answers
528 views

Why CleanUp doesn't work for the Blobs Table?

We have a Sitecore 8.1.1 with Sharepoint Connector 2.1. the connector imports 4000 documents from the Sharepoint (max 10 GB). The problem is that the Blob Tables last time were more than 80 Gb on ...
6
votes
3answers
534 views

Filter standard Sitecore log messages into separate logs

We would like to make the main Sitecore log file more clean,and filter away all the unnecessary information that makes finding errors and other relevant information harder. After upgrading to Sitecore ...
2
votes
2answers
193 views

Config files change while upgrade sitecore 8.0

Currently, I have Sitecore 8.0(update 1) site and I want it to upgrade it to update 2. I am following the 8.0 Update-2 Upgrade Guide. In this guide, there is a step of Apply the configuration file ...
3
votes
2answers
1k views

When is the website's temp folder cleaned?

I'm trying to figure out when the temp folder gets cleaned. Talking about this setting in Sitecore.Config: `<sc.variable name="tempFolder" value="/temp"/>` From what I found, there is a ...
5
votes
3answers
219 views

Patch forceDownload in Sitecore media types for PDF files

I want to patch only the ForceDownload attribute in below config: <mediaLibrary> <mediaTypes> <mediaType name="PDF file" extensions="pdf"> <mimeType>...
2
votes
2answers
2k views

Adding new connection into ConnectionStrings.config gives “exceptions occurred while processing the subscribers to the 'property:changed' event”

After I added new connection string into ConnectionStrings.config file, I cannot log into Sitecore and getting this exception: Exception textually: > Server Error in '/' Application. > One or more ...
0
votes
0answers
27 views

Does runAllManagedModulesForAllRequests need to be set to “true”

I want to prevent the Session module (and other unnecessary modules) from running for static resources (.js, .css, etc..)
5
votes
2answers
4k views

What is a pipeline?

In the Sitecore configuration, I see a lot of different nodes under the <pipelines> element. I have been through the Sitecore Certification course and don't recall us covering these in detail? ...
12
votes
3answers
2k views

Cannot patch Sitecore initialize pipeline (Sitecore 8.1 Update 3)

I am trying to patch the initialize pipeline to add a processor. I simply add the following config (obtained from a KB article here) in include folder: <?xml version="1.0" encoding="utf-8"?> &...
5
votes
2answers
2k views

How to patch 'system.webServer' using Sitecore patch config file

The browser console was showing errors for woff font type. So, in the site's web.config I included this property and it was fixed. <system.webServer> ...... ...... <staticContent> <...
5
votes
2answers
233 views

Fixing wrong wizard titles

I use the WFFM module for a client. The problem is just that there are wrong texts in the wizard for inserting a form: Select Insert an existing form, press next. The subtitle under Select a Form is ...
5
votes
2answers
166 views

Can I use Sitecore's Configuration patching mechanics for my Identity Server configuration?

Fairly sure I can guess the answer, but getting this question on record is still useful. Long story short: Can I use config patch files to manage configuration settings on my Sitecore IS web ...
-1
votes
2answers
311 views

Error: The type or namespace name 'MVC' does not exist in the namespace 'Sitecore' [closed]

I'm facing this issue in one of my testing instances: Sitecore 9.1.0 Inner Exception: c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\84f876eb\34615233\App_Web_events....
2
votes
1answer
69 views

Excluding template fields from indexing - difference between documentOptions exclusion vs regular exclusion

I reducing the number of fields which get indexed in my site. I looked at App_Config\Include\Sitecore.ContentSearch.Azure.DefaultIndexConfiguration.config and see the section <configuration <...
14
votes
2answers
789 views

Server role config with ContentManagement,Processing,Reporting not working

We wanted to setup a server as ContentManagement,Processing and Reporting instance. As we can combine roles, we changed the config accordingly. <add key="role:define" value="ContentManagement,...
2
votes
1answer
43 views

Sitecore Desktop database selection shows non-existent database

On my instance of Sitecore 8.2 Update 7, the database selection list in the lower right hand corner show two webs: There is only one web in publishing targets: And my connection strings only have ...
1
vote
0answers
33 views

What would cause a rendering to not show in preview mode for non-admins?

I have a rendering that shows fine for admin users but doesn't display for non-admins in preview mode. This happens on our production server but on our development server the rendering displays fine ...
0
votes
1answer
91 views

Sitecore patch files not overriding the value in Rainbow.config

I am using Sitecore 9.1.1 and I am trying to override the value of Rainbow.SFS.SerializationFolderPathMaxLength in the foundation.serialization.settings.config. But sitecore is taking the value from ...
1
vote
1answer
135 views

System.InvalidOperationException: geoIpServiceUri

I am troubleshooting why GeoIP information is not being resolved in my Sitecore 9.1.1 instance on Azure PaaS To try and ascertain whether the Sitecore GeoIP services has been subscribed to correctly, ...
0
votes
0answers
46 views

Need to know the configuration files to be modified in CD server

I have installed Sitecore 9.1 XP scaled(XP1) topology using PowerShell script shared in installation guide. I have sitecore.cm, sitecore.cd and other app process installed (REP,PRC,etc). When i ...
1
vote
1answer
117 views

Patching in a custom StandardValues provider

I am trying to add a custom StandardValues provider to a Sitecore 8.1 site (8.1.0 rev 160519) and I am not having a good time. To do this I reflected the standard Sitecore.Data.StandardValuesProvider ...
5
votes
2answers
142 views

Sitecore populating date field with yesterday's date via $date token

I have a date field in one of my templates who's default value is $date. When I create an item using that template, the raw value is 20190522Z, but when I view it not raw I see it as yesterday's date ...
2
votes
1answer
58 views

How does Sitecore read .jssconfig and .sxaconfig files?

So we know that Sitecore.Configuration.Factory reads through all files ending in *.config in the App_Config/Include folder of your website root. But I've seen with SXA and JSS, that additional config ...
1
vote
2answers
741 views

CD server throws “Unknown connection string. Name: 'master'”

I think I'm completely missing some step in my CD server deployment as I'm setting up my first XP Scaled environment in Azure and I'm facing the following issue with my CD server: Unknown ...
1
vote
1answer
231 views

Use Seq for logging with log4net instead of text file

Using Sitecore 8.2. I want to log to SEQ instead of a standard file for the Sitecore log. Since Sitecore uses log4net, I've been looking at this documentation: https://docs.getseq.net/docs/using-...
2
votes
1answer
184 views

How to solve ambiguous constructors when trying to start Sitecore

We have a local Sitecore 9.0.2 installation that is relatively vanilla. It is currently failing to load the Configuration Manager because of the following error message. Server Error in '/' ...
1
vote
1answer
116 views

Boosting in solr vs lucene

I am changing the search engine from lucene to solr , and i want to make config changes in my custom indexes , i am using the search_keywords field for the predictive search , and the field is also ...
2
votes
1answer
77 views

Logged user is always sitecore\Anonymous during processor in SC 9.1

I'm using Sitecore 9.1, thus an identity provider. I have a custom domain named aba and I'm logged in Sitecore Administration Console using an aba\hsantos user. Then I have this processor which is ...