Questions tagged [container]

Any questions related to the docker container in the context of Sitecore should use this tag

Filter by
Sorted by
Tagged with
0
votes
0answers
28 views

Progressing Sitecore Helix .Net Core example to Production Build

So I am using the .Net Core Helix example from Nick Wesselman (https://github.com/Sitecore/Helix.Examples/tree/master/examples/helix-basic-aspnetcore/). I have managed to get it all up and running and ...
0
votes
1answer
24 views

JSS Containers setup, CM container does not start or attempt to start

I'm following the JSS walkthrough with container and I'm running into an issue running the up.ps1 script. Most of the script runs fine, but when it goes to start the containers the cm container doesn'...
0
votes
1answer
31 views

Getting Started Template - File in use by another process [duplicate]

So I am doing the walkthrough: https://doc.sitecore.com/en/developers/101/developer-tools/walkthrough--using-the-getting-started-template.html Everything seems to work just fine (the occasional ...
1
vote
0answers
49 views

Sitecore 10.0 Update 1 CM container Health check error

I am using Sitecore 10 update 1 and XP1 topology. All containers are healthy except CM container. I can see following errors in logs - ERROR Health check Sitecore.XConnect.Client.WebApi....
1
vote
1answer
69 views

Install certificate to store on container

I'm working on migrating my existing Sitecore 10.1.1 site into containers. My code requires a cert to be available in the local certificate store on the container. It seems like the Sitecore ID ...
0
votes
0answers
97 views

Sitecore 10 MVC Multisite Container Architecture?

Problem There is lots of documentation on how to create an MVC Sitecore site with Docker and containers. But how would you recommend creating a multisite Sitecore site for a multitenant 8+ site ...
0
votes
1answer
95 views

Remove dependencies in liveness and readiness probes

I'm working on setting up Sitecore 10.1 in Containers. I read this blog post and found following recommendation: "Configure liveness and readiness probes for your pods. Sitecore provides out-of-...
2
votes
0answers
107 views

Sitecore shutting down after Cache created: SqlDataProvider - Prefetch data(master)

I am running Sitecore XM 10.0.1 in an AKS cluster. Everything has been running smooth for quite some time, but every once in a while the CM and CD containers just won't start. The container logs just ...
0
votes
1answer
95 views

Issue browsing CM Sitecore container

I'm having an issue when I try to browse my Sitecore 10.1 CM Container in the browser. The message I get is a 404 error. Investigating a bit more I checked traefik logs and saw lots of errors: *Failed ...
0
votes
0answers
43 views

Helix publishing pipeline uses bin folder as source in docker setup

We are using the Helix Publishing Pipeline (HPP) and defined the settings to exclude the default dlls (Sitecore, Commerce, Newtonsoft etc). There is a publish project in VS for this and when clicked ...
3
votes
1answer
132 views

How do the xConnect Docker containers correspond to the Azure xConnect app services?

I've tried to find documentation on the various xConnect roles that exist and their names and map them to the names of the xConnect containers in an XP1 container setup and an Azure PaaS configuration,...
2
votes
1answer
123 views

Sitecore Commerce installation fails in Docker

Using - Sitecore.Commerce.Container.SDK.2.0.159 We were able to successfully install Sitecore XP 10.1 in docker on our local machine running on Windows 10 64-bit. However, when we tried to install ...
6
votes
1answer
2k views

Why won't Visual Studio load symbols when attaching to a container's w3wp process?

I want to debug my code running in a Sitecore CM Docker container. When I attach my debugger, it never breaks at my breakpoints and hovering over them always says The breakpoint will not currently be ...
5
votes
1answer
171 views

Sitecore Docker containers stop unexpectedly after a few minutes

I'm having an issue keeping my containers running consistently. After I run docker-compose up -d, some of them stop unexpectedly after only 10-15 minutes, sometimes less. When I run docker ps -a to ...
4
votes
1answer
498 views

Local Sitecore containers unable to access Docker DNS

We are working on setting up Sitecore 10 in containers in Docker. I have been able to set up a simple XP0 configuration which works when I run docker-compose up -d on a Windows Server 2019 machine. ...
2
votes
1answer
494 views

Error on mssql-init container during the deployment of Sitecore to AKS

I am following the production installation guide to install sitecore on AKS. I am at the step of "Deploy the data initialization jobs". I have run the command and it created 2 jobs in ...
4
votes
4answers
2k views

Docker-Compose up -d fails with unhealthy xconnect and cm

I'm having trouble getting a basic xp0 environment set up on my local development machine. When I run docker-compose up it times out on the xconnect healthcheck because of a SQL login error to the ...
3
votes
1answer
347 views

SItecore XP 10 on Docker: how to install a package when the bin/ folder is read-only?

I am testing Sitecore 10 using docker containers. I followed the guide in Sitecore docs Everything seems to work fine, but I had some problems while installing new packages. For example I wanted to ...
3
votes
1answer
208 views

Error viewing JSS app: Item has already been added. Key in dictionary: 'PSMODULEPATH' Key being added: 'PSModulePath'

We are using Sitecore JSS running against Sitecore 9.2 in containers. The containers are built from https://github.com/Sitecore/docker-images with only minor changes (adding Unicorn, App Insights etc)....
12
votes
1answer
489 views

Does Sitecore have support for Sitecore products in containers?

I know that Sitecore has a repository for Docker images (https://github.com/Sitecore/docker-images) but as far as I understand currently the code and examples found in this repository are created and ...
0
votes
2answers
71 views

Image build stuck - Step 14/25 : RUN & 'c:/solr/bin/solr.cmd

Have been trying to setup the sitecore docker with command below: Import-Module Sitecore.DockerImages.Management -Force -Verbose # Check parameters: #-VersionsFilter ".*\\9\.0\.1 rev\. 171219\\.*...