Skip to main content

Questions tagged [container]

Any questions related to the docker container in the context of Sitecore should use this tag

Filter by
Sorted by
Tagged with
1 vote
1 answer
57 views

I'm unable to install headless CMS in sitecore 10.2 Docker Setup?

Encountering error: invalid from flag value headless_image: pull access denied for headless_image, repository does not exist or may require 'docker login': denied: requested access to the resource is ...
Bharath's user avatar
  • 11
1 vote
1 answer
28 views

SXA search result API is not giving the result for the custom index on newly setup preview CD based on publishing target

We have created the custom indexes on the newly set CD server based on the new publishing target using docker. Please quickly check one of the posted questions to get an idea of how I've set up the ...
Jumping Rabbit's user avatar
0 votes
1 answer
75 views

New publishing target based CD server is not showing index data

In docker, I created the new publishing target as preview and set the new container by copying the docker-componse instructions of the CM service and removed the master connection string from this, ...
Jumping Rabbit's user avatar
0 votes
1 answer
28 views

SitecoreAIStandardContainerDeployment

I want to install Sitecore with SitecoreAIStandardContainerDeployment. I am following up on this link, as recommended by Sitecore. https://dev.sitecore.net/Downloads/...
biswajit sahu's user avatar
0 votes
1 answer
88 views

Docker cd service intermittently fails to start

I am running SQL from my host machine rather than via the OOTB mssql service. I did this by customizing the database query strings in my docker compose override file: cd: environment: ...
Marcel Gruber's user avatar
0 votes
2 answers
346 views

Can I install sitecore10 without installing container with it?

I don't need to use docker in my local training env. Is it possible to not install containers when installing Sitecore 10 or is it mandatory?
Doaa Abdallah's user avatar
1 vote
1 answer
4k views

Error getting SSL certificate - Nginx Ingress Controller (Kubernetes)

I am trying to deploy the vanilla Sitecore packages to Kubernetes. I have an issue mapping the domain into the cluster via the Ingress Controller. When I exec into the ingress controller pod, I can ...
Dean OBrien's user avatar
  • 1,635
3 votes
2 answers
2k views

Error response from daemon: Get "https://scr.sitecore.com/v2/": context deadline exceeded

Getting below error while running container in windows 11. Hyper-V is enabled. Keeping XM Cloud base image up to date Error response from daemon: Get "https://scr.sitecore.com/v2/": context ...
Akash Savalagi's user avatar
2 votes
1 answer
328 views

Cumulative hotfix for Sitecore XP 10.2 - Container

Need your help on the below, Issue: Sitecore CM - Unable to access content Editor - Need to install the Cumulative hotfix (Sitecore XP 10.2.0). Description: In one of our Sitecore applications, we ...
Raj's user avatar
  • 21
0 votes
1 answer
34 views

Am I wrong or the horizon-integration-xp1-assets:3.0.0-ltsc2022 is missing the module/db folder?

It looks that horizon-integration-xp1-assets:3.0.0-ltsc2022 is missing the module/db folder. Attached is LTSC2022 vs. 1809 Databases Deployment: LTSC2022: Step 8/13 : FROM ${...
victor pro's user avatar
2 votes
1 answer
566 views

Sitecore Docker Development Image for MS SQL Server 2019

The Sitecore container registry contains mssql-developer images for Windows OS targeting only MS SQL Server 2017 (see full list here). The Microsoft Artifact Registry contains only MS SQL Server ...
Alessandro Faniuolo's user avatar
0 votes
1 answer
309 views

Sitecore Docker exited with code 1 while setting Sitecore admin password

While running up.ps1 in step 7 of Create the ScNext(MyProject name locally) solution in Walkthrough: Setting up a development environment with the Sitecore Containers template for Next.js, container ...
vikramsagarag's user avatar
1 vote
0 answers
505 views

mssql-init container not able to connect with mssql container

While trying to setup XMCloud in local, mssql-1 container is build and is healthy. mssql-init container throws the below error 2023-03-05 11:12:01 Sqlcmd: Error: Microsoft ODBC Driver 17 for SQL ...
ayanpush's user avatar
0 votes
1 answer
575 views

Error while installing Sitecore in docker [duplicate]

I am trying to setup Sitecore 10.3 with docker containers. While trying to run the .\up.ps1, I am facing below error with the certificate while building the containers: Unable to load the service ...
Anonymous's user avatar
0 votes
1 answer
104 views

problem with establishing connection with Container website with TDS

facing issue with establishing TDS connection with container website. i already setup local instance using https://github.com/Sitecore/docker-examples/tree/develop/custom-images its is working fine. ...
Balaji Balasubramanian's user avatar
1 vote
1 answer
205 views

SolrCloud Base ConfigSet does not exist: sitecore_content_config

I run Sitecore 10.2 with SXA in containers and I deleted all my SOLR data, SOLR Cloud have 0 collections and only a default configset in ZooKeeper. The solr-init containers give the following error on ...
Jan Bluemink's user avatar
  • 1,185
1 vote
0 answers
158 views

Unable to debug Sitecore 10.2 docker containers-msvsmon process is not getting enabled

The msvsmon process is not enabled, so I cannot debug the docker container. Does anybody have any idea how to enable this process?
Rajendra Patil's user avatar
2 votes
1 answer
213 views

Cd url is going to 404

I have downloaded Sitecore Next JS containers setup and installed XP1 in our local instance. But the default CD url is going to 404. The CM Sitecore url including Experience Editor & Preview and ...
Shakti Patro's user avatar
0 votes
1 answer
987 views

Docker can not start myproject_mssql-init_1 and myproject_solr-init_1

I'm running up.ps1 in step 7 of Create the MyProject solution in the Sitecore 10 Getting Started Template. All containers are started except myproject_mssql-init_1 and myproject_solr-init_1 But up....
Nhan Nguyen's user avatar
0 votes
1 answer
828 views

ERROR: Service 'dotnetsdk' failed to build : Build failed

I am getting failed to register layer: Error processing tar file(exit status 1): link /Files/Program Files/common files/Microsoft Shared/Ink/en-US/micaut.dll.mui /Files/Program Files (x86)/common ...
Nhan Nguyen's user avatar
1 vote
1 answer
851 views

The remote name could not be resolved "rendering" error in experience editor

I am using Sitecore 10.2 and did the local setup by following the below link-- https://doc.sitecore.com/xp/en/developers/hd/200/sitecore-headless-development/walkthrough--setting-up-a-development-...
Shakti Patro's user avatar
1 vote
1 answer
247 views

How can I deploy custom config files to an Identity Server container?

We'd like to enable the Sitecore Federated Authentication on Sitecore 10.2 with containers. I've updated the ClientId, TenantId, claim transfermations, etc... in different xml files. But I don't know ...
Ray Zhang's user avatar
1 vote
1 answer
125 views

Sitecore MVP-Site Docker Error

I am following the readme for the MVP-Site: https://github.com/Sitecore/MVP-Site I am getting the default site coming up and the cm site at https://cm.sc-mvp.localhost/sitecore/ but the https://mvp.sc-...
Colema18's user avatar
  • 321
-1 votes
2 answers
93 views

Create “Application for a Site” in Sitecore 10.2 containers

We are migrating our existing solution from Sitecore 8.2 (IaaS) to Sitecore 10.2 containers. Migration is completed for the main site, but one of our main functionality is hosted as “Application for ...
PremKumar_2530's user avatar
2 votes
2 answers
327 views

When creating a new solution do I have to run the .\init.ps1 command again to prepare the container environment?

I am going through the Developer Fundamentals training for Sitecore 10 on the Sitecore website. I created a solution before starting the training following my company's documentation. I ran .\init.ps1,...
newDev051's user avatar
1 vote
0 answers
510 views

Hard Time Creating mssql-init image with Multiple Modules on XP1

I'm trying to create an mssql-init image for XP1 that will install the following components: SPE module CH connector SXA module Coveo Coveo SXA I'll be using this to deploy to an Azure SQL server. I ...
Rafael Medeiros's user avatar
2 votes
1 answer
1k views

JSS Containers setup, CM container does not start or attempt to start

I'm following the JSS walkthrough with container and I'm running into an issue running the up.ps1 script. Most of the script runs fine, but when it goes to start the containers the cm container doesn'...
NDaigle's user avatar
  • 21
0 votes
1 answer
344 views

Getting Started Template - File in use by another process [duplicate]

So I am doing the walkthrough: https://doc.sitecore.com/en/developers/101/developer-tools/walkthrough--using-the-getting-started-template.html Everything seems to work just fine (the occasional ...
Joe Dearsley's user avatar
1 vote
1 answer
1k views

Sitecore 10.0 Update 1 CM container Health check error

I am using Sitecore 10 update 1 and XP1 topology. All containers are healthy except CM container. I can see following errors in logs - ERROR Health check Sitecore.XConnect.Client.WebApi....
Siddharth's user avatar
  • 527
1 vote
1 answer
893 views

Install certificate to store on container

I'm working on migrating my existing Sitecore 10.1.1 site into containers. My code requires a cert to be available in the local certificate store on the container. It seems like the Sitecore ID ...
Jeroen's user avatar
  • 1,224
1 vote
1 answer
472 views

Sitecore 10 MVC Multisite Container Architecture?

Problem There is lots of documentation on how to create an MVC Sitecore site with Docker and containers. But how would you recommend creating a multisite Sitecore site for a multitenant 8+ site ...
w00ngy's user avatar
  • 155
0 votes
1 answer
595 views

Remove dependencies in liveness and readiness probes

I'm working on setting up Sitecore 10.1 in Containers. I read this blog post and found following recommendation: "Configure liveness and readiness probes for your pods. Sitecore provides out-of-...
Jeroen's user avatar
  • 1,224
2 votes
0 answers
502 views

Sitecore shutting down after Cache created: SqlDataProvider - Prefetch data(master)

I am running Sitecore XM 10.0.1 in an AKS cluster. Everything has been running smooth for quite some time, but every once in a while the CM and CD containers just won't start. The container logs just ...
GuidovTricht's user avatar
0 votes
1 answer
510 views

Issue browsing CM Sitecore container

I'm having an issue when I try to browse my Sitecore 10.1 CM Container in the browser. The message I get is a 404 error. Investigating a bit more I checked traefik logs and saw lots of errors: *Failed ...
Diego's user avatar
  • 5,688
0 votes
0 answers
124 views

Helix publishing pipeline uses bin folder as source in docker setup

We are using the Helix Publishing Pipeline (HPP) and defined the settings to exclude the default dlls (Sitecore, Commerce, Newtonsoft etc). There is a publish project in VS for this and when clicked ...
sukesh's user avatar
  • 3,162
3 votes
1 answer
309 views

How do the xConnect Docker containers correspond to the Azure xConnect app services?

I've tried to find documentation on the various xConnect roles that exist and their names and map them to the names of the xConnect containers in an XP1 container setup and an Azure PaaS configuration,...
Dan Sinclair's user avatar
  • 5,394
2 votes
1 answer
347 views

Sitecore Commerce installation fails in Docker

Using - Sitecore.Commerce.Container.SDK.2.0.159 We were able to successfully install Sitecore XP 10.1 in docker on our local machine running on Windows 10 64-bit. However, when we tried to install ...
sukesh's user avatar
  • 3,162
11 votes
1 answer
6k views

Why won't Visual Studio load symbols when attaching to a container's w3wp process?

I want to debug my code running in a Sitecore CM Docker container. When I attach my debugger, it never breaks at my breakpoints and hovering over them always says The breakpoint will not currently be ...
Dan Sinclair's user avatar
  • 5,394
5 votes
1 answer
784 views

Sitecore Docker containers stop unexpectedly after a few minutes

I'm having an issue keeping my containers running consistently. After I run docker-compose up -d, some of them stop unexpectedly after only 10-15 minutes, sometimes less. When I run docker ps -a to ...
Dan Sinclair's user avatar
  • 5,394
6 votes
2 answers
1k views

Local Sitecore containers unable to access Docker DNS

We are working on setting up Sitecore 10 in containers in Docker. I have been able to set up a simple XP0 configuration which works when I run docker-compose up -d on a Windows Server 2019 machine. ...
Dan Sinclair's user avatar
  • 5,394
2 votes
1 answer
1k views

Error on mssql-init container during the deployment of Sitecore to AKS

I am following the production installation guide to install Sitecore on AKS. I am at the step of Deploy the data initialization jobs. I have run the command and it created 2 jobs in kubernetes cluster,...
Prasanth Nittala's user avatar
4 votes
6 answers
6k views

Docker-Compose up -d fails with unhealthy xconnect and cm

I'm having trouble getting a basic xp0 environment set up on my local development machine. When I run docker-compose up it times out on the xconnect healthcheck because of a SQL login error to the ...
Dan Sinclair's user avatar
  • 5,394
3 votes
1 answer
826 views

SItecore XP 10 on Docker: how to install a package when the bin/ folder is read-only?

I am testing Sitecore 10 using docker containers. I followed the guide in Sitecore docs Everything seems to work fine, but I had some problems while installing new packages. For example I wanted to ...
Olivier Michel's user avatar
3 votes
1 answer
271 views

Error viewing JSS app: Item has already been added. Key in dictionary: 'PSMODULEPATH' Key being added: 'PSModulePath'

We are using Sitecore JSS running against Sitecore 9.2 in containers. The containers are built from https://github.com/Sitecore/docker-images with only minor changes (adding Unicorn, App Insights etc)....
sussexrick's user avatar
12 votes
1 answer
498 views

Does Sitecore have support for Sitecore products in containers?

I know that Sitecore has a repository for Docker images (https://github.com/Sitecore/docker-images) but as far as I understand currently the code and examples found in this repository are created and ...
Tamas Varga Sitecore's user avatar
0 votes
2 answers
106 views

Image build stuck - Step 14/25 : RUN & 'c:/solr/bin/solr.cmd

Have been trying to setup the sitecore docker with command below: Import-Module Sitecore.DockerImages.Management -Force -Verbose # Check parameters: #-VersionsFilter ".*\\9\.0\.1 rev\. 171219\\.*...
Nil Pun's user avatar
  • 2,293