Questions tagged [content-delivery]

Questions relating to Sitecore instances that have been optimised for serving managed content to internet users.

Filter by
Sorted by
Tagged with
0
votes
1answer
195 views

Lucene indexes not updating on CD

We have an issue in our UAT environment where the sitecore_web_index Lucene index is not getting updated on a content delivery server when content is published. I found this solution on Stack ...
9
votes
2answers
1k views

Content delivery setup - Lucene indexes

I have an issue that Lucene indexes are not updated or properly created on the content delivery server after a rebuild of the indexes on the content management server or after an item publish. The ...
3
votes
2answers
1k views

Web API 404 on content delivery server

I am using Sitecore on azure and have a CD and a CM server. The Web API works fine on CM but throws a 404 error (and no more information in logs). I have deleted the following dll files from server ...
7
votes
5answers
2k views

Post Condition Failed on Sitecore 9 Content Delivery Server

The CD version of Sitecore 9 was installed on our CD server. The error below is typically seen with a SwitchMasterToWeb.config file issue in previous versions: Post condition failed Description: ...
2
votes
2answers
411 views

Trouble creating content item using Glass Mapper on a CD server

I have a Sitecore 8.1 CD server. I have a page where a user can create a new shipping address and save it back to the Master database. I am using Glass Mapper for this. Here is my code: Models....