Questions tagged [content-editor]

For questions related to the Content Editor interface. Includes context menu, ribbon, content tree, field sections, field validations, etc.

Filter by
Sorted by
Tagged with
0
votes
1answer
24 views

RTE “Show Editor” edit adds one extra <a> to HTML <a>

We wrote below code in RTE "HTML editor". Saved it. published it. <div class="content-center"> <a href="https://google.com"> <div class="...
1
vote
1answer
53 views

Is there a built in report to list all items of one type that link to items of another type?

I'm hoping there is a report of all pages that utilize items of a certain type (created from one template). I'm probably not asking this right, but here goes: I have a number of items created from ...
0
votes
0answers
19 views

Add new language version not working

Im running into an issue that is only happening for our non english users. This issue is only happening with a specific Page Template as well. When a regional user click on the Add new Version button ...
2
votes
1answer
48 views

Load content editor with item pre-selected & translation mode turned on

I'm trying to create a link that opens the content editor with the following conditions: Specific item pre-selected Specific language pre-selected Translate mode (version tab > translate button) with ...
0
votes
0answers
27 views

How can a previously removed component be fully restored from standard values?

When a component coming from a template has been removed from a page item, it can be restored by resetting layouts from standard values. However, if changes are made to the component at the template ...
0
votes
0answers
23 views

Why are page components getting bumped to bottom of components list after template is deployed?

After a particular template is deployed during a release, page level components are getting bumped to the bottom of the components list on page final layout. We've pulled that template from getting ...
0
votes
0answers
92 views

If I add a CSV file to the media library and visit that item in Sitecore, a file is downloaded automatically with the content of that media item

I want to upload a CSV file into our media library. In our Dev environment, this works as expected, the file uploads, shows up in the content tree, mime-type/extension is getting set appropriately, ...
0
votes
0answers
19 views

How to programmatically expand a TreeviewEx to a specific folder, without collapsing existing expanded folders

I can expand a TreeviewEx to a specific item with the below code, but any existing folders are collapsed. How can I expand a folder without collapsing the existing expanded ones? var datacontext = ...
0
votes
0answers
40 views

Experience editor missing Workflow

When I edit the content on the content editor the workflow is triggering and showing Request for approval command option under the Review tab, whereas when I edit the content through Experience editor ...
0
votes
1answer
29 views

Customizing Rich Text Editor to automatically link email addresses while editing

While I know you can hook into the item:save command or override the scSendRequest method, is there a better way to automatically make email addresses self mailto link when entered? (think of MS word, ...
1
vote
1answer
39 views

CD reporting placeholder was not found in the “Home” item

Sitecore 8.2 Update 3 There were a lot of broken links so I used the admin tool to remove them, but I am still getting tons of "placeholder was not found in the 'Home' item" messages in the log. I ...
1
vote
1answer
45 views

How do I hide a field from display in the Experience Editor's component editor?

I need to hide a template field on both Content Editor and Experience Editor. For Content Editor, I could achieve it by overriding the GetFields pipeline. It still shows up on the Experience Editor. ...
0
votes
1answer
27 views

Rendering Parameters on EXM missing in CE tree

When you are creating an email campaign on EXM, and go to the message tab, and select the body of message, then select one of the renderings, More, Edit component Properties, Add a rendering Parameter:...
1
vote
0answers
43 views

Closing custom tab on item context change

I have a custom button in content editor that will trigger a command that will run the following code(simplified for this purpose) SheerResponse.Eval((new ShowEditorTab() { ...
1
vote
2answers
264 views

Track Sitecore Login

I need to pull up how many users logged in to Sitecore CM per month (for the past 6 months). Is there a way I can do this through Sitecore or maybe in core db, which table should I look at?
0
votes
1answer
85 views

Where will an orphaned item be restored from recycle bin?

Where will Sitecore restore an item from the recycle bin whose Original Location is [orphan]/Item Name?
3
votes
0answers
61 views

Modifications to Content Editor for Accessibility Input Labels

Is there a Sitecore supported or unsupported way of modifying html structure of Content Editor and Experience Editor for the purpose of supporting screen readers used for accessibility/visually ...
0
votes
1answer
37 views

Show [shared] text for non admins [duplicate]

When I have a shared field, then I can see that this is a shared field as admin in content editor like: with the "[shared]" at the end. but when I login with my contentmanager there is nothing an the ...
3
votes
1answer
246 views

How to create Dropdown in Rich Text Editor (wysiwyg) in Sitecore 9.0.2

I am trying to create a Dropdown in WYSIWYG. I have added the Item using the Html Editor Drop Down Button template and Dropdown values using the Html Editor List Item in the core database. However, it'...
0
votes
0answers
21 views

Not Able to Publish Items from Experience Editor after cloning component in SXA

Recently i started working on SXA and cloned the Event List Component and named Custom Event List in which i added some fields , after drag/drop the component in the Experience Editor , and created ...
1
vote
1answer
38 views

NexusPipelineApi.Resume exception

I am on SC 9.2. When I try to edit an item as a non-administrator that is under workflow, I am getting the following error. The item is getting checked out, and a new version is created, but the ...
1
vote
1answer
27 views

MVC Route within content editor

I have a custom tab on the right-hand side(where we can see item fields) for my items in content editor and I am loading a MyTab.cshtml page within this custom tab. This .cshtml I'm trying to post a ...
4
votes
2answers
166 views

Placeholders of same name all using same data source

I am really new to Sitecore and I have run into a problem. I have a placeholder called "sectionBlock" that I am using multiple times on one page. The view rendering that I have allowed it to use is ...
0
votes
1answer
55 views

How to get/publish the items removed from the multilist field

Recently i was trying to get the items which are removed from the multilist field , suppose i have a multilist field and i added 3 items from left side to right side and saved and published those ...
0
votes
2answers
104 views

Updating a field Standard Value for Page Data Template without affecting the field value for existing Pages

I have a slightly strange situation where essentially the Standard values for a droptree field have been set incorrectly for quite some time on a number of page templates. The 'Content Type' field ...
4
votes
1answer
344 views

Is the 100 child item limit still a valid rule of thumb?

I always understood that Sitecore recommends having fewer than 100 items under a node. Is this rule still valid? Does having too many child items only impact the Content Editor when opening the ...
0
votes
2answers
43 views

droptree field -Return data by language

I used droptree field to allow the content author to select news items, and the content author has a specific language for example (en), but I can not filters news by languages. is there any way to ...
3
votes
3answers
220 views

Multilist with search display results without Template name

I used the multilist with search and it works fine, but the results return the items and (Template name), and I want to return items name only without template name. is there any way to do that? my ...
0
votes
1answer
86 views

exceptions occurred while processing the subscribers to the 'item:saved'

Whenever I try and copy a single item anywhere, I get this error. I have serialized the item and it has a template. NOTE: This is an item in a branch 12304 14:24:32 ERROR One or more exceptions ...
4
votes
2answers
604 views

Get list of Sitecore items updated by Specific User

My project is running on Sitecore 9, before 10 days I deployed changes on production environment after that content editor started updating content on production, we have created new user and that ...
1
vote
0answers
39 views

On Item Creation: Warning/Confirmation dialog for invalid Item Name

I want to create a Warning/Confirmation dialog when certain items do not pass our custom item name validation rules. The user can still override the warning dialog via OK/Cancel Buttons. I've tried ...
3
votes
2answers
328 views

Dynamic DataSource for Droplist in Content Editor

I have a Droplist for Approvers and the DataSource of Droplist to /SharedData/Approvers. I don't want the current user to have his own name in the list. For example, DataSource List is having A, B ...
1
vote
1answer
93 views

“ForceDownload” downloads images in CM even when set to false [closed]

I'm using Sitecore 9.1.1 and SXA 1.8.1. I needed to make .png and .txt files downloadable in my site, so I followed the answer here, and added a config patch where forceDownload is set to true for ...
1
vote
0answers
24 views

how to create custom saveactions at content tree side

sitecore 9.1 how to create forms saveactions at content tree side,like sitecore 8.2 wffm's saveactions.? In sitecore 9.1 directly select save action at forms module but we need to same at content ...
2
votes
1answer
130 views

Can we set the default content language in dropdown

I want to set the language in the dropdown -as shown in the image below- to another language on a per user basis. Our website is only in Japanese. Every time a new item is created or the page loads, ...
1
vote
0answers
141 views

Default enabling checkbox in rendering parameter isn't recognized by view

We have a view that uses rendering parameters, one of which sets a model property that determines whether a form should show inside the view. When I change the default value to 1 for that checkbox, ...
0
votes
1answer
178 views

Custom checkbox field for Enum C# Type

My problem: The code in solution contains an Enum type that is used to render some view and needs to be configured for different items. I am looking for a way to create a custom checkbox field to be ...
2
votes
2answers
387 views

Search in content editor for checkbox field value

In the content editor's search functionality, is there a way to perform a search to find items where I'm checking for the value of a boolean/checkbox field? Like if I have an "active" checkbox in my ...
1
vote
2answers
100 views

Search query custom path

I'm trying to build a search query to find an item that is a child of the current item. Something like this: custom:path|./_local/* But this returns 0 results (should be 3 results). How do I do ...
1
vote
0answers
80 views

What is the difference between Speak UI and Sheer UI?

We are switching from Speak UI to Sheer UI due to performance issue. We would like to know what are the screens which would change for an Author in Sitecore CMS
2
votes
1answer
63 views

Manually change the updated date of an item?

I've created a processor that archives items that haven't been updated in 2 years, and I'm trying to test this by altering a date of an item, but every time I change it and save, it reverts back. I'm ...
2
votes
1answer
83 views

Content and Experience Editor custom buttons - only show for certain roles

I've added a couple of custom buttons on the Publish Chunks of the Content and Experience Editors Publish Strips. Right now, these custom buttons show for everyone, but I only want them to show up for ...
4
votes
1answer
235 views

Nesting placeholders in Standard Values

I know (and I do it) that I can put a default value in a placeholder so that when I create a new item for my route type it populates my placeholder with a component that I will choose. I do it like ...
0
votes
1answer
317 views

Rich Text Editor target for mailto links

Using Sitecore 8.2, when I add a mailto:link it gives me a validation error that external links require a target. However, the modal tab for mailto links doesn't contain a target field, and if I ...
0
votes
1answer
143 views

Sitecore item name not accepting more than 100 characters

I am using sitecore 9.1 initial release and i created an item and gave the item name above 100 characters but sitecore is not accepting the item name more that 100 charaters , so in the sitecore....
3
votes
1answer
39 views

Create a link to My Items on the launchpad

I know how to create a custom launchpad button, but I'd like to make one that links to the content editor with a view of My Items displayed (maybe even maximized). It looks like this is a JS call ...
0
votes
1answer
136 views

Enable view buckets by default? [duplicate]

Is there a way to enable Buckets view by default for all users? I can see the Buckets item in the core database, but there doesn't seem to be a field that allows for enabling by default.
0
votes
0answers
68 views

TreeList field cannot be updated

TreeListType field is not getting updated when selecting value from left pane to right pane. Updated the value to display the raw value. But it is not updated. The value was updated or deleted with ...
1
vote
1answer
414 views

How to remove the blank field for Sitecore Droplink and Droplist

In Sitecore 9.0, when I create a Droplink or Droplist Sitecore generates a "blank" selection. For example I have a Droplink from Monday to Sunday, the first option will be a blank selection. How can ...
1
vote
1answer
67 views

Custom bucketing structure on the basis of date is not working properly

Recently I was creating a custom action for creating custom bucket rules, and I followed the instructions from this link. Everything went well but when I sync the bucketed folder, then on the basis of ...

1
2 3 4 5 6