Questions tagged [content-editor]

For questions related to the Content Editor interface. Includes context menu, ribbon, content tree, field sections, field validations, etc.

Filter by
Sorted by
Tagged with
4
votes
4answers
586 views

Open Content Editor From Speak Dialog with Specific Item Selected

I have a speak dialog that creates a group of items based on some user input. I want to be able to open a new content editor frame if the user is currently in the shell. I have access to the id or ...
4
votes
2answers
749 views

Content Editor: Add properties link for General Link, Image field and Rich text editor

Does anyone know how I can add a new link button to perform custom actions for the fields Image, General Link and Rich text editor on the content editor? For example on the Rich text field we get ...
0
votes
2answers
134 views

Branch ID missing from web db

I'm using Sitecore 8.2 Update 3. I created an item with a branch template, and I see that template/ID in the "Created From" area of the quick info. However, when I publish to the web database, the "...
2
votes
1answer
487 views

How to Hide one publish target?

I have added one extra publish target for some reason. I want only admins to see this.This has to be hidden in both the places (publish window and DB switcher) for non admins.
3
votes
1answer
405 views

Can Sitecore be customized to auto save pages including the rich text editor?

Trying to solve the issue where an editor is updating content and gets timed out. When they log back in they lost changes. I know you can increase that time out, but can you implement auto save? ...
2
votes
1answer
45 views

Post Upgrade Content Editor Font Problem

Post upgrading with the Express Migration Tool, my fonts and forms are a little wonky. If I didnt know any better Id say a css file was missing. But, nothing in the browser console to this point. ...
1
vote
1answer
263 views

Where is the Content Manager in 8.2

In Sitecore 7.2 I was setting the content editor context language in code: public class DefaultLanguageContentEditorForm : Sitecore.Shell.Applications.ContentManager.ContentEditorForm { protected ...
5
votes
2answers
323 views

How do you extend the item:new command without breaking a previous patch for it?

In my example, Sitecore PowerShell Extensions (SPE) patches the command in order to provide insert options. Reviewing the ShowConfig.aspx I see the following: <command name="item:new" type="...
7
votes
1answer
192 views

Open item in language version in which search result was returned

Currently facing an issue where when you search bucketed items within Sitecore, in let us say Danish language, you get Danish results but clicking on that item opens an English version in new content ...
5
votes
2answers
593 views

What is the proper syntax for a 'Grouped Droplink' field?

What is the proper syntax for a 'Grouped Droplink' field? I can't seem to find proper documentation on this anywhere. Can I use this to group results from 2 sections of the content tree?
7
votes
1answer
457 views

Order the Languages by Display Name in the Content Editor

I would like to list out the languages by display name in the language selection. Right now they default to the item name.
3
votes
0answers
102 views

Multi-list with search showing gibberish after switching to SOLR Cloud

I'm running Sitecore 8.1 (Original Release), and last night we switched our SOLR indexes to use a dedicated SOLR Cloud set of servers instead of using a stand-alone SOLR instance on our CM server. ...
7
votes
2answers
514 views

How do i validate an image for byte-size in Content Editor?

I would like to Validate the Image Field say i shouldn't allow the image more than 1 MB. How do I do that in content editor?
4
votes
2answers
460 views

Custom message in Sitecore Content Editor, Experience Editor, or Launchpad

Is it possible to display a temporary custom message in Sitecore launch pad. The main idea is to reminder/heads up for content authors regarding activities like planned maintenance. Thanks in ...
2
votes
0answers
571 views

Adding custom control dynamically to Custom Field in Sitecore gives App_Web_xxxx.dll not found

I have a created a simple user control and dynamically added that control to a new custom field in Sitecore. When viewing the item having that custom field in content editor, it works just fine. If I ...
4
votes
2answers
141 views

Prevent Content Editor from automatically switching ribbons

On this one site, I frequently have to go in and deploy media items. In order not to publish things from other users that might not be ready, I publish the items individually. One of the most ...
0
votes
1answer
962 views

How do a open a Speak Dialog (or Dashboard Application) from within code?

So I need the ability to trigger a Speak Application (either a Dialog or a Dashboard) from within code. This is going to happen from a custom command I have created that will process specific logic ...
3
votes
0answers
222 views

Droptree fails on certain items

I've got a strange error with a droptree field, it works for all items except those below a certain folder, as below. Debugging with Chrome the last request before the null item is returned was to ...
6
votes
1answer
345 views

How can I make the publishing restrictions dialog use the user's time zone?

When a user sets an item's publishing restrictions, it's possible to define dates and times in the "publishable from" and "publishable to" fields. These date/time values will be interpreted in the ...
2
votes
0answers
206 views

Error occurred during a cryptographic operation [closed]

After upgrading from Sitecore 7.5 to 8 .when i try to open Control panel in CMS i get an Error saying "Error occurred during a cryptographic operation." Note : i do have an entry for machine in my ...
1
vote
1answer
530 views

Restrict Content Editor Language Dropdown Options

I am trying to only display certain languages for Editors in the Sitecore Content Editor Language dropdown/selector. In the access viewer, it shows the permission correctly for the editors. (i.e. ...
1
vote
0answers
143 views

Model has not been found Exception while adding WFFM form in Content Editor

I'm trying to insert a WFFM form via content editor (Presentation > Insert Form) in a page. Instead of showing the list of placeholders, it shows the page. When I add via experience editor it is fine. ...
1
vote
1answer
439 views

Internal Link 'Target' dropdown options not populating [duplicate]

We are using sc8.0u5. When the Insert Link of a General Link field is clicked, there is a Select Target dropdown. But there are no options being populated in it. This works fine in the DEV system but ...
3
votes
1answer
331 views

Access to both Experience Profile and Presentation Details

I have a user that needs access to both Experience Profile and Presentation Details. We found a Sitecore KB reference (https://kb.sitecore.net/articles/820320) that stated if a user had the Author or ...
1
vote
0answers
55 views

Automatically assign tags based on a single parent value

I'm new to Sitecore and am hoping someone can help. What is the best/easiest way to set this up for content editors so that if they choose a value from one tree, it automatically tags for other ...
2
votes
1answer
276 views

Enable Field level fallback for Final Renderings Field

I want to enable field level fallback for Layout->Final Renderings so when ever content editor creates a version in new language he/she will get all the content from Fallback language. But whats the ...
4
votes
1answer
769 views

Why did Sitecore display the wrong image?

Consider this scenario: a user has two images in a Sitecore media folder with the same name. They go into a content item (page) and into a rich text field to fill out the body of the page. They click ...
3
votes
1answer
2k views

In the Content Editor, how can I have a Sitecore alert popup code run after the ProgressBox Execute code has finished running?

I have set up a custom button in the Content Editor that makes a third-party API call when clicked. In order to let the user know that the client is performing some work, I have implemented a ...
3
votes
1answer
96 views

Why are new content items created in the content editor populated with data not in the __Standard Values of the template in Sitecore 7.2?

In Sitecore 7.2 I am having an issue in the Content Editor where when I add a new item based off of a template that has no __Standard Values the fields are being populated with data from an unknown ...
3
votes
1answer
1k views

Empty string is not allowed error when adding or renaming item on Sitecore content tree

Getting the error below in the CMS when trying to insert items into content tree or when re-naming existing items Exception: System.ArgumentOutOfRangeException Message: Empty string is not allowed. ...
1
vote
1answer
176 views

Is it possible to extend the Content Editor search?

My website requires that Content Editors have access to a custom Search mode which shows them results based in a format that's not directly available in Sitecore. Is it possible to extend the Search ...
5
votes
1answer
1k views

Disable the “Edit Experience Editor Options” button for my editor users

I have a number of users which should have access to create/edit/delete content on my site, including inserting new components to pages. To ensure that they can insert and change components I have ...
4
votes
1answer
2k views

How can I add a custom button inside the Content Editor application?

I'm building a custom page with extended functionality for Content Management. How can I allow users to access it directly inside the Content Editor? Ideally I'd like to add my own button inside the ...
0
votes
1answer
364 views

How do I insert items within a large body of HTML?

I'm working on making the editing experience better for our users by trying to simplify the process of adding "special" components into a body of HTML text. We publish news articles and many times ...
7
votes
1answer
1k views

How can I search for date field values on the Content Editor?

I have a website with Sitecore.NET 7.2 (rev. 160123). Using facets I see I can search for different things, and I have a few filters. However, I didn't manage to be able to filter for a date field on ...
1
vote
2answers
1k views

Display Name not changing

Sitecore 8.2 update 0 I have a few items in my tree that when I try and change the display name, nothing happens. The display name stays the same. On the Audit of the change in the logs. No error. ...
2
votes
2answers
527 views

Prevent special characters in online content editor

We are on Sitecore 7.5 and recently discovered that when a content editor copies and pastes some content from other documents using Sitecore in-page editor, some special characters make it into the ...
1
vote
1answer
94 views

Content tree outputing request

Has anyone seen this? I have Sitecore 8.0 update 7 running and at times(it comes and goes, haven't determined when exactly and why) I see this request output showing along side with the content tree ...
2
votes
3answers
456 views

Datetime Field in multilingual environment

We have multilingual site, which has content editors from around the world. We have a maintenance banner on home page which display "Site will be down from dd:mm:yyyy time to this dd:mm:yyyy". This ...
4
votes
1answer
1k views

Add full media url in Rich text editor

We have email templates that are stored in Sitecore. We are using Richtext field to store html of emails. When I add images from Sitecore media library to that rich text field links are generating as ...
2
votes
1answer
334 views

Renamed item and now not displaying child pages [closed]

What would cause content not to load if we rename the parent page? We have various categories of content on our homepage that all get pulled in. We had to change the name (and display name) of some of ...
1
vote
0answers
61 views

How related publish works? [duplicate]

Recently our client content author was trying to do the below steps and am not sure if the problems are actual problems or that's how SC related publish should work? Heres what our Content Author is ...
4
votes
2answers
539 views

How content changed in ContentEditor is being displayed in website even item not published

I changed content in one field in ContentEditor and then shifted to web database. Here I could see content change is not available which is fine because I haven't yet published but when I browsed the ...
5
votes
1answer
329 views

Content Author sees compare mode of the item fields always

On our Sitecore 8.1 site, we had a new content author role setup for the French-Canada culture. The problem is that if I log in as a user with this role and navigate to the Content Editor, I see all ...
-2
votes
2answers
321 views

Sitecore ribbon doesn't show up

I am running Sitecore 8.0 on my development machine but I am not seeing the ribbon in the Content Editor anymore. I haven't made any drastic changes to my environment in the last week, except minor ...
6
votes
2answers
663 views

Hiding Specific Fields for Specific Language in Content Editor

We need some specific customization to hide a specific field for a specific language. like hiding Title field for English language but not for Spanish etc. Please suggest a any way to do this.
5
votes
1answer
597 views

Raw field values in content editor

Sitecore content editor is displaying raw values of only some fields even though Raw values is not checked. This happening on only certain fields such as Final rendering, Workflow, States and Default ...
5
votes
2answers
3k views

Could not load type 'Sitecore.Shell.Applications.WebEdit.Commands.WebEditCommand'

I am working on a Sitecore 8.1 site. I was given a zipped package with the Website folder in it and I am trying to get it set-up on our Development server. The website itself works fine and I can ...
5
votes
2answers
513 views

Disable database switching in sitecore backend

A customer of ours asked if it is possible to fix the account they are using in the sitecore backend (Experience Editor, Centent ediror, Media library, ...) to only the master database. Our accounts ...
6
votes
1answer
266 views

Unhide Ribbon strips

I have managed to hide all ribbon strips by right clicking on ribbon and un checking them. I have zero strips now, on the ribbon and so, ribbon is hidden. I cannot able to get them back. I have ...