Questions tagged [content-hub]

Questions about the Sitecore Content Hub product.

Filter by
Sorted by
Tagged with
0 votes
0 answers
15 views

Getting error while installing content hub on premise in sitecore 9.2

After setting all the variables, when I executed deploy.ps1 script received below error I also tried the below command to resolve this issue but still, the error is coming. $PSDefaultParameterValues[&...
user avatar
0 votes
0 answers
23 views

User management in the Content Hub

I am trying to understand a few things regarding Sitecore Content Hub but cannot figure them out. When a user logs in, the SAML response contains GUIDs under the groups. None of the documentation I ...
user avatar
  • 1,108
1 vote
1 answer
69 views

What Security Policies are necessary to enable the Annotate function?

I am unable to get the Annotate function working for a non-SuperUser. My test user sees this (note missing Annotation option): And has a group with these policies: Things I've tried: Enabling all ...
user avatar
  • 1,912
2 votes
2 answers
102 views

Watermark Preview won't display

I've created a role that can only see watermarked versions of certain assets. Rather than displaying a watermarked preview, the assets are not being shown at all. The Preview rendition is configured ...
user avatar
  • 1,912
1 vote
1 answer
43 views

Search component Flyout fields not displaying

As a discovery task, I build a small Search page ("New Search") patterned after the Assets page, enabling Asset search functionality bit by bit to understand (and explain) how the Search ...
user avatar
  • 1,912
0 votes
1 answer
61 views

Get the count of results

I am unable to fetch the count of the results in Content Hub. How to get the result of the "asset items" count in rest API reference API call: https://{{hostname}}/api/entities/query?query=...
user avatar
1 vote
0 answers
47 views

Why is my Related Entity Mapping field only returning one result when there are multiple listed

I am currently working through setting up my connection between Content Hub and Sitecore using Sitecore Connect for Content Hub (SCCH). I have a Document entity that has multiple M.Asset children ...
user avatar
0 votes
0 answers
41 views

Sitecore Connect for Content Hub Culture is required for culture sensitive properties

I am running Sitecore Connect for Content Hub in my local instance of Sitecore 10.2. I am currently working through creating an action in Content Hub that sends my custom content from Content Hub to ...
user avatar
0 votes
1 answer
77 views

Sitecore Content Hub non-taxonomy facets not visible

I've created an entity with relation to other entity (which is not a taxonomy). How can I configure search facets to search by that relation (relative entity's name in that example)? I've tried to ...
user avatar
1 vote
1 answer
95 views

nuget package problems with content hub linq queries

I am trying to create a very basic test project to see if I can query content hub using linq as the documentation suggests and am having some trouble. I have created a .net5 console application and ...
user avatar
  • 111
0 votes
1 answer
25 views

Nothing happens when clicking on Create button while creating a new API key

I am trying to create a new API key in my content hub instance using https://xyz.sitecoresandbox.cloud/en-us/admin/api-keys. But while hitting the Create button, nothing happens. It simply refreshes ...
user avatar
0 votes
1 answer
77 views

How can I use the taxonomy identifier instead of the id, using the REST API?

I am working on a connector with a Sitecore Content Hub environnement. I am using the REST API, sending POST request to create some Assets. I wonder if there is a way to set a taxonomy relation with ...
user avatar
  • 11
0 votes
1 answer
58 views

Content Hub Javascript SDK is throwing Error: Cannot find module 'form-data'

I am trying to authenticate and create a Content Hub client using CH Javascript SDK based on this document I have installed the npm package as described in this document I am getting the below error ...
user avatar
1 vote
2 answers
290 views

How can I send the full Taxonomy Hierarchy from Content Hub to Sitecore?

I am currently working through building my Taxonomy in Content Hub and working through sending it to Sitecore through CMP. As of right now I have a trigger set up that sends any new Assets from ...
user avatar
0 votes
0 answers
112 views

Upload file more than 200 mb in content hub

I am trying to upload files more than 200 MB in Sitecore Content Hub using Blob Storage URLs. For file size 700 MB it is working fine. But for more than 1 GB files, the Azure Blob SAAS URL is getting ...
user avatar
  • 421
0 votes
2 answers
89 views

"Insert from Sitecore DAM" page is empty after installing Sitecore Connect for Sitecore DAM-2.0.0

I am running on Sitecore 10.1. I have installed the latest available DAM Connect Sitecore Connect for Sitecore DAM-2.0.0.zip and configured it as per the instruction given in the installation guide. ...
user avatar
0 votes
1 answer
85 views

While access preview API for Sitecore Content Hub, getting "HTTP ERROR 401" This page isn’t working error

While access preview API https://my.stylelabsdemo.com/api/graphql/preview/v1 for Sitecore Content Hub 4 sandbox enviornment, getting "HTTP ERROR 401" This page isn’t working error. Am I ...
user avatar
0 votes
0 answers
18 views

Exception of type 'Stylelabs.M.Common.Web.Api.Validation.HttpResponseException' was thrown

I am getting an exception while accessing a "Content Collection" created by the current user itself in Sitecore Content Hub 4.0. Exception of type 'Stylelabs.M.Common.Web.Api.Validation....
user avatar
0 votes
1 answer
22 views

No "Delivery Platform" feature in Manage page for my content hub instance

I am not able to see Delivery Platform on the Manage page of my Sitecore ConentHub 4.0 instance. Why it is missing? I have the superuser account and should be able to see this.
user avatar
0 votes
1 answer
47 views

Exception "The M-Entity (id: 33711) was not found in M." while connector trying to create CMP item in Sitecore

I am trying to integrate Sitecore Connect for Content Hub and following the installation guide. When I am creating an entity in Content Hub, it is properly triggering it to Azure Service Bus but ...
user avatar
3 votes
3 answers
279 views

How to call api from external component

I am developing external component in Sitecore Content Hub 4.X. I want to call REST API as a current logged user. Custom component expose some options, for example options.api but it is only text... ...
user avatar
1 vote
2 answers
214 views

Sitecore Content Hub Azure Active Directory Login

I am trying to implement Azure AD in my Content Hub portal. I have created the App in Azure Active Directory and also add the Application ID URI, federation metadata & get the Entity Id. In my ...
user avatar
  • 421
1 vote
0 answers
43 views

How can I send existing CMP content/entities to Sitecore in bulk?

I have the basic Sitecore connect for CMP set up so that when a content item goes into the final workflow state, it is sent to Sitecore. I have also managed to set it up to send over some taxonomy ...
user avatar
  • 3,263
0 votes
1 answer
107 views

Sort Order in the Query [closed]

I want to retrieve the Sitecore content objects in a specified order like ascending or descending. Currently I am using the following query, I want to retrieve the objects in an ascending order. https:...
user avatar
0 votes
1 answer
298 views

Download asset from Sitecore Content Hub programmatically

I have a request from my customer to download asset from Sitecore Content Hub programatically. I googled a lot, found examples of uploading programmatically, but no downloading. I was thinking there ...
user avatar
  • 3
5 votes
1 answer
140 views

Calling a script on asset download in Sitecore Content Hub

Does anyone know a way to trigger a script on asset download? Can't find anything in the docs and don't see an obvious trigger condition for that.
user avatar
0 votes
2 answers
101 views

Why doesn't my restricted Content Hub script have a ChangeTracker?

I have a restricted action script that looks to see if a specific property has changed and stores the new value in the PropertyBag. It's based on this example in the documentation. using System.Linq; ...
user avatar
  • 5,085
0 votes
1 answer
137 views

Why doesn't my Content Hub script log DEBUG messages?

I have an Action Script I've created in Content Hub and it has various calls to log messages: MClient.Logger.Debug("Running script"); MClient.Logger.Info($"Context.ExecutionSource: {...
user avatar
  • 5,085
0 votes
1 answer
292 views

Issue setting up CMP and connecting to Azure Service Bus

I have installed CMP into a Sitecore 9.1 instance and I have gone through the setup instructions as per the CMP 2.0 installation and configuration manual. I'm seeing this error in sitecore logs which ...
user avatar
  • 5,636