Questions tagged [content-search]

Questions about searching (querying) Sitecore projects with the ContentSearch API. Use the Lucene or Solr (or Coveo) tags if the question is specific for any of those technologies.

Filter by
Sorted by
Tagged with
0 votes
2 answers
42 views

Indexed items not showing in Content Collection

I have an entity called "Degree": I have a source that retrieves 92 items successfully. Inside of sources configuration, I have the following settings: Tags definition Document Extractor ...
Godiez's user avatar
  • 1
0 votes
1 answer
117 views

Sitecore Graph QL Search getting unknown argument "FieldsEqual"

I am trying to execute search on Graph QL. When I try "FieldsEqual" query, I am getting unknown argument in "Query.Search". Any help to overcome this issue will be highly ...
Sylesh JL's user avatar
  • 179
1 vote
1 answer
53 views

Content Editor search is not working for the template Ids

I have Sitecore 10.3 with SOLR search. In the "Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config" I have mentioned the <indexAllFields>false</indexAllFields> and next ...
Rameshkumar's user avatar
1 vote
0 answers
33 views

item version history to create items with Date field [closed]

We have requirement to show some text content (rich text field) based on revision date updated (date field). Latest updated content (sorted by date in descending) will be shown at the top . So content ...
Akshay D's user avatar
2 votes
0 answers
41 views

Buckets/Services/Search.ashx 500 error

We have a Sitecore 10.3 version and we see the 500 error with the following URL in the console. Multilist with search is not working along with the Sitecore tab search. /sitecore/shell/Applications/...
Imran Hamid's user avatar
2 votes
1 answer
87 views

How to set the JVM Memory for Solr running on an Azure App Service

If you are following one of these blog posts on setting up Solr in an Azure App Service (instead of an VM) such as: https://www.getfishtank.com/blog/installing-solr-app-service-in-sitecore-azure-paas, ...
Adam Seabridge's user avatar
0 votes
1 answer
57 views

Map droplist field in SearchResultItem not working

I have a template EventPage defined several attributes, datetime, single-line text, droplist etc. I defined a EventPageSearchItem inherit from SearchResultItem as follows: public class ...
John's user avatar
  • 77
0 votes
0 answers
48 views

Order search results by frequency of the search item (Wildcard and substring)

Extending my previous question We have a requirement to order search results based on the number of occurrence of the search term (wildcard and substring) in a list of fields(not all the fields). Ex : ...
D J's user avatar
  • 385
1 vote
1 answer
57 views

Order search results by frequency of the search item in a list of fields in Solr

We have a requirement to order search results based on the number of occurrence of the search term in a list of fields(not all the fields). We tried the below query in sort, but this does not provide ...
D J's user avatar
  • 385
0 votes
0 answers
25 views

Azure Search Provider does not index any template fields

The azure search based Sitecore instance deployed as App service does not index any fields defined in the template. I dumped the key:value from searchresult object's Fields and we got the following ...
John's user avatar
  • 77
0 votes
0 answers
32 views

How to construct a query to search any field in given page templates?

I have few page templates defined such as basic page, article page, event page, directory page and each of them has different fields. how do I construct a query in search api to query any item that ...
John's user avatar
  • 77
0 votes
0 answers
39 views

How to search related article page in sitecore [duplicate]

I have an ArticlePage template with a TopicTags field, which is a treelist pointing to a list of tags. Users can select one or two tags. I have a requirement to search for two related articles that ...
John's user avatar
  • 77
1 vote
2 answers
250 views

Media (Images) not loading and media dialog shows error

We have upgraded Sitecore 9.0.2 to Sitecore 9.3 and it is SXA based solution. And media search is not working after the upgrade. The Media dialog box shows an empty result and returns a response as ...
Sumit Helaiya's user avatar
0 votes
1 answer
106 views

Setting update.autoCreateFields=false via API when creating Solr Cores for Sitecore 10.3

I'm trying to Automate some of the Setup of Solr Core's for Sitecore 10.3 and everything works fine - apart from one thing which is that there is a requirement to set update.autoCreateFields=false in ...
Adam Seabridge's user avatar
1 vote
2 answers
302 views

Get Only one language version per item by using Find-Item

I am using a PowerShell script given below $indexName = "sitecore_web_index" $criteria = @( @{Filter = "Contains"; Field = "industry_sm"; Value = ...
Vinesh's user avatar
  • 127
2 votes
2 answers
712 views

Sort by title asc on Solr not working as expected

When trying sort search results in Solr using title (alphabetical) asc or desc does not work as expected and not sorted.
Sara Elgendy's user avatar
1 vote
0 answers
39 views

sort by Title in solr not working as expected [closed]

the result not sorted alphabetical esc as expected
Sara Elgendy's user avatar
1 vote
0 answers
31 views

seeing this error after sitecore installtion ,local setup Could not find configuration node: databases/database[@id='web_am'], what could be the issue [duplicate]

I am facing issue on doing local setup for this sitecore, Could not find configuration node: databases/database[@id='web_am'] not sure why and where exactly this issue is occuring,and what could be ...
Siddhesh U Ghate's user avatar
0 votes
0 answers
40 views

All the facets terms not loading in multi list filter from solr on initial load

We are using Sitecore 10.2 with SXA on Azure Kubernetes, and Solr as a search service. On a multi-list facet filter (facet-multi-selection-list), trying to fetch facet terms, where facets are added ...
user13291's user avatar
0 votes
0 answers
67 views

Solr search result not coming when full keyword is searched

I have search results coming based on meta fields Title and Description. When I search for the partial keyword "fir". results are coming but when I search for the full keyword "first&...
aditya's user avatar
  • 1
0 votes
0 answers
45 views

The fastest way to flush items into SOLR?

The general, the task is to denormalize 3 indexes into 1. Please, don't ask why I use SOLR as a data source here. Imagine I have 3 normalized indexes: index1 with fields: id, name, type, address ...
Yngvin's user avatar
  • 25
1 vote
1 answer
74 views

Index rebuild batch sizing setting?

I need to change the size of the batches during the index rebuild. The most suitable setting I've found is ContentSearch.Update.BatchSize with the description: The size of document batch before ...
Yngvin's user avatar
  • 25
1 vote
1 answer
24 views

Amend ContentSearch settings to a single index?

I have a bunch of custom indexes and I need to finetune only 1 of them, not affecting the others. Let's say, I want to change ContentSearch.Update.BatchSize, is there a way to apply this setting for 1 ...
Yngvin's user avatar
  • 25
0 votes
1 answer
55 views

Sitecore Content Editor Search is behaving unusual for items with SPACE

We have the following issue with SC9.3 Solr 8.1.1 A Media item with sample name "Text_20230101 Hello world". We have the below behavior in the CMS content editor search. (free text search on ...
D J's user avatar
  • 385
1 vote
1 answer
142 views

SwitchOnRebuildSolrSearchIndex is providing wrong results for SOLR master-slave setup

Our custom indexes have primary (search_index) and Secondary (search_index_rebuild) cores which are pointing differently in master and slave servers as we are using SwitchOnRebuildSolrSearchIndex. Due ...
Ruchi Gupta's user avatar
1 vote
1 answer
92 views

Multiple Master_Index entries are coming on job queue on full reindexing the Sitecore_Master_Index

At the time of sitecore_master_index rebuild (full reindexing or on update) we can see multiple sitecore_master_index entries in the index job queue. Can anyone explain the reason for this? url : ...
Ruchi Gupta's user avatar
3 votes
1 answer
309 views

In solr Master-Slave configuration custom indexes are getting out of sync sometimes in one of the slave servers

In our production environment, we have Master-Slave SOLR server configuration. We have 2 SOLR slave servers and configured SOLR load balancing URLs in prod CM and CD servers. Right now we are facing ...
Ruchi Gupta's user avatar
0 votes
1 answer
65 views

Results not filtering by language

I have an item which has 2 language versions - English & Chinese. This Search query is returning both versions when the expected is only English. Not passing the languageCode so by default it is ...
sukesh's user avatar
  • 3,131
0 votes
3 answers
529 views

Solr - How to fetch data by page

There are no results when I apply pagination to the query. But when I comment that code, I get results. Search log without pagination: INFO Solr Query - ?q=: AND val:__boost&start=0&rows=...
sukesh's user avatar
  • 3,131
0 votes
1 answer
335 views

Solr query not returning search results

I can see all the records in the Solr portal when I run the query. Here is the data of one product. https://localhost:8983/solr/stratum_products_master_index/select?q=_templatename%3A%22product%...
sukesh's user avatar
  • 3,131
0 votes
3 answers
640 views

Solr - Recommended way to search by filters

I'm trying to build a generic Search method GetSearchResults that would fetch results from Solr. Sample use Case: Get a list of all products where the searchTerm can be in the Title OR Description ...
sukesh's user avatar
  • 3,131
2 votes
2 answers
65 views

Is it possible to generate Sitecore Search Scope across the entire tenant?

I have a requirement to display pages based on two different templates on two separate sites. For example: Let's say I have one site called Site A and another site called Site B. In Site A, I have a ...
Anjali Nirmani's user avatar
2 votes
1 answer
234 views

Sitecore Solr - Content Editor search returns no results but Experience editor and context search works fine

We are having the following issue. Please let me know if you have come across a similar issue or know of a potential solution. In Sitecore Content Editor, all search queries works fine if logged in as ...
D J's user avatar
  • 385
1 vote
1 answer
297 views

Solr - The Content field in SearchResultItem is always null

Using Sitecore 10.2 with Solr 8.4.0. I have Product pages which inherit from a template - Product Details. This template has the following fields: Title - Rich Text Description - Rich Text Category - ...
sukesh's user avatar
  • 3,131
2 votes
3 answers
692 views

Solr stripping out the HTML from Rich Text Field while indexing

I want to prevent stripping out the HTML from my one of the Rich Text Field. I have the following field reader by field name in my index configuration file in place under the mapFieldByTypeName ...
Jey's user avatar
  • 343
1 vote
0 answers
53 views

How to skip the search Special Character in Sitecore SXA Search

I have worked on the Sitecore SXA search and Version is 10.2. Created respective Solr core and configuration for search then did the Indexing. After that browse the web page and type %,$ (all special ...
Rameshkumar's user avatar
0 votes
0 answers
51 views

Sitecore Select Media return empty in Experience Editor - Multisite SXA

We have recently upgraded the Site from v9.2 to 10.2. We have maintained multisite with SXA. In the old Site, we used Azure Search and now converted it into Solr search. After integrating all the ...
Rameshkumar's user avatar
1 vote
0 answers
88 views

Solr default search indexes exception: IDocumentBuilderOptions of wrong type for this crawler

We are in the process of upgrading from Sitecore 10.0.1 to Sitecore 10.3. We used Azure search which is no longer supported. Following the installation process, and setting up the default indexes ...
Edmar Langendoen's user avatar
2 votes
1 answer
131 views

Newly created Facet is not showing in Content Search view

I created a facet as per the documentation: https://doc.sitecore.com/xp/en/developers/92/sitecore-experience-manager/facets.html In the "Field Name" field I tried the field name as in the ...
iusmar's user avatar
  • 239
1 vote
0 answers
96 views

Facets are not loading for custom Solr index

We are working on a new site and have created a new index for it. This index is similar to sitecore_sxa_web_index except for the root path. Instead of /sitecore, we have /sitecore/content/<Tenant ...
Imad's user avatar
  • 235
1 vote
1 answer
70 views

What is the best practice approach to populating a navigation component

I have been spending a bit of time looking at the Sitecore Debugger. Using this you can see the 'hotspots', the components on the page that take the longest time to load and make the most calls to the ...
Dean OBrien's user avatar
  • 1,570
1 vote
0 answers
107 views

Why does my Sitecore site start rebuilding indexes after a restart even though I'm using the manual index strategy?

I'm using Sitecore 9.2 XM and (don't shoot me for this) Lucene search provider... I want to do some investigation and timing, so patched all my search indexes to use the manual indexing strategy, but ...
Matthew Dresser's user avatar
4 votes
1 answer
321 views

ERROR Solr Error : [undefined field content_type] - upgarding from Sitecore 8.2 to 10.1 and from Lucene to Solr

I'm working on a Sitecore upgrade from 8.2 to 10.1, which includes replacing Lucene with Solr. I have a content listing page that allows filtering by content type as well as many other fields - these ...
Erica Stockwell-Alpert's user avatar
1 vote
0 answers
23 views

Azure Search and Linq for Exact Phrase [duplicate]

We are using Azure Search engine (I know...) and need to so a search for an exact phrase. Using the PredicateBuilder, if I have a statement like: keyword = "Mary Smith"; predicate = ...
Gary Williams's user avatar
3 votes
2 answers
422 views

Sitecore 10.2.1 (pre release) error loading hook

We are upgrading from 9.1 to 10.2.1 (pre release) and we're seeing this error when trying to load the CM instance: 11608 17:56:05 WARN Could not find constructor in ReflectionUtil.CreateObject: ...
Calum's user avatar
  • 392
2 votes
2 answers
338 views

Refreshing single document in ContentSearch/Solr index using IndexCustodian?

I have a working custom index configured, it includes some custom fields and has specifically included fields and templates to keep it light. It uses the default SitecoreItemCrawler. I'm on 10.1 ...
geedubb's user avatar
  • 153
0 votes
2 answers
90 views

Can You Perform a Bucket Search on Unpublished Content

Our customer is creating a large body of new bucketed content (using a new template) below a parent item (which is also new). In order to publish all this at once, they're leaving the parent ...
Ron Ritchie's user avatar
4 votes
2 answers
424 views

SOLR Search result order is different due to the query _val_:__boost function

After upgrading the project to Sitecore10.2 SOLR search result is different in order due to the query _val_:__boost function. I have investigated the issue and found out that in Sitecore 9.0.2 our ...
Himmat Singh Dulawat's user avatar
2 votes
1 answer
86 views

Inconsistent behavior when use Solr boosting

I'm using Sitecore 9.3 and Solr 8.1.1, I have this simple query q=itemName_t:(*test*)^80&fl=itemName_t,_templateID,score&fq=_indexname:(custom_index)&wt=xml And these are the results: ...
Mohamed Yaseen's user avatar
0 votes
1 answer
410 views

Nested Solr Structure

Is it possible to create a nested data structure in Solr using the content search index configurations? I'm curious if I can create a document like the following, then query against and/or facet the ...
Jay's user avatar
  • 3

1
2 3 4 5
11