Questions tagged [content-search]

Questions about searching (querying) Sitecore projects with the ContentSearch API. Use the Lucene or Solr (or Coveo) tags if the question is specific for any of those technologies.

Filter by
Sorted by
Tagged with
0
votes
0answers
85 views

SXA autosuggest results sorting

I'm using Sitecore 9.1 and SXA 1.8, this the configuration of the SXA suggester : <searchComponent name="suggest" class="solr.SuggestComponent"> <lst name="suggester"> <str name="name"&...
1
vote
3answers
213 views

Techniques and Rules to Eliminating Template fields from Indexing

I am investigating my site's indexing and looking at working around the Azure Search index 1000 field limit (see here Rebuilding Sitecore Core Index on Azure search throwing exceeding index limitation ...
2
votes
2answers
531 views

Computed index fields on Sitecore 9.1.1 CD server

I have a custom computedfield in Sitecore 9.1.1. I am getting the below error on CD server only as my web.config has: <add key="role:define" value="ContentDelivery" /> Current CustomIndex ...
0
votes
1answer
76 views

How to escape “media library” in Linq to Sitecore

I'm trying to write a query that searches only items in the media library. The problem appears to be related to the space character in the phrase "media library", which is causing the code to return ...
0
votes
1answer
193 views

Refreshing custom index without rebuild

I know that I can configure my custom crawler (FlatDataCrawler) with manual strategy, and then I can start Rebuilding manually. But how can I configure my crawler to start Refreshing every specific ...
2
votes
2answers
463 views

Solr search query by Datetime.Year

I configured Solr index to the path where I created some articles using templates, templates have the same fields with data type as in below model <Root>/sitecore/content/Articles</Root> ...
1
vote
2answers
974 views

Sitecore upgrade to 9.1 not indexing solr fields

I have upgraded my Sitecore instance from Sitecore.NET 8.2 (rev. 161221) to Sitecore 9.1 update-1. while running migration I ran into the issue where I had <indexAllFields> in the following ...
0
votes
1answer
64 views

Where should I put SOLR Autosuggest configurations

I'm using Sitecore 9.1 and SXA 1.8, there are two cores for the master index now , instance_name_sxa_master_index and instance_name_master_index, which index should I put the SXA autosuggester ...
0
votes
1answer
368 views

How to get Current Item ID in search scope

In Page I used search result to display items from Template, and this template contains "drop link field" I need to filter these results like that I need to use "Current Item ID" in search scope to ...
0
votes
1answer
393 views

SXA Tags are not searchable

I'm using Sitecore 9 and SXA 1.7, I want when the user enters a SXA tag name, all the items tagged by this tag are returned at the search results. I tried it but no results are returned, I checked ...
4
votes
1answer
99 views

Content Editor Search by ID returns no results

I am very new to Sitecore, going through training, trying to get certified. In the Content Editor, I am trying to find an item by it's ID / GUID. I can navigate down into the tree, find an item, ...
1
vote
1answer
58 views

Can I use Content Search with Glass to query children of a specific template?

My Sitecore Item has children of different Templates. To query them, I use the following field declaration: [SitecoreQuery("*[@@templateid = '{ID of my Template}']", InferType = true, IsRelative = ...
1
vote
2answers
186 views

SXA get data based on current year

I work on sxa Project where I have news Template, I trying to display all news items where the (News_Creation_date)field value in current year, I created search Scope to retrieve data and Rendering ...
0
votes
0answers
109 views

SXA Boosting Rules not working

I'm using SXA 1.7 and Sitecore 9, I made a SXA boosting rule to a search scope and it works well on CM(Master Database), I publish the scope and I checked that it's published, but it's not reflecting ...
1
vote
1answer
105 views

Azure search random behavior running for Sitecore 9.0.2

I am having issue with the Azure Search where I am not getting results from the search index (it is random issue). I’ve verified the configurations of Azure search and computed index fields. Below is ...
0
votes
1answer
148 views

Index stops updating after a search query

I'm using Sitecore 9.0.2 with Azure Search and Solr. I have the weirdest search issue I've seen in a while. Take the following steps: Restart the application (iisreset or similar) Rebuild the search ...
2
votes
2answers
963 views

Searching a substring using solr

I am trying to move my code from Lucene to Solr, but am facing an issue. I have 4 fields indexed, all the field are of text_general type (from the managed schema). The code from Lucene is: ...
4
votes
1answer
136 views

Azure Search duplicate results for multilingual countries in same site with different language versions

We have a multi-lingual site where the group of countries (say for example Asia Region) is hosted in one Site folder. Thus Home, Pages, Settings have different language versions (zh-HK, en-HK, en-AU)...
-1
votes
1answer
231 views

date field in solr not indexing proper date from sitecore

i am changing search from lucene to solr and faced an issue in this , i have DateTime a field in sitecore and an item is using that field and have value of now ( DATE -- 4/4/2019 TIME -- 12:00 AM) ...
0
votes
0answers
114 views

When searching with solr sitecore does not search in the right fields

We know that sitecore uses solr dynamic fields so that we don't need to declare all the fields that we have in sitecore separately in the solr schema to get them indexed. In our case we have a ...
3
votes
1answer
301 views

Getting the primary Azure Search Index name after index re-build

We are using Azure Search on Sitecore 8.2 update 7 and have enabled switch on rebuild. This is documented here: https://doc.sitecore.com/developers/91/platform-administration-and-architecture/en/zero-...
1
vote
0answers
186 views

Custom query in SXA search scope

Using Sitecore, I have defined some tags, related to food or pet type and assigned some of these tags to pages How can I limit search scope to find all pages which have any food tag assigned ?
2
votes
1answer
307 views

Index Update Strategy not Firing on Publish End with Custom Publishing Target and Custom Solr Index [duplicate]

We have a prod set up that has one CM and two CDs. The CD servers serve content from a second web database that we call "live". This database is a clone of web. We use web as a staging environment on ...
0
votes
0answers
38 views

DatabaseCrawler override no longer works after upgrade from Sitecore 7.2 to 9

In 7.2, Below function AddAllFields was overridden for a custom search implementation. public class DatabaseCrawler : Sitecore.Search.Crawlers.DatabaseCrawler { protected override void ...
1
vote
1answer
796 views

Sitecore 9.1 upgrade Error loading hook

We're upgrading from Sitecore 8.1 Update 3 to Sitecore 9.1. We use Solr for xConnect search, Lucene for web site search The CM is working, but the CD is not. Got the following error message: Server ...
3
votes
1answer
533 views

Convert Ancestor-or-self to content search

I'm currently converting Sitecore queries to use Contentsearch. There is a query that uses ancestor-or-self. Specifically it's looking for an item with a template. Sample code below: Sitecore....
0
votes
1answer
393 views

Where to check the index that is configured from SXA Search API?

When I request the url https://mydomain/sxa/search/results?q=test, below is the response {"TotalTime":259,"CountTime":211,"QueryTime":38,"Signature":null,"Index":"sitecore_sxa_web_index","Count":0,"...
1
vote
1answer
98 views

Do indexes with computed fields with storageType=“no” need to be rebuilt?

If a computed field is computed at run-time when storageType is set to no, does does the index need to be rebuilt at all as it's all done in memory?
2
votes
1answer
106 views

Do we need to trigger SXA indexes after cloning a new site?

This is the first time working on SXA Search. We have an SXA site with search in working condition. We cloned a new site from the existing one and using master database for now but the search page is ...
4
votes
0answers
94 views

Sitecore Content Search API returns expected results with Lucene as search provider but not with Solr

I'm currently writing a service that needs to integrate with Eventbrite to store external event information as items in Sitecore. We run a Sitecron job every 4 hours to pull in and update the ...
1
vote
0answers
67 views

How does sitecore search (Lucene) handle duplicate field names stored in index?

Luke is showing two fields with the same name for a document. When executing a search does sitecore search both fields or does it only search the first one. And if that's the case is there a way to ...
0
votes
1answer
133 views

Change the rendering of SXA Search from a page to overlay

I'm trying to view the search results of a search box in a popup not in a page, I've created an overlay with a search results rendering in it and then choose it as the "Search result page", the ...
1
vote
1answer
146 views

Sitecore Solr Slop Defaulting

Running into a bit of an issue using Slop with SOLR. Previously on Lucene indexes we were able to use the .Like() method on the IQueryable result from the SearchContext. The code runs roughly like so ...
2
votes
1answer
94 views

Search on custom solr index

I am trying to search on a solr core which contains static data without any Sitecore details. <doc> <str name="_property_text">1</str> <str name="_itemnumber_string">1250000&...
2
votes
0answers
81 views

Solr Document Boosting

I'm attempting to item boosting working with Solr and I can't for the life of me get it to work. I'm certain that I've had it working in the past for other projects. The problem looks to be on the ...
0
votes
1answer
228 views

Azure Search &search=This_Is_Equal_ConstNode_Return_Nothing

I have a site that I have recently been upgrading from 8.2 to 9.1 and everything is looking good EXCEPT anything that relies on search funcionality. Any Azure search has in the info log: 2019-02-...
1
vote
1answer
178 views

Error message: Value of the StartSearchLocation '' is not a valid GUID. '{11111111-1111-1111-1111-111111111111}' will be used instead

I'm seeing this error repeatedly in the logs in our CM instance of Sitecore 8.1 update-3. Where does it come from? ERROR Value of the StartSearchLocation '' is not a valid GUID. '{11111111-1111-...
3
votes
2answers
252 views

How is the name of the primary index name stored when using SwitchOnRebuild in Azure Search?

We are using Azure Search for a custom index and I have SwitchOnRebuild enabled in my config patch. <!-- USE SWITCHONREBUILD Determines if Azure Search provider uses SwitchOnRebuild() ...
4
votes
1answer
428 views

Hide a page from search results in SXA

Is it possible to mark a page as hidden from search results in SXA 1.8 Sitecore 9.0.2? I have a scope defined where the particular page template is allowed but there are exceptions when I would like ...
1
vote
1answer
133 views

_content field not populating correctly

We're on Sitecore 8.1 update 2 and I'm having issues with the content search API. Its my understanding the _content field in the index should contain an amalgamation of all the fields in the template. ...
1
vote
1answer
73 views

Is there a way to append an indexed field to a glass mapper object?

I'm generating a custom sitewide search by indexing the rendered HTML of the pages on my site. Some pages will have a title and description field defined to display in the results, however, some ...
3
votes
1answer
254 views

ContentSearch Where vs Filter

When using the ContentSearch API what is the difference in using Where vs Filter and can this have any influence on the results? From the Sitecore documentation : Filtering is similar to using ...
1
vote
0answers
46 views

Custom index search -Solr [closed]

Any good suggestions for implementation of custom index based solr search in sitecore 9 For example any product name is clicked.the filtered result of product name should be populated in the home ...
4
votes
2answers
136 views

Sitecore ContentSearch results order is not same as raw Solr search results

Sitecore ContentSearch is not providing result in the same order like Solr query does. http://localhost:8983/solr/sitecore_web_index/select?indent=on&q=_content:testorder&wt=json we are ...
2
votes
1answer
936 views

Rebuilding Indexes with SOLR throws Exceptions

I set up a fresh Sitecore 9.1 with SXA on my local machine. When rebuilding the indexes, I get the following messages: (Core) 19676 14:50:03 WARN Could not compute value for ...
-1
votes
1answer
233 views

Product ID or name is not searchable

I am working on Sitecore commerce 9 update-1. Many customizations are already done till now. For searching I'm using the default Search component. Issue :- Product is not searchable by Product ID/...
2
votes
1answer
542 views

Custom Azure Search Index returns '&search=This_Is_Equal_ConstNode_Return_Nothing' for searches

I have setup an custom Azure Search index in Sitecore 8.2 u7 and was getting no results returned even though I have data in it (I can see the data in the Azure console). Looking in the Sitecore Search ...
0
votes
1answer
265 views

Fuzzy search with SearchStringModel in sitecore

Is there any way to implement Fuzzy search with SearchStringModel technique in sitecore?
0
votes
1answer
173 views

How to sort Sitecore items by popularity

I'm using Sitecore 9 update 1 and SXA 1.7, I want to sort Sitecore pages by popularity, I opened the Reporting database and found many tables like Fact_Visits, Fact_PageViewsMetrics and ...
2
votes
1answer
270 views

search component- suggestion issue

Working on Sitecore commerce 9 update 1. Search-box is listing multilingual suggestions when typing. I have an item with content in English and Chines version. I have 2 issues to highlight, When ...

1 2
3
4 5
8