Questions tagged [content-search]

Questions about searching (querying) Sitecore projects with the ContentSearch API. Use the Lucene or Solr (or Coveo) tags if the question is specific for any of those technologies.

Filter by
Sorted by
Tagged with
1
vote
1answer
116 views

How to set a item field as ParameterExpression in Coveo

When I try to create a custom rule and pass field name, I get Instance property 'textField' is not defined for type 'Sitecore.ContentSearch.SearchTypes.SearchResultItem' exception. This is how my ...
1
vote
1answer
58 views

Displaying SXA Search Results on the separate page

I'm currently working on SXA OOTB the Search Box and Search Result rendering. SXA sites structure is as below Sites Country Site 1 Country Site 2 Shared Site I have search box in the site header ...
1
vote
1answer
49 views

Solr ContentSearch returning too many results for a string comparison that should return just one

I have a very straightforward ContentSearch issue. My code is as follows: var filter = PredicateBuilder.True<PersonObject>(); filter = filter .And(i => i.Email == "my.email@address.com");...
1
vote
2answers
127 views

SXA get data based on current year

I work on sxa Project where I have news Template, I trying to display all news items where the (News_Creation_date)field value in current year, I created search Scope to retrieve data and Rendering ...
1
vote
2answers
212 views

How to make a media library image searchable with few keywords rather just the item name?

Simply wondering how to tag an image with a few different keywords and find it that way later on within the media library. It seems like currently the search function of the media library only picks ...
1
vote
2answers
427 views

Sitecore Elastic Search

In Sitecore (Sitecore 9) to get search results from different-2 third party systems including Sitecore, we need to use Elastic search instead of default Solr search in Sitecore 9. Is my understanding ...
1
vote
1answer
96 views

Plural terms and Sitecore lucene

Sitecore 8.2 U6 I have been experimenting with the Sitecore stemming analyzer. Sitecore.ContentSearch.LuceneProvider.Analyzers.StandardAnalyzerWithStemming But it isn't perfect. It has trouble ...
1
vote
2answers
367 views

Sitecore Content Search Exception: Entry point was not found

I'm having an issue taking an older version of our site running under Sitecore 7.2 (with some older dll's such as glass mapper) and switching over from Lucene to Solr (6.6.2). I've followed the steps ...
1
vote
2answers
733 views

Sitecore Search and Standard Values

Let's say you have an item with a checkbox field "DisplayOnPage", and the standard values for the Items template has "DisplayOnPage" set to be checked by default (thus the standard value for this ...
1
vote
1answer
788 views

Why does my Solr index only contain English language versions? Sitecore 8u4

Any idea why my master and web index only have the "en" language versions of items in my 4 language site? Where are languages for the crawler configured?
1
vote
1answer
45 views

IS there a simple way to get the current Azure Search index name programatically?

I need to get the current active index name for Sitecore search for logging purposes. Because of the swap on rebuild functionality, I can't simply use the name field of the index, since on alternating ...
1
vote
2answers
579 views

Sitecore upgrade to 9.1 not indexing solr fields

I have upgraded my Sitecore instance from Sitecore.NET 8.2 (rev. 161221) to Sitecore 9.1 update-1. while running migration I ran into the issue where I had <indexAllFields> in the following ...
1
vote
1answer
137 views

Error message: Value of the StartSearchLocation '' is not a valid GUID. '{11111111-1111-1111-1111-111111111111}' will be used instead

I'm seeing this error repeatedly in the logs in our CM instance of Sitecore 8.1 update-3. Where does it come from? ERROR Value of the StartSearchLocation '' is not a valid GUID. '{11111111-1111-...
1
vote
1answer
40 views

Is there a way to do a search in Sitecore against with Lucene using a dynamic field?

My client needs me to write a speak app that can do a search where they can type in whatever field they want to equal a value in the search bar. Is there a way to do a search against Lucene to within ...
1
vote
2answers
643 views

Search for Items Content under the Data Folder

Is there a way to include the content in the Data folder in the search results? when I search for an item using the search box it doesn't show up and I get 0 results but when the search box query is ...
1
vote
1answer
547 views

How to enable full-text searches within the Content Editor?

Our client would like to do full-text searches within all of their Content (e.g. the values of the Rich Text Fields). Is it possible to enable this within the standard Content Editor search function? ...
1
vote
1answer
55 views

Dropdown Filter - Language English Name

I am using SXA Search component and with that I want to use "Dropdown" filter which will have "Language" facets in the dropdown for the search items. I am able to achieve it by getting "_language" ...
1
vote
1answer
67 views

SXA Search functionality works only with the whole search query

I'm using Sitecore 9.1 and SXA 1.8, I implemented search functionality using Search box and Search results OOB SXA components, When I search with a sentence, it only returns the exact match for the ...
1
vote
2answers
60 views

OrderBy not being respected for item field when using content search

Using Lucene, and content search I cannot sort items by their name nor custom title field. The items are imported from a read-only data provider and are successfully indexed (I've inspected it ...
1
vote
1answer
47 views

Can I use Content Search with Glass to query children of a specific template?

My Sitecore Item has children of different Templates. To query them, I use the following field declaration: [SitecoreQuery("*[@@templateid = '{ID of my Template}']", InferType = true, IsRelative = ...
1
vote
1answer
68 views

Do indexes with computed fields with storageType=“no” need to be rebuilt?

If a computed field is computed at run-time when storageType is set to no, does does the index need to be rebuilt at all as it's all done in memory?
1
vote
1answer
65 views

Is there a way to append an indexed field to a glass mapper object?

I'm generating a custom sitewide search by indexing the rendered HTML of the pages on my site. Some pages will have a title and description field defined to display in the results, however, some ...
1
vote
1answer
245 views

SXA Checlikst filter not working with special characters

SXA Checlikst filter is not working when filtering by a choice with a special character like : '&' then filter by other filter I think the problem is in the encoding because when I checked the ...
1
vote
2answers
785 views

Failed to execute datasource query System.NullReferenceException while setting Datasource on Rendering

Has anyone seen this error before or know how to solve it? 996 16:35:46 WARN Failed to execute datasource query System.NullReferenceException: Object reference not set to an instance of an ...
1
vote
2answers
218 views

Lucene for multiple server scenario

I have been told that when there are load balancers and multiple servers, lucene will not work. Is there an alternative that we can still use Lucene as the search engine.
1
vote
1answer
318 views

Add facet to Content editor search - field name with two words not working

I am trying to add a new facet to the content editor, everything is working fine with single word fields (Ex: Authors, Subjects, locations, etc), but same is not working with two word fields (EX: ...
1
vote
1answer
39 views

Search results count not updated when deleting items

I am using Sitecore 9.0.2. and SXA 1.8. I am facing a strange issue when I delete an item. The search results that returns this item is retrieved with the old count (including the deleted item) ...
1
vote
1answer
80 views

Azure search random behavior running for Sitecore 9.0.2

I am having issue with the Azure Search where I am not getting results from the search index (it is random issue). I’ve verified the configurations of Azure search and computed index fields. Below is ...
1
vote
1answer
567 views

Sitecore 9.1 upgrade Error loading hook

We're upgrading from Sitecore 8.1 Update 3 to Sitecore 9.1. We use Solr for xConnect search, Lucene for web site search The CM is working, but the CD is not. Got the following error message: Server ...
1
vote
1answer
93 views

_content field not populating correctly

We're on Sitecore 8.1 update 2 and I'm having issues with the content search API. Its my understanding the _content field in the index should contain an amalgamation of all the fields in the template. ...
1
vote
1answer
118 views

Could SocketException be caused by CloudSearchRetryPolicy?

I'm investigating an issue where we are seeing SocketExceptions and socket handle leaks. Using Sitecore 8.2 rev 107614, in Azure using Azure Search as the search provider. Drilling down to one of the ...
1
vote
1answer
112 views

Multilist with search not loading for non admin

Data on the left side of the multi-list is not loading if the user is a non-admin. I have multisite on a single node so on the data source I've put Sitecore query as StartSearchLocation=query:./...
1
vote
1answer
366 views

Search using a Search string in SXA Search service

I have a requirement to implement a custom search box and pull search results based on scope and then present the search results by combining components created using two templates. I am trying to ...
1
vote
1answer
91 views

Content Search and Azure how to apply negative boost based on a checkbox value

I want to apply negative boosting to items, based on the value of an indexed checkbox field in order to move those items to the bottom of the search results. I am applying (positive) boosting to other ...
1
vote
1answer
99 views

Rebuild Search indexes error: “System.ArgumentException”

My "Rebuild search indexes" aborts and produces this error: "System.ArgumentException: it doesn't make sense to have a field that is neither indexed nor stored". but which field, which Item ID? ...
1
vote
1answer
199 views

How can I modify SXA search component to search also in the Accordions content?

I'm trying to modify Sitecore default behaviour to search also in accordions content. I have checked Is Displayed in Search Results at /sitecore/templates/Feature/Experience Accelerator/Composites/...
1
vote
1answer
127 views

SXA Search Results Grouping

I am using Sitecore 9.0 with SXA 1.6 and Solr search provider. Is there a way to display results grouped in SXA Search results components?
1
vote
1answer
389 views

Error when adding computed index field: InvalidOperationException contextDatabase

I add a custom computed field to the fieldmap node in the Lucene Search config like so: <fieldNames hint="raw:AddFieldByFieldName"> <field fieldName="my_field" indexType="UNTOKENIZED" ...
1
vote
1answer
338 views

Grouped Result in Solr

I have seen documentation mentioning Sitecore.ContentSearch.SolrNetExtension for Sitecore 9 indicating that its able to group results by a field (ie: _group field). What I am unable to find is a nice ...
1
vote
2answers
507 views

No facets showing in Sitecore Search when using SOLR

There is no facets showing when I change the search provider to SOLR. The sample item here is the Content item.
1
vote
1answer
821 views

Customizing SXA checklist filter facet component

I would like to do pivoted search using SXA Search filter facet Component. Is there a way to customize SXA Search component and have pivoted kind of search? I see that sxa delivers SearchController ...
1
vote
1answer
1k views

Search indexing not working as expected

I'm new to search and indexing. We are implementing this for a search feature on the website for the end user (not the internal search) and using Solr 4.10.3 with sc8.0 u5 Solr is setup with all the ...
1
vote
1answer
174 views

Is it possible to extend the Content Editor search?

My website requires that Content Editors have access to a custom Search mode which shows them results based in a format that's not directly available in Sitecore. Is it possible to extend the Search ...
1
vote
1answer
1k views

Issue with Sitecore Solr indexes Sitecore 8.1 Update 3

I am trying to convert the base Sitecore indexes from Lucene to Solr. I am using Sitecore 8.1 Update 3. I have 2 custom indexes that are still going to use Lucene for the time being so I still need ...
1
vote
1answer
177 views

How to avoid double quotes for is equal to when using segment builder

I'm creating a condition for the segment builder inheriting from TypedQueryableStringOperatorCondition. I'm overriding the method GetResultPredicate to apply my filter like this return base....
1
vote
1answer
33 views

Working with chinese language with the SXA Search Component

We have an issue, where we have content in multiple languages, and we are doing a basic keyword site search using the SXA Search Component. As far as I can tell (from the search.log), the SXA Search ...
1
vote
0answers
34 views

Sitecore SXA search doesnt work

I have recently installed a fresh Sitecore 8.2 update 5 including Power Shell 4.7.2 SXA 1.5 rev 171010 Sitecore SXA Showcase v1.2 Everything seems working fine except for the search function. When ...
1
vote
0answers
29 views

SXA search result returns Error 400

I am using Sitecore 9.0.2 and SXA 1.7.1. Search results return Error 400 with response "Exception has been thrown by the target of an invocation." while facets return results as expected. any idea ...
1
vote
0answers
33 views

Not able to Perform multi-language search Sitecore with searchstring

Using Solr as Default search provider. Content Search is working when website language is -en example.com/en/sxa/search/results/?l=en&q=query From localhost:8983(solr) Able to query the data ...
1
vote
0answers
38 views

Adding hashtag to the internal link that leads to blog search page with tag filter search Sitecore SXA 1.9

The blog index page has all articles are listed and the filter based on tag that works with solr search. The search results based on sxatags filter will get added on the blog index page when apply ...