Questions tagged [coveo]

All questions related to Coveo for Sitecore

Filter by
Sorted by
Tagged with
0
votes
1answer
21 views

Powershell script for Coveo Indexing

I am using this Powershell script for Coveo indexing, but I do not see the output after waiting for a long time. I can see that indexing is running in "Coveo indexing manager". But its not ...
0
votes
0answers
17 views

Issue with Coveo Indexing

Exception while processing an item: -> Unable to connect to the remote server -> A connection attempt failed because the connected party did not properly respond after a period of time, or ...
0
votes
0answers
18 views

Is there a way for running coveo for sitecore queries directly?

I am able to see some output from Coveo Index on My admin tool => Content =>Index browser. Which i dont see on my Search Page (Javascript Framework). How can i debug this ? can i run my Coveo ...
0
votes
1answer
34 views

What is the role of Encryption Key in Coveo for sitecore

My understanding is Encryption key is used to read the passwords. Why is it stored in Data folder and Core DB (properties) table? In my case say I am creating a new environment by copying the Website ...
0
votes
1answer
26 views

Do i need to install CES and Coveo Search API on CD servers as well?

I am very new to Coveo and trying to understand the basics of Coveo. Do i need to CES and Search API in CD Servers as well ? or Should it use the CM Search API and query the CM index ? I am trying to ...
0
votes
1answer
27 views

How do i change the Coveo configuration for Sitecore in an existing setup

I have copied an existing sitecore/coveo setup from test environment to my local machine . How do i change the Coveo for sitecore configuration like Search API Url , Application Secret Key ,Admin ...
-1
votes
1answer
30 views

Understand the connection strings in Coveo

I am very new to Coveo. We are trying to introduce a new environment in between QA and Prod.I have just duplicate the QA Setup for this. What are the settings and connection strings that i have to ...
0
votes
0answers
28 views

Coveo Index Item Url Issue Using Sitecore 8.2 and Coveo 5.0

I am facing an issue with the Coveo index Item URL. After Coveo indexed on dev environment, item URL formation is in a right format like /en/za/news/news1 while on uat environment after Coveo indexed ...
0
votes
1answer
22 views

Issue in getting the correct Model.Field from “Coveo.UI.Mvc.Models.FacetModel”

We are using multisites with a single sitecore instance and single coveo source in the cloud but there are 2 same documents for each site but are having different computed fields. So I have two ...
1
vote
0answers
30 views

Coveo Wildcard Search Not working [closed]

I wanted to enable Wild Card Search in my Coveo JavaScript Search Framework (Coveo - 4.0.222.0 On Premise) , I had added the attributes data-enable-query-syntax="true" and data-enable-wildcards="true"...
0
votes
1answer
52 views

Coveo DNE feature -new facet styling

I'm going to implement a new Coveo feature Dynamic navigation When I define CoveoDynamicFacet instead of CoveoFacet, I automatically get a new facet style with that. Is there a way to keep the old ...
1
vote
1answer
55 views

Coveo Search Word match

In my content, I have the following text water engine, Fire engine Features now available on the test model: 01ANB is the test string If I search for engin (not engine), it brings up this particular ...
0
votes
1answer
34 views

Coveo Config based on Environment [closed]

I am new to coveo and our dev environment is not working as expected, I am trying to duplicate the QA Environment and set up dev environment When i do this what are all the changes i should keep in ...
0
votes
1answer
122 views

FXM CORS Sends OPTIONS request and 405s

I'm attempting to add a Coveo searchbox to another site using FXM. The Searchbox in question works fine locally on the Sitecore Server. It searching terms properly. It has type-ahead/query ...
0
votes
1answer
98 views

Coveo Breadcrumb - How do you customize the Text?

I am using vanilla Coveo Hive components on my Sitecore website. I have created and configured a search page. This page uses the Coveo Breadcrumbs component, and everything is hooked up and working. ...
-1
votes
1answer
42 views

Why doesn't my range facet work?

When I add a Coveo Numeric Facet Range facet to my search page, it displays a list of values, not a list of ranges as I would expect. Is there a way to get it to show ranges instead of individual ...
1
vote
2answers
88 views

Getting search results from respective crawlers of multisite with single Coveo index

I am using Sitecore 8.2 with Coveo 4.0. I'm working on a multisite solution with two sites and created two crawlers inside a single index. How can I make sure that on the search page data comes ...
0
votes
2answers
94 views

Index Rebuild option not appearing in Sitecore Control Panel

I am using Coveo 4.0 Cloud platform with Sitecore 8.2. I don't see an option for Index Rebuild in Sitecore control panel(Please refer attached screenshot). Kindly let me know how to rebuild indexes.
0
votes
1answer
70 views

Search Results not appearing in Coveo Search [closed]

I have implemented Coveo search in my application. Its working fine on Prod but stopped working on local. The search results are not appearing in local When I tried to figure out what is the issue , ...
0
votes
1answer
97 views

Issue with relative path

Good day, I have a issue when my page is loading. The normal behaviour is that all javascripts files are loaded in the request url: http://example.com/Coveo/Hive/js/Searchbox.min.js . But sometimes ...
0
votes
0answers
45 views

Sitecore Command Locking Up Entire Web Server

So I have an issue, not sure what to do I have a standard Sitecore command, that is running about a 15 minutes process It is crawling a restful API and sticking documents into Coveo Push source, ...
0
votes
1answer
78 views

I do not want to show the port in clickUri [closed]

Good day, I do not want to show the port of the link in COVEO. Example: In this moment: https://test.testpage.com:443/places/cub What I want: https://test.testpage.com/places/cub Is any ...
0
votes
1answer
110 views

Invalid credential Error while activating Coveo for Sitecore 5

So I am installing and configuring Coveo 5 for Sitecore, first time There is a new activation interface, not just the dialog as before but now a whole page I can't get past this error, the Coveo ...
1
vote
3answers
207 views

Initializing two Coveo Search Results Lists in one page

Is it possible to have two Coveo Search Results Lists in one page? I need to display two kinds of results, one for the filtered results list and one for the rest of the results (not retrieved by the ...
0
votes
1answer
36 views

Platform.Cloud.Coveo.Com doesnt have any information for my Organisation

I have newly started with the Existing coveo project where everything looks fine,Except the platform.cloud.coveo.com doesnt have any info on index etc.Its completely blank. I checked in showconfig....
0
votes
1answer
63 views

Coveo security cache update timing

Is there any detriment to increasing the frequency of Coveo updating the security cache (the on-prem edition)? I noticed it's set to do it nightly at midnight, but if new users register during the day ...
1
vote
1answer
84 views

Secured document I have permission to not showing in Coveo search

This is using Sitecore 8.1 Update 1, Coveo on-premises version 7 (8388.7) free edition, and Coveo for Sitecore version 4.0.222.0. I have a document that's been secured such that everyone is denied ...
6
votes
1answer
125 views

How to prevent a website outage because of Coveo service unreachable

I am running Coveo 4.1.125 (on a on-premise server) for Sitecore 8.1 I noticed that sometimes when my dedicated Coveo server is unreachable, that the complete website is going down with the following ...
2
votes
1answer
1k views

An error occurred while rebuilding the search index

I am unable to build the Coveo for Sitecore master index. While the rebuild is supposedly happening, the number of items processed is always 0. In the Sources of the cloud panel, the index doesn't ...
3
votes
1answer
497 views

Item preview fails with “Section or group name 'system.web.webPages.razor' is already defined”

I've created a Coveo search page using the reference here: https://developers.coveo.com/display/public/SitecoreV4/Inserting+and+Customizing+a+Search+Interface+Component. When I try to preview it, I ...
4
votes
2answers
231 views

Coveo Facet View only showing up 2 Tags instead of all

​I have created 4 tags in Sitecore at Sitecore/System/Settings/Buckets/TagRepository. I have added Coveo Facet View rendering on the page and selected Tags field in the properties. It is only showing ...
1
vote
1answer
115 views

Installing Coveo Enterprise Search 7.0 throwing COM Error

I have installed and configured Enterprise Coveo Search as per documentation and after installing Coveo for Sitecore, when I browse the diagnostic page I am facing the issue below: I have tried ...
0
votes
1answer
70 views

Coveo external source - anonymous users denied

We are using the Coveo Cloud edition, and I've added an external data source to the index. I see the results in the context browser in the admin tool, but not on the search page after adding the ...
1
vote
1answer
42 views

Sitecore 7.2 - Coveo/rest is throwing the error “The service is unavailable.”

I have installed Coveo for sitecore 3.0 in my local/developer machine. Search indexes are having content in CES and but when I search, my search page does not return any results or coveo facets does ...
1
vote
1answer
147 views

Coveo Facet Field Indexing Issue

We are using the Sitecore 8.1, and I have patched a field called categories in the coveo default Index configuration node to make it a facet. <configuration xmlns:patch="http://www.sitecore.net/...
2
votes
1answer
112 views

How Coveo reads indexes?

We are using Coveo on perm 4.0 edition with Sitecore 8.1 update 3. We have CM and CD configured to use the Coveo indexes. When I query the results on CM and on CD it uses different indexes So how ...
0
votes
1answer
293 views

Excessive updates of the EventQueue table

We are using Sitecore 7.2 and Coveo for sitecore in our multilingual CMS website. Our sitecore really gets slow sometimes and we could also see deadlocks happening in our application logs. Upon ...
5
votes
1answer
285 views

“The user ”sitecore\[USERNAME]“ does not exist” errors attributed to Coveo in Sitecore log

One of our clients is seeing these errors related to users, and appearing to be in part due to Coveo (Sitecore 8.1 Update 1, Coveo June 2016 instance with on-prem free version). In the first two ...
1
vote
0answers
104 views

Coveo for Sitecore issue with SearchBox and SearchView with OmniboxResultView

I am using a Search box with suggestions and 4 OmniboxResults view (each with filter expression to group different results) on all pages. It internally uses Coveo Search View Resources and Search Box ...
1
vote
1answer
129 views

Sitecore Coveo Cloud on 8.1 Initial release with WFFM installed, locks up

Anyone have an issue installing Coveo for Sitecore (Cloud) module "82 4.0 (895).zip" on Sitecore 8.2 Initial Release with WFFM? Coveo said it is a known issue https://support.coveo.com/s/article/...
1
vote
1answer
195 views

Coveo modify query suggestion url

Using Coveo for Sitecore 4 and query suggestion using SearchBoxView. I need to modify the suggestion result item's url. Currently it performs a free text query when I click the suggestion. Instead I ...
0
votes
1answer
104 views

After reindex, some base Coveo-defined fields missing from content

I've added some computed fields so I did the necessary re-indexing. Along the way, though, I noticed that a couple of the "default" Coveo fields (that is, field definitions in Coveo.SearchProvider....
0
votes
1answer
234 views

Coveo multi-list - find if field has only one value

I'm using several multi-list fields in my searches, and they work great to say "field = value" and it finds a matching value in the list. What I need now, though, is to check if the value I'm looking ...
3
votes
2answers
949 views

How to apply query boost on certain fields

I am using regular ContentSearch API in front of Coveo for Sitecore 3 (not using Coveo UI). I am trying to boost keywords in Title and Subtitle fields to have higher weights compared to page Content. ...
3
votes
1answer
232 views

CoveoForSitecore how to override numberOfResults property

I am trying to override the numberOfResults property in Coveo Search UI before initializing, but doesn't seem to take affect. What could I be doing wrong? Coveo.$('#@Model.Id').on("buildingQuery", ...
3
votes
1answer
91 views

Content does not show in Coveo despite matching criteria

I have a Coveo search view I've customized to show content based on the page you're on matching to whether that value is in a multilist field in Sitecore. The server environment is on-prem CES 7 free ...
3
votes
1answer
98 views

Coveo UI return to result list

Using Coveo UI and infinite scroll. How can we return user back to same place in search result list? Ex: user scrolls through the results and clicks on a result item to view the article. Is there a ...
2
votes
1answer
780 views

Indexing section is disappeared from control panel

I am trying to rebuild the search indexes through index manager, as an admin user. I am working on a Sitecore 8.0 instance from another developer, and I am not super familiar with Sitecore, myself. ...
2
votes
1answer
251 views

Using ToCoveoFieldName in backend

Is there a way to get Coveo equivalent field name helper such as ToCoveoFieldName in CoveoProcessParsedRestResponseArgs pipeline code? Basically I am trying to see if a property of SearchResult item ...
3
votes
1answer
101 views

Coveo initialize components via code

Currently all Coveo UI components are initialized through Experience Editor. Setting their appropriate properties. Is there a way to initialize them through code? Example CoveoSortFieldView.cshtml and ...