Questions tagged [coveo]

All questions related to Coveo for Sitecore

Filter by
Sorted by
Tagged with
0
votes
1answer
22 views

Issue in getting the correct Model.Field from “Coveo.UI.Mvc.Models.FacetModel”

We are using multisites with a single sitecore instance and single coveo source in the cloud but there are 2 same documents for each site but are having different computed fields. So I have two ...
0
votes
0answers
17 views

Issue with Coveo Indexing

Exception while processing an item: -> Unable to connect to the remote server -> A connection attempt failed because the connected party did not properly respond after a period of time, or ...
0
votes
0answers
18 views

Is there a way for running coveo for sitecore queries directly?

I am able to see some output from Coveo Index on My admin tool => Content =>Index browser. Which i dont see on my Search Page (Javascript Framework). How can i debug this ? can i run my Coveo ...
0
votes
1answer
33 views

What is the role of Encryption Key in Coveo for sitecore

My understanding is Encryption key is used to read the passwords. Why is it stored in Data folder and Core DB (properties) table? In my case say I am creating a new environment by copying the Website ...
0
votes
1answer
26 views

Do i need to install CES and Coveo Search API on CD servers as well?

I am very new to Coveo and trying to understand the basics of Coveo. Do i need to CES and Search API in CD Servers as well ? or Should it use the CM Search API and query the CM index ? I am trying to ...
0
votes
1answer
25 views

How do i change the Coveo configuration for Sitecore in an existing setup

I have copied an existing sitecore/coveo setup from test environment to my local machine . How do i change the Coveo for sitecore configuration like Search API Url , Application Secret Key ,Admin ...
0
votes
1answer
51 views

Coveo DNE feature -new facet styling

I'm going to implement a new Coveo feature Dynamic navigation When I define CoveoDynamicFacet instead of CoveoFacet, I automatically get a new facet style with that. Is there a way to keep the old ...
2
votes
1answer
1k views

An error occurred while rebuilding the search index

I am unable to build the Coveo for Sitecore master index. While the rebuild is supposedly happening, the number of items processed is always 0. In the Sources of the cloud panel, the index doesn't ...
-1
votes
1answer
30 views

Understand the connection strings in Coveo

I am very new to Coveo. We are trying to introduce a new environment in between QA and Prod.I have just duplicate the QA Setup for this. What are the settings and connection strings that i have to ...
0
votes
0answers
25 views

Coveo Index Item Url Issue Using Sitecore 8.2 and Coveo 5.0

I am facing an issue with the Coveo index Item URL. After Coveo indexed on dev environment, item URL formation is in a right format like /en/za/news/news1 while on uat environment after Coveo indexed ...
15
votes
3answers
448 views

Coveo user in a new Sitecore 8.1 update 3 instance gets locked consistently

I have cleared the security cache on Coveo several times, verified the certs, the encryption key and the Coveo license. I have also verified the password hash and physically gotten on the master and ...
1
vote
0answers
29 views

Coveo Wildcard Search Not working [closed]

I wanted to enable Wild Card Search in my Coveo JavaScript Search Framework (Coveo - 4.0.222.0 On Premise) , I had added the attributes data-enable-query-syntax="true" and data-enable-wildcards="true"...
2
votes
1answer
250 views

Using ToCoveoFieldName in backend

Is there a way to get Coveo equivalent field name helper such as ToCoveoFieldName in CoveoProcessParsedRestResponseArgs pipeline code? Basically I am trying to see if a property of SearchResult item ...
1
vote
1answer
53 views

Coveo Search Word match

In my content, I have the following text water engine, Fire engine Features now available on the test model: 01ANB is the test string If I search for engin (not engine), it brings up this particular ...
3
votes
1answer
119 views

Group results using OmniboxResultsView

How to get grouped results with SearchBoxView and OmniboxResultListView? I've added those 2 components on the page along with SearchViewResources and was able to get results as I type in ...
2
votes
1answer
112 views

How Coveo reads indexes?

We are using Coveo on perm 4.0 edition with Sitecore 8.1 update 3. We have CM and CD configured to use the Coveo indexes. When I query the results on CM and on CD it uses different indexes So how ...
0
votes
1answer
33 views

Coveo Config based on Environment [closed]

I am new to coveo and our dev environment is not working as expected, I am trying to duplicate the QA Environment and set up dev environment When i do this what are all the changes i should keep in ...
0
votes
1answer
111 views

FXM CORS Sends OPTIONS request and 405s

I'm attempting to add a Coveo searchbox to another site using FXM. The Searchbox in question works fine locally on the Sitecore Server. It searching terms properly. It has type-ahead/query ...
9
votes
1answer
774 views

Update same rendering of several templates using SPE

I have a bunch of templates that have a Coveo Search Box View rendering associated with the standard values. I need to update the property "Reveal Advanced Query Suggestions" of all of them(a lot of ...
0
votes
1answer
95 views

Coveo Breadcrumb - How do you customize the Text?

I am using vanilla Coveo Hive components on my Sitecore website. I have created and configured a search page. This page uses the Coveo Breadcrumbs component, and everything is hooked up and working. ...
-1
votes
1answer
42 views

Why doesn't my range facet work?

When I add a Coveo Numeric Facet Range facet to my search page, it displays a list of values, not a list of ranges as I would expect. Is there a way to get it to show ranges instead of individual ...
0
votes
1answer
70 views

Search Results not appearing in Coveo Search [closed]

I have implemented Coveo search in my application. Its working fine on Prod but stopped working on local. The search results are not appearing in local When I tried to figure out what is the issue , ...
1
vote
2answers
86 views

Getting search results from respective crawlers of multisite with single Coveo index

I am using Sitecore 8.2 with Coveo 4.0. I'm working on a multisite solution with two sites and created two crawlers inside a single index. How can I make sure that on the search page data comes ...
2
votes
1answer
124 views

Error saving search page after adding filter rule to tab

I am setting up a search page, but I'm getting an error when hitting save on the tab component, after adding a filtering rule. If I remove the rule, it saves fine. The rule is simple. just filter by ...
0
votes
2answers
92 views

Index Rebuild option not appearing in Sitecore Control Panel

I am using Coveo 4.0 Cloud platform with Sitecore 8.2. I don't see an option for Index Rebuild in Sitecore control panel(Please refer attached screenshot). Kindly let me know how to rebuild indexes.
6
votes
1answer
113 views

Online index rebuild?

I've used Solr for previous Sitecore projects, but I'm looking at Coveo for my latest project. Similar to the Solr core swap: does Coveo provide the ability to rebuild an index, while still ...
6
votes
1answer
183 views

Multiple Search Fields on the Same Page with Suggested Results

We have implemented a global Coveo search box, in our global header on our site that drives to our search page. This appears on our search page as well. Both the search box on the search page and the ...
9
votes
1answer
345 views

Speeding up Coveo reindex

I've got a CM server with Coveo for Sitecore installed (free edition) and Coveo Enterprise Search on a separate server. I set up Sitecore with Coveo on CM and reindexed relatively quickly. When I set ...
7
votes
4answers
519 views

Loading Content Editor Leads to A Coveo Licensing Error

The site was recently upgrdaded to 8.1 and although I can access the Desktop, the content editor throws an error when launched. This is a local instance of Sitecore that uses Coveo. After all the ...
0
votes
1answer
95 views

Issue with relative path

Good day, I have a issue when my page is loading. The normal behaviour is that all javascripts files are loaded in the request url: http://example.com/Coveo/Hive/js/Searchbox.min.js . But sometimes ...
0
votes
0answers
45 views

Sitecore Command Locking Up Entire Web Server

So I have an issue, not sure what to do I have a standard Sitecore command, that is running about a 15 minutes process It is crawling a restful API and sticking documents into Coveo Push source, ...
0
votes
1answer
77 views

I do not want to show the port in clickUri [closed]

Good day, I do not want to show the port of the link in COVEO. Example: In this moment: https://test.testpage.com:443/places/cub What I want: https://test.testpage.com/places/cub Is any ...
0
votes
1answer
110 views

Invalid credential Error while activating Coveo for Sitecore 5

So I am installing and configuring Coveo 5 for Sitecore, first time There is a new activation interface, not just the dialog as before but now a whole page I can't get past this error, the Coveo ...
1
vote
3answers
198 views

Initializing two Coveo Search Results Lists in one page

Is it possible to have two Coveo Search Results Lists in one page? I need to display two kinds of results, one for the filtered results list and one for the rest of the results (not retrieved by the ...
0
votes
1answer
36 views

Platform.Cloud.Coveo.Com doesnt have any information for my Organisation

I have newly started with the Existing coveo project where everything looks fine,Except the platform.cloud.coveo.com doesnt have any info on index etc.Its completely blank. I checked in showconfig....
6
votes
1answer
125 views

How to prevent a website outage because of Coveo service unreachable

I am running Coveo 4.1.125 (on a on-premise server) for Sitecore 8.1 I noticed that sometimes when my dedicated Coveo server is unreachable, that the complete website is going down with the following ...
3
votes
1answer
101 views

Coveo initialize components via code

Currently all Coveo UI components are initialized through Experience Editor. Setting their appropriate properties. Is there a way to initialize them through code? Example CoveoSortFieldView.cshtml and ...
2
votes
1answer
637 views

“The remote server returned an error: (401) Unauthorized” Error while accessing item binary data in Coveo with Windows Auth

I have Windows Authentication on the IIS of sitecore site (for limited external access). Coveo is running remotely on another server. When trying to access item binary data p_Args.CoveoItem.BinaryData ...
1
vote
1answer
225 views

Coveo cloud indexing error with “NameResolutionFailure” error code

I am using Coveo for Sitecore 4 450 build. Noticing this error only on few environments. I looked up there is no CleanUpIndexAfterRebuildException entry in the coveo configs. Any ideas on how I can ...
5
votes
1answer
278 views

“The user ”sitecore\[USERNAME]“ does not exist” errors attributed to Coveo in Sitecore log

One of our clients is seeing these errors related to users, and appearing to be in part due to Coveo (Sitecore 8.1 Update 1, Coveo June 2016 instance with on-prem free version). In the first two ...
0
votes
1answer
62 views

Coveo security cache update timing

Is there any detriment to increasing the frequency of Coveo updating the security cache (the on-prem edition)? I noticed it's set to do it nightly at midnight, but if new users register during the day ...
1
vote
1answer
83 views

Secured document I have permission to not showing in Coveo search

This is using Sitecore 8.1 Update 1, Coveo on-premises version 7 (8388.7) free edition, and Coveo for Sitecore version 4.0.222.0. I have a document that's been secured such that everyone is denied ...
1
vote
0answers
103 views

Coveo for Sitecore issue with SearchBox and SearchView with OmniboxResultView

I am using a Search box with suggestions and 4 OmniboxResults view (each with filter expression to group different results) on all pages. It internally uses Coveo Search View Resources and Search Box ...
3
votes
1answer
488 views

Item preview fails with “Section or group name 'system.web.webPages.razor' is already defined”

I've created a Coveo search page using the reference here: https://developers.coveo.com/display/public/SitecoreV4/Inserting+and+Customizing+a+Search+Interface+Component. When I try to preview it, I ...
2
votes
1answer
238 views

Coveo Suggested Results Returning the Wrong URL on Search View

We are using this to provide suggested results on our search view page. https://developers.coveo.com/display/SitecoreV4/Provide+Result+Suggestions However the results provided are returning a URL ...
3
votes
1answer
230 views

CoveoForSitecore how to override numberOfResults property

I am trying to override the numberOfResults property in Coveo Search UI before initializing, but doesn't seem to take affect. What could I be doing wrong? Coveo.$('#@Model.Id').on("buildingQuery", ...
3
votes
2answers
933 views

How to apply query boost on certain fields

I am using regular ContentSearch API in front of Coveo for Sitecore 3 (not using Coveo UI). I am trying to boost keywords in Title and Subtitle fields to have higher weights compared to page Content. ...
2
votes
2answers
76 views

Coveo pin items between results

Using Coveo UI's SearchView.cshtml, Is there a way in Coveo to pin external items into results list in certain order? Basically I am trying to insert ads between search results list. I have n no. of ...
1
vote
1answer
147 views

Coveo Facet Field Indexing Issue

We are using the Sitecore 8.1, and I have patched a field called categories in the coveo default Index configuration node to make it a facet. <configuration xmlns:patch="http://www.sitecore.net/...
3
votes
1answer
232 views

Sitecore FXM with Coveo, dynamic html does not seem to render

Sitecore 8.1 (160302) I have a client using Sitecore FXM to export HTML/JS/CSS to an external site in order to preserve the same experience outside of Sitecore. The "experience" itself is mostly the ...