Skip to main content

Questions tagged [custom-route]

All questions related to custom routing including route registration, pipeline configuration and execution.

Filter by
Sorted by
Tagged with
0 votes
0 answers
48 views

hostname could not be parsed error when hitting custom MapHttpRoute

I am running Sitecore (10.2)/SXA backend in Docker. I am running NextJS directly on my host machine via npm run start:connected. On upstream environments, when I hit /export/doc?id=xxxxxxx, a file is ...
0 votes
2 answers
55 views

HTTP 500 errors when accessing custom route which can't find a controller

Every time somebody tries to access a route "below" our custom API routes, we see an HTTP 500 error. Such errors are quite messy in our log, and we would like to convert it into 404 errors ...
0 votes
1 answer
39 views

{virtualFolder} in route config is not taking full path defined on the site defnition file

My current Sitecore(9.0.2) project have multisite implementation with URL structure as follows Url: www.MainSite.com virtual folder:/ Url: www.MainSite.com/SubSite virtual folder:/SubSite Url: www....
1 vote
1 answer
6k views

Sitecore WebApi custom route not working controller not found

Controller: public class ExampleController : Controller { private readonly ISitecoreContext _sitecoreContext; public ExampleController () { } [System.Web.Http....
2 votes
1 answer
224 views

How to add custom route in Angular JSS ? Domain/<Page>/<id>

We are working hybrid headless SSR approach. The pages have a header and footer from Sitecore with wrapper angular components as shown in the image. We should pass the id of the article from the ...
1 vote
1 answer
270 views

Custom route for wild card

I'm trying to develop a custom route for this use case. The following URL patterns: https://example.com/new/Brand-1/product-1.htm https://example.com/used/Brand-2/product-2.htm should be redirected to ...
1 vote
1 answer
739 views

Adding sitemap.xml custom route causes EnsureLoggedInForPreview.Process

I am adding a sitemap to my site. I created a custom route and am adding it in a pipeline processor. When I brows to the page I get the following error: Object reference not set to an instance of an ...
2 votes
1 answer
756 views

Requested document not found when using MVC routes

I am getting 404s (requested document not found) when I try to use a custom route I created per the guide here: https://kb.sitecore.net/articles/700677. My patch config is showing up in showconfig, ...
5 votes
1 answer
770 views

How to set default controller for an area

I'm creating utility pages and the structure of the code files is as below: /Areas/MyTools/Controllers/UpdateField /Areas/MyTools/Views/UpdateField/Index.cshtml When I browse http://mysite/...
0 votes
0 answers
966 views

Custom routes never matched in Sitecore request execution

I followed the steps below to define custom ASP.NET MVC routes. Created a custom processor for the initialize pipeline and defined custom route in the Process method similar to the following: public ...