Questions tagged [docker]

Questions relating to the use of Docker Containers to run instances of Sitecore.

Filter by
Sorted by
Tagged with
0
votes
1answer
63 views

Sitecore 10.2 Docker Deploy exits with Named Pipes Error

I have recently installed Docker Desktop for Windows, version 20.10.10. It is running in Windows Container mode. I am running Windows 10 Pro Version 20H2. I am going through the Sitecore XP 10.2.0 ...
0
votes
0answers
17 views

JSS Containers setup, CM container does not start or attempt to start

I'm following the JSS walkthrough with container and I'm running into an issue running the up.ps1 script. Most of the script runs fine, but when it goes to start the containers the cm container doesn'...
0
votes
0answers
35 views

Sitecore Lighthouse Setup

We are trying to Setup Lighthouse(https://github.com/Sitecore/Sitecore.Demo.Platform/blob/main/docs/Usage.md) environment on Azure VM We were able to execute all the steps to provision Demo ...
0
votes
1answer
21 views

NuGet Restore not Working When Building Sitecore Images

I'm trying to spin up the following Sitecore environment using docker: https://github.com/Sitecore/docker-examples/tree/develop/custom-images I've already run the Init.ps1 script that fills in all the ...
0
votes
0answers
33 views

Getting Started template - Unable to find package Microsoft.Build.CentralPackageVersions. No packages exist with this id in source(s): Nuget, Sitecore

Getting Started template Sitecore 10 While running up.ps1 getting below errors: C:\build\Directory.Build.targets : warning : Unable to load the service index for source https://api.nuget.org/v3/index....
0
votes
1answer
27 views

Getting Started template Sitecore 10- running up.ps1 - failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0

Trying to do local Sitecore 10 setup using Getting Started Template. While running up.ps1 getting error failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0: ...
0
votes
0answers
22 views

Getting Started Template - File in use by another process

So I am doing the walkthrough: https://doc.sitecore.com/en/developers/101/developer-tools/walkthrough--using-the-getting-started-template.html Everything seems to work just fine (the occasional ...
0
votes
0answers
58 views

Sitecore Docker 10.2 on Windows 11

I am trying to build Sitecore 10.2 for containers on my Windows 11 system. Quite surprised when I got this message: 2017-10.2-20H2: Pulling from sxp/nonproduction/mssql-developer image operating ...
0
votes
0answers
28 views

Docker getting started template: You are not authorized to perform the task you are attempting. You may need to be assigned additional permissions

Hi when i tried to run the docker getting started template from Sitecore i got following error Your login is complete. You can close the browser tab now. Login information has been saved. Populating ...
0
votes
1answer
33 views

Cannot find any service with service name 'MSSQLSERVER' on docker-compose build

Has anyone ever run into the error below when running a build for Sitecore 10.1? It used to work fine and now this error pops up. I'm adding SPE and SXA to MSSQL. Again, it just started breaking but ...
3
votes
2answers
58 views

Deploy Docker Images to Multiple AKS Environments

I'm creating a CI/CD pipeline, and I'd want to understand how am I going to use the same docker image (assuming it is possible) and deploy it to multiple AKS environments such as QA, STG, and Prod. ...
0
votes
0answers
31 views

Publishing Database Error in Docker Container Environment

In a 10.1.1 upgraded from 9.0 U2 Docker container install, whenever publishing or even rebuilding indexes I get an error. Seems database related, but checked connections and they seem to be setup ...
0
votes
0answers
25 views

Helix Sample ASPCore using Docker

I tried to run the Helix Sample for ASPCore using docker but I get an error that says MsBuild timeout out while trying to get project to project references. The command 'powershell -Command $...
1
vote
1answer
97 views

Creating a custom Solr core in docker using docker

I am trying to create a custom solr index using custom schema with docker container approach. I am able to create a custom index, but I am not able to associate it with the custom schema. I did copy a ...
0
votes
1answer
41 views

AllowInvalidCertificates error after turning on XDB

After turning on XDB in a Docker installation after upgrading from 9.0 u2 to 10.1.1. I get the following error. XDB works fine in a vanilla install using the same license. Any ideas?
1
vote
0answers
44 views

Sitecore 10.0 Update 1 CM container Health check error

I am using Sitecore 10 update 1 and XP1 topology. All containers are healthy except CM container. I can see following errors in logs - ERROR Health check Sitecore.XConnect.Client.WebApi....
0
votes
0answers
39 views

Sitecore in container not accessible within Corporate VPN (Global Protect)

Outcome Able to run and access sitecore container within Corporate VPN network (Global Protect) so that we can rollout sitecore docker container practice for all developers. Problem We managed to get ...
0
votes
1answer
46 views

Deploying files to Identity Server Container

I am trying to configure a non-interactive client login in a Sitecore 10 container environment (https://doc.sitecore.com/en/developers/100/developer-tools/configure-a-non-interactive-client-login.html)...
0
votes
2answers
76 views

Sitecore CM returning 404 when running in docker container

I am running Sitecore XP1 topology in docker containers. I am facing following issues : 1)I am getting SSL warning even after running init.ps1 script & generating certificates : Sitecore default ...
0
votes
0answers
8 views

Cannot open database "Sitecore.Xdb.Collection.ShardMapManager" Login failed for user 'sa' when docker-compose up [duplicate]

I'm trying to set up a Sitecore instance with Docker using the https://github.com/Sitecore/docker-examples/tree/develop/getting-started After init.ps1 the docker-compose up fails with unhealthy ...
1
vote
1answer
50 views

Error when running "docker-compose build solution" from sitecore 10 docker guide

I'm at this stage of the guide whereby I'm required to build a solution from custom-images directory. After running docker-compose build solution from the directory, it throws the below error at step ...
0
votes
2answers
77 views

Sitecore custom-images from examples, docker-compose build solution command not working

I have cloned Sitecore docker-examples repository and started to go through tutorial of building custom images Building Custom Sitecore images. I noticed that when I use the command docker-compose ...
1
vote
2answers
186 views

Container-based solution build errors with "Could not create SSL/TLS secure channel"

I am doing container-based builds of my Sitecore solution, based on examples provided by Sitecore. However when I attempt to build, I get the following error: RUN Invoke-WebRequest "https://dist....
0
votes
0answers
95 views

Sitecore 10 MVC Multisite Container Architecture?

Problem There is lots of documentation on how to create an MVC Sitecore site with Docker and containers. But how would you recommend creating a multisite Sitecore site for a multitenant 8+ site ...
0
votes
2answers
143 views

Sitecore on MAC machine using Docker

Has anyone installed Sitecore on MAC machine using docker? Steps provided by Sitecore is compatible to Windows machine but not MAC. Few of the Frontend developers are comfortable with MAC machine and ...
0
votes
1answer
94 views

Remove dependencies in liveness and readiness probes

I'm working on setting up Sitecore 10.1 in Containers. I read this blog post and found following recommendation: "Configure liveness and readiness probes for your pods. Sitecore provides out-of-...
0
votes
0answers
144 views

kubernetessitecoreinstallation Exceeded Its Progress Deadline

We have a Sitecore XP1 Kubernetes cluster hosted in Azure using the lighthouse demo solution from Github. We are using Azure DevOps to build and deploy our images to the container registry. We are ...
0
votes
2answers
171 views

Sitecore 10 with containers error : Get https://scr.sitecore.com/v2/: x509: certificate signed by unknown authority

I am trying to set up Sitecore 10 with Docker and following this document https://doc.sitecore.com/developers/100/developer-tools/en/set-up-the-environment.html I have done the below steps: Installed ...
3
votes
1answer
105 views

Add SPE module to custom Sitecore Docker Image

I am trying to add SPE module to XP0 but getting error as shown in the image and its occurring while building the image. what am I doing wrong ? I have tried SPE 6.2-1809 version as well. SPE_IMAGE: ...
0
votes
0answers
341 views

Sitecore 10 installation through Docker gives error

I am getting an error like this when I am trying to install Sitecore 10 using docker following https://doc.sitecore.com/developers/100/developer-tools/en/walkthrough--using-the-getting-started-...
4
votes
1answer
112 views

Why does my asset image have .dat files instead of .dacpac files?

I have an asset image that was generated/provided to me by a Sitecore team that does not appear to conform with the traditional file structure that I see in the other asset images. Specifically, the ...
0
votes
1answer
94 views

Issue browsing CM Sitecore container

I'm having an issue when I try to browse my Sitecore 10.1 CM Container in the browser. The message I get is a 404 error. Investigating a bit more I checked traefik logs and saw lots of errors: *Failed ...
2
votes
1answer
340 views

Solr intermittently failing with "java.nio.file.NoSuchFileException"

I have a vanilla Sitecore 10.1 SXA setup on Docker. And for all intents and purposes it functions fine. However. Sometimes, and I've not been able to track down when or why this happens exactly, Solr &...
0
votes
0answers
43 views

Helix publishing pipeline uses bin folder as source in docker setup

We are using the Helix Publishing Pipeline (HPP) and defined the settings to exclude the default dlls (Sitecore, Commerce, Newtonsoft etc). There is a publish project in VS for this and when clicked ...
0
votes
0answers
57 views

Unknown command 'DockerBuild' while installing sitecore 10 demo site

I am trying to install Sitecore Demo site (https://github.com/Sitecore/Sitecore.Demo.Platform) on my local using the steps mentioned in this guide - https://buoctrenmay.com/2020/11/06/sitecore-xp-10-...
1
vote
1answer
104 views

Sitecore Docker Registry Versions

I need to add the Management module to my image. The instructions are on the Sitecore, but the compose files all append a specific version to the images to pull. How do I find the available versions ...
10
votes
2answers
2k views

Sitecore containers exit with "Failed to update IIS configuration" error

I am attempting to run Sitecore 10.0 in containers, but the environment fails to start successfully. If I try to access my Content Management container, I get a 404 error: 404 page not found I see ...
0
votes
0answers
114 views

Sitecore 10.0.1 containers unstable on localhost

I am new to Sitecore / new to docker. I am working on a Sitecore 10.0.1 project using docker containers. The docker containers frequently do not start. I have 32 gig ram. docker-compose up -d Docker ...
3
votes
1answer
132 views

How do the xConnect Docker containers correspond to the Azure xConnect app services?

I've tried to find documentation on the various xConnect roles that exist and their names and map them to the names of the xConnect containers in an XP1 container setup and an Azure PaaS configuration,...
2
votes
1answer
121 views

Sitecore Commerce installation fails in Docker

Using - Sitecore.Commerce.Container.SDK.2.0.159 We were able to successfully install Sitecore XP 10.1 in docker on our local machine running on Windows 10 64-bit. However, when we tried to install ...
1
vote
0answers
49 views

Sitecore PowerShell Remoting doesn't work with http://localhost/ and http://127.0.0.1/ addresses

I have Sitecore 9.3 with SXA and SPE 6.0 installed in a Docker container. docker-compose.yml map containers 80 port to 80 on local machine. ports: - "80:80" I have an additional ...
8
votes
1answer
260 views

How should a sitecore hotfix be applied to a Sitecore Docker image?

Assume the hotfix contains both files and items. If the hotfix is installed via the Sitecore shell, it works as expected until the next build where some or all of the dlls are replaced with the the ...
0
votes
2answers
112 views

Nodejs not part of docker in Getting Started Template for JSS to work

Nodejs is a pre-requisite for Sitecore 10 JSS and after setting up the solution for JSS with Getting started template https://doc.sitecore.com/developers/100/developer-tools/en/walkthrough--using-the-...
6
votes
1answer
2k views

Why won't Visual Studio load symbols when attaching to a container's w3wp process?

I want to debug my code running in a Sitecore CM Docker container. When I attach my debugger, it never breaks at my breakpoints and hovering over them always says The breakpoint will not currently be ...
1
vote
0answers
112 views

Sitecore CM container unhealthy after adding new volume

I have created a blank project using https://doc.sitecore.com/developers/100/developer-tools/en/walkthrough--using-the-getting-started-template.html Added a new volume to CM to sync Unicorn items as ...
6
votes
1answer
6k views

pywintypes.error: (2, 'CreateFile', 'The system cannot find the file specified while installing Sitecore Docker images

I am following the document https://doc.sitecore.com/developers/100/developer-tools/en/walkthrough--using-the-getting-started-template.html to create a test sample project for Sitecore Headless ...
5
votes
1answer
168 views

Sitecore Docker containers stop unexpectedly after a few minutes

I'm having an issue keeping my containers running consistently. After I run docker-compose up -d, some of them stop unexpectedly after only 10-15 minutes, sometimes less. When I run docker ps -a to ...
4
votes
1answer
243 views

'$path' not recognized as internal or external command when running up.ps1 for the getting started template sc 10

TLDR I am getting '$path' is not recognized as an internal or external command, when running up.ps1 in step 7 of Create the MyProject solution in the Sitecore 10 Getting Started Template. The bit of ...
4
votes
1answer
491 views

Local Sitecore containers unable to access Docker DNS

We are working on setting up Sitecore 10 in containers in Docker. I have been able to set up a simple XP0 configuration which works when I run docker-compose up -d on a Windows Server 2019 machine. ...
0
votes
2answers
135 views

What is the purpose of Sitecore.Assemblies.Platform nuget package?

What is this package for? What problem does it solve? How should it be used? Example https://sitecore.myget.org/feed/sc-packages/package/nuget/Sitecore.Assemblies.Platform/9.3.0