Questions tagged [docker]

Questions relating to the use of Docker Containers to run instances of Sitecore.

Filter by
Sorted by
Tagged with
1
vote
1answer
39 views

config transformation in docker

We are currently working on migrating our Sitecore solution to docker. Earlier we were utilizing octopus for config transformation between CD and CM server roles and variable replacement between ...
0
votes
2answers
143 views

Sitecore 10.2 Docker Deploy exits with Named Pipes Error

I have recently installed Docker Desktop for Windows, version 20.10.10. It is running in Windows Container mode. I am running Windows 10 Pro Version 20H2. I am going through the Sitecore XP 10.2.0 ...
0
votes
1answer
121 views

Remove dependencies in liveness and readiness probes

I'm working on setting up Sitecore 10.1 in Containers. I read this blog post and found following recommendation: "Configure liveness and readiness probes for your pods. Sitecore provides out-of-...
0
votes
0answers
19 views

Configure remote solr server for Sitecore 10 running on docker container

I have Sitecore 10 instance running on docker. It uses a default solr container, indexing also works fine. But I want to use a remote Solr server (I have configured solr search service in azure). I ...
0
votes
0answers
38 views

ASP.Net Core Docker error: Sqlcmd: Error: Named Pipes Provider: Could not open a connection to SQL Server

Following the Getting Started template tutorial, I have run into this particular error (right in the end, when the containers are starting): When I get docker logs for the first unhealthy container I ...
0
votes
0answers
56 views

Cannot start service traefik: The virtual machine could not be started because a required feature is not installed

I am trying to install Sitecore 10.1.1 with Docker. I am able to successfully pull all docker images with docker-compose pull but when I am trying to do docker-compose up -d, All containers are up ...
2
votes
1answer
72 views

Creating a custom Solr core using solr-init container in docker

I am using docker approach with Sitecore V10.2. I am trying to create a custom index with it's associated schema. I followed following article as the reference point : Add your custom index to Solr in ...
6
votes
1answer
7k views

pywintypes.error: (2, 'CreateFile', 'The system cannot find the file specified while installing Sitecore Docker images

I am following the document https://doc.sitecore.com/developers/100/developer-tools/en/walkthrough--using-the-getting-started-template.html to create a test sample project for Sitecore Headless ...
1
vote
2answers
46 views

How to install Sitecore Custom Languages in Containers based deployment

I am looking for inputs to install Custom Languages into Containers based deployment. Generally in ASP.NET MVC application (IaaS) we need to follow steps mentioned at https://sitecore.stackexchange....
0
votes
0answers
51 views

Error when starting CM and XConnect containers from docker examples custom-images

I have cloned the Sitecore docker examples repository and used docker-compose up to start up the containers. Solr, Sql and Id containers are running successfully, however CM and XConnect are showing ...
0
votes
1answer
124 views

Sitecore 10 MVC Multisite Container Architecture?

Problem There is lots of documentation on how to create an MVC Sitecore site with Docker and containers. But how would you recommend creating a multisite Sitecore site for a multitenant 8+ site ...
0
votes
0answers
27 views

NuGet update step is failing as private NuGet feed url is inaccessible from docker

We are trying to create a custom image as part of containerizing our Sitecore solution. But it is failing at NuGet restore step. We are using a private NuGet feed which can be accessed only with our ...
0
votes
1answer
43 views

JSS Containers setup, CM container does not start or attempt to start

I'm following the JSS walkthrough with container and I'm running into an issue running the up.ps1 script. Most of the script runs fine, but when it goes to start the containers the cm container doesn'...
0
votes
0answers
33 views

Progressing Sitecore Helix .Net Core example to Production Build

So I am using the .Net Core Helix example from Nick Wesselman (https://github.com/Sitecore/Helix.Examples/tree/master/examples/helix-basic-aspnetcore/). I have managed to get it all up and running and ...
0
votes
1answer
42 views

Getting Started Template - File in use by another process [duplicate]

So I am doing the walkthrough: https://doc.sitecore.com/en/developers/101/developer-tools/walkthrough--using-the-getting-started-template.html Everything seems to work just fine (the occasional ...
0
votes
2answers
177 views

Sitecore 10 with containers error : Get https://scr.sitecore.com/v2/: x509: certificate signed by unknown authority

I am trying to set up Sitecore 10 with Docker and following this document https://doc.sitecore.com/developers/100/developer-tools/en/set-up-the-environment.html I have done the below steps: Installed ...
0
votes
1answer
42 views

AllowInvalidCertificates error after turning on XDB

After turning on XDB in a Docker installation after upgrading from 9.0 u2 to 10.1.1. I get the following error. XDB works fine in a vanilla install using the same license. Any ideas?
0
votes
0answers
37 views

Sitecore Lighthouse Setup

We are trying to Setup Lighthouse(https://github.com/Sitecore/Sitecore.Demo.Platform/blob/main/docs/Usage.md) environment on Azure VM We were able to execute all the steps to provision Demo ...
0
votes
1answer
53 views

NuGet Restore not Working When Building Sitecore Images

I'm trying to spin up the following Sitecore environment using docker: https://github.com/Sitecore/docker-examples/tree/develop/custom-images I've already run the Init.ps1 script that fills in all the ...
0
votes
2answers
126 views

Sitecore CM returning 404 when running in docker container

I am running Sitecore XP1 topology in docker containers. I am facing following issues : 1)I am getting SSL warning even after running init.ps1 script & generating certificates : Sitecore default ...
0
votes
0answers
65 views

Getting Started template - Unable to find package Microsoft.Build.CentralPackageVersions. No packages exist with this id in source(s): Nuget, Sitecore

Getting Started template Sitecore 10 While running up.ps1 getting below errors: C:\build\Directory.Build.targets : warning : Unable to load the service index for source https://api.nuget.org/v3/index....
0
votes
1answer
31 views

Getting Started template Sitecore 10- running up.ps1 - failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0

Trying to do local Sitecore 10 setup using Getting Started Template. While running up.ps1 getting error failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0: ...
0
votes
0answers
119 views

Sitecore Docker 10.2 on Windows 11

I am trying to build Sitecore 10.2 for containers on my Windows 11 system. Quite surprised when I got this message: 2017-10.2-20H2: Pulling from sxp/nonproduction/mssql-developer image operating ...
0
votes
1answer
57 views

Cannot find any service with service name 'MSSQLSERVER' on docker-compose build

Has anyone ever run into the error below when running a build for Sitecore 10.1? It used to work fine and now this error pops up. I'm adding SPE and SXA to MSSQL. Again, it just started breaking but ...
0
votes
0answers
30 views

Docker getting started template: You are not authorized to perform the task you are attempting. You may need to be assigned additional permissions

Hi when i tried to run the docker getting started template from Sitecore i got following error Your login is complete. You can close the browser tab now. Login information has been saved. Populating ...
0
votes
2answers
210 views

Sitecore on MAC machine using Docker

Has anyone installed Sitecore on MAC machine using docker? Steps provided by Sitecore is compatible to Windows machine but not MAC. Few of the Frontend developers are comfortable with MAC machine and ...
3
votes
2answers
62 views

Deploy Docker Images to Multiple AKS Environments

I'm creating a CI/CD pipeline, and I'd want to understand how am I going to use the same docker image (assuming it is possible) and deploy it to multiple AKS environments such as QA, STG, and Prod. ...
1
vote
0answers
71 views

Sitecore 10.0 Update 1 CM container Health check error

I am using Sitecore 10 update 1 and XP1 topology. All containers are healthy except CM container. I can see following errors in logs - ERROR Health check Sitecore.XConnect.Client.WebApi....
0
votes
0answers
35 views

Publishing Database Error in Docker Container Environment

In a 10.1.1 upgraded from 9.0 U2 Docker container install, whenever publishing or even rebuilding indexes I get an error. Seems database related, but checked connections and they seem to be setup ...
0
votes
2answers
95 views

Sitecore custom-images from examples, docker-compose build solution command not working

I have cloned Sitecore docker-examples repository and started to go through tutorial of building custom images Building Custom Sitecore images. I noticed that when I use the command docker-compose ...
0
votes
0answers
26 views

Helix Sample ASPCore using Docker

I tried to run the Helix Sample for ASPCore using docker but I get an error that says MsBuild timeout out while trying to get project to project references. The command 'powershell -Command $...
1
vote
1answer
157 views

Creating a custom Solr core in docker using docker

I am trying to create a custom solr index using custom schema with docker container approach. I am able to create a custom index, but I am not able to associate it with the custom schema. I did copy a ...
0
votes
0answers
43 views

Sitecore in container not accessible within Corporate VPN (Global Protect)

Outcome Able to run and access sitecore container within Corporate VPN network (Global Protect) so that we can rollout sitecore docker container practice for all developers. Problem We managed to get ...
0
votes
5answers
2k views

Remote name could not be resolved 'dist.nuget.org'

I"m following the guide on this page below. But I keep getting error below. I'm using Win 10 Enterprise 1809 "Invoke-WebRequest : The remote name could not be resolved: 'dist.nuget.org'&...
0
votes
1answer
66 views

Deploying files to Identity Server Container

I am trying to configure a non-interactive client login in a Sitecore 10 container environment (https://doc.sitecore.com/en/developers/100/developer-tools/configure-a-non-interactive-client-login.html)...
0
votes
0answers
8 views

Cannot open database "Sitecore.Xdb.Collection.ShardMapManager" Login failed for user 'sa' when docker-compose up [duplicate]

I'm trying to set up a Sitecore instance with Docker using the https://github.com/Sitecore/docker-examples/tree/develop/getting-started After init.ps1 the docker-compose up fails with unhealthy ...
2
votes
0answers
542 views

Getting up.ps1 error whilst using the Sitecore 10 Getting Started walkthrough

So I'm trying to follow the Sitecore 10 walkthrough using the getting started template: https://doc.sitecore.com/developers/100/developer-tools/en/walkthrough--using-the-getting-started-template.html ...
0
votes
2answers
125 views

Nodejs not part of docker in Getting Started Template for JSS to work

Nodejs is a pre-requisite for Sitecore 10 JSS and after setting up the solution for JSS with Getting started template https://doc.sitecore.com/developers/100/developer-tools/en/walkthrough--using-the-...
1
vote
1answer
51 views

Error when running "docker-compose build solution" from sitecore 10 docker guide

I'm at this stage of the guide whereby I'm required to build a solution from custom-images directory. After running docker-compose build solution from the directory, it throws the below error at step ...
0
votes
2answers
1k views

ERROR: for traefik Container "c76ca635f085" is unhealthy. Sitecore docker installation Issue

I was trying to setting up Sitecore Helix Example, getting issue during docker-compose ERROR: for traefik Container "c76ca635f085" is unhealthy. looked more about the issue by looking at ...
1
vote
2answers
236 views

Container-based solution build errors with "Could not create SSL/TLS secure channel"

I am doing container-based builds of my Sitecore solution, based on examples provided by Sitecore. However when I attempt to build, I get the following error: RUN Invoke-WebRequest "https://dist....
7
votes
3answers
7k views

ERROR: Container is unhealthy

I have installed Sitecore 10 on Docker on my local machine. Today I am trying to start using following command error message coming on powershell: Command: docker-compose.exe up --detach Error: ERROR:...
4
votes
4answers
2k views

Docker-Compose up -d fails with unhealthy xconnect and cm

I'm having trouble getting a basic xp0 environment set up on my local development machine. When I run docker-compose up it times out on the xconnect healthcheck because of a SQL login error to the ...
0
votes
0answers
166 views

kubernetessitecoreinstallation Exceeded Its Progress Deadline

We have a Sitecore XP1 Kubernetes cluster hosted in Azure using the lighthouse demo solution from Github. We are using Azure DevOps to build and deploy our images to the container registry. We are ...
3
votes
1answer
120 views

Add SPE module to custom Sitecore Docker Image

I am trying to add SPE module to XP0 but getting error as shown in the image and its occurring while building the image. what am I doing wrong ? I have tried SPE 6.2-1809 version as well. SPE_IMAGE: ...
0
votes
0answers
438 views

Sitecore 10 installation through Docker gives error

I am getting an error like this when I am trying to install Sitecore 10 using docker following https://doc.sitecore.com/developers/100/developer-tools/en/walkthrough--using-the-getting-started-...
4
votes
1answer
123 views

Why does my asset image have .dat files instead of .dacpac files?

I have an asset image that was generated/provided to me by a Sitecore team that does not appear to conform with the traditional file structure that I see in the other asset images. Specifically, the ...
0
votes
2answers
200 views

No matching manifest for unknown in the manifest list entries

I've cloned the repository https://github.com/Sitecore/docker-images. Now when I am trying to run one of the images I am getting error message no matching manifest for unknown in the manifest list ...
0
votes
1answer
102 views

Issue browsing CM Sitecore container

I'm having an issue when I try to browse my Sitecore 10.1 CM Container in the browser. The message I get is a 404 error. Investigating a bit more I checked traefik logs and saw lots of errors: *Failed ...
4
votes
4answers
448 views

Sitecore 10 docker containers can't communicate to each other

I've been trying to launch Sitecore 10 setup from docker-compose in docker-examples repository. Compose was failing after spinning first 5 containers: solr, mssql, id, xconnect, cm. After some ...