Questions tagged [experience-editor]

Use for all Sitecore 8+ page editing questions specifically using the Experience Editor.

Filter by
Sorted by
Tagged with
2
votes
1answer
49 views

How to open Experience Editor with Preview mode in a new tab?

The requirement is to open Experience Editor in the Preview mode in a new tab.
0
votes
1answer
37 views

Experience Editor Exception for Some Users

We have a website with a number of sub-sites. Recently the content developers and reviewers on one of the sub-sites have been unable to access the Experience Editor or Preview modes: an exception is ...
0
votes
2answers
57 views

Prompt SPEAK dialog in Experience Editor?

Is it possible to use Sitecore specific prompt dialog in Experience Editor, like this below? If so, can somebody provide an example, please?
1
vote
1answer
41 views

How to debug JavaScript in Experience Editor?

I'm doing changes in Experience Editor JavaScript command file of ribbon button, but I'm not able to find this file in browser (Chrome Dev Tools > Network > JS), so how I can find my file and ...
0
votes
1answer
42 views

Is it possible to disable a rendering after it has been chosen in the Experience Editor?

as the title suggests, I would like to know if it's possible to disable the selection of a specific rendering in the experience editor after it has been chosen. For instance after I have chosen and ...
1
vote
1answer
46 views

Is there a way to use @Editable (Glass-mapper) and an anonymous model in an html input placeholder?

I have an input box and I would like to be able to have the placeholder text XP editor friendly. <input type="text" class="form-control" placeholder="@Editable(x => x....
0
votes
1answer
44 views

Ordering of field data source

I have filter which filters content on a field e.g. 'topic' (art, sport, food). I display this as an horizontal accordion which slides out and the user can select a topic to narrow the search results. ...
1
vote
1answer
59 views

Publish button under Home tab is not visible in Sitecore experience editor

We are using Sitecore 9.1 and SXA. When we try to open any page in the Experience Editor, Publish button is not getting displayed under the Home tab. This is not happening over all the environments.
0
votes
0answers
62 views

How to add if else condition for sitecore experience editor in aspx Layout file

I need to add experience editor condition in the Sitecore aspx layout file. I tried adding this <%if(Sitecore.Context.PageMode.IsExperienceEditor){%> ...
0
votes
2answers
45 views

How to select an item property in a drop list using Sitecore 8.2 and Glassmapper

it's been a while since I've used Sitecore and I'm struggling with an issue. There is a model which is being autogenerated by TDS and uses Glassmapper for its mapping. [SitecoreType(TemplateId=...
0
votes
0answers
27 views

Wrong url of partial design from page from Experience Editor Tab

When I am opening my partial design directly in experience editor it's redirecting to https://sc93.sc/site1/?from=2021-01-01&to=2021-12-31&languages=English where site1 is the virtual folder ...
0
votes
0answers
28 views

Preview mode uses anonymous user despite Preview.AsAnonymous=false [duplicate]

I am on Sitecore 10.0.1 and I have a page that has authentication on it for my custom domain's anonymous account to have read access denied. In Experience Editor, when I click the Preview button, I'm ...
1
vote
2answers
112 views

How to improve load performance in experience editor [duplicate]

When I open page in experience editor it takes 3 to 4 minutes to load the page . Is there any suggestions to improve performance of the page in EE?
0
votes
1answer
105 views

XHTML markup is incorrect near field

I am getting the following error only in Experience Editor : The code associated is : <div class="about-text"> @Html.Sitecore().Field("{B5C0D199-7FFF-4B7A-A158-4D41DCAC81A0}&...
0
votes
1answer
48 views

Experience editor showing home page instead of specific page on refresh

While working in experience editor on certain page and when we refresh the page, the experience editor shows home page instead of that specific page. Now if we refresh the page again, the experience ...
2
votes
1answer
46 views

Sitecore 9.3 Change Select Rendering Dialog size

I am trying to change the default size of the "Select a Rendering" Dialog. it would be ok if I change the size of every dialog box, not just this one. I've tried to override the css, but I ...
0
votes
0answers
29 views

How do I get the preview value of item field values instead of the content editor field value? AKA change the context to preview

I have a button on the Preview ribbon. And when you click the button it generates an html email that marketing can copy into the email system that my company uses. My issue is that ExpandDynamicLinks()...
0
votes
0answers
42 views

Workflow in the Experience Editor - state does not refresh

Using Sitecore 9.3 - just implementing workflow. In the Experience Editor, workflow commands appear in the blue information bar. They are working, but after performing any of these command: Submit, ...
0
votes
0answers
29 views

Sitecore Experience Editor content do not refresh after alternative condition selection [duplicate]

I got a problem on experience editor when you swap between the available condition for a component it doesn't refresh to show the alternative content. You then need to save and refresh to see the ...
0
votes
1answer
50 views

How to make a Custom field to be Editable from Experience Editor in Sitecore 9.0.1

I am using Sitecore 9.0.1 with SXA 1.7. We have a requirement for video component with some extra fields so I have cloned the existing video component and added a custom field for it and I want to ...
0
votes
0answers
27 views

Data is always empty in Sitecore Personalized Experience

In my Sitecore instance, I have added different personalization rules on different components. I want to see the effect of these personalization rules. But in Personalized Experience dialogue, the ...
1
vote
2answers
110 views

Optimization tab is missing from Sitecore Experience Editor Ribbon

I see that this Optimization tab (in screenshot) is missing from my Sitecore Experience Editor Ribbon. I checked and Xdb is enabled and working fine. Can somebody suggest what can be the reason for ...
0
votes
0answers
32 views

Is there a way to add extra identifier class if you're viewing Partial Design (header in my case) on Experience Editor?

I'm currently doing a specific styling for header partial design that will only apply when you viewed it on Experience Editor (EE). I'm aware of the on-page-editor class on body tag but I need extra ...
0
votes
1answer
109 views

A potentially dangerous Request.Path value was detected from the client (:) [closed]

I followed the steps on https://jss.sitecore.com/docs/client-frameworks/getting-started/app-deployment to get my local starter app connected to my local sitecore install. In the nextjs app it works ...
0
votes
0answers
52 views

How to disable content editing to users other than content owners and super admin in Sitecore workflow

We need to disable 'lock and edit' option for authors other than content owner who initiated the workflow. I able to achieve this by changing the below settings in Sitecore.config ...
0
votes
0answers
75 views

Create new item is not appearing in the associated content dialog in experience editor

I am using Sitecore 9.3, sxa and I am having issues with the Create new content option appearing when selecting associated content in the experience editor. This used to work. I have double checked ...
2
votes
2answers
326 views

Rich-Text field in experience editor mode adds unwanted break points in Firefox

When using Firefox for content authoring, when you paste a paragraph of content in your rich text field, it adds unwanted tags at the end. I can replicate this issue on the Vanilla instance of ...
1
vote
0answers
72 views

SXA doesn't recognize font files - how do I include them in my theme?

I have a pretty typical font setup: in my creative-exchange theme folder, I placed some custom font files and I reference my fonts like so: @font-face { font-family: "Graphik"; font-...
1
vote
1answer
81 views

Page in Experience Editor hangs forever with page unresponsive dialogs

We are using Sitecore 8.2. We have a page with Marketo Form which contains Google Recaptcha. We lazyload the scripts and styles on the page. In experience editor, once we scroll down to the form, the ...
0
votes
1answer
127 views

Unpublish an item using Experience Editor Mode in Sitecore

I have a requirement to be able to unpublish an item using experience editor mode in Sitecore. It requires to either unpublish a module as a whole or to unpublish a particular item from that module(as ...
1
vote
1answer
73 views

My Items button in Experience Editor lists items not locked by anyone

I am using Sitecore 8.2. Content Authors are complaining that when they click on My Items in EE and then click on Unlock All in LockedItems Dialog that appears, all items dont get unlocked and some ...
1
vote
0answers
77 views

Removing width and height attributes using JSS <Image/>

I was wondering whether there is a way to suppress rendering the width and height attributes when using the Image component from @sitecore-jss/sitecore-jss-react? Or under the hood, it basically uses ...
0
votes
1answer
120 views

How to apply styles for partial designs in SXA?

I'm creating the header for an SXA site. I created a new header Partial Design, and then in Experience Editor added some stuff from SXA toolbox. So now, how do I apply (my custom) header CSS classes ...
0
votes
1answer
67 views

"Review" tab is missing in Experience Editor but appears in Content Editor

Both on my local and in upstream environments, the "Review" tab is missing in the Experience Editor (even when I'm signed in as an admin): However, the Content Editor does show the "...
0
votes
1answer
52 views

Unable to preview component variant

We're looking to set up an A/B test for a JSS component from the Experience Editor. We made a component variant that uses a different data source item. We are unable to preview the component variant. ...
0
votes
1answer
64 views

Shared/Final Layout switch/toggle button not available or visible

I'm using Sitecore 9.2. We have an issue where the shared/final layout button is available for some roles and not others in Experience Editor's Presentation Ribbon. When I access a page with my admin ...
3
votes
1answer
204 views

How to create button at EE and run powershell script

I need to add a custom button for EE and run a script if the user clicks on the button. basically, I know how to create a button at the core database at /sitecore/content/Applications/WebEdit/Ribbons/...
-2
votes
1answer
37 views

Adding Edit frames while following Helix Guidelines

I want to create a TDS package to include the edit frames related to my components and I want to make sure that I am following the helix guidelines. The edit frames are added in the core database but ...
3
votes
1answer
227 views

Customize 'Select a Rendering' window

How can I add custom button on Select a Rendering dialog which comes up after clicking on Add here in Experience Editor, as shown below? When click on this newly added button, below screen should ...
0
votes
1answer
138 views

Experience editor "view" tab is missing

I am experiencing issue with Sitecore 9.2. When I open Experience Editor: sitelocation/?sc_mode=edit Ribbon tab "VIEW" is missing and I am not able to navigate to another page using ...
1
vote
1answer
136 views

Null refrence exception for RenderingExtensions.IsSerializable

Sitecore 9.3 JSS What is happening: Many a time, we are getting 500 from the layout service. In the log we have the following entry: ERROR Exception during Layout Service RenderItem (configuration: ...
0
votes
0answers
154 views

Experience editor does not show the empty placeholder before saving/refreshing the page

We are using Sitecore 9.3 in our application and facing issue in experience editor. When we add any component in empty placeholder in experience editor and then remove the component, we do not see the ...
0
votes
1answer
75 views

Add here buttons in Experience Editor don't match placeholder

I'm having some oddball things happening with my sitecore environment's experience editor. We have a pretty basic layout - one single placeholder named 'content', where we can add multiple components/...
0
votes
1answer
51 views

Overriding styles of email templates for Sitecore Exm

I need to use Sitecore email templates after overriding its styles to be of different theme colors. There is a place holder named styles override that is not accepting any renderings Also, I find ...
0
votes
2answers
536 views

Sitecore experience editor site does not resolve to sc_site

When trying to preview an item the resolved site and context does not belong to the correct site chosen in our multisite setup. Rendering.SiteResolving is true. Rendering.SiteResolvingMatchCurrentSite ...
0
votes
1answer
76 views

Experience Editor Permissions - How to edit rendering parameters

I have a Sitecore 9.3 instance. I have create a role for my users. It is a member of the following roles: Analytics Management Reporting Analytics Content Profiling Analytics Maintaining Analytics ...
0
votes
0answers
113 views

Sitecore JSS Personalization simple display rule not working

We are using Sitecore 9.1 with JSS and have a fully functional site running using Angular -- all working great. Now, we would like to add personalization to our site. To do so as a simple starting ...
2
votes
0answers
96 views

A rendering error occurred: Cannot read property 'fields' of undefined

Trying to add RouteType item (as provided in samples on creating a new JSS app). Once I add in experience editor, it appears fine like below But as soon as I click save, I got below error message. ...
0
votes
1answer
358 views

Could not create instance of type: Glass.Mapper.Sc.Pipelines.GetChromeData.EditFrameBuilder

Sitecore 9.3 We upgraded from Sitecore 8.2.3 by installing vanilla 9.3 on a server and applying our update to it. When I try to view any page in experience editor I get the error Error Rendering View: ...
0
votes
0answers
42 views

ERROR MediaRequestProtection: An invalid/missing hash value was encountered. The expected hash value: [duplicate]

For all uses of MediaManager I have code like: string mediaItem = MediaManager.GetMediaUrl(sourceItem, mediaUrlOptions); itemUrl = HashingUtils.ProtectAssetUrl(mediaItem); I do have setting set: ...

1
2 3 4 5
8