Questions tagged [experience-editor]

Use for all Sitecore 8+ page editing questions specifically using the Experience Editor.

Filter by
Sorted by
Tagged with
0 votes
0 answers
9 views

Error Rendering Sitecore.JavaScriptServices.ViewEngine.Presentation.JsLayoutRenderer when using HttpRendering to SSR Angular App in docker [closed]

Currently, I have an SSR app and CM hosted in docker on the same network. When I try to open the Experience Editor I an error saying the Json cannot be parsed. When I load my SSR url directly it ...
2 votes
1 answer
36 views

Experience Editor / preview mode throws error when viewing branch template items

I'm working on a SC 10.2 JSS site. On previous MVC projects I was always able to enter Experience Editor / Preview mode while building branch templates for pages. That is, the items such as /sitecore/...
0 votes
0 answers
35 views

Sitecore Select Media return empty in Experience Editor - Multisite SXA

We have recently upgraded the Site from v9.2 to 10.2. We have maintained multisite with SXA. In the old Site, we used Azure Search and now converted it into Solr search. After integrating all the ...
0 votes
1 answer
37 views

Images and contents don't show when a Data Source item is cloned

I am adding a rendering in Experience Editor and when it asks for a datasource, I am cloning a datasource item within that pop up and the rendering is using the cloned datasource item. But when I ...
0 votes
1 answer
35 views

Sitecore Form from Experience Editor [closed]

Can someone please tell me if It is possible to add Sitecore forms from in Experience Editor ?
2 votes
2 answers
118 views

Sitecore Experience Editor does not work for the fields rendering inside foreach loop

Trying to make a component experience editable. However, having some issues with Fields those are getting rendered through loop. Any suggestion is really appreciated.
2 votes
1 answer
79 views

Incorrect datasource location being displaying in Experience Editor while adding new component

I am having an issue regarding datasource location while adding a component in experience editor. The component datasource location is set to a particular datasource folder item(/sitecore/content/Site ...
0 votes
1 answer
122 views

Allow CORS request from CM to Rendering host

Related to Missing fonts when previewing Next.js app in Experience Editor. I've got the Rendering container with SITECORE_API_HOST set to CD. In CM Experience Editor I see some CORS errors caused by ...
0 votes
2 answers
132 views

making image editable in experience editor in sitecore jss with nextjs

I'm using Sitecore 10.2 in my local as headless and nextjs for FrontEnd. I'm able to open the home page on the experience editor and able to update content on Text/RichText html elements. I'm using ...
0 votes
1 answer
112 views

Editing content on Experience Editor on master db and fetch data from web db for Sitecore JSS with NextJS

I'm using Sitecore 10.2 in my local as headless and nextjs for FrontEnd. I'm able to open the home page on the experience editor and can update content. in Sitecore JSS with next js, we dont need to ...
2 votes
1 answer
82 views

Missing fonts when previewing Next.js app in Experience Editor

I've got a Next.js-based app that uses custom fonts. On the Rendering host the fonts are accessible via the following url: https://www.myapp.localhost/_next/static/media/lato-latin-400-normal.b7ffde23....
2 votes
2 answers
97 views

Fields not editable in Sitecore Experience Editor when using GraphQL

I'm using Sitecore 10.2 in my local as headless and nextjs for FrontEnd. I'm able to open the home page on the experience editor and edit fields as well when I use Layout service to fetch data on ...
0 votes
1 answer
106 views

React/JSS Components and Experience editor compatibillity

Is it possible to have a full editing experience within Experience Editor with components that don't use the built-in @sitecore/sitecore-jss-nextjs Fields and Types? For example, I have a component ...
1 vote
3 answers
68 views

Broken local environments - media library search, experience editor, can't rebuild index / indices

Three local Sitecore environments have several core functionalities that don't work as expected despite having little or no recent changes. Media library search fails giving the error message: "...
  • 157
2 votes
3 answers
67 views

Get Renderings for page currently being edited

I'm trying to get the renderings of the current item being edited. So, when components are added to a placeholder in the Experience Editor, I want to be able to get those renderings. If I use Context....
2 votes
1 answer
93 views

Experience Editor current chrome is null, crashes editor when referencing chrome.parent

Having an odd issue in Experience Editor (Sitecore 10.1.2, containers). Intermittently, when adding a new component from the ribbon, EE will not respond and print the following to console: Uncaught ...
2 votes
1 answer
52 views

Sitecore editing an item or using experience editor returns a 403 "Access Denied"

We are currently upgrading from Sitecore 10.1 XP to 10.2 XM. This issue didn't occur on 10.1.XP. But in 10.2 XM, When accessing or editing an item using the experience editor we are receiving a 403 &...
  • 21
1 vote
1 answer
87 views

Cd url is going to 404

I have downloaded Sitecore Next JS containers setup and installed XP1 in our local instance. But the default CD url is going to 404. The CM Sitecore url including Experience Editor & Preview and ...
1 vote
0 answers
54 views

Custom Ribbon Button Error: Failed to call scGetFrameValue in IFrame tag

I'm creating some custom ribbon buttons for the experience editor in version 10.1. I have set them up using a combination of the below guides... https://sitecorebaek.wordpress.com/tag/speak/ https://...
  • 218
1 vote
0 answers
46 views

Experience editor ribbon disappear

When I open a site in experience editor mode, I see the editor ribbon, but after I navigate on the site, the ribbon disappears. Everything is fine in the local environment, but the error occurs in ...
0 votes
0 answers
26 views

Using Scriban Template with Sitecore 10.2 XM License (Part of Downgrade from XC to XM)

Anyone has any information about the impacts on Scriban Templates used to create custom components for normal sites, not SXA Shop Fronts , if we downgrade from Sitecore 9.3 XC to Sitecore 10.2 XM Our ...
0 votes
0 answers
38 views

When uploading large video file Sitecore becomes unresponsive

when is uploading large video file Sitecore become unresponsive, and upload takes long time, but never finishes.
1 vote
1 answer
173 views

The remote name could not be resolved "rendering" error in experience editor

I am using Sitecore 10.2 and did the local setup by following the below link-- https://doc.sitecore.com/xp/en/developers/hd/200/sitecore-headless-development/walkthrough--setting-up-a-development-...
0 votes
1 answer
68 views

Experience Editor error: The item "/sitecore/content/Applications/WebEdit/WebEdit Texts" was not found. It may have been deleted by another user

When I am trying to open pages which have Image in the experience editor the Image fails to render and I am getting the following error in Experience Editor, The item "/sitecore/content/...
0 votes
1 answer
87 views

Rendering variants for 'Page Content' SXA rendering not showing

I have added a few Rendering Variants for the SXA rendering Page Content (SS below) But, when I try to use this rendering on the page from the Experience Editor the dropdown for the Rendering Variant ...
0 votes
1 answer
92 views

How to add custom ribbon button in Experience Editor

I am currently using a custom Ribbon Button which has a command attached to it in the Content editor. I want to create the same ribbon button in experience editor mode and use the same command.
1 vote
1 answer
181 views

Headless jss-render endpoint failing. Missing environment variable

Whenever I try to use Experience Editor towards my headless (dotnet) rendering host I get the following error: Connection to your rendering host failed with a Not Found error. Ensure the POST endpoint ...
3 votes
1 answer
92 views

Using Edit Frames Breaks Rendering Parameters (Edit Component Properties)

I have a question or maybe a misunderstanding in regards to Edit Frames. Some of my renderings use rendering parameters templates that work well when I choose Edit Component Properties in Experience ...
  • 61
2 votes
1 answer
196 views

Failed to find ID. Ensure that you have an ID property on your model error in Sitecore Experience editor

I have upgraded my Sitecore instance instance from Sitecore 8.2 to Sitecore 9.3 I am getting below errors in experience editor mode but in normal mode component is not showing because we added error ...
1 vote
1 answer
94 views

Experience Explorer not showing personalization

Having an intermittent issue with Experience Explorer not showing personalizations on a standalone Sitecore 10.2 local dev instance. It's mostly not working, but has worked twice in the last two days ...
  • 57
0 votes
0 answers
75 views

Add a message in experience editor if datasource is not selected for a component in toolbox SXA

I need to add a message stating "Select the data source" in Experience Editor programmatically for Content Authors when the data source is null or the model is empty. I'm using the SXA ...
  • 45
0 votes
1 answer
307 views

Sitecore JSS next.js headless Experience Editor not working in html mode

I'm facing the issue that Experience Editor is loading with components, ribbon and all kind of stuff. Components are selectable but no interaction in ribbon is working whenever I would expect some ...
  • 171
0 votes
1 answer
65 views

A non-interactive client login to Experience Editor (Sitecore 9.3)

I am writing a service tool where I need to invoke a web request to Experience Editor page from command line. I need to authorize the request with Sitecore user. How can I do this? I found some ...
0 votes
0 answers
22 views

Disable the checking of custom Role Provider in Experience Editor

We have our own RoleProvider for our users on our website. I would like to open a public page from Experience Editor but it just redirects me to our own login. How can I disable the checking of our ...
0 votes
1 answer
89 views

Unable to make Visual studio model fields editable in experience editor for Sitecore SXA

I'm using a custom Sitecore SXA controller rendering for the first time with Visual Studio and I want to make the model fields in the .cshtml view file editable in Sitecore Experience editor. Is there ...
  • 45
0 votes
1 answer
44 views

Field guids shown in Edit Frame instead of edit button

We can see a list of field guids on Edit Frame on other environments to local dev like this: All is working fine locally: Image is not available in iconcache: Looks like the problem is only with ...
0 votes
2 answers
179 views

How to show "No Text Here" from Rich Text Editor in Experience Editor?

I am trying to show the [No Text Here] to Content Editors when there is not a value in that field (for example name of the field "Text") in Experience Editor so that they can edit the text ...
  • 349
2 votes
1 answer
67 views

Disabling the Usage button that show associated content used number on the experience editor

We have a shared datasource item that has been used many times on a component across the site. When click the component on the experience editor, the browser freezes. Is there anyway to disable the &...
0 votes
0 answers
89 views

How to trigger CSS or JavaScript events in Experience Editor?

Is there any way for me to trigger the CSS or JavaScript onClick events in Experience Editor? I have hamburger menu which is not the basic toggle rendering from the Toolbox beacuse I wanted to make my ...
  • 349
1 vote
0 answers
63 views

Sitecore Connect for Content Hub Culture is required for culture sensitive properties

I am running Sitecore Connect for Content Hub in my local instance of Sitecore 10.2. I am currently working through creating an action in Content Hub that sends my custom content from Content Hub to ...
1 vote
3 answers
137 views

How to fix the bug with header set as position fixed in Sitecore 9.3?

How to fix the problem of having the navbar as position: fixed in Sitecore 9.3. I saw some solutions on the blogs, but it only fixes the issue on the Sitecore 8 versions. Basically when I open the ...
  • 349
0 votes
0 answers
32 views

Custom Experience Editor panel

I'd like to extend the Experience Editor ribbon by adding a custom panel that should display some informational text about the item that is currently being edited. It is supposed to be very simple, ...
  • 1,801
1 vote
1 answer
32 views

Select A Rendering Not Recognizing Allowed Controls From Placeholder after App Pool Recycle

I'm experiencing an issue in Sitecore 9.0.2, Lucene index, and 10.2, Solr index, where some, but not all, of our placeholders in Experience Editor are not recognizing the renderings inside the Allowed ...
  • 21
0 votes
0 answers
132 views

Sitecore Save Check Revision Custom processor

Using Sitecore 10 Experience editor save is not working. So i got a custom processor to use instead of the default one from sitecore support. I created a class and added the processor and also a patch ...
0 votes
0 answers
29 views

Experience editor does not save changes in sitecore 10 [duplicate]

Experience editor throws following errors in one page, it does not allow to edit the fields in other pages, after editing, when clicking on save a pop up with "Changes you made may not be saved.&...
  • 1
0 votes
1 answer
257 views

Editing fields in Experience Editor not working

For carousel components, when hovering over some text fields to edit, it does not show the cursor to edit. All other component fields are editable except for this carousel field. Using Sitecore 10. ...
1 vote
1 answer
85 views

How to get current page item inside uiReturnFieldEditorValues pipeline

I have an EditFrame on a component and I need to make some changes on some fields, and it depends on some factors. I catch the events when the edit frame fields are saved like on this blogpost: https:/...
0 votes
1 answer
117 views

Rendering video control with Glass mapper and Experience Editor support

Hi, I am trying to render a video using <video> tag and it expects a url to video file. Looks very straight forward this way but can anyone suggest how I can provide Experience Editor support ...
0 votes
3 answers
126 views

Context.PageMode is not working in Experience editor

When I load the page in Experience Editor for the first time, I am able to get Context.pagemode.IsExperienceEditor as true. We have a few ajax begin forms on the page. When I call any method in the ...
0 votes
0 answers
37 views

Ajax begin form unobstrusive.js not working in Experience Editor

We are using Ajax Begin form in one of our page for post action. This is working fine normally. But when I am on Experience Editor unobstrucive.js is not working properly and the result is loaded in ...

1
2 3 4 5
9