Questions tagged [experience-editor]

Use for all Sitecore 8+ page editing questions specifically using the Experience Editor.

Filter by
Sorted by
Tagged with
11
votes
4answers
3k views

Copy final layout to shared layout

Our content authors, makes a lot of mistake when whey work in Experience Editor. Quite often they do some changes on final layout, but expect to have it on shared layout. Is is any tool exist that ...
5
votes
4answers
648 views

Datasource Location not working as expected

I created a rendering for my form and linked the datasource location to sitecore/forms (which should be correct). The mysterious thing about this is that when I select my rendering in the experience ...
11
votes
2answers
4k views

What Role or Security Permission is required to edit the Placeholder and Datasource fields of a component?

We are setting up permission for users of our site, and have assigned our users to the roles sitecore\Sitecore Client Authoring and sitecore\Sitecore Client Designing. However this does not allow the ...
6
votes
1answer
207 views

Experience Editor Yellow Screen After Timeout

If user times out in Experience Editor, it fails ungracefully with a yellow screen on refresh. This happens even if user subsequently re-logs into Sitecore. We are considering increasing the timeout,...
14
votes
2answers
2k views

Editing Content in Experience Editor in Multi-site configuration

We have a multi-site setup and have the following sites defined in config: <sites> <site name="mysite1" patch:before="*[@name='website']" rootPath="/sitecore/content/mysite1" startItem="...
7
votes
2answers
1k views

Sitecore 8.0 Preview Mode not rendering all the way

The preview mode loads the page, but it has the SPEAK square just spinning over the top of it with an server error in '/' Application at the top where the ribbon is suppose to be. If I inspect the ...
5
votes
1answer
3k views

Sitecore MVC - Edit Frame for treelist field

We are implementing editframe in sitecore MVC to make treelist field editable (List of address) in experience editor. We have created the Edit button for field in sitecore core DB and add the field ...
1
vote
1answer
224 views

Placeholders generated by partial design are behaving differently

Environment: Sitecore 9.0.2 + SXA 1.7.1 What I have done: I created a partial design, say PartialD1. In the 'main' placeholder of the PartialD1, i added a column splitter generating 2 placeholders '...
7
votes
2answers
2k views

How do I add a button to the Experience Editor Ribbon?

I would like to add a button to the Experience Editor ribbon that will open a modal or new window with a set of fields from the context item. I had some custom code to do this with the old Sheer UI ...
6
votes
2answers
680 views

Is it possible to limit Renderings so they can only be placed once on a page?

I'm using Sitecore 8.1 rev. 151207 - And I have that rendering which only should be placed once on a page. Is it possible to limit that in terms of letting the user not add another one of the same ...
3
votes
1answer
62 views

Get clicked version details in the Experience editor through programming in Sitecore SXA?

I want to fetch clicked version details in the Experience editor through programming. I tried override the OnLoad method of the GalleryVersionsForm class from the namespace Sitecore.Shell.Applications....
1
vote
1answer
98 views

Make link to experience editor in launchpad different for different users

We have or going to have numerous users who will be able to access the site at different levels of the content tree, but the current link to the experience editor is just https://[domain]/?sc_mode=...
1
vote
1answer
1k views

Inline editing of rendering parameters in Experience Editor

I'm investigating multiple solutions for being able to dynamically build a page using multiple blocks of HTML, and other non-structural content. I'm trying to optimise the editing experience and ...
7
votes
2answers
2k views

Automatically set datasource when adding a rendering to a page

My goal is to automatically set the datasource of a rendering when an certain rendering is added to the page in the Experience Editor. Since the datasource item is created when the user adds a ...
12
votes
2answers
1k views

Force shared layout in experience editor

I know there's a button in experience editor to decide whether to use the shared layout or the final layout when adding renderings (and the default is final layout). Is there a setting that forces ...
6
votes
3answers
873 views

DatasourceUsagesCount request slowing down Experience Editor

I am using Sitecore 8.2. The Experience Editor has a feature called as "Usage" which appears in the widget that shows when we select a component/rendering. The purpose of the usage functionality is to ...
5
votes
2answers
722 views

Set Default Value of Ribbon Checkbox

I recently discovered a checkbox on the "View" ribbon of the Experience Editor in Sitecore 8.1. This checkbox is used to display validation errors, but it is not checked by default. How would I go ...
5
votes
2answers
2k views

Improving the performance of MyItems Count in Sitecore 8.1

I am trying to increase the performance of Experience Editor and one of the slowest calls is to get the number of locked items. It used to be possible to disabled this in older versions of Sitecore (...
15
votes
1answer
6k views

Editable Sitecore fields with Glass

Folks I'm trying to do something basic here which is have a general link and an image field as editable in experience editor on my view using Glass. my end goal is to have two editable fields which ...
10
votes
1answer
3k views

Component not showing as an option to add to a placeholder?

All my other components display as options to add when I click on my main placeholder in Experience Editor. However one component is not shown in the list and I can't see why. I've added it to the ...
9
votes
1answer
453 views

What is the recommended pattern for dynamic paragraph systems in Sitecore?

It's not at all uncommon to have an article page designed that is intended to be dynamically formed from a number of components: <rich text> <left image with additional comment> <rich ...
7
votes
0answers
699 views

Bootstrap 3 accordion not opening in experience editor

I have a bootstrap 3 accordion on my Sitcore 8.2 update 5 page, see full markup in bottom. This accordion works as expected, however the accordion panels do not expand any more when the page is opened ...
5
votes
3answers
1k views

Why placeholder settings when you can bypass them?

In sitecore documentation it says "If you do not create a placeholder settings item, you will still be able to bind components to placeholders using the Presentation Details dialog. ". So why would ...
4
votes
1answer
969 views

Experience Editor Ribbon 'siteName' error

I have deployed a simple Sitecore 9 website in Azure PaaS. There's nothing so special about the code as it is only a newsletter sign up with Personalization. It works well, I can personalized my ...
4
votes
2answers
1k views

How to make Experience Editor placeholders editable without placeholder settings?

Normally, we need to define placeholders with allowed renderings in placeholder settings, to allow Experience Editor to support. What is the way to configure placeholders editable in the Experience ...
3
votes
1answer
404 views

Speak Disable Button In Experience Editor Mode

I have made a custom /sitecore/templates/System/Layout/Renderings/View renderingcalled UpdateButton. I would like to only enable this for certain templates. Currently I am completely hiding it when on ...
2
votes
1answer
1k views

Experience Editor Editing is disabled

I have done something to my environment - In the experience editor, "Editing" and "Designing" check boxes are greyed out, so I cant actually edit anything. Is ExperienceEditor.Enabled a setting ...
12
votes
1answer
1k views

Experience Editor changes force refresh

When in Experience Editor making changes to some fields, such as a multilist that could control a rendering of items to show, do not reflect on the page until it is saved. This can be confusing and ...
9
votes
3answers
2k views

Error in Experience Editor when Saving Rendering with Image Field Rendering Parameter

I have a rendering that has a custom rendering parameters template. That rendering parameters template contains an image field. When I add the component to the page, add an image to the field, and ...
9
votes
1answer
505 views

Personalization conditions switching doesn`t work in Experience Editor (9.1.0, Initial Release)

We personalize one particular rendering on page item. There are some different conditions that have different datasource item for this rendering. Personalization works good on website - datasource is ...
7
votes
2answers
922 views

Personalization using a Campaign not working

I have created a Test Campaign. I am now trying to Personalize a home page component using the Campaign trigger. However the Personalization rule is not firing. I can see the campaign has been ...
7
votes
2answers
645 views

“Replace Rendering” in Experience Editor disabled

We have renderings which have compatible renderings configured. The button in the Experience Editor (Sitecore 8.1 Update-3) shows up on our local development environments and renderings can be ...
7
votes
1answer
858 views

Item not found when saving page in Experience Editor

I have a strange situation where I get a 'Item not found' on postback in Experience Editor when I edit an page. The culprit is a controller rendering which has a line of code in to get the current ...
6
votes
1answer
836 views

Sitecore Experience Editor Slow on Servers?

Does anyone have any ideas why Experience Editor would take 5-6 seconds to display a component I add when running on development or staging servers vs less than 2 seconds when running Sitecore and the ...
6
votes
1answer
780 views

Add custom attributes to the General Link field and have it work in Experience Editor and Content Editor

I would like to add a couple of custom fields for Dataattributes on links and to add in NoFollow for the link in Sitecore 8.2 update 2 and above. So NoFollow would be a check box and Dataattributes ...
4
votes
2answers
592 views

Sitecore 9.0.1 Datepicker displaying wrong format

I'm facing DateTime format issue on the SPEAK DateTime Picker. Basically, when the user is in the Content Editor, the format displays ok (mm/dd/yyyy). But when the user opens the Experience Editor, ...
3
votes
2answers
941 views

Strip HTML when pasting into single-line text field

If someone copies HTML from another site (like a title) and pastes it into a single-line text field, is there any way to automatically strip the HTML out? I know with rich text fields there are paste ...
3
votes
1answer
2k views

How to use Glass Mapper's BeginEditFrame(string buttons, string dataSource, string title)

I've created my own custom experience button to edit some responsive images for a logo in my header and I added the button to the rendering. It works as expected and I am not having any problems with ...
3
votes
2answers
1k views

Experience Editor Server Error 8.1 [closed]

I am trying to use Experience Editor but it keeps throwing server error in the ribbon: I can see the page loads under the bar and progress indicator keeps going on. Here is the error in detail: I ...
3
votes
2answers
248 views

Integrated GraphQL is not executed in Experience Editor

We use Sitecore 9.2, SXA 1.9 + JSS 12.0. As for the JSS, we are using Sitecore First approach. Some JSON renderings have integrated GraphQL queries. The Jss site was created trough JSS Tenant/JSS ...
2
votes
1answer
198 views

SItecore 9.3 - Horizon - Page keeps on reloading issue

We have an SXA site hosted in Sitecore 9.3, website browsing works fine. When we installed Horizon on Sitecore 9.3 and started it to edit a page, but the page keeps on reloading, the horizon page ...
2
votes
0answers
515 views

CreateCyclePreventer throwing NullReferenceException with final rendering details

I'm running into a weird issue with Sitecore 8.2 Update-6 where after I modify an item (with MVC controls) using the Sitecore Experience Editor I start getting NullReferenceExceptions when I view the ...
2
votes
1answer
319 views

Glassmapper | Cannot save a class that does not contain a property that represents the item ID

Environment: Sitecore 9.0.2 + Glass Mapper I have a class like this: public class Sample { public Glass.Mapper.Sc.Fields.Image Logo { get; set; } public string Destination_Name { get; set; }...
1
vote
1answer
1k views

Custom Experience Editor Buttons - no fields appear

I have a rendering based on a data source. One of the fields on the data source is a DropLink. I added a Custom Experience Editor Button to the rendering to edit the DropLink. The field I want to edit ...