Questions tagged [experience-editor]

Use for all Sitecore 8+ page editing questions specifically using the Experience Editor.

92 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
10
votes
1answer
241 views

A rendering snippets in Web Forms

I would like to add a rendering that also has some other rendering added to its own place holder ahead of time. An example is to add a striped rendering and place a 1 column grid rendering in the ...
7
votes
0answers
701 views

Bootstrap 3 accordion not opening in experience editor

I have a bootstrap 3 accordion on my Sitcore 8.2 update 5 page, see full markup in bottom. This accordion works as expected, however the accordion panels do not expand any more when the page is opened ...
6
votes
0answers
158 views

How to create a custom button for experience editor that creates a new rendering?

Right now I'm in the process of expanding our experience editor functionality. I've followed these articles for adding chrome around renderings and placeholders, and now I'm trying to extend this ...
6
votes
0answers
382 views

Component disappears when another component is added and the page was not saved

We're having an issue where a user adds a component to a page, and then adds another component to the first component. But when they add the second component the page reloads and since the content ...
5
votes
1answer
673 views

Could not find the rendering in the HTML loaded from server. Sitecore experience editor issue

We recently moved from Sitecore 7.2 to 9.0.2 and since then we have started getting following error when we try to add a control(by clicking "Add here") with datasource from the experience editor. ...
5
votes
0answers
123 views

Experience Editor overwriting items edited elsewhere

I have an interesting problem. On my home page I have multiple controls that link to items (articles). The controls are in the Final Rendering of the home page and the data source for the control is ...
5
votes
0answers
368 views

Gzip causing an error in the experience editor

Just set up a new machine, so... I have a site running locally Sitecore 8.1.160519, The site has GZip enabled. I see the appropriate header if I just browse to the site. But if I go to the ...
4
votes
0answers
121 views

Using Experience Editor on a multisite solution. Custom linkProvider to solve problems?

We have multiple sites in sitecore but all are edited by the same editors and they want to be able to edit it all in one place. The majority of our editors use EE. Problems: When you follow a link (...
4
votes
0answers
228 views

Experience Editor - “” is not a valid number

I am currently facing an error with the Experience Editor and integer field. So I have a Datasource template that has a field of integer type (without validation - meaning not required). Through the ...
4
votes
0answers
47 views

Switch Renderings In Placeholder

Is it possible to build a command button that swaps all renderings in one placeholder with another? I'd expect this button to show up when the placeholder itself is selected but I'm not sure how I ...
3
votes
1answer
402 views

Publishing Related Items from Experience editor

We are using Sitecore 9.0.2 and SXA and we are allowing Authors to create and publish pages using Experience editor. A component takes Datasource of "Datasource-Folder" with X numbers of "Datasource-...
3
votes
0answers
324 views

Caching Experience Editor JS and CSS

As part of the performance improvements I've been working on for Experience Editor in Sitecore 8.1 I wanted to cache the Ribbon files. I followed the guidance here to put them into the browser cache ...
3
votes
0answers
163 views

Sitecore components added in random order

Our setup is like this - layout left side placeholder left component 1 left component 2 left component 3 right side placeholder component 2 component 3 component 1 (added onto standard values) ...
2
votes
1answer
872 views

Experience Editor issue after upgrading to Sitecore 9.3

After upgrading to Sitecore 9.3 getting below error in Experience Editor:- sitecore Method not found: 'Void Sitecore.Pipelines.GetChromeData.GetChromeDataProcessor We are using Glass Mapper
2
votes
0answers
83 views

“Database name is null or empty” in experience editor once I click on language version button

We are getting the error once we click on version and the language. This is happening only the first time. The second time I am clicking it is working fine. error is mentioned herewith image Database ...
2
votes
0answers
90 views

Run Validation Item on Save in Experience Editor

I have created a custom Rule in /sitecore/system/Settings/Validation Rules/Item Rules When I press the validate button, I can see the Rule and its result, so far so good. But the Validation Button is ...
2
votes
0answers
516 views

CreateCyclePreventer throwing NullReferenceException with final rendering details

I'm running into a weird issue with Sitecore 8.2 Update-6 where after I modify an item (with MVC controls) using the Sitecore Experience Editor I start getting NullReferenceExceptions when I view the ...
2
votes
0answers
203 views

Sitecore experience editor throws error when saving datasource number field

I've created a config item with a number field (without validation rules), I've added a rendering to my page with this config as datasource. When I edit the item in the Content Editor, everything is ...
2
votes
0answers
203 views

Combine Default Experience Editor Buttons and Custom Buttons

When rendering an image field inside of a link field the experience editor buttons for the two fields collapse into one toolbar. Is it possible to do something similar with an edit frame rendered ...
1
vote
0answers
29 views

SXA doesn't recognize font files - how do I include them in my theme?

I have a pretty typical font setup: in my creative-exchange theme folder, I placed some custom font files and I reference my fonts like so: @font-face { font-family: "Graphik"; font-...
1
vote
0answers
61 views

A rendering error occurred: Cannot read property 'fields' of undefined

Trying to add RouteType item (as provided in samples on creating a new JSS app). Once I add in experience editor, it appears fine like below But as soon as I click save, I got below error message. ...
1
vote
0answers
80 views

How to hide rendering component in Experience Editor in Sitecore SXA?

I have a page with 3 datasource rendering. 1st datasource rendering has 3 number version, 2nd datasource rendering has 2 number version, 3rd datasource rendering has 1 number version I am hiding 3rd ...
1
vote
0answers
29 views

How can a previously removed component be fully restored from standard values?

When a component coming from a template has been removed from a page item, it can be restored by resetting layouts from standard values. However, if changes are made to the component at the template ...
1
vote
0answers
47 views

Post condition failed when trying to open personalization

We have a Tabs rendering which is a composite, when I clicked the personalization button on the rendering's toolbar it threw an exception: [InvalidOperationException: Post condition failed] ...
1
vote
0answers
26 views

Field Compatibility in Experience Editor

I have a Custom Time field that inherits the the IContentField of namespace Sitecore.Shell.Applications.ContentEditor. I am trying to edit this field in Experience Editor using Edit Frame. But the ...
1
vote
0answers
26 views

Explore mode GeoIP data not available

In Sitecore Experience Editor Explore view I am facing one issue in which I am not getting any country list in GeoIP section under Visitor information. Below is the screenshot of my page. Please ...
1
vote
0answers
24 views

Field of “CustomType” Not working properly in Experience Editor

I have a date field which is of "CustomType". It has a validation in the 'Validation' field with this Regex ^(?!\s*$).+ I need to edit this field in Item through Experience Editor. I have created a ...
1
vote
0answers
62 views

Create new content missing when adding a component in experience editor

I'm using Sitecore 9.3 with JSS 13. When I try to use the add here and select one of my components I get the Select the associated Content dialog box. This box is missing the create new content ...
1
vote
0answers
132 views

Experience Editor issue - Server Error in '/' Application

We are using Sitecore 9.3 version, Sitecore Experience Editor Ribbon not loading- and showing Server Error in Application error. Note: We run the db upgrade scripts on sitecore 8.2 update 3 ...
1
vote
2answers
164 views

Insert Options for a child item via the experience editor

We build composable pages where the page has a child item folder that contains the details for how the page is to render (and the appropriate content) I'd like to make the Experience Editor give the ...
1
vote
0answers
325 views

Experience Editor - An error occurred. [Log message: Value cannot be null. Parameter name: source]

I have a new Sitecore 9 vanilla install. I created a JSS site and entered the connected mode. Immediately I'm getting an error in the Experience Editor. On-screen I see: An error occurred. [Log ...
1
vote
0answers
60 views

Experience Editor disabled on local machine

I am facing a weird issue where experience editor (sitecore 9) is not getting enabled on my local system while it works fine on all the dev environment as well as other developers machine. I have ...
1
vote
0answers
105 views

How to programmatically refresh a Sitecore screen?

I have an Event firing on item:saved, that ends up modifying some fields on the same item being saved. This of course is not immediately reflected on the Sitecore interface, causing a misleading ...
1
vote
0answers
320 views

Creating footer and header components in SXA using Page and Partial Designs from Shared site

I am trying to create a footer component in SXA 1.8, Sitecore 9.0.2. The current solution setup consists of one tenant, one shared site ('Site A') and multiple regular (not shared) sites (let's call ...
1
vote
0answers
163 views

Some files/functionality missing in one of the Sitecore 9 setup

I have sitecore 9 installed on a couple of environments. On just 1 of the environments, the ribbon icons are visible in the XP editor. In the other environments, no icons are appearing in the ribbon ...
1
vote
0answers
141 views

Lock the item in Experience Editor

We have upgraded from Sitecore 6.6 to Sitecore 8.2 We are getting a weird issue when user opens a page in the Experience Editor and locks page to edit it. We expected to get edit options but we are ...
1
vote
0answers
83 views

Getting a HTTP 500 upon opening the Experience Editor in Sitecore 8.1

On a long running site a certain user always gets an HTTP 500 when opening the Experience Editor in Sitecore 8.1. This also persists if I create a new user with the same roles, leading me to believe ...
1
vote
0answers
28 views

Getting ClientSide Piplines to fire

I am on Sitecore.NET 8.0 (rev. 160115) January 15, 2016 .NET Framework 4.0.30319.42000. I am trying to follow these instructions on how to fix a fixed position navigation So, I created the Js file &...
1
vote
0answers
313 views

403 Forbidden error on saving form after opening experience editor

A few days ago I posted this question:- 403 Forbidden when saving form I was facing an issue where whenever I tried to save the form,I would get the 403 forbidden error in the console. After ...
1
vote
0answers
314 views

“Forbidden” error when attempting to create test through Experience Editor

I need some help on creating Content level testing in my pages through Experience Editor. I get a "Forbidden" message when trying to create a test on a page on my website page through Experience ...
1
vote
0answers
105 views

Experience Editor always asks to save after adding workflow comments

When I add comment to the workflow transitioning from one state to another. Experience editor always asks to save the page as shown below: Is there a way not to show this pop-up? Or Can this be ...
1
vote
0answers
233 views

HttpAntiForgeryException (0x80004005)

The Experience Editor is showing the following message: A serious error occurred please contact the administrator Sitecore logs are displaying the following information: 6732 11:46:21 ERROR Error ...
1
vote
0answers
615 views

Experience Editor not working properly in 8.2

We upgraded to 8.2 back in August and haven't had issues on the front or the back end for the most part. However we don't use the Experience Editor very much. Our client might but hasn't reported ...
1
vote
0answers
234 views

Custom Experience Editor Ribbon Button: error in FieldEditor.aspx

I'm trying to add a custom button to the ribbon in the Experience Editor (Sitecore 8.2). I've been following this blogpost: http://reyrahadian.com/2015/04/15/sitecore-8-adding-edit-meta-data-button-in-...
1
vote
0answers
151 views

Move renderings issue

Sitecore 8.0 (150812) It looks like move rendering button in the Experience Editor isn't working for me.
0
votes
0answers
21 views

Data is always empty in Sitecore Personalized Experience

In my Sitecore instance, I have added different personalization rules on different components. I want to see the effect of these personalization rules. But in Personalized Experience dialogue, the ...
0
votes
0answers
23 views

Is there a way to add extra identifier class if you're viewing Partial Design (header in my case) on Experience Editor?

I'm currently doing a specific styling for header partial design that will only apply when you viewed it on Experience Editor (EE). I'm aware of the on-page-editor class on body tag but I need extra ...
0
votes
0answers
25 views

How to disable content editing to users other than content owners and super admin in Sitecore workflow

We need to disable 'lock and edit' option for authors other than content owner who initiated the workflow. I able to achieve this by changing the below settings in Sitecore.config ...
0
votes
0answers
42 views

Create new item is not appearing in the associated content dialog in experience editor

I am using Sitecore 9.3, sxa and I am having issues with the Create new content option appearing when selecting associated content in the experience editor. This used to work. I have double checked ...
0
votes
0answers
33 views

Removing width and height attributes using JSS <Image/>

I was wondering whether there is a way to suppress rendering the width and height attributes when using the Image component from @sitecore-jss/sitecore-jss-react? Or under the hood, it basically uses ...