Questions tagged [experience-editor]

Use for all Sitecore 8+ page editing questions specifically using the Experience Editor.

Filter by
Sorted by
Tagged with
1
vote
0answers
26 views

Explore mode GeoIP data not available

In Sitecore Experience Editor Explore view I am facing one issue in which I am not getting any country list in GeoIP section under Visitor information. Below is the screenshot of my page. Please ...
1
vote
0answers
24 views

Field of “CustomType” Not working properly in Experience Editor

I have a date field which is of "CustomType". It has a validation in the 'Validation' field with this Regex ^(?!\s*$).+ I need to edit this field in Item through Experience Editor. I have created a ...
0
votes
2answers
339 views

Extra P tag is added in Single-Line-Text while updating from Experience Editor in Sitecore 9.3

I am using Siteore 9.3 also using Glass mapper 5 and I have one Single-Line-Text and I am binding value just like mentioned below: <div class="heading-5 header-text">@Html.Glass().Editable(...
2
votes
2answers
210 views

Personalization conditions switching not working in Experience Editor(Sitecore 9.2)

Conditions switching is not working in experience editor. But if I remove the content part from default rule conditions switching works properly. Any suggestions please?
1
vote
1answer
93 views

Editable checkbox in Page

I have a Sitecore field of checkbox type. I am showing it in Experience Editor as below and is Editable : My code of Cshtml is: IsNavigable: @Html.Glass().Editable(Model,x=>x.IsNavigable) How ...
3
votes
1answer
112 views

Customize WorkFlow Message Dialog box in Experience editor

In Experience Editor Mode when we click on the work flow command,the below dialog box comes up, How can I show a customized dialog instead of default:
0
votes
0answers
66 views

Lock and edit feature for all user including Admin

An Item if 'Lock and Edit' then creates a new version if not an admin. As a admin When I select lock from Experience Editor Ribbon and edit the Item which is published once and save then new version ...
0
votes
2answers
87 views

Need to remove Experience Editor mode , when going directly to a WCM URL

In Content Editor, I select an Item and from the publishing tab, I select experience editor. Then the page opens in Experience Editor and the URL like this: wcm-example.com/?sc_mode=edit&sc_itemid=...
1
vote
2answers
237 views

How to display Droplist Field Value in Page and Edit in Experience Editor?

I Have a Field of Droplist type. The source of the field is of a Folder under which two items are present. In the droplist field we can select the name of the two Item present in the source folder. I ...
0
votes
0answers
60 views

Experience editor missing Workflow

When I edit the content on the content editor the workflow is triggering and showing Request for approval command option under the Review tab, whereas when I edit the content through Experience editor ...
1
vote
1answer
71 views

How to Hide or not Load Non Editable Component in Experience Editor?

In a Page component like Header or Footer are not editable,Is there a way that i can hide these component in Experience Editor mode. Or do not load the component at all in Experience Editor.
2
votes
1answer
54 views

How do I hide a field from display in the Experience Editor's component editor?

I need to hide a template field on both Content Editor and Experience Editor. For Content Editor, I could achieve it by overriding the GetFields pipeline. It still shows up on the Experience Editor. ...
1
vote
1answer
621 views

Understanding Shared vs. Final layout, Experience Editor and Publishing

I understand that theoretically the Final layout is the versioned one of the layouts, what I don't understand is the behavior I get with making changes in the Experience Editor and how it seems to ...
1
vote
1answer
146 views

File field not working in edit frame

I'm pretty certain the issue exists in previous versions too. Steps to reproduce: - Create a template with a "File" field in it (among other things) Create an item with that template - assign proper ...
1
vote
0answers
62 views

Create new content missing when adding a component in experience editor

I'm using Sitecore 9.3 with JSS 13. When I try to use the add here and select one of my components I get the Select the associated Content dialog box. This box is missing the create new content ...
0
votes
1answer
56 views

Static Rendering and Editing in Experience Editor

I am adding a statically bound rendering inside of a view like this: @Html.Sitecore().Rendering("myControllerRenderingId", new { DataSource = "myDatasourceId" }) This is working fine and the ...
1
vote
0answers
132 views

Experience Editor issue - Server Error in '/' Application

We are using Sitecore 9.3 version, Sitecore Experience Editor Ribbon not loading- and showing Server Error in Application error. Note: We run the db upgrade scripts on sitecore 8.2 update 3 ...
3
votes
1answer
257 views

Experience Editor removing opening paragraph tag in RTE

We've noticed that when editing RTE fields in the experience editor of version 9.3 the first paragraph tag is being stripped. For example: This (prior to save): <p>test</p> <p>test&...
2
votes
1answer
199 views

SItecore 9.3 - Horizon - Page keeps on reloading issue

We have an SXA site hosted in Sitecore 9.3, website browsing works fine. When we installed Horizon on Sitecore 9.3 and started it to edit a page, but the page keeps on reloading, the horizon page ...
1
vote
2answers
164 views

Insert Options for a child item via the experience editor

We build composable pages where the page has a child item folder that contains the details for how the page is to render (and the appropriate content) I'd like to make the Experience Editor give the ...
0
votes
1answer
251 views

Sitecore preview redirects to desktop

Extending below issue to the preview option from Sitecore V9.3 back office. Error while previewing the Sitecore item/Sitecore.Pipelines.LoggedIn.LoggedInArgs' does not contain a constructor that ...
1
vote
1answer
74 views

Datasource location overwritten at JSS deploy

The datasource location field of the renderings after deploying the items with JSS is by default : ./Page Components|/sitecore/content/tudorlocal/Components/ContentTest However, when adding a ...
4
votes
2answers
215 views

Rendering always shows children of current page as datasource

Sitecore 9.2 (no SXA) The code below is the Sitecore.Pipelines.GetRenderingDatasource.GetDatasourceLocation pipeline. The issue I am having is that if I set the datasource field, in the rendering. It ...
2
votes
2answers
271 views

Page designs not visible in in main placeholder

I am using Sitecore 9.2 with SXA 1.9. My experience with using the out of the box sxa layout is that three placeholders are present: header, main, and footer. About a week ago we began to see a ...
0
votes
0answers
70 views

Render anchor tag with content in web form and Experience Editor

I am looking to Render a General Link Field in Sitecore 8.2 with Webforms. I also have the content inside the anchor <a> tag which needs to content editable in Experience Editor. Also, I want ...
0
votes
2answers
79 views

Not able to point to correct datasource location after upgrading Sitecore 9.0.1 to 9.2

We recently migrated our site from 9.0.1 instance to 9.2. Everything works fine except that when I select a rendering in experience editor and try to locate the Datasource location for creating/ ...
0
votes
1answer
70 views

How to change data-source path “local:/data/test” to GUID programatically when saving page in Experience editor

We are using Sitecore 9 with SXA. As per my understanding, it was designed to have a path with local:/ for certain reasons. But, as per our business requirements, we need to update rendering with a ...
0
votes
0answers
25 views

How to set final layout renderings to shared layout [duplicate]

We have assembled pages in the final layout of the Item (In Experience Editor, unfortunately, we didn't switch into shared layout). We need that renderings copied into the shared layout also. Is ...
0
votes
2answers
250 views

Preview mode opens blank page

I am facing an issue that whenever I preview any page from the Sitecore content tree, it displays a blank page. Although the pages have the page design set correctly and are displayed correctly on the ...
1
vote
0answers
325 views

Experience Editor - An error occurred. [Log message: Value cannot be null. Parameter name: source]

I have a new Sitecore 9 vanilla install. I created a JSS site and entered the connected mode. Immediately I'm getting an error in the Experience Editor. On-screen I see: An error occurred. [Log ...
1
vote
2answers
217 views

Can't switch between Final Layout and Shared Layout

I'm encountering a problem where I can't switch between Final Layout and Shared Layout in the Experience Editor. The button is not grayed out though. It just doesn't make the switch when selected. ...
1
vote
1answer
65 views

Show Multiple Validation Failures Of The Same Type In Experience Editor

I have created a few custom field validators in Sitecore and I'm running into an issue when testing them in the experience editor. For each error, I only see one banner at a time showing a failed ...
1
vote
1answer
179 views

Preview mode in Experience Editor is broken

Whenever I change to Preview mode in experience editor, some SXA components are throwing exceptions: Error Rendering Controller: Sitecore.XA.Feature.Navigation.Controllers.LinkController,Sitecore.XA....
2
votes
2answers
59 views

Modifying renderings programatically - can update the Shared Layout and Final Layout together but can't seem to only update the Final Layout?

I'm working on a script to modify rendering parameters. I noticed that I seem to only be able to modify the Shared Layout and not the Final Layout. I can retrieve the Final Layout field and work based ...
0
votes
1answer
58 views

Partial design and page design not adding in home page

I have just started working with sxa. I installed sxa 1.8 with sitecore 9.1. I have created one header partial design and one landing page design. I have selected this page design into home page of my ...
3
votes
2answers
248 views

Integrated GraphQL is not executed in Experience Editor

We use Sitecore 9.2, SXA 1.9 + JSS 12.0. As for the JSS, we are using Sitecore First approach. Some JSON renderings have integrated GraphQL queries. The Jss site was created trough JSS Tenant/JSS ...
0
votes
0answers
81 views

Sitecore throws error on Experience Editor if page name is same as any folder name under webroot

Recently, we had an issue when an item has 2 languages and multiple versions available, if you try to change language on Experience Editor, it returned 500 error. Normally when you click Experience ...
2
votes
1answer
101 views

Rendering page after the sitecore ribbon in EE

i want to preview changes to the header, but the Sitecore Ribbon is overlapping the page's header in edit or preview Mode of the page. Is there some configuration I can do to start rendering the ...
0
votes
0answers
135 views

Custom Field Type - WebEdit Buttons not showing in Experience Editor

I've created a custom Field Type that's very similar to Rich Text (a Duplicate, in fact) and want to use it with a custom HTML Editor Profile that's similar to Rich Text XA (you guessed it, also a ...
2
votes
1answer
872 views

Experience Editor issue after upgrading to Sitecore 9.3

After upgrading to Sitecore 9.3 getting below error in Experience Editor:- sitecore Method not found: 'Void Sitecore.Pipelines.GetChromeData.GetChromeDataProcessor We are using Glass Mapper
0
votes
0answers
25 views

Edit frame in a page with synonyms fields [duplicate]

I'm new to experience editor in sitecore. I'm writing an edit frame in razor page using as datasource the page item ID. The edit frame should modify some fields read by a rendering in the page. But ...
3
votes
1answer
114 views

How to apply rendering to child items

Assume I have a menu with menu sections. The menu has a title, opening paragraph, and a list of menu sections. content title - Single line text paragraph - Rich text sections - Multilist ...
1
vote
1answer
88 views

page template and his base template instance items

I have an Item in Sitecore, and I know it's derived from a certain base template. I have that base template ID, but I want to get the instance of this base template that is part of my page. I want it ...
4
votes
1answer
99 views

HTML Support for Experience Editor Info Notifications

I'm trying to add simple html such as bullets, underline, bold inside an Custom Experience Editor Notification. I have followed the example outlined by Marek Below (and looked at many other examples ...
0
votes
0answers
150 views

Experience Editor is not loading theme style sheets

Application is running Sitecore v9 Update 1 with SXA v1.6. I have cloned a site and I have added a new language to this site. I'm trying to edit a page in Experience Editor in new language version but,...
1
vote
1answer
187 views

Experience editor always opens another site in a multi-site instance

I have a multi-site instance having site1, site2, site3,... and the instance name is Mysite. Each site has its own SiteDefinition.config When I try to open a site2 or site3 page in the experience ...
0
votes
1answer
346 views

Experience Editor error when adding element to placeholder in a JSS component that doesn't by default render its placeholder

I'm using sitecore JSS, I have a component with a placeholder and I am trying to add a child component into that placeholder. I'm getting an unhelpful popup error saying An error occurred and then in ...
1
vote
1answer
60 views

String not geting rendered in Experience Editor

Environment: Sitecore 9.0.2 + Glass mapper I have a model class like this: public class SingleStack { public Glass.Mapper.Sc.Fields.Image Logo { get; set; } public string ...
2
votes
1answer
321 views

Glassmapper | Cannot save a class that does not contain a property that represents the item ID

Environment: Sitecore 9.0.2 + Glass Mapper I have a class like this: public class Sample { public Glass.Mapper.Sc.Fields.Image Logo { get; set; } public string Destination_Name { get; set; }...
1
vote
1answer
124 views

How does Sitecore Experience Editor deal with component items on a page when a new version of a page is created?

I've come across an instance where a client was using the Experience Editor to create a new version of a landing page and the components on the page did not increment the version number. Is this ...

1
2
3 4 5
8