Questions tagged [federated-authentication]

All questions related to Federated Authentication in Sitecore

Filter by
Sorted by
Tagged with
12 votes
2 answers
2k views

How can I get SXA login working with my Federated Authentication via IdentityServer?

Background We're building an internal site where all users are required to be authenticated. I've configured IdentityServer to connect to the organisation's Azure AD and this is working fine. When I ...
user avatar
  • 24.4k
8 votes
2 answers
2k views

Unsuccessful login with external provider

I have setup federated authentication for my Sitecore 9.1 website, to allow end users to login using Azure B2C AD. Our website is following Helix architecture. This is my code: Portal.Website.config: &...
user avatar
  • 844
2 votes
3 answers
395 views

Sitecore Federated Authentication on CM server - remove Login form

I am using Sitcore 9 and have implemented federated authentication on CM server. I need to remove normal login authentication , so that the only way that user can be authenticated is form from third ...
user avatar
  • 767
1 vote
1 answer
726 views

Storing custom data in Redis

Our Sitecore 9.2 PaaS website uses federated authentication for logging in our end users, and we are looking for a secure place to store refresh- and access-tokens (pref. serverside). We would prefer ...
user avatar
  • 844
2 votes
1 answer
109 views

2 SXA sites on same Azure app service need different federated authentication providers

I have 2 SXA sites running on the same Azure app service. Both sites require Okta federated authentication (OIDC). Is it possible to have more than one IdentityProvidersProcessor (1 for each SXA site ...
user avatar
  • 51
0 votes
1 answer
368 views

Federated Authentication with Azure AD - Sitecore 9.3 - .Aspnet .Cookies not getting created

We are using Sitecore version 9.3 for our solution. For our CD instance (the public-facing website), we need to use Azure ADB2C with OpenIdConnect for authentication. And for our Sitecore CM instance, ...
user avatar
2 votes
4 answers
3k views

Using Okta OpenId Connect "A client_id must be provided in the request"

I am trying to use Sitecore 10.0.1, IdentityServer4, with Okta and OpenID Connect. When I click logout I get this error: {"errorCode":"invalid_client","errorSummary":&...
user avatar
7 votes
1 answer
1k views

Sitecore Logged In Pipeline in Identity Server?

I've created a Two Factor Authentication. It's working by adding our custom processor before Sitecore.Pipelines.LoggedIn.Ticket. But now in 9.1 with Identity Server, it won't be triggered unless I ...
user avatar
  • 335
4 votes
1 answer
1k views

Federated authentication with OpenIDConnect gives "Unsuccessful login with external provider"

In my Sitecore 9.1 installation I'm trying to use Federated Authentication and have almost successfully set it up. When I click the "log in" button on my public website I'm redirected to the ...
user avatar
3 votes
1 answer
999 views

PostLogoutRedirectUri with Owin and Azure ADb2C

Can anyone confirm if the Sitecore.Security.Authentication.AuthenticationManager.Logout(); handles the logout from AdB2c IDP as well, as per documentation from at: https://doc.sitecore.com/...
user avatar
  • 1,603
1 vote
1 answer
166 views

Issues with IdentityProvidersProcessor Sitecore Federated Autentication in multisite architecture

We have 5 websites (e.g. A, B, C, D and E) and with separate clientId in Auth0. We have relevant IdentityProvidersProcessor for these applications. Sometimes when cms is left idle, upon reloading the ...
user avatar
1 vote
1 answer
1k views

Could not find configuration node: federatedAuthentication/sharedTransformations/setIdpClaim

The configuration for federated authentication, was working fine with the Sitecore version 8.2. <?xml version="1.0" encoding="utf-8"?> <configuration xmlns:patch="http://www.sitecore.net/...
user avatar