Skip to main content

Questions tagged [habitathome]

Sitecore Habitat Home is a sample solution that is built on Sitecore Experience Accelerator™ (SXA) using Sitecore Experience Platform™ (XP) following the Helix architecture principles.All questions around this example site including configuration and implementation, should use this tag.

Filter by
Sorted by
Tagged with
1 vote
1 answer
288 views

Cake.exe : Error: Unable to find package 'Cake.SitecoreDemo'

I'm trying to install "Sitecore.HabitatHome.Platform" which is using Sitecore v9.3. I'm following Viet Hoangs blog for the installation. I used the default site name and installation folder. ...
Ercan Polat's user avatar
0 votes
1 answer
199 views

Sitecore.HabitatHome.Platform - Sync-Unicorn fails [closed]

While I'm trying to install Sitecore.HabitatHome.Platform, I'm getting Unicorn Sync issue. I did install Sitecore XP Single v9.2 using SIF. I verified the installation by logging in to Sitecore and ...
Ercan Polat's user avatar
1 vote
0 answers
1k views

Index was outside the bounds of the array exception when using personalisation via EXM

When I try to personalise an element within an email, I receive an error: [IndexOutOfRangeException: Index was outside the bounds of the array.] Sitecore.Data.Query.Tokenizer.NextToken() +2090 ...
El_Shaddai's user avatar
1 vote
0 answers
214 views

Error while using Exm in Marketing automation

Recently i installed habitat home and enabled the exm by using the custom smtp settings ,exm was working fine , but got an error while creating an automated campaign in marketing automation tab , when ...
Rohan Bhateja's user avatar
2 votes
1 answer
74 views

Solr cores are not switched when putting SXA 1.7 in live-mode

I switched my SXA Storefront & Habitat Home based site to live mode by setting the database to master in /sitecore/content/Tenant/Site/Settings/Site Grouping/Site. I was expecting the site to use ...
Joost's user avatar
  • 1,917
1 vote
0 answers
286 views

Custom SXA component does not appear in home page toolbox

I tried to develop a custom SXA component on top of Habitat Home Commerce demo (Sitecore 9.0.2). The custom SXA component is showing in all pages' toolbox, but not home page toolbox. Is there any ...
WenHao's user avatar
  • 213
0 votes
0 answers
696 views

500 Internal Server Error /commerceops/CleanEnvironment()

I am trying to setup HabitatHome.Commerce on Sitecore Experience Commerce 9 update 2. On Postman the Post for GetToken SitecoreIdentityserver is working fine and so as I can see when I run the "...
Amitabh's user avatar
  • 1,066
2 votes
2 answers
921 views

Could not load file or assembly 'Sitecore.DataExchange' while installing Sitecore Provider for Data Exchange Framework 2.0.1 Package

I am trying to setup my Habitat Home Commerce solution (Sitecore Experience Commerce 9.0.2) and as a step for it I am trying to install the package Sitecore Provider for Data Exchange Framework 2.0.1 ...
Amitabh's user avatar
  • 1,066
7 votes
1 answer
1k views

Habitat Home error on SXA

Sitecore 9 U1 I have stood up a new instance of Habitat Home using this link and this repo. I am not crazy familiar with SXA. I can edit/preview the pages without issue, but when I try and view the ...
Chris Auer's user avatar
  • 13.1k