Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [identity-server]

IdentityServer is a free, open source OpenID Connect and OAuth 2.0 framework for ASP.NET Core. Questions related to it in Sitecore environment, should use this tag.

3
votes
0answers
40 views

Sitecore 9.1 and auth0 integration

I am trying to integrate Sitecore 9.1 and auth0 platform. I was following this tutorial for Sitecore 9.0 - https://blog.baslijten.com/enable-federated-authentication-and-configure-auth0-as-an-identity-...
1
vote
1answer
89 views

How to configure Identity Server 2.0.1 (Sitecore 9.1.1) to use Active Directory?

Has anyone successfully configured Identity Server 2.0.1 (SC 9.1.1) to use Active Directory? The only official documentation and examples I have seen are with Azure AD (not regular on prem AD). I ...
3
votes
0answers
52 views

Installation issue on migration 9.1.1

I am trying to migrate a Sitecore 9.0.2 to 9.1.1. Following the upgrade guide https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform/91/Sitecore_Experience_Platform_91_Update1.aspx, I have to ...
3
votes
1answer
77 views

Why is SignInProcessor triggered twice?

I've created a custom pipeline to process the login to sent 2FA token. But somehow the pipeline is triggered twice. It doesn't happen with LoggingInProcessor (Used before Sitecore 9). Anyone know why? ...
0
votes
0answers
57 views

How to setup sitecore 9.1.0 CD server on same domain/different server and CM but have Active directory access, without a login box

Need some direction for a corporate intranet portal where CM/CD are different servers but in same domain behind a firewall, we are self hosted (not using Azure). We are running Sitecore 9.1.0 and ...
1
vote
0answers
73 views

Automatically attach user to external identity

On SC 9.0.2 we want to map an existing user in sitecore automatically to an external identity provider, but get the following error: [InvalidOperationException: Unable to create a user. Reason: ...
6
votes
1answer
143 views

Sitecore Logged In Pipeline in Identity Server?

I've created a Two Factor Authentication. It's working by adding our custom processor before Sitecore.Pipelines.LoggedIn.Ticket. But now in 9.1 with Identity Server, it won't be triggered unless I ...
5
votes
1answer
138 views

CM to Identity Server redirection issue

I'm running the Content Management (CM) and Sitecore Identity Server (SIS) roles on a single AWS EC2 instance. This is behind an AWS application load balancer, which accepts traffic on port 443 only ...
3
votes
0answers
163 views

Sitecore 9.1 forced back to log in screen

I have a Sitecore 9.1 instance in a PaaS environment in Azure. On the CM, when I try to log in to Sitecore, I get to the log in screen, I log in successfully, when it tries to redirect me back to ...
0
votes
0answers
83 views

Sitecore Identity server without return url

I have installed Sitecore 9.1 version. So I use the Sitecore Identity (SI) server to sign in standard Sitecore Client URL : https://sc91initial.identityserver/account/login?returnUrl=%2Fconnect%...
1
vote
0answers
82 views

IdentityServer URL throws HTTP Error 502.5 - Process Failure

I have vanilla 9.1 instance and I can login successfully. I browsed the Identity server URL and receiving HTTP Error 502.5 - Process Failure. Any idea why it is throwing 502.5 error? Log file shows ...
4
votes
1answer
159 views

IsAdministrator check no longer working on Sitecore 9.1

I created a few pages within our Sitecore setup to be accessed only by the Sitecore administrator while our site was still running on 8.2, using Sitecore.Context.IsAdministrator to check if the user ...
3
votes
1answer
92 views

Sitecore 9.1 password complexity

It seems that Sitecore 9.1, with the new Identity Server, no longer uses the same way of configuring password complexity as the previous versions. Some of the links that I found related to 9.0 and ...
6
votes
1answer
97 views

Where is the License file location for Identity Server in Sitecore 9.1?

I installed Sitecore 9.1 and noticed the new Identity Server site in IIS. My license is expired now. Where can i find the license file to replace for Identity Server?
0
votes
1answer
236 views

Sitecore 9.1 IdentityServer AzureAD subprovider user cannot login to the Admin site

I have configured Sitecore Identity to use Azure AD as the sub provider following the Sitecore document I can authenticate using my Azure AD account, but then I get the following message You do ...
1
vote
0answers
46 views

How to setup authentication when using a combination of Azure AD and a custom database to store user accounts?

I am using SXC 9.0.2. I have an Azure AD and would like to let Azure AD accounts access both the Content Editor and the Commerce Business Tools. End-users will also need to sign-in - these users will ...
0
votes
2answers
130 views

Troubleshooting Sitecore Identity Server routing errors in Sitecore 9

I am upgrading Sitecore 8.1 to 9.1. After resolving a number of config and dll-related errors, if I try to reach /sitecore I get redirected to /identity/login/shell/SitecoreIdentityServer Which ...
3
votes
1answer
153 views

Using the new Identy server in 9.1, it is still possible to implement a custom ASP.NET Membership provider?

Reading the documentation here: https://doc.sitecore.com/developers/91/sitecore-experience-management/en/sitecore-identity-server-authentication.html "The SI server uses identityserver-contrib-...
1
vote
1answer
78 views

Where can I change the Certificate Thumbprint from a Sitecore IdentityServer website?

I had to recreate my certs and after doing so and importing them into my IIS, I'm struggling now to find where exactly on the Sitecore IdentityServer website I must update its Thumbprint. Has anyone ...
1
vote
1answer
67 views

How to create a Sitecore Framework Plugin-based project in Visual Studio

The instructions for configuring a sub-provider for the Sitecore Identity Server (https://doc.sitecore.com/developers/91/sitecore-experience-management/en/use-the-sitecore-identity-server-as-a-...
8
votes
0answers
404 views

Website login is broken after introducing Sitecore 9.1 identity server

Currently we are having problem in upgrading to Sitecore 9.1 Problem started to happen after Sitecore 9.1 introduced IdentityServer based authentication. Sitecore 9.1 uses <add key="owin:...
6
votes
0answers
271 views

Can the Identity Server be used for multiple sites/clients?

For Sitecore 9.1, can the Identity Server be used for multiple sites/clients? For example, on a local developer machine I have several 9.1 installs for separate clients. Could I use that Identity ...
8
votes
2answers
282 views

Login to Sitecore 9.1 across multiple subdomains

I am trying to login to Sitecore across multiple domains. I mean, I have two different sites abc.x.com and xyz.x.com. is there a way to set the auth cookies at parent domain level, in my case at x....
8
votes
1answer
345 views

use external application to get Identity Server token / cookie

Does anyone have experience connecting to Identity Server in 9.1 to get an authentication token / cookie of sorts? I'm trying to do this in PowerShell. In Commerce 9.x, you could connect directly to ...
4
votes
1answer
377 views

JWT tokens for authentication for 9.1

I want to protect some APIs using OAuth and I want to use Sitecore's new instance of IdentityServer 4. I could just build my own login logic and stick it in the API call. But I would like to use the ...
1
vote
1answer
77 views

Unable to create a user. Reason: DuplicateUserName" error while trying to map map federated logins to existing users

we have setup IdentityServer 3 as IDP for our test Sitecore setup. However, we are not able to map incoming federated logins to existing users (Users created with legacy forms authentication enabled). ...
14
votes
3answers
1k views

Installing 9.1 XP0 - Sorry, there was an error : unauthorized_client

After installing 9.1 I see the following error on the login screen: Steps I followed: Updated XP0-SingleDeveloper with ".dev.sc.local" to the site names Ran the installation using XP0-...