Questions tagged [indexing]

Questions about indexes in Sitecore (standard or custom) in general. For questions that apply to Lucene or Solr, use the appropriate tags.

Filter by
Sorted by
Tagged with
0
votes
1answer
38 views

ANCM Failed to start within startup time limit

Using SC10.1 & XC 10.1 I see this error when building the master & web indexes. All the other indexes build fine without any issues. Tried restarting the instance with no luck.
0
votes
1answer
50 views

Could not map index document field to property “Paths” on type Sitecore.ContentSearch.SearchTypes.SearchResultItem

Has anyone seen this error in the logs Could not map index document field to property "Paths" on type Sitecore.ContentSearch.SearchTypes.SearchResultItem. Guid should contain 32 digits with ...
1
vote
3answers
191 views

The method 'Concat' is not supported. Declaring type: System.Linq.Queryable

I have two IQueryables that i need to merge. This is my code: such that all results having region name "UK" will appear on top while all results having region other than UK will appear after search ...
4
votes
1answer
1k views

Custom Solr Fields in Sitecore 9 and Solr 7.2.1

I am converting my custom index fields from Sitecore 8.1. Previously, I would declare them like this: <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:set="http://www....
1
vote
1answer
36 views

Rebuild the xDB index in Solr - error mongo

I have problem with rebuilding xDB index in solr. I changed IndexPIISensitiveData to true in job SerachIndexer and after executing the command \XConnectSearchIndexer.exe -rr there is no sensitive data ...
2
votes
1answer
165 views

Rebuild lucene index after publishing issue

I have an issue related to the lucene index. The index is not being built when I do smart publish even if there is onPublishEndAsync added, but it does when I do republish. <strategy ref="...
1
vote
0answers
215 views

Custom index, stategy to publish items under a certain path

We have this custom index that only contains pages for one section of the content tree. We want it setup so that publishing items under this path reindexes those items automatically. This seems like ...
1
vote
1answer
644 views

Could not create instance of type: Sitecore.ContentSearch.Azure.CloudSearchProviderIndex. No matching constructor was found

Currently in progress of upgrading from Sitecore 8.1 to 8.2 update 7. So I'm currently converting existing indexes from luecene to Azure search, I have done all the basic steps like, disabling all the ...
0
votes
1answer
42 views

How to enable Synchronizing the Index in if(EventDisabler())?

I am adding data in event item:versionAdded and when adding new version then it is calling item:versionAdded event again. For solving this issue I am adding data under: using (new EventDisabler()) { --...
2
votes
0answers
91 views

Sort By Grouping NumFound Field

Hello Sitecore Stack Exchange, Environments: Sitecore 9.2, Solr 7.5.0|SolrCloud 7.5.0, Custom search index. In the Search logic I have the next requirement: I should group search response and sort ...
2
votes
1answer
44 views

Control the order of indexes during rebuild

I have the following scenario implemented in sitecore 9.2 and which uses azure search: index1 is configured to index around 100k items under /sitecore/content/shared/data index2 is indexing around ...
0
votes
0answers
52 views

copyField dest :'description_t_ta_str' is not an explicit field and doesn't match a dynamicField

I have added Bengali & Tamil in Sitecore 9.2. In publishing the data I am not getting any issue. But while running the indexing, getting the below error for the fields of the item. copyField dest :...
2
votes
1answer
181 views

Solr indexed date field is off by a day

I have a computed date field in Solr that for certain items is off by 1 day. The code is really simple: public class SearchDateField : BaseContentComputedField { public override object ...
1
vote
2answers
575 views

Getting a Sitecore Commerce Sellable Item List Price at Indexing Time

I am indexing Sitecore Commerce 9.0.2 sellable items through a regular SitecoreItemCrawler. The HabitatHome demo sellable items are in my content tree at /sitecore/content/Habitat Sites/Habitat Home/...
1
vote
1answer
42 views

How to index Catalog Generated Template Field's in Azure search

In Azure Search Index configuration, there is an option to include Fields that need to be indexed. But the catalog generated Templates Field may be having different id's in different environments (Dev,...
1
vote
1answer
140 views

Can a TOKENIZED index field be remapped to an UNTOKENIZED field of a different name without using a computed? (LUCENE)

Having some search issues with using the "Name" field on items ("_name") I'd like to map it to another field that I can search on without having to create a custom computed field to do the mapping. ...
1
vote
3answers
75 views

sitecore_master_index is huge SC 9.1.1

In Sitecore 9.1.1 The Sitecore_master_index is huge on CM server. It goes up to like 450-500k documents than IIS resets. (think this is because memory dump?) On Test-environment, which has similar ...
2
votes
1answer
84 views

How to make a cache exist for the duration of an indexing operation

Is there a way to create a Sitecore custom cache which exists for the duration of an indexing operation. I would like to store frequently looked up relationships which can be re-used by different ...
0
votes
2answers
574 views

Adding custom contact facet to Sitecore Analytics index

Sitecore 8.2 Update 4 with Lucene search on a local single instance Sitecore site: I have created a Custom Contact facet and I can see it is being saved to MongoDB. I want to add it to the Analytics ...
0
votes
0answers
41 views

Sitecore Commerce Re-index sub-tree of items/products without modifying them

Is there a way to force re-indexing of a subtree of Sitecore Commerce products (Sellable Items)? I'm using Sitecore 9.0.2 with Commerce 9.0.3. I tried to open the developer toolbar within the Content ...
0
votes
1answer
426 views

Sitecore reindex AlreadyClosedException: this IndexWriter is closed

Reindexing locally works fine, but when I reindex upstream I get this error: org.apache.lucene.store.AlreadyClosedException: this IndexWriter is closed How can I fix this error?
0
votes
1answer
308 views

How to stop ongoing Indexing in Sitecore?

We have started indexing contacts by using Helpfulcore.AnalyticsIndexBuilder due to some reason we would like to stop contact indexing forcefully. May I know how can we stop indexing in Sitecore.
0
votes
0answers
18 views

Sitecore Indexing Manager CORS exception

Im seeing a CORS exception when trying to open the Indexing manager on the Sitecore Control Panel Uncaught DOMException: Blocked a frame with origin "https://cm.jssapp.dev.local" from ...
0
votes
0answers
150 views

LowerCaseKeywordAnalyzer does not work

We have overriden the default mapping by adding: <indexConfigurations> <defaultSolrIndexConfiguration type="Sitecore.ContentSearch.SolrProvider.SolrIndexConfiguration, Sitecore....
0
votes
1answer
40 views

Why have commerce items been indexed in my sitecore_master_index

I was running a query against my Solr index (sitecore_master_index) and see that some commerce items have made it into the index. This is odd because I thought the commerce_master and commerce_web ...
0
votes
0answers
43 views

Sitecore Form Custom Index Not Working

I have created a new index for Sitecore forms named sitecore_forms_index following the below link: https://doc.sitecore.com/developers/100/sitecore-experience-manager/en/walkthrough--creating-a-custom-...
0
votes
0answers
25 views

Rebuild index feature from CM not updating indexes on CD server

Lucence indexes are not in sync on CM and CD server which seems expected as per this post but for me even manual trigger is not working. I tried Index rebuild in Developer tab from top ribbon from ...
1
vote
1answer
120 views

SOLR Spellcheck relevant collations

I'm using Solr 7.2.1, I'm implementing did you mean functionality using Solr spellchecker, I want the collation results to be relevant to a field, for example if I search with 'drive cay', the result ...
0
votes
0answers
27 views

Solr spellchecker inconsistent behavior with multiple words

I'm using Solr 7.2.1, I'm implementing did you mean functionality using Solr spellchecker, It's working fine except for some cases with multiple words, as far as I understand the correct spelled words ...
1
vote
1answer
46 views

Sitecore Indexing GetLocalDatasourceDependencies

Sitecore 8.2 update 5 on Azure App Services. Anyone knows what could be the reason <pipelines> <indexing.getDependencies> <processor type="Custom....
0
votes
1answer
130 views

Solr spellchecker inconsistent behavior when first character is misspelled

I'm using Solr 7.2.1, I'm implementing did you mean functionality using Solr spellchecker, It's working fine except for some cases that I don't understand its behavior, like in my dictionary I have a ...
0
votes
0answers
28 views

Issue with Coveo Indexing

Exception while processing an item: -> Unable to connect to the remote server -> A connection attempt failed because the connected party did not properly respond after a period of time, or ...
0
votes
0answers
21 views

Enabling Idexing for the Annonymous Contacts on sitecore 9.1 [duplicate]

I tried to use the Sitecore Goals in my site and it is working fine with logged-in users but it is not working with annonymous users so I applied the steps of enabling indexing for annoynmous contacts ...
0
votes
1answer
60 views

Sitecore doesn't add the indexed field with Traditional Chinese & Simplified Chinese postfix on the Azure custom index

I am doing a POC in Sitecore.Net 9.2 vanilla setup for enabling the Traditional Chinese and Simplified Chinese in the CMS and looking for how can I perform the Azure search for the content in zh-HK ...
1
vote
1answer
247 views

WARN Item with ID={97ADE186-643D-46A9-BAC5-C88077260694} cannot be deleted because it is not found

On our CD server i'm seeing a lot of warnings (see below), not quite sure where this is getting invoked from or whats triggering this even though the analytics and tracking is disabled. Noticed ...
0
votes
0answers
79 views

Some of the items are missing in Index after performing full index rebuild on cores

We are facing an issue in our sitecore instance. When we perform full index rebuild for web/master core in sitecore, we have noticed that some of the items are missing in solr and they are not found ...
0
votes
1answer
65 views

Indexing Boost value, Boosting rules, and Facets

I'm using Sitecore 9.0 (Solr 6.6.2) and am confused by the "Indexing" section found on items. Through experimentation I've found that entering a number may or may not actually change the search ...
2
votes
0answers
55 views

Not able to fetch search result in Content search API with Solr and Azure

I am using content search API in Sitecore 9.1.1. However, it is not fetching result if i am using search with any of the template field. The below code fetching result based on template id but when we ...
3
votes
3answers
285 views

How to rename Azure Search index

I tried to index master, web indexes using the Azure Search service. Indexing works fine, but we have a requirement to have the index names unique in Azure as we are using single search services for ...
1
vote
1answer
148 views

Sitecore 8.1 crashes during Lucene indexing

I am getting errors frequently with the below errors after adding user in prod environment and then Sitecore crashes. Checked lucene index exception occurs. Error Details: ERROR Unhandled exception ...
1
vote
1answer
589 views

“Lock held by this virtual machine” exception with Solr 6.6.1

For a customer i created a solution based on CMS Sitecore 8.2.7. The architecture is hosted on MS Azure infrastructure and basically consists of a Content Management VM (Windows Server 2016), two ...
1
vote
0answers
115 views

Any insight on how to fix “XConnect Exception Filter OnException” errors?

Our instance has been pretty stable until recently we started receiving the following errors in XConnect. Main log [Error] XConnect Exception Filter OnException(), url - "https://site.com/odata/...
4
votes
1answer
2k views

An error occurred while rebuilding the search index

I am unable to build the Coveo for Sitecore master index. While the rebuild is supposedly happening, the number of items processed is always 0. In the Sources of the cloud panel, the index doesn't ...
1
vote
2answers
82 views

Unwanted Type string appended in Computed Index field

I am creating computed index field for a Multilist field and want to return the items as String in a comma separated list. However after indexing the Solr, an type text is getting appended to the ...
4
votes
3answers
2k views

What is the fix for solr error 'undefined field _indexname' after building custom index in sitecore (v9.1.0)?

I created a new custom index named CUSTOM_SERVICES_INDEX using this command: C:\solr\solr-7.2.1\bin>solr.cmd create -c [custom index name] (cmd as administrator) then I created the config file ...
2
votes
1answer
52 views

Automated index document merge complains about invalid index name but index names are valid

I get thousands of the following error in the minions log: 00007 09:21:07 ERROR AzureContextCommand.MergeOrUploadDocuments.Error: Message=Index name must only contain lowercase letters, digits or ...
1
vote
0answers
63 views

Switch on rebuild for Commerce Cores

I am using two Solr Cloud Instance with two Zookeeper and indexed Commerce Indexes (CustomersScope, OrdersScope, CatalogItemsScope) in it. And now I want to apply Switch On Rebuild for that ...
4
votes
4answers
424 views

Getting duplicate data on server. Indexing issue?

Using Sitecore 9.0.1 and DEF 2.0.1, I have a pipeline which reads from an API and then resolves matching Sitecore items using the standard ResolveSitecoreItemStepProcessor and ...
2
votes
1answer
252 views

How do you properly query xdb for a contact by email?

I am trying to search an email in Sitecore Xdb using the code : var queryable = client.Contacts .Where(c => c.GetFacet<EmailAddressList>(EmailAddressList....
2
votes
1answer
207 views

XConnect: An error occured during resuming a previous index rebuild process

Does anyone have an idea about what could be causing this error? It happens after doing a re-build of the XConnect index. This is in Sitecore 9.3 2020-03-30 20:11:02.896 -05:00 [Error] An error ...

1
2 3 4 5