Questions tagged [indexing]

Questions about indexes in Sitecore (standard or custom) in general. For questions that apply to Lucene or Solr, use the appropriate tags.

57 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
5
votes
0answers
742 views

Sitecore Solr index FieldNameTranslator is null

I am currently playing around with Sitecore indexes - both Solr and Lucene. I have made my own custom index and it works fine for Lucene, but I cannot get it to work with Solr. My problem is that ...
5
votes
0answers
579 views

Rebuild reporting database. Exception Message: String or binary data would be truncated

Sitecore 8.0 update 5 I've set up clean sitecore.analytics and sitecore.analytics_secondary databases. Also I've deployed the Marketing Definitions and ran necessary SQL script to copy data from old ...
5
votes
1answer
353 views

Sitecore multiple CD web databases publishing/indexing EventQueue database name

Say I have a single CM with 1x master db, 1x core db and 2x web dbs (2x publishing targets) for 2x CD servers in different regions. I can't call both web dbs "web" - one must be something ...
4
votes
1answer
1k views

Custom Solr Fields in Sitecore 9 and Solr 7.2.1

I am converting my custom index fields from Sitecore 8.1. Previously, I would declare them like this: <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:set="http://www....
4
votes
0answers
275 views

Sitecore Index_Update Job Performance

We just updated from Sitecore 8.2 Update 4 to Update 7 and we've started seeing some strange behavior when publishing new items. The issue presents itself in that it takes awhile for newly created ...
3
votes
0answers
74 views

Sitecore indexing a SXA Multisite configuration for more than 500 sites

I am stuck with issue for indexing a SXA Multisite configuration for 600 sites. The case study is as below. Issue: Indexing get failed at certain point of time from CM itself for Solr Master(after 2 ...
3
votes
0answers
40 views

Is it possible to run a CD deployment without any indexing tools in place?

When deploying your application into e.g. Azure there are lots of configurations that allow adding or removing features. A good example would be XP vs XM. We have the situation where we don't use ...
3
votes
0answers
861 views

Error with indexWorker process in Sitecore 9 xConnect with Solr 6.6.2

I am running Sitecore 9 with Solr 6.6.2 and I am seeing lot of error in the IndexWorker logs in Sitecore xConnect as below: 018-02-21 16:16:13.686 +10:00 [Error] An error occured. System.Net.Http....
3
votes
0answers
577 views

“org.apache.solr.common.SolrException: undefined field 0001-01-01T00” when rebuilding index

When I rebuild one of my indexes in Sitecore, I get the following error in the Solr log: org.apache.solr.common.SolrException: undefined field 0001-01-01T00 I don't have a field called 0001-01-...
2
votes
0answers
39 views

Safe to delete Sitecore master/web old index after rebuild/swap?

We're using the Swap and Rebuild feature of Sitecore 9.1 when we need to rebuild our indexes for Azure Search. Occasionally, after the rebuild and swap is complete; Sitecore won't delete the old ...
2
votes
1answer
141 views

Rebuild lucene index after publishing issue

I have an issue related to the lucene index. The index is not being built when I do smart publish even if there is onPublishEndAsync added, but it does when I do republish. <strategy ref="...
2
votes
0answers
328 views

Sitecore-Core-Index rebuild at Azure Search for Sitecore 9.0.1 PaaS fails

I have deployed Sitecore 9.0.1 XP Scaled in Azure PaaS (default, no customization). It is used self-signed certificate and configured with allowInvalidClientCertificates="true" in azuredeploy....
2
votes
0answers
872 views

Sitecore.Social: Social messages index could not be determined for master database

We are on Sitecore 8.1 rev. 160519 (Update-3) and using SOLR 6.2.1 Logs on one of our CM server is suddenly overflowing with the following error message: Sitecore.Social: Social messages index ...
2
votes
0answers
66 views

Custom content search (crawler) sent old indexed ids

I have a completely custom search crawler that pushes data to Algolia. If I run the full reindex it works great. When trying to use a onPublishEndAsync strategy I see the first item come in I publish ...
2
votes
0answers
63 views

Is there any way to delay publishing and indexing when updating or creating items with the ItemService?

I am syncing a significant amount of data into Sitecore from external systems on a fairly regular basis. To do this, I am utilizing the Sitecore ItemService. The problem I'm currently facing is that ...
1
vote
0answers
47 views

Not able to fetch search result in Content search API with Solr and Azure

I am using content search API in Sitecore 9.1.1. However, it is not fetching result if i am using search with any of the template field. The below code fetching result based on template id but when we ...
1
vote
3answers
117 views

The method 'Concat' is not supported. Declaring type: System.Linq.Queryable

I have two IQueryables that i need to merge. This is my code: such that all results having region name "UK" will appear on top while all results having region other than UK will appear after search ...
1
vote
1answer
91 views

Can a TOKENIZED index field be remapped to an UNTOKENIZED field of a different name without using a computed? (LUCENE)

Having some search issues with using the "Name" field on items ("_name") I'd like to map it to another field that I can search on without having to create a custom computed field to do the mapping. ...
1
vote
1answer
451 views

Could not create instance of type: Sitecore.ContentSearch.Azure.CloudSearchProviderIndex. No matching constructor was found

Currently in progress of upgrading from Sitecore 8.1 to 8.2 update 7. So I'm currently converting existing indexes from luecene to Azure search, I have done all the basic steps like, disabling all the ...
1
vote
0answers
49 views

Sitecore 9.2 JSS with Solr 7.5 , JSS route items and its subitems are not indexing

Currently we are developing Sitecore JSS app with React frontend. in this we are using Headless SSR mode to create the content in sitecore and rendering. our application is working fine with React, ...
1
vote
0answers
107 views

Security Error Rebuilding Indexes

Sitecore 8.1 rev. 160302. Looking into my logfiles, there are lots of errors such as: Job Started: Index_Update_IndexName=RSearch ... Exception: System.NullReferenceException Message: Object ...
1
vote
0answers
128 views

Solr query works in the web UI, not when invoked though code

I'm on Solr 4.10.4, Sitecore 8.1 160519. I have a query used internally by my application that returns 0 records. In the Search.log I can see that same query; if I copy the querystring value to the ...
1
vote
0answers
188 views

Custom index, stategy to publish items under a certain path

We have this custom index that only contains pages for one section of the content tree. We want it setup so that publishing items under this path reindexes those items automatically. This seems like ...
1
vote
0answers
40 views

Search index not updating for new site nodes

I have created new site node and my web site search functionality is not working for the new site. I have rebuilt the search index from the Indexing Manager and I have checked the indexes, it seems ...
1
vote
0answers
1k views

The remote server returned an error: (400) Bad Request Error while building the custom index in SOLR 5.1

We have created a custom Itembuket_community and rebuliding the index. while Rebuilding the index, getting follwoing error Job started: Index_Update_IndexName=sitecore_Community_index|#Exception: ...
1
vote
0answers
188 views

PowerShell find-item doesn't return values

I'm currently using find-item on Sitecore PowerShell Find-Item -Index sitecore_master_index -Criteria @{Filter = "Equals"; Field = "recipe id"; Value = "Recipe_Lambada"}, @{Filter = "DescendantOf"; ...
1
vote
0answers
65 views

Search results error on single server setup

We have a client site that is spread across 2 cd's and 1 cm which we have migrated to a single server instance for QA purposes. The production site has a public address for the cd's and a private ...
1
vote
0answers
28 views

Sitecore 8.2 integrated search function with Salesforce

This is my first question for SE...and forgive my lack of technical expertise in this area. We're building a our new website on Sitecore which has to be integrated with Salesforce. In Saleforce, we ...
1
vote
0answers
82 views

Solr query on read/deny roles

We have a custom Solr index which includes read and deny roles. Both are added as predicates using the following code: protected virtual IQueryable<TIndexable> ApplyDenyUserRules<TIndexable&...
0
votes
0answers
19 views

Solr spellchecker inconsistent behavior with multiple words

I'm using Solr 7.2.1, I'm implementing did you mean functionality using Solr spellchecker, It's working fine except for some cases with multiple words, as far as I understand the correct spelled words ...
0
votes
0answers
17 views

Issue with Coveo Indexing

Exception while processing an item: -> Unable to connect to the remote server -> A connection attempt failed because the connected party did not properly respond after a period of time, or ...
0
votes
0answers
53 views

Some of the items are missing in Index after performing full index rebuild on cores

We are facing an issue in our sitecore instance. When we perform full index rebuild for web/master core in sitecore, we have noticed that some of the items are missing in solr and they are not found ...
0
votes
0answers
77 views

LowerCaseKeywordAnalyzer does not work

We have overriden the default mapping by adding: <indexConfigurations> <defaultSolrIndexConfiguration type="Sitecore.ContentSearch.SolrProvider.SolrIndexConfiguration, Sitecore....
0
votes
1answer
30 views

How to enable Synchronizing the Index in if(EventDisabler())?

I am adding data in event item:versionAdded and when adding new version then it is calling item:versionAdded event again. For solving this issue I am adding data under: using (new EventDisabler()) { --...
0
votes
0answers
48 views

Any insight on how to fix “XConnect Exception Filter OnException” errors?

Our instance has been pretty stable until recently we started receiving the following errors in XConnect. Main log [Error] XConnect Exception Filter OnException(), url - "https://site.com/odata/...
0
votes
1answer
24 views

How to index Catalog Generated Template Field's in Azure search

In Azure Search Index configuration, there is an option to include Fields that need to be indexed. But the catalog generated Templates Field may be having different id's in different environments (Dev,...
0
votes
0answers
40 views

Switch on rebuild for Commerce Cores

I am using two Solr Cloud Instance with two Zookeeper and indexed Commerce Indexes (CustomersScope, OrdersScope, CatalogItemsScope) in it. And now I want to apply Switch On Rebuild for that ...
0
votes
0answers
48 views

Initialization is failed for index sitecore-analytics-index

I'm currently working on Sitecore 8.2 update 7. with azure search. I got the complete db/code back up from QA environment (perfectly working environment) and restored in local. The only change I made ...
0
votes
0answers
33 views

sitecore solr search indexing getting stopped

We are seeing Solr master and web index updates are getting stopped randomly in mid of the day. I tried one approach that is mentioned in this answer. Updated the master index strategy to use ...
0
votes
0answers
20 views

Rebuild Reporting DB on Sitecore Managed Cloud

I am experiencing an issue where my Experience Analytics data is current but my Experience Profile data is out of sync. I believe to fix this issue, I need to rebuild the Reporting db and Analytics ...
0
votes
0answers
23 views

Azure search, using SwitchOnRebuild, master index is not showing in indexes

We are using Sitecore 9.3 with SwitchOnRebuild Option enabled by default, within Sitecore Azure Search Service, under indexes am not able to see sitecore-master-index, instead it creates sitecore-...
0
votes
0answers
15 views

Error while indexing contact data using AnalyticsIndexBuilder.aspx

I am trying to index contact data from MONGODB (Migrated from external System) using AnalyticsIndexBuilder.aspx (https://github.com/vhil/helpfulcore-analytics-index-builder) but I am getting below ...
0
votes
0answers
16 views

TypeLoadException on all custom rules that don't use the basic RuleContext type

I'm using Sitecore 8.1 rev 3. I created my custom fields inside sitecore_analytics_index. I have thus created custom Conditions that can be used to create Analytics Filters based on them, as per this ...
0
votes
0answers
53 views

Why does “Re-Index Tree” sometimes trigger indexing of message statistics

We are using Sitecore 9.0-Update-1 with EXM enabled. We are not exploiting any EXM features yet, but I have noticed that when selectively reindexing a part of the tree in Content Editor, it sometimes ...
0
votes
0answers
19 views

Number of contacts in segmentation list is not matching with XDB

We have migrated new contacts from external system to Mongo DB. We have ran the Sitecore Analytics Indexing using Helpfulcore.AnalyticsIndexBuilder. We have created segmentation list on EXM but data ...
0
votes
1answer
194 views

Sitecore reindex AlreadyClosedException: this IndexWriter is closed

Reindexing locally works fine, but when I reindex upstream I get this error: org.apache.lucene.store.AlreadyClosedException: this IndexWriter is closed How can I fix this error?
0
votes
0answers
91 views

Sitecore XConnect, Index Worker, XdbSearchUnavailableException

I am trying to search Xdb contacts on the basis of email id. using this code : var queryable = client.Contacts.Where(c => c.GetFacet<EmailAddressList>(EmailAddressList.DefaultFacetKey)....
0
votes
1answer
173 views

How to stop ongoing Indexing in Sitecore?

We have started indexing contacts by using Helpfulcore.AnalyticsIndexBuilder due to some reason we would like to stop contact indexing forcefully. May I know how can we stop indexing in Sitecore.
0
votes
0answers
39 views

Manually add/update a single record in an index

I've created a custom index to store users in based on the code found at https://gist.github.com/jorgelusar/150a607dcf96acb54b60, but because there's no Sitecore item to trigger the usual indexing ...
0
votes
0answers
44 views

Index values loss after smart publish, returns after an Index Rebuild or Republish

In the image below you can see how the search index for a sitecore item looks like before and after a Smart Publish. On the left is what I get when I recently did a Rebuild or a Republish and on the ...