Questions tagged [indexing]

Questions about indexes in Sitecore (standard or custom) in general. For questions that apply to Lucene or Solr, use the appropriate tags.

43 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
5
votes
0answers
641 views

Sitecore Solr index FieldNameTranslator is null

I am currently playing around with Sitecore indexes - both Solr and Lucene. I have made my own custom index and it works fine for Lucene, but I cannot get it to work with Solr. My problem is that ...
5
votes
1answer
285 views

Sitecore multiple CD web databases publishing/indexing EventQueue database name

Say I have a single CM with 1x master db, 1x core db and 2x web dbs (2x publishing targets) for 2x CD servers in different regions. I can't call both web dbs "web" - one must be something different, e....
4
votes
1answer
969 views

Custom Solr Fields in Sitecore 9 and Solr 7.2.1

I am converting my custom index fields from Sitecore 8.1. Previously, I would declare them like this: <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:set="http://www....
4
votes
0answers
233 views

Sitecore Index_Update Job Performance

We just updated from Sitecore 8.2 Update 4 to Update 7 and we've started seeing some strange behavior when publishing new items. The issue presents itself in that it takes awhile for newly created ...
3
votes
0answers
61 views

Sitecore indexing a SXA Multisite configuration for more than 500 sites

I am stuck with issue for indexing a SXA Multisite configuration for 600 sites. The case study is as below. Issue: Indexing get failed at certain point of time from CM itself for Solr Master(after 2 ...
3
votes
0answers
39 views

Is it possible to run a CD deployment without any indexing tools in place?

When deploying your application into e.g. Azure there are lots of configurations that allow adding or removing features. A good example would be XP vs XM. We have the situation where we don't use ...
3
votes
0answers
747 views

Error with indexWorker process in Sitecore 9 xConnect with Solr 6.6.2

I am running Sitecore 9 with Solr 6.6.2 and I am seeing lot of error in the IndexWorker logs in Sitecore xConnect as below: 018-02-21 16:16:13.686 +10:00 [Error] An error occured. System.Net.Http....
3
votes
0answers
517 views

“org.apache.solr.common.SolrException: undefined field 0001-01-01T00” when rebuilding index

When I rebuild one of my indexes in Sitecore, I get the following error in the Solr log: org.apache.solr.common.SolrException: undefined field 0001-01-01T00 I don't have a field called 0001-01-...
2
votes
0answers
35 views

Safe to delete Sitecore master/web old index after rebuild/swap?

We're using the Swap and Rebuild feature of Sitecore 9.1 when we need to rebuild our indexes for Azure Search. Occasionally, after the rebuild and swap is complete; Sitecore won't delete the old ...
2
votes
1answer
118 views

Rebuild lucene index after publishing issue

I have an issue related to the lucene index. The index is not being built when I do smart publish even if there is onPublishEndAsync added, but it does when I do republish. <strategy ref="...
2
votes
0answers
301 views

Sitecore-Core-Index rebuild at Azure Search for Sitecore 9.0.1 PaaS fails

I have deployed Sitecore 9.0.1 XP Scaled in Azure PaaS (default, no customization). It is used self-signed certificate and configured with allowInvalidClientCertificates="true" in azuredeploy....
2
votes
0answers
767 views

Sitecore.Social: Social messages index could not be determined for master database

We are on Sitecore 8.1 rev. 160519 (Update-3) and using SOLR 6.2.1 Logs on one of our CM server is suddenly overflowing with the following error message: Sitecore.Social: Social messages index ...
2
votes
0answers
63 views

Custom content search (crawler) sent old indexed ids

I have a completely custom search crawler that pushes data to Algolia. If I run the full reindex it works great. When trying to use a onPublishEndAsync strategy I see the first item come in I publish ...
2
votes
0answers
61 views

Is there any way to delay publishing and indexing when updating or creating items with the ItemService?

I am syncing a significant amount of data into Sitecore from external systems on a fairly regular basis. To do this, I am utilizing the Sitecore ItemService. The problem I'm currently facing is that ...
2
votes
3answers
82 views

How to rename Azure Search index

I tried to index master, web indexes using the Azure Search service. Indexing works fine, but we have a requirement to have the index names unique in Azure as we are using single search services for ...
1
vote
1answer
122 views

Could not create instance of type: Sitecore.ContentSearch.Azure.CloudSearchProviderIndex. No matching constructor was found

Currently in progress of upgrading from Sitecore 8.1 to 8.2 update 7. So I'm currently converting existing indexes from luecene to Azure search, I have done all the basic steps like, disabling all the ...
1
vote
0answers
33 views

Sitecore 9.2 JSS with Solr 7.5 , JSS route items and its subitems are not indexing

Currently we are developing Sitecore JSS app with React frontend. in this we are using Headless SSR mode to create the content in sitecore and rendering. our application is working fine with React, ...
1
vote
0answers
86 views

Security Error Rebuilding Indexes

Sitecore 8.1 rev. 160302. Looking into my logfiles, there are lots of errors such as: Job Started: Index_Update_IndexName=RSearch ... Exception: System.NullReferenceException Message: Object ...
1
vote
0answers
144 views

Custom index, stategy to publish items under a certain path

We have this custom index that only contains pages for one section of the content tree. We want it setup so that publishing items under this path reindexes those items automatically. This seems like ...
1
vote
0answers
39 views

Search index not updating for new site nodes

I have created new site node and my web site search functionality is not working for the new site. I have rebuilt the search index from the Indexing Manager and I have checked the indexes, it seems ...
1
vote
0answers
1k views

The remote server returned an error: (400) Bad Request Error while building the custom index in SOLR 5.1

We have created a custom Itembuket_community and rebuliding the index. while Rebuilding the index, getting follwoing error Job started: Index_Update_IndexName=sitecore_Community_index|#Exception: ...
1
vote
0answers
140 views

PowerShell find-item doesn't return values

I'm currently using find-item on Sitecore PowerShell Find-Item -Index sitecore_master_index -Criteria @{Filter = "Equals"; Field = "recipe id"; Value = "Recipe_Lambada"}, @{Filter = "DescendantOf"; ...
1
vote
0answers
65 views

Search results error on single server setup

We have a client site that is spread across 2 cd's and 1 cm which we have migrated to a single server instance for QA purposes. The production site has a public address for the cd's and a private ...
1
vote
0answers
27 views

Sitecore 8.2 integrated search function with Salesforce

This is my first question for SE...and forgive my lack of technical expertise in this area. We're building a our new website on Sitecore which has to be integrated with Salesforce. In Saleforce, we ...
1
vote
0answers
76 views

Solr query on read/deny roles

We have a custom Solr index which includes read and deny roles. Both are added as predicates using the following code: protected virtual IQueryable<TIndexable> ApplyDenyUserRules<TIndexable&...
0
votes
1answer
27 views

Indexing Boost value, Boosting rules, and Facets

I'm using Sitecore 9.0 (Solr 6.6.2) and am confused by the "Indexing" section found on items. Through experimentation I've found that entering a number may or may not actually change the search ...
0
votes
1answer
36 views

Can a TOKENIZED index field be remapped to an UNTOKENIZED field of a different name without using a computed? (LUCENE)

Having some search issues with using the "Name" field on items ("_name") I'd like to map it to another field that I can search on without having to create a custom computed field to do the mapping. ...
0
votes
0answers
13 views

Error while indexing contact data using AnalyticsIndexBuilder.aspx

I am trying to index contact data from MONGODB (Migrated from external System) using AnalyticsIndexBuilder.aspx (https://github.com/vhil/helpfulcore-analytics-index-builder) but I am getting below ...
0
votes
0answers
28 views

Why does “Re-Index Tree” sometimes trigger indexing of message statistics

We are using Sitecore 9.0-Update-1 with EXM enabled. We are not exploiting any EXM features yet, but I have noticed that when selectively reindexing a part of the tree in Content Editor, it sometimes ...
0
votes
0answers
17 views

Number of contacts in segmentation list is not matching with XDB

We have migrated new contacts from external system to Mongo DB. We have ran the Sitecore Analytics Indexing using Helpfulcore.AnalyticsIndexBuilder. We have created segmentation list on EXM but data ...
0
votes
1answer
27 views

Sitecore reindex AlreadyClosedException: this IndexWriter is closed

Reindexing locally works fine, but when I reindex upstream I get this error: org.apache.lucene.store.AlreadyClosedException: this IndexWriter is closed How can I fix this error?
0
votes
0answers
48 views

Sitecore XConnect, Index Worker, XdbSearchUnavailableException

I am trying to search Xdb contacts on the basis of email id. using this code : var queryable = client.Contacts.Where(c => c.GetFacet<EmailAddressList>(EmailAddressList.DefaultFacetKey)....
0
votes
0answers
32 views

Manually add/update a single record in an index

I've created a custom index to store users in based on the code found at https://gist.github.com/jorgelusar/150a607dcf96acb54b60, but because there's no Sitecore item to trigger the usual indexing ...
0
votes
0answers
33 views

Index values loss after smart publish, returns after an Index Rebuild or Republish

In the image below you can see how the search index for a sitecore item looks like before and after a Smart Publish. On the left is what I get when I recently did a Rebuild or a Republish and on the ...
0
votes
0answers
55 views

Unable to populate boolean field from index value

My Lucene web Index is correctly populated with the field parsed_is_line_manager. In the BasePerson class, I thus added this field: [SitecoreIgnore] [IndexField("parsed_is_line_manager")] public ...
0
votes
0answers
270 views

ERROR Year, Month, and Day parameters describe an un-representable DateTime

We are receiving below errors during Indexing. We are on Sitecore 9 update-2, SXA 1.7.1 and using Azure search. The errors below seems related to SXA fields. Has anyone come across this issue? 10752 ...
0
votes
0answers
176 views

Duplicate item records in SOLR index (web)

We have a strange issue on our UAT environment where duplicate records are being returned for a single content item in a new web index we have created and both are marked with 'latestversion:true' (...
0
votes
0answers
61 views

Sitecore index update strategy manual

In an experiment, I want to build the site specific index in the CD environment manually right after publish event. I created a processor which is hooked in the publish end event for rebuilding the ...
0
votes
0answers
103 views

Solr query works in the web UI, not when invoked though code

I'm on Solr 4.10.4, Sitecore 8.1 160519. I have a query used internally by my application that returns 0 records. In the Search.log I can see that same query; if I copy the querystring value to the ...
0
votes
0answers
434 views

SOLR search index not updating

I've renamed fields on a Sitecore template from uuid to uuid2, but for some records the solr index contains items with the field name uuid (in SOLR admin). I've populated my SOLR schemas again and ...
0
votes
0answers
220 views

SOLR on load balance

I have 2 CD instances. When I enable both the instances I get below error on website Index proj_web_index was not found. Although it works fine when only one instance is enabled. Indexes are on ...
0
votes
2answers
521 views

Adding custom contact facet to Sitecore Analytics index

Sitecore 8.2 Update 4 with Lucene search on a local single instance Sitecore site: I have created a Custom Contact facet and I can see it is being saved to MongoDB. I want to add it to the Analytics ...
-1
votes
1answer
46 views

How to give few rendering's data in custom API response

Hi please see the picture below, so that I can tell you the requirement. Now, I have a requirement as, if I see page-1 there is content on this page which is coming from following renderings: Header, ...