Questions tagged [indexing]

Questions about indexes in Sitecore (standard or custom) in general. For questions that apply to Lucene or Solr, use the appropriate tags.

Filter by
Sorted by
Tagged with
0
votes
1answer
293 views

Index Subtree Of Items For A Specific Index

Is there a way to index a subtree of items for one specific index in code? I know there's the reindex tree button but that reindexes the subtree for all indexes the items are in. I don't see a good ...
0
votes
2answers
628 views

Error while rebuilding the search index on Sitecore 8.2 and Solr 6.6.1

We are able to successfully build all the indexes for the first time except sitecore_master_index, sitecore_web_index and Sitecore_core_index And when trying to rebuild sitecore_master_index for the ...
0
votes
1answer
231 views

Sitecore 8.2 Lucene Indexes Syncing Between CD and CM Servers

We have a custom Lucene index configured on our Content Management and Content Delivery server. The rebuild strategies on the index are <strategies hint="list:AddStrategy"> <strategy ref="...
0
votes
1answer
138 views

sitecore_web_index corrupted on Content Delivery server [closed]

What does the Lucene sitecore_web_index do on the Content Delivery server? How can it become corrupted?
1
vote
0answers
1k views

The remote server returned an error: (400) Bad Request Error while building the custom index in SOLR 5.1

We have created a custom Itembuket_community and rebuliding the index. while Rebuilding the index, getting follwoing error Job started: Index_Update_IndexName=sitecore_Community_index|#Exception: ...
1
vote
0answers
140 views

PowerShell find-item doesn't return values

I'm currently using find-item on Sitecore PowerShell Find-Item -Index sitecore_master_index -Criteria @{Filter = "Equals"; Field = "recipe id"; Value = "Recipe_Lambada"}, @{Filter = "DescendantOf"; ...
2
votes
1answer
676 views

No Indexes showing in Index Manager on Azure CM AppService

We have created our Sitecore production environment (Sitrecore 8.2 Update 5, EXM + XDB Cloud) using ARM templates. This means we have CM, CD, Reporting, Processing and DDS (Data Distribution Server) ...
5
votes
1answer
943 views

How to configure Sitecore to index “everything but something” or “nothing but something”?

In one of the video from "Search Driven" module of Sitecore 9.0 Essential for Developers e-learning, the speaker says "You can configure Sitecore to index everything but something or nothing but ...
3
votes
1answer
183 views

What are some methods for indexing and searching content from multiple sites? [closed]

Pretend you have a small client that is on Sitecore 8.2 on-premise (virtual servers). Traffic is pretty light, and they get away with using just 2 servers (1 DB and 1 Web). Needless to say budget is ...
7
votes
1answer
591 views

Is it possible to get Azure Search to support EDM.GeographyPoint?

With regard to spatial searching capabilities of Azure Search in Sitecore. How do you go about customising your index configuration so that you can perform spatial searching using the OData geospatial ...
2
votes
1answer
186 views

How to correctly process index dependencies for correct language?

I am updating index dependencies as mentioned in Sitecore Full Content Search where we are using GetDatasourceDependencies. Now, the issue is that this works fine for the English language, but, ...
2
votes
2answers
300 views

Sitecore HTML Indexing

We have custom indexer which indexes all the RTF Data in present in content tree and this indexed RTF Data can have Div's ,breaker Tags and anchor tags. When we get search result out from Solr we ...
3
votes
1answer
432 views

Sitecore Azure Search - There is no appropriate index for /sitecore - {11111111-1111-1111-1111-111111111111}

I have a Sitecore 9.0.1 instance running in Azure and uses Azure Search. My search index is working as far as I know and can be rebuilt. Earlier this week, I hit the problem with Sitecore Azure ...
1
vote
0answers
65 views

Search results error on single server setup

We have a client site that is spread across 2 cd's and 1 cm which we have migrated to a single server instance for QA purposes. The production site has a public address for the cd's and a private ...
3
votes
0answers
749 views

Error with indexWorker process in Sitecore 9 xConnect with Solr 6.6.2

I am running Sitecore 9 with Solr 6.6.2 and I am seeing lot of error in the IndexWorker logs in Sitecore xConnect as below: 018-02-21 16:16:13.686 +10:00 [Error] An error occured. System.Net.Http....
0
votes
3answers
353 views

Lucene Search Indexing Issue

In a project, I have used Lucene Search. Earlier everything was working fine. But from last few days I am facing issue in getting items through search on production server. I performed Index ...
7
votes
1answer
1k views

How do you programmatically exclude an item from being indexed?

We would like to exclude items from being indexed. Ideally, we want this control to be within Sitecore so that as new pages get created, content authors can determine whether to index them as they ...
1
vote
1answer
310 views

SItecore 8.2.6 - IndexField attribute is not recognized in code

IndexField attribute is not recognized although Sitecore.ContentSearch.dll reference is added and namespace is included.
2
votes
3answers
3k views

Custom index field returning “Server Error in '/' Application. Could not find add method: AddComputedIndexField”

I am trying to create a commuted index field in sitecore 9 but can't get the configuration to work. I have a local environment which is running Solr and also environment is Azure. I have added the ...
11
votes
1answer
2k views

How does Sitecore decide the Index to use with GetIndex

A new index was added to a Sitecore instance I am working on. This ended up causing a different module in the implementation to have a problem. The part having an issue uses Sitecore.ContentSearch....
8
votes
1answer
1k views

Custom index configuration cannot work for Sitecore 9.0.1 in Azure

I got a trouble about custom index with Sitecore 9.0.1 in Azure. My custom index configuration can rebuild successfully and this index can create in Azure search with Sitecore 9.0. After I changed to ...
1
vote
0answers
27 views

Sitecore 8.2 integrated search function with Salesforce

This is my first question for SE...and forgive my lack of technical expertise in this area. We're building a our new website on Sitecore which has to be integrated with Salesforce. In Saleforce, we ...
2
votes
0answers
767 views

Sitecore.Social: Social messages index could not be determined for master database

We are on Sitecore 8.1 rev. 160519 (Update-3) and using SOLR 6.2.1 Logs on one of our CM server is suddenly overflowing with the following error message: Sitecore.Social: Social messages index ...
0
votes
1answer
1k views

Web indexes not updated upon publish

I am hoping to understand the cause of this and hopefully find a solution - I have looked at every possible solution, but haven't been able to fix it. Sitecore v8.2 update 3 using SOLR. In my ...
2
votes
0answers
63 views

Custom content search (crawler) sent old indexed ids

I have a completely custom search crawler that pushes data to Algolia. If I run the full reindex it works great. When trying to use a onPublishEndAsync strategy I see the first item come in I publish ...
0
votes
0answers
220 views

SOLR on load balance

I have 2 CD instances. When I enable both the instances I get below error on website Index proj_web_index was not found. Although it works fine when only one instance is enabled. Indexes are on ...
0
votes
2answers
527 views

Adding custom contact facet to Sitecore Analytics index

Sitecore 8.2 Update 4 with Lucene search on a local single instance Sitecore site: I have created a Custom Contact facet and I can see it is being saved to MongoDB. I want to add it to the Analytics ...
0
votes
2answers
221 views

Restricting some item from being indexed

We are using search index in our website and we want to restrict some items based on conditions. Any suggestions will help us.
1
vote
0answers
76 views

Solr query on read/deny roles

We have a custom Solr index which includes read and deny roles. Both are added as predicates using the following code: protected virtual IQueryable<TIndexable> ApplyDenyUserRules<TIndexable&...
2
votes
0answers
61 views

Is there any way to delay publishing and indexing when updating or creating items with the ItemService?

I am syncing a significant amount of data into Sitecore from external systems on a fairly regular basis. To do this, I am utilizing the Sitecore ItemService. The problem I'm currently facing is that ...
6
votes
4answers
2k views

When and why to create a custom index

In my experience, the default sitecore_master_index and sitecore_web_index work pretty fast with Solr. We have around 1 million documents in the index and it returns a result in between 0 to 10ms. I ...
3
votes
1answer
176 views

Lucene fails to start up properly on CD Server

We have a CM/CD setup where the CM works as intended, but the CD does not. The problem is that after following Sitecores guides on how to configure a CD server, lucene indexing seems to be ...
2
votes
1answer
1k views

An error occurred while rebuilding the search index

I am unable to build the Coveo for Sitecore master index. While the rebuild is supposedly happening, the number of items processed is always 0. In the Sources of the cloud panel, the index doesn't ...
5
votes
1answer
1k views

SOLR Custom Index Causing Error

I am converting a Lucene custom index to a SOLR custom index. I got the Cores working for the default indexes, but having trouble converting my custom indexes. I got through some of the issues, but ...
6
votes
1answer
160 views

Using custom classes in LinqScratchPad.aspx

The problem The default/sample code in the LinqScratchPad.aspx shows a TryYourOwnClass class. Sadly, this class is not used in any way in the sample. The sample code looks like this: namespace Test ...
3
votes
0answers
519 views

“org.apache.solr.common.SolrException: undefined field 0001-01-01T00” when rebuilding index

When I rebuild one of my indexes in Sitecore, I get the following error in the Solr log: org.apache.solr.common.SolrException: undefined field 0001-01-01T00 I don't have a field called 0001-01-...
1
vote
0answers
65 views

Sitecore PDF Document Content Indexing with Lucene [duplicate]

I assume with the latest releases of Sitecore (8.2), PDF and other document indexing comes by default. Can someone please point me to a document related to any setting, to enable these media document ...
5
votes
0answers
643 views

Sitecore Solr index FieldNameTranslator is null

I am currently playing around with Sitecore indexes - both Solr and Lucene. I have made my own custom index and it works fine for Lucene, but I cannot get it to work with Solr. My problem is that ...
2
votes
1answer
645 views

Rebuilding custom Index on Sitecore Azure WebApp doesn't work

I'm new to Azure deployments. We have installed Sitecore 8.2 webapp and deployed and everything works fine except that our custom indices have not been created. Pages that use indices crash. ...
9
votes
4answers
4k views

How does one verify that an item is properly indexed in Sitecore?

How do I figure out whether or not an item is indexed properly? Indexing depends on which tables in the Sitecore DBs? When I search for an item in the search field, I am not able to fetch the item. ...
1
vote
1answer
1k views

502 Bad Gateway error when reindexing with Solr to localhost address

I'm using the Bitnami Solr 6.5.1 installer, and I've used it successfully on other servers. On our QA server, which is sharing CM/CD in one site and has Solr installed locally, I'm getting the ...
5
votes
1answer
3k views

Solr multivalued fields

We are currently working on migrating from Lucene to Solr and we're having a couple of issues with our index data. There hasn't been any code changes so we're assuming it is stemming from the indexed ...
11
votes
2answers
2k views

Indexing PDF content with Solr error

I've been trying to get Solr configured right with Sitecore, but the one bit that's still causing background errors is indexing PDF content. I've been searching about and I'm not finding a clear-cut ...
2
votes
1answer
570 views

Do I really need MediaItemContentExtractor if I'm not indexing media?

I have a site that allows visitors to upload a PDF via a WFFM form. However, each time a visitor does so, the logs fill up with the following errors: ManagedPoolThread #2 17:14:20 WARN Could not ...
7
votes
2answers
883 views

Azure Search indexes are not created

We are seeing a lot of Depenendy Failures in Application Insights because some non exisiting Azure Search indexes are queried. The following indexes on Azure search return a 404: sitecore-marketing-...
2
votes
2answers
4k views

SolrNet.Exceptions.SolrConnectionException: The operation has timed out

After sitecore upgrade from 7.2 to 8.2u3 and solr from 5.4.1 to v6.1, below solr timeout starts to happen in one server, works fine in local machine setup. We have increased from 125500 (on local ...
3
votes
1answer
707 views

Why does Rebuilding a Search Index peg my CPU at 100%?

If I rebuild any search index, whether through Indexing Manager, or programatically, the CPU pegs at 100% until the rebuilding operation completes. This happens on development machines and production ...
2
votes
1answer
1k views

Indexing options are not showing up in sitecore control panel (v8.2 update 3) and developer tab is not visible

We are in the process of upgrading sitecore website from v7.2 to v8.2 and are not seeing the indexing manager links in sitecore control panel and Developer tab is also not showing up within content ...
3
votes
2answers
2k views

Index has not been initialized on content delivery server

I'm using Sitecore on Azure, and I followed the wizard to create a project with a CD and a CM. I have a custom index SinglePageUrl on both of them with a web and a master version to Rewrite some ...
2
votes
1answer
526 views

Reference field computed index field in multiple language

My sitecore item contains dropdown for City, state, category etc. It's all in multiple languages but on sitecore item dropdown, it's appearing in english only. I've created computed index field for ...