Questions tagged [indexing]

Questions about indexes in Sitecore (standard or custom) in general. For questions that apply to Lucene or Solr, use the appropriate tags.

Filter by
Sorted by
Tagged with
5
votes
1answer
1k views

SOLR Custom Index Causing Error

I am converting a Lucene custom index to a SOLR custom index. I got the Cores working for the default indexes, but having trouble converting my custom indexes. I got through some of the issues, but ...
6
votes
1answer
163 views

Using custom classes in LinqScratchPad.aspx

The problem The default/sample code in the LinqScratchPad.aspx shows a TryYourOwnClass class. Sadly, this class is not used in any way in the sample. The sample code looks like this: namespace Test ...
3
votes
0answers
528 views

“org.apache.solr.common.SolrException: undefined field 0001-01-01T00” when rebuilding index

When I rebuild one of my indexes in Sitecore, I get the following error in the Solr log: org.apache.solr.common.SolrException: undefined field 0001-01-01T00 I don't have a field called 0001-01-...
1
vote
0answers
65 views

Sitecore PDF Document Content Indexing with Lucene [duplicate]

I assume with the latest releases of Sitecore (8.2), PDF and other document indexing comes by default. Can someone please point me to a document related to any setting, to enable these media document ...
5
votes
0answers
658 views

Sitecore Solr index FieldNameTranslator is null

I am currently playing around with Sitecore indexes - both Solr and Lucene. I have made my own custom index and it works fine for Lucene, but I cannot get it to work with Solr. My problem is that ...
2
votes
1answer
654 views

Rebuilding custom Index on Sitecore Azure WebApp doesn't work

I'm new to Azure deployments. We have installed Sitecore 8.2 webapp and deployed and everything works fine except that our custom indices have not been created. Pages that use indices crash. ...
9
votes
4answers
4k views

How does one verify that an item is properly indexed in Sitecore?

How do I figure out whether or not an item is indexed properly? Indexing depends on which tables in the Sitecore DBs? When I search for an item in the search field, I am not able to fetch the item. ...
1
vote
1answer
1k views

502 Bad Gateway error when reindexing with Solr to localhost address

I'm using the Bitnami Solr 6.5.1 installer, and I've used it successfully on other servers. On our QA server, which is sharing CM/CD in one site and has Solr installed locally, I'm getting the ...
4
votes
1answer
596 views

How do you stop optimizing sitecore_analytics_index

We have our analytics_index over 150 million documents now (with Solr on a standalone windows server). How can we stop Sitecore from optimizing the index? Solr says optimizing should only be done on ...
5
votes
1answer
3k views

Solr multivalued fields

We are currently working on migrating from Lucene to Solr and we're having a couple of issues with our index data. There hasn't been any code changes so we're assuming it is stemming from the indexed ...
11
votes
2answers
2k views

Indexing PDF content with Solr error

I've been trying to get Solr configured right with Sitecore, but the one bit that's still causing background errors is indexing PDF content. I've been searching about and I'm not finding a clear-cut ...
2
votes
1answer
595 views

Do I really need MediaItemContentExtractor if I'm not indexing media?

I have a site that allows visitors to upload a PDF via a WFFM form. However, each time a visitor does so, the logs fill up with the following errors: ManagedPoolThread #2 17:14:20 WARN Could not ...
7
votes
2answers
974 views

Azure Search indexes are not created

We are seeing a lot of Depenendy Failures in Application Insights because some non exisiting Azure Search indexes are queried. The following indexes on Azure search return a 404: sitecore-marketing-...
2
votes
2answers
4k views

SolrNet.Exceptions.SolrConnectionException: The operation has timed out

After sitecore upgrade from 7.2 to 8.2u3 and solr from 5.4.1 to v6.1, below solr timeout starts to happen in one server, works fine in local machine setup. We have increased from 125500 (on local ...
3
votes
1answer
738 views

Why does Rebuilding a Search Index peg my CPU at 100%?

If I rebuild any search index, whether through Indexing Manager, or programatically, the CPU pegs at 100% until the rebuilding operation completes. This happens on development machines and production ...
2
votes
1answer
1k views

Indexing options are not showing up in sitecore control panel (v8.2 update 3) and developer tab is not visible

We are in the process of upgrading sitecore website from v7.2 to v8.2 and are not seeing the indexing manager links in sitecore control panel and Developer tab is also not showing up within content ...
3
votes
2answers
2k views

Index has not been initialized on content delivery server

I'm using Sitecore on Azure, and I followed the wizard to create a project with a CD and a CM. I have a custom index SinglePageUrl on both of them with a web and a master version to Rewrite some ...
2
votes
1answer
531 views

Reference field computed index field in multiple language

My sitecore item contains dropdown for City, state, category etc. It's all in multiple languages but on sitecore item dropdown, it's appearing in english only. I've created computed index field for ...
5
votes
2answers
833 views

Combining multiple Items into one Document

Sitecore indexing works great for simple indexing scenario's, as the main working entity is a sitecore item. With computed fields you can add custom logic and fields for a record. But I have 2 more ...
5
votes
1answer
233 views

Sitecore Lucene indexing two versions of the same keyword

Here is the situation: I have three items - Categories - Corporate, Financial and Product which I am using to categorize other items. They can be selected from a Droplink field (so Sitecore holds ID ...
3
votes
1answer
1k views

Duplicate Item in Lucene Index [duplicate]

I have a Lucene index for the Master db. It seems like every save creates a new entry in the Lucene index. At first I thought it was versioning but as you can see in the screen shot, it's the same ...
5
votes
0answers
522 views

Rebuild reporting database. Exception Message: String or binary data would be truncated

Sitecore 8.0 update 5 I've set up clean sitecore.analytics and sitecore.analytics_secondary databases. Also I've deployed the Marketing Definitions and ran necessary SQL script to copy data from old ...
0
votes
1answer
986 views

Recursive read lock acquisitions not allowed in this mode

Im using Sitecore 7.2 on a split CM/CD environment. When I publish an item on the CM I get: ManagedPoolThread #73 10:01:10 ERROR Could not update index entry. Action: 'Saved', Item: '{8EDE5C9E-265D-...
6
votes
2answers
9k views

Value cannot be null. Parameter name: fieldNameTranslator - Opening Content Editor [closed]

I was trying to setup the Sitecore with Solr. I created the Default Instance and added Solr. I use Castle Windsor as IOC, updated the Global.asax. Since I was not able to download the Solr Support ...
7
votes
4answers
1k views

Sitecore 7.2 Not rebuilding Lucene Index

We're using Sitecore 7.2 Update 4, and have 6 Lucene indexes across our sites in a single Sitecore instance. In the production environment, but not locally or on staging, the web index is not rebuilt ...
3
votes
2answers
527 views

What is the difference between Indexing via an ISearchIndex object and using IndexCustodian?

The best I could find in documentation was this: Rebuild search indexes ... but that doesn't really help me. I'm trying to do this programatically an would like best practices for doing this sort of ...
3
votes
3answers
1k views

An index with the name “sitecore_web_index” have already been added

I'm trying to setup custom Lucene indexing but getting An index with the name "sitecore_web_index" have already been added.. Here's my config files. Have I missed something out? CustomSpatialIndex....
2
votes
1answer
384 views

Index are not updating after db restore

I restored databases from production to Test environment. After that index's are not working with OnPublishEnd strategy. Could you please help me. I have truncated History,EventQueue and ...
3
votes
1answer
718 views

Using alternate ContentSearch analyzers

I am looking into using some of the alternate analyzers provided in the Sitecore.ContentSearch.LuceneProvider.Analyzers namespace. Specifically what I would like to achieve is to: Create copies of ...
0
votes
5answers
2k views

“$name” showing up in website content

We have a website that uses a lot of search indexes, and today some of the dropdowns are displaying "$name" as the first item in the dropdown list. I've done some googling and some say it is due to ...
5
votes
2answers
413 views

What is the correct root node for 'sitecore_marketingdefinitions_master' index?

I am working on a task to move a Sitecore installation search from Lucene to Solr on Sitecore version 8.2. I am using Solr version 5.1 as it is the recommended version for sitecore 8.2. All the other ...
4
votes
1answer
429 views

Appending index fields in Lucene

Does anyone know if it is possible to append a Lucene computed index field's value? Say that there is a computed index field that stores a list of ids based on some generic logic. Then there is an ...
4
votes
1answer
533 views

Lucene search in load balance environment is not showing proper results

I'm using Lucene for Search in Load balanced environment. Indexes are working fine, but sometimes index is updating in only one of the servers. If we rebuild the index manually then its showing proper ...
0
votes
1answer
419 views

Custom Lucene Index Field with Children

I want to create a custom field to be indexed in Lucene that has the children of the item being indexed. Is there an easy way to do this that I am overlooking?
6
votes
2answers
392 views

Master index updated even though manual strategy is set

I have changed update strategy for Master database to be "manual" rather than "sync", which to my understanding should not update "master" when data changes in master database. I can see in crawling ...
8
votes
2answers
1k views

Issue with multiple crawlers on Solr custom search index

I have custom search Index(SOLR) which has two root locations defined, one points to /home node and another points to repository(videos), we also have indexing strategy(onPublishEndAsync) in place. &...
4
votes
2answers
1k views

How do I rebuild the Quick Search Index in Sitecore 8.2?

I've upgraded my solution from sitecore 8.1 Update 1 to Sitecore 8.2 initial release. After finishing the upgrade, and configuration changes, I opened the launchpad to rebuild Quick Search Index, I ...
7
votes
1answer
382 views

Performance Issue With Facets

We are having some performance issue when setting Datasources and Linking items in Sitecore 8.2. The test server just hangs when trying to expand a node in the dialog box. The CPU spikes to 100% and ...
3
votes
2answers
1k views

Remote CD Indexing Not Working

Republish All Items (Completed with no errors) Rebuild Indexes Using Control Panel (Completed with no errors) Inspect Data/indexes directory. (Date modified is from over a month ago) Verified correct ...
8
votes
3answers
809 views

Lucene analytics index constantly loads HDD

We see performance issue on CM server. Content editor is very slow periodically and resource monitor shows that HDD is busy - reading and writing sitecore_analytics_index files nearly 50% of the time. ...
2
votes
1answer
567 views

Representing relational data in Lucene/Solr index for Segmented lists

Scenario: In Sitecore Experience platform (8.1+) we have a xProfile/Contact, with zero-to-many Sitecore Certifications relation, as an example The contact Arthur Dent has over the years has earned ...
4
votes
2answers
486 views

Can Azure Search be combined with on premises Sitecore hosting?

We are preparing a Sitecore upgrade and looking into Azure Search for indexing. Can anyone tell me if Azure Search can be comined with on premises hosting? Or do you need to host Sitecore in Azure to ...
5
votes
3answers
2k views

Lucene indexing item url

I'm struggling to get the Sitecore item url from indexing, the SearchResultItem.url is always null. I tried creating a ComputedField but I'm not getting the correct url. With Sitecore.Links....
5
votes
2answers
2k views

How to delete a Contact programmatically in xDB

Does anyone know how delete/remove a xDB Contact programmatically in Sitecore (8.1+), which also ensures a correct (re)-indexing? Or, is there another strategy? Such as scrambling the identifier? - ...
12
votes
2answers
2k views

Indexing jobs queued

On the CM server, all jobs are getting queued, after the following jobs appear in a running state: UpdateIndex_filesystem Indexing Running False 08.11.2016 15:43:19 ...
13
votes
4answers
4k views

How to switch Lucene to Solr

We are planning on changing from Lucene to Solr due to number of items and because we have more than one CM server. What are the steps needed to migrate default lucene indexes to Solr? Is it just a ...
13
votes
1answer
1k views

If I unpublish an item will Sitecore update the search index?

I have a Sitecore 8.1 / Solr 4.10 instance. I know that if I add a new content item or I delete a content item and then publish, that Sitecore is smart enough to do a partial rebuild of the Solr ...
2
votes
1answer
285 views

What are the consequences of disabling the analytics index?

If I were to delete the data from the analytics index, and then disable the observables declared in the in the crawlers defined here, Sitecore.ContentSearch.Lucene.Index.Analytics.config <index ...
11
votes
2answers
1k views

How can I reduce the size of the analytics index? [alt: Populating the Analytics Index]

I'm working with a customer right now that has seen their Solr implementation become unstable lately. Based on some initial analysis, signs are pointing towards the analytics index. They've been live ...
5
votes
2answers
402 views

Helix and Computed Index Fields with DI

In my solution, I have some Computed Index Fields that I need to add that combine the values of fields from templates that belong to multiple Project-layer modules. I am using DI for initializing my ...