Questions tagged [installation]

For questions related to the installation of a Sitecore instance, package, or update package

Filter by
Sorted by
Tagged with
0
votes
1answer
41 views

Sitecore 10 Installation Error: Failed to Start Service 'Sitecore Marketing Automation Engine' while an instance of 9.0.2 also running on my system

Note: I have multiple solr installed on my local environment one is for previous version and now I have added solr for sitecore 10 on port 8984 So my solr path for the sitecore 10 is https://localhost:...
1
vote
0answers
38 views

Install Sitecore 10 without admin access to SQL Server or user sa

I want to install Sitecore but not having user admin user for SQL Server. Anyway of installing this with Windows authentication.
0
votes
0answers
38 views

Getting Started template - Unable to find package Microsoft.Build.CentralPackageVersions. No packages exist with this id in source(s): Nuget, Sitecore

Getting Started template Sitecore 10 While running up.ps1 getting below errors: C:\build\Directory.Build.targets : warning : Unable to load the service index for source https://api.nuget.org/v3/index....
0
votes
1answer
27 views

Getting Started template Sitecore 10- running up.ps1 - failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0

Trying to do local Sitecore 10 setup using Getting Started Template. While running up.ps1 getting error failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0: ...
1
vote
1answer
18 views

Sitecore 10.2 Horizon Internal Server Error

After installing Sitecore 10.2 Horizon I got this error. I compared this with Sitecore 10.1 Horizn web.config and found a change for modules="AspNetCoreModuleV2". Here is the section <...
1
vote
1answer
75 views

Not Able to Sync Azure Key Vault Secrets Into Sitecore Pods

I'm following this Microsoft document to integrate AKS with KeyVault: https://docs.microsoft.com/en-us/azure/aks/csi-secrets-store-driver I'm using Sitecore 10.1.0 that uses AKS, my idea is to sync ...
1
vote
1answer
35 views

The compatibility level of the target schema 150 is not supported

I did try to search for Answer, could not find. I am trying to install Sitecore 10. I am getting below error. "The compatibility level of the target schema 150 is not supported" can you ...
0
votes
1answer
52 views

Installation Sitecore 10.1.1 SIA error

I am trying to Install Sitecore 10.1.1, while on first step, in prerequisite installation, I am getting below error: "The term 'Get-PackageProvider' is not recognized as the name of a cmdlet, ...
0
votes
0answers
44 views

Sitecore Identity Server GetToken, No signing credential is configured. Can't create JWT token Error

13:41:45 User profile is available. Using '"C:\windows\system32\config\systemprofile\AppData\Local\ASP.NET\DataProtection-Keys"' as key repository and Windows DPAPI to encrypt keys at rest. ...
0
votes
1answer
66 views

Sitecore developer workstation requirement for Sitecore Experience Platform (XP Single)

I am new in Sitecore and now I am trying to setup my machine. I want to ask you that what is a recommendation for developer workstation in terms of below points: RAM CPU Disk Any other specific ...
0
votes
1answer
63 views

Sitecore Commerce 10 installer Commerce Ops Bootstrap

My Sitecore commerce installer fails to bootstrap commerce services. I made sure my Sitecore XP installer doesn't get interrupted and the XP is working. Any idea what could be causing this problem? ...
0
votes
2answers
44 views

Sitecore Commerce installer SXA framework install module [closed]

My Sitecore commerce installer is throwing an error 404 when it tries to access the page http://sxa.sotefront.com/SiteUtilityPages/Installmodules?=... I made sure my Sitecore XP installer doesn't get ...
-1
votes
1answer
46 views

Sitecore 9.2 with JSS installation Error

I am new in Sitecore and I am working on a project it is in Sitecore 9.2 and JSS. For the installation I am referring to the below URL: https://github.com/Sitecore/Sitecore.HabitatHome.Utilities/tree/...
0
votes
2answers
44 views

How to Provision Sitecore 9.3 XP scaled in Azure as App Services only for CM and CD role using Azure tool kit

We have an requirement to provision fresh Sitecore 9.3 XP scaled in Azure as App Services only for CM and CD role. We don't need xDB and EXM as of now but may be it will be configure in future. But as ...
0
votes
1answer
139 views

Collection was modified; enumeration operation may not execute

We are installing Sitecore 9.3 SXA Vanilla instance and after completing the installation I have created an aspx page that will be executed from PowerShell and that will install some packages on the ...
0
votes
1answer
39 views

Find Controller That Is Installed From a Package

I Installed Sitecore Twitter Feed Integration package from the market place. The module installs a controller called SitecoreTwitterFeed.Web.Controllers.TwitterController, which I'm trying to view its ...
1
vote
1answer
57 views

Installing Sitecore 9.3 Offline

I am trying to Install Sitecore 9.3 in one of our servers (not connected to internet). But in the end it throws this error. I installed Solr separately before installing Sitecore using traditional ...
1
vote
0answers
48 views

Not able to create Web DB on Separate Web SQL server

We are installing Sitecore 9.3 using XP scaled topology, and while setting up the CM server we have to install only the Web Database to the Web SQL server and other Databases (Master, Core, Experience ...
2
votes
1answer
123 views

Sitecore Commerce installation fails in Docker

Using - Sitecore.Commerce.Container.SDK.2.0.159 We were able to successfully install Sitecore XP 10.1 in docker on our local machine running on Windows 10 64-bit. However, when we tried to install ...
0
votes
1answer
238 views

Error: spawn 'Files\Git\dist\' ENOENT - The system cannot find the path specified

I have installed a fresh Sitecore 9.2 install and I'm trying to deploy an existing react solution to my local. When I run the npm build task I get the following error. > my-sitecore-site@1.2.0 ...
0
votes
1answer
47 views

Configuration options for xConnect when installing Sitecore 10 XP1 using Sitecore Installation Framework (SIF)

My question is related to the configuration of SIF installation scripts for the xConnect component. There are some options within the example XP1 topology scripts for which I need some additional ...
1
vote
1answer
68 views

Error While Installing a Package in sitecore 9.0.1

I am getting this below error when i try to install a package in sitecore 9.0.1 with sxa 1.7 Log Error ManagedPoolThread #2 12:19:48 ERROR One or more exceptions occurred while processing the ...
0
votes
1answer
22 views

Is it possible to install Sitecore in Client Only mode on CD server with private IP not public IP of Database Server?

For Sitecore 8.1 , is it anyhow possible to install Sitecore in Client only mode on CD using Private IP of Remote SQL instance Database server during installation, if Database server and CD server are ...
1
vote
1answer
167 views

"Execution Timeout Expired" exception while installing Sitecore 10.1

I was trying to install the latest Sitecore 10.1. While installing it, I got the below exception. [-------------- XConnectXP0_InstallWDP : WebDeploy ---------------------------] [WebDeploy]:[Path] C:\...
1
vote
2answers
56 views

Unable to add SXA components throwing application error in Sitecore 9.0.1 using sxa 1.7 [closed]

I am using Sitecore 9.0.1 and SXA version 1.7 .I have created many components and worked on but suddenly the experience editor is giving the popup saying an error occurred. I have not changed any ...
1
vote
0answers
34 views

Sitecore.core.mdf is not in a valid directory from Instance Manager

I'm trying to "Install Instance" via the Sitecore Instance manager. For reference the SQL Server Connection String goes to a remote sql server which I access through a vpn. I go through all ...
2
votes
6answers
2k views

Sitecore 9.3 Installation failing - 'Failed to start the Marketing Automation Engine service

I am trying to set up Sitecore 9.3 XP0 locally in a VM using SIA and it is failing at Step 67 of 92 with an error failed to start the marketing Automation Engine Service. System....
1
vote
0answers
85 views

Sitecore 10 update 1 using SIA Installation issue CX509PrivateKey::Create: Access is denied. 0x80070005 (WIN32: 5 ERROR_ACCESS_DENIED)

While installing with Sitecore 10 update 1 using SIA facing an issue as below [ IdentityServerCertificates_CreateR... : NewRootCertificate ------------------] CertEnroll::CX509PrivateKey::Create: ...
0
votes
1answer
479 views

ERROR: Exception when executing agent aggregation/aggregator( Execution Timeout Expired)

I'm getting Execution Timeout Expired I tried below with no chance : increase the time out on the connection string. Set ping enabled to false. Set the Ping Maximum Response Time (seconds) to a large ...
0
votes
1answer
47 views

problem trying to install sitecore commerce experience 9.0.2

I got the following error and search online looks like it's something to do with xconnect remoting? I have disabled the xconnect site and also the Go to C:\inetpub\wwwroot\fsni.sc\App_Config\Sitecore\...
4
votes
2answers
519 views

SItecore 10 docker build solution issue - Invoke-Expression

I am trying to follow sitecore 10 example in docker (https://containers.doc.sitecore.com/docs/build-solution) and as an out of box step worked correctly, I am having issue on step 6 with build ...
4
votes
1answer
547 views

What to do if I can't download packages from Sitecore?

I am a Sitecore certified developer but when I go to https://dev.sitecore.net/ and I am logged in I still cannot download the packages. What can I do in this case?
3
votes
2answers
636 views

Hard time installing Sitecore 10 external resources in Kubernetes AKS in Azure

I'm trying to install Sitecore 10 on AKS so I was following the steps in Installation_Guide_for_Production_Deployments_with_Kubernetes_XP10.0.0.pdf Installed azureCli & helm on my local pc az ...
1
vote
1answer
88 views

I've trying to install Sitecore, getting error: Missing source parameter

I am trying to install Sitecore 9 update 2 on Azure. I am getting this error: Package deployment failed ARM-MSDeploy Deploy Failed: 'Microsoft.Web.Deployment.DeploymentClientServerException: Missing ...
2
votes
2answers
292 views

Sitecore 10 walkthrough - Get-SitecoreCertificateAsBase64String failing on init.ps1

I've come across the below error when running the initialisation script of the Sitecore 10 with docker walkthrough with license and password as parameters. .\init.ps1 -InitEnv -LicenseXmlPath "C:\...
1
vote
2answers
236 views

Do you need to be a certified Sitecore developer to download installation files?

I am trying to migrate the site from 8.2 to 9. In order to upgrade the site, we require the migration files, which you can usually download from the Sitecore Downloads site. If the client has ...
0
votes
2answers
400 views

Sitecore 9.3.0 installation error. Sitecore.Xdb.Collection.Database.SqlShardingDeploymentTool.exe returned a non-zero exit code - (2)

When I try to install Sitecore 9.3.0 with Sitecore Install Assistant I got an error: [------------- XConnectXP0_CleanShards : Command -----------------------------] [ShardingTool - Clean]:[Path] C:\...
6
votes
1answer
494 views

Error in Identity Server when opening Sitecore 10

I have installed new Sitecore 10 instance without any trouble using SIA. When I tried to open sitecore interface via appending /sitecore to URL, I received this error when redirected to Identity ...
1
vote
0answers
49 views

Sitecore Items are not installed correctly with Sitecore TDS package Installer

Our application is on Sitecore 8.2 Update 7 with TDS 5.8 We install TDS packages using TDS Package Installer function doCustomContentManagementInstall() { param ( [string]$siteName, [string]$...
0
votes
0answers
187 views

Sitecore 901 installation issue - Could not find Cert: mysite.xconnect_client in Cert:\Localmachine\My

when I am trying to install Sitecore 9.0 update 1 in my local PC with the script provided in the installation guide I am getting this error. [---------------------------------------------------------...
1
vote
0answers
151 views

Failed to start marketing service in Sitecore 9.1.1 (Stopped Installation)

I am trying to install Sitecore 9.1 update 1 in my work machine and it always fails with the error "Failed to start marketing service". I have gone though many article and almost applied all the ...
1
vote
1answer
142 views

Cake.exe : Error: Unable to find package 'Cake.SitecoreDemo'

I'm trying to install "Sitecore.HabitatHome.Platform" which is using Sitecore v9.3. I'm following Viet Hoangs blog for the installation. I used the default site name and installation folder. ...
1
vote
0answers
135 views

Can not start xConnect Index Worker during Sc 9.3 XP0 local installation - FormatException

During the SC 9.3 installation (XP0 local) via SIF and SIA I receive this cannot-start-service error at the last third of the installation: [--------------------------- XConnectXP0_StartServices [1] :...
4
votes
3answers
550 views

Sitecore 9.3 installation change webroot location

I have installed Sitecore 9.3 and it created the files in C:\inetpub\wwwroot. I would like to change some of the default settings, like The webroot location to D: drive, The SiteRootName etc ....
1
vote
1answer
441 views

Add a new Sitecore 9 instance

I'm having a lot of trouble finding documentation for Sitecore 9 and setting everything up. I installed Sitecore 9 and have a working website, but how would I add another website instance? In 8, it ...
0
votes
1answer
171 views

Failed to start Marketing Automation service

I've an issue in installing Sitecore 9.2 in a machine where Sitecore is getting installed for the first time. On the middle of the installation, I'm getting Failed to start Marketing Automation ...
0
votes
1answer
69 views

Sitecore.Courier PowerShell Installation error

I'm trying to install the "Sitecore XP 9.3.0 and SXA 9.3.0 Demo – Habitat Home" by following the blog from Viet Hoang. https://buoctrenmay.com/2019/12/23/sitecore-xp-9-3-0-and-sxa-9-3-0-demo-habitat-...
1
vote
2answers
500 views

Packaging and installing media items not working - items are created but have no attached file

My content authors uploaded a ton of media items in our UAT environment. I'm trying to package these and install in prod, but the installation isn't working. I'm created a regular Sitecore package ...
1
vote
2answers
674 views

Sitecore Install Assistance - Installation error SC-v9.3 - Unable to parse [resolvepath(variable('IdentityServer_Package

I'm trying to install the Sitecore v9.3 with "Sitecore Install Assistance", however, I did get this error. Note: The "Sitecore.IdentityServer 4.0.0 rev. 00257 (OnPrem)_identityserver.scwdp.zip" file ...
1
vote
1answer
568 views

WebDeploy unable to deploy package

Web Deploy is unable to deploy package. I have all the prerequistes installed and have double checked that the Sitecore psgallary and Sitecore gallery are trusted repos and I am not sure why I am not ...