Questions tagged [installation]

For questions related to the installation of a Sitecore instance, package, or update package

Filter by
Sorted by
Tagged with
1
vote
2answers
342 views

Sitecore 9 - Cloning instances

In all previous versions of Sitecore 9, we could easily clone and export instances using SIM. Hence was wondering if there is such an option to do so for version 9 Initial Release or Update 1. Thanks....
1
vote
1answer
2k views

Could not create instance of type: Sitecore.Data.Database error while Installing a Sitecore module on CD server

I imagined this would be fairly simple given the lack in posts about it (anywhere really) but we're hitting a bit of a problem with this one. The module in question is URL Rewrite. It's installed ...
4
votes
1answer
1k views

XM topology for on-premises

What is the best practice for installing a XM only instance for dev locally? Should we just install XP0, and then disable xDB? There doesn't seem to be a XM single package, and when I try to install ...
6
votes
3answers
4k views

'sqlcmd' is not recognized at CreateShardApplicationDatabaseServerLoginSqlCmd step

I'm trying to install Sitecore 9 Update 1 XP0 topology and everything looks great until the step CreateShardApplicationDatabaseServerLoginSqlCmd The server I am running the installation was ...
1
vote
2answers
437 views

SqlShardingDeploymentTool causes Sitecore 9.0 update 1 installation to fail during SIF installation

I'm trying to setup a Sitecore 9.0 update 1 installation on my local machine using windows 10 Solr 6.6.2 SQL Server 2016 SP1 Sql Express 2017 SIF-less 0.6.0.0 Despite a couple of annoying hickups I ...
4
votes
0answers
577 views

Unhandled .net error while creating an item using insert from template

I have installed Sitecore 9 on Windows 8.1. While trying to create a new item from a template I am getting the error below An unhandled Microsoft .net Framework exception occurred in w3wp.exe [12500] ...
3
votes
2answers
708 views

Exception while executing the powershell script for Sitecore 9.0 installation XP0

I am trying to install Sitecore 9 XP0 as standalone instance on my Windows 8.1 machine. I have followed all the steps mentioned in the installation guide but in the final step I am getting a private ...
7
votes
1answer
5k views

Sitecore 9 Update 1 installation EXM Master DB Name

I'm trying to install Sitecore 9 Update 1 and i'm getting the following error i'm using the following script: #define parameters $prefix = "S9U1Demo" $PSScriptRoot = "C:\Resourcefiles" $...
14
votes
1answer
2k views

Any reason Sitecore 9.x data folder now defaults it's location to inside web root?

All previous installs to version 9 had a folder structure like this: /Data /Databases /Website Now in version 9.x the /Data directory is nested inside the /Website root. SIF default logic even has ...
1
vote
1answer
932 views

Unable to access Launchpad following Sitecore 8.2 Install [closed]

I'm trying to debug a 8.2 install. The databases have been deployed to Azure using the DACPAC files and the client installed using the EXE. I can see the vanilla website homepage and I can see the ...
9
votes
3answers
1k views

Is there any way to install Sitecore 9 without Solr?

We are planning to host the solution on Microsoft Azure PaaS, and using Azure Search instead of Solr. When we install Sitecore 9 on Azure PaaS, Solr is not required. Is there any way to configure ...
9
votes
1answer
231 views

Is there a list of external domains that Sitecore calls as part of normal operating?

I'm looking to get a complete list of the URLs that Sitecore calls during normal functionality of the base product. We have a client's IT group that needs to whitelist the outbound external calls to ...
4
votes
1answer
2k views

Error 500.19 installing Sitecore 9 XP0 on a clean Windows 10 machine

While installing Sitecore 9 XP0 on a new Windows 10 VM I came across the following error. HTTP Error 500.19 - Internal Server Error The requested page cannot be accessed because the related ...
10
votes
2answers
2k views

Is there a specific order to install Sitecore 9 XP1?

I'm installing Sitecore 9 XP1 and facing issues with my certificate for XConnect as you can see here That being said, I wonder if is there a specific order to install Sitecore 9 XP1 and that's the ...
3
votes
2answers
273 views

How to check if a hotfix is needed

I've got a customer who's said they need a hotfix (https://kb.sitecore.net/articles/574334). They're on 8.2 Update 3, but the notes for what download to get only goes through 8.1. So I don't know if ...
24
votes
12answers
19k views

You must have a user with the same password in master or target server

I'm installing the Sitecore 9 XP0 locally and struggling with the following problem: installation process fails with the following error: Unable to connect to master or target server '...
1
vote
0answers
643 views

Experience Editor not working properly in 8.2

We upgraded to 8.2 back in August and haven't had issues on the front or the back end for the most part. However we don't use the Experience Editor very much. Our client might but hasn't reported ...
7
votes
5answers
3k views

SIF installation process fails because it cannot start website

In the latest steps, SIF installation process fails because it tries to start the website, but it gets the error below: Invoke-ManageWebsiteTask : The process cannot access the file because it is ...
2
votes
1answer
545 views

Update installation slowness during deployment

We have an installation of Sitecore 8.1 (rev 160519). We have a rather laborious process presently of uploading TDS update packages (generated by our build process) using the Sitecore update ...
14
votes
3answers
6k views

Configuring SSL for Solr

So I'm working my way through the Sitecore 9 install instructions, and part of it is to install Solr with SSL. Since the install guide just refers you over to Solr, I've been following the ...
1
vote
1answer
233 views

Error after Sitecore Installation while accessing content editor

I have installed fresh Sitecore 8.2 rev 170614 instance on my machine. The installation is successful and when I login to Sitecore CMS, the launchpad opens, but when I am trying to access content ...
0
votes
4answers
2k views

Sitecore Habitat Installation issue

I tried to install Habitat and followed all the instructions mentioned at: https://github.com/Sitecore/Habitat/wiki/01-Getting-Started When I run the default task as mentioned in step 5 of wiki, I ...
0
votes
1answer
76 views

Deleting SitecoreDev.Web, as per the Professional Sitecore 8 Developer book, breaks Sitecore [closed]

I'm on the exercises in chapter 4 and am having issues with cleaning up the webroot. 18.Open File Explorer and navigate to your web root. In the Website folder, open the App_Config\Include folder. ...
10
votes
2answers
546 views

Can v7 and v8 coexist on the same server

Can I (and if so how) setup SC 7 and SC 8 on the same server? I do all my dev work in a VM and I need access to both at various times of the day. It would really make my life easier on my laptop if I ...
9
votes
1answer
318 views

Unable to install Commerce Server-- silent installation

I am trying to install Commerce Server in silent mode using this command: setup.exe /l %systemdrive%\install.log /ADDLOCAL ALL /PRODUCT CommerceServer /passive /norestart based on this MSDN link. ...
2
votes
1answer
4k views

Error message "Cannot bind parameter 'Uri'. Cannot convert value" when trying to install update package via PowerShell DSC

I am trying to install .update file with instructions provided by davis from previous post How to install zip file package from Installation Wizard using Powershell DSC? I am using another developer'...
2
votes
1answer
353 views

Getting "Could not access network location SC_SQL_SERVER_USER" while installing Sitecore using Powershell DSC

I am trying to install Sitecore using PowerShell DSC following below link https://jermdavis.wordpress.com/2015/11/09/development-environments-with-powershell-dsc-part-5/ I am getting "Could not ...
0
votes
2answers
77 views

Excel Transfer Utility installation issue

I tried to install "Excel Transfer Utility" package in Sitecore 8.1 instance but it's continuously spinning only and doesn't install. Does this utility is not compatible with Sitecore 8.1? https://...
0
votes
1answer
538 views

InvalidDeploymentException installing Sitecore SIM Tool

When I try to install the Sitecore SIM Tool on a Windows 10 VM, I get the following error when the ClickOnce application is download/installing: Activation of C:\Users[username]\Downloads\SIM.Tool....
1
vote
1answer
129 views

Sitecore Coveo Cloud on 8.1 Initial release with WFFM installed, locks up

Anyone have an issue installing Coveo for Sitecore (Cloud) module "82 4.0 (895).zip" on Sitecore 8.2 Initial Release with WFFM? Coveo said it is a known issue https://support.coveo.com/s/article/...
7
votes
1answer
1k views

Which IIS role services are required for Sitecore?

I'm working on a new Sitecore 8.1 dev/uat/production infrastructure. We would like to reduce our possible attack surface and have a hardened installation from the start. One of the Sitecore ...
1
vote
1answer
10k views

Strange "Could not load type" error in Global.asax

I am trying to install a Sitecore site on a QA server and I am getting a very strange error that I can't figure out. Basically what I did was first a clean install of Sitecore 8.1. I verified that ...
10
votes
3answers
1k views

What is the most efficient & fastest way to speed up the installation of packages with thousands of items?

We are soon going be pulling thousands of items from a PROD instance back into a QA Environment. These packages have thousands of items and take a VERY long time to install, sometimes even beyond 8 ...
1
vote
2answers
461 views

Sitecore Commerce Connect Module License Missing on Fresh Install

I've just installed a fresh Sitecore 8.1 Update-2 instance on my dev machine for a client and I'm getting the following warning on the Home item: Required license is missing. You require one of the ...
1
vote
1answer
751 views

Sitecore Not Finding Home Page [closed]

This might be an obvious answer. I am setting up an existing site (website link changed, but still should point to the same directory) and I get the following error on the URL notfound?item=%2f&...
2
votes
1answer
229 views

Error when trying to install Sitecore using SIM - "Service WAS was not found on computer"

I'm currently trying to install Sitecore 8.1 rev. 160519 using SIM Tool 1.4.0.92 rev 150618 and I'm getting this error message in the logs: > 1 12:48:04,739 ERROR Service WAS was not found on ...
9
votes
1answer
584 views

Server Role for SQL Server Account?

Connecting to SQL Server I currently have set the Server Role sysadmin on the account accessing SQL Server where I'm about to host Sitecore databases. My guess is that it's way to much privileges for ...
5
votes
1answer
612 views

Sitecore Rocks Package Installation Error - "Could not find configuration node: databases/database[@id='live']"

Getting this error when trying to install a package to my local Sitecore instance via Sitecore Rocks. I am not aware of a "live" database so I am not sure where this is coming from. I have checked the ...
6
votes
2answers
2k views

Package installation hangs on Sitecore 8.1

I've encountered an issue on Sitecore 8.1 when installing Sitecore PowerShell Extensions. The same issue is happening for other larger packages as well. This is a vanilla installation. No instance of ...
10
votes
2answers
383 views

Sitecore Instance Manager developer environment setup

I am looking for a way to keep all IIS settings, modules and Sitecore versions in sync across multiple developer environments in a team setting. Is there a way to use Sitecore Instance Manager (SIM), ...
10
votes
4answers
4k views

Installing package acting different between 2 environments

I've got 2 developer sandbox instances of Sitecore 8.2, and in one instance the package works fine. However, in the other one, I'm getting this error while trying to install a package: > ...
11
votes
3answers
7k views

An item name must satisfy the pattern: ^[\w\*\$][\w\s\-\$]*(\(\d{1,}\)){0,1}$ (controlled by the setting ItemNameValidation)

While installing a content package from my production environment (Sitecore 8.1) into my development environment (Sitecore 8.2), I'm seeing this error message in my Sitecore log: ManagedPoolThread #...
8
votes
2answers
2k views

An item name lenght should be less or equal to 100 while installing a content package

I've got a vanilla instance of Sitecore 8.2 installed on my sandbox and I'm getting this error (taken from the logs): Exception: Sitecore.Exceptions.InvalidItemNameException Message: An item name ...
10
votes
1answer
4k views

Is there anyway to find packages installed into Sitecore instance

In Sitecore, there is a facility to install Sitecore packages. Is there a way to view what packages are installed into our Sitecore instance and when they got installed ? Are there any modules ...
4
votes
1answer
428 views

Installing WFFM with SIM - post-install steps

When installing the WFFM module with SIM, does it perform the post-install steps for you, like running the SQL script against the reporting database or updating the web.config for the captcha controls?...

1 2 3
4