Questions tagged [links]

For questions related to links and link field-types within Sitecore, including rendering, setting, references, etc.

Filter by
Sorted by
Tagged with
1 vote
1 answer
156 views

Creating Internal Links in General Link Fields is Failing in Sitecore 8.2 Environments

We have a few templates in our project which use the General Link field type. We're finding them unpredictable. In our Staging environment, by clicking the Insert Link field to create a link to ...
0 votes
1 answer
190 views

Javascript link rendered without onclick attribute in preview

When using javascript link the edit mode renders the target script in onClick attribute <a href="#" onclick="javascript:void(0);onclick=javascript:openOverlay('test-overlay',event);...
2 votes
1 answer
35 views

Links table on multiple publishing targets out of sync

We have set up 2 publishing targets (web and web2). The web items tables are in sync with the same number of items and the items match when comparing. The problem is we are seeing the links tables ...
1 vote
2 answers
53 views

Urls in CanonicalUrl Rendering Showing Http Instead of Https

I'm hoping this is an easy one. The CanonicalUrl rendering in the Metadata Partial design isn't honoring our https settings for the website. Instead, it always shows http in the canonical link for ...
2 votes
3 answers
624 views

Calling ItemUrlBuilder method in Sitecore 10.1

We have upgraded to Sitecore 10.1 from Sitecore 8.7. In Sitecore 8.7 We used MultisiteItemLinkProvider which derives from LinkProvider and its obsolete in Sitecore 10.1. In Sitecore 8.7 we use the ...
1 vote
2 answers
800 views

How Does One Create a Download Link to Media Library Content in Rich Text Editor

A page on the site contains rich text, part of which is a series of links to PDF documents the user can download. Clicking on these, however, results in a 404 error. I've tried several RTE editing ...
1 vote
1 answer
402 views

How do I force the Sitecore FieldRenderer or Glass.Mapper, when rendering rich text fields, to always render absolute urls for my API?

I have an API in Sitecore that takes content from Sitecore and provides it to an external non-Sitecore site. While retrieving content, the API renders a rich text field using a glass mapper. This rich ...
0 votes
1 answer
141 views

Issue with links for a SXA Multisite when a site definition has multiple hostnames

I've got this odd issue with our Sitecore 10.2 with SXA implementation. I have a site definition that has multiple host names associated with it. On occasion, the links on the site will include the ...
0 votes
0 answers
46 views

Duplicate related items in Links under Navigate after Sitecore upgrade to 10.2

Upgraded an application on Sitecore XM from version 9 to 10.2.1. I installed Sitecore CM\CD via SIF and performed the clean-up of databases as per the SC-XP-10.2.0-Upgrade-Guide-en under section 3.1.3....
1 vote
3 answers
163 views

How can I check all internal link target values from the entire content tree using Sitecore PowerShell?

Im writing a powershell script which at the moment is checking an item ID, and if it contains an internal link that is set to anything other then "Active Browser" it will change the Target ...
0 votes
0 answers
53 views

Error message in EXM when using the external image hosting link

I have created an Email campaign via Sitecore, and in my HTML code for the E-mail I used an external link for the image (from the media hosting). When I wanted to send it out via list delivery, I got ...
3 votes
1 answer
116 views

How to add new target to Internal Link in Sitecore Experience Editor

We are required to bring a custom target attribute in sitecore general link field called “Preview” <a href=”xxx” target=”preview”>XXX</a> We added a new item in Sitecore Core Database ...
0 votes
1 answer
70 views

How do I add an external URL to my site's navigation menu?

I am new to Sitecore and I am trying to figure out how to add an external URL link to the site's navigation menu. The URL in question is supposed to link to the business's YouTube channel. I've ...
1 vote
2 answers
965 views

How to update the link field properties in Sitecore Powershell Extensions?

I want to write a script to bulk update the link field title and text for all the components of a particular type to Read more but I struggle with figuring out how to update these properties. Here is ...
1 vote
1 answer
660 views

How to set link field href attribute to "#"

Using a general link field, I want to be able to author the field such that the final contents of an outputted link are: <a href="#">Anchor Text</> (notice the empty anchor "...
0 votes
1 answer
56 views

How to set the 'Link Description' value from CMS

I am using a Link component and I want to make the 'Link Description' field a dynamic value. Is there a way to set the 'Link Description' value from the CMS side?
0 votes
1 answer
268 views

Custom link target in sxa

I was trying to insert an external link . In link target there was an option in target is custom. What does it mean?
3 votes
0 answers
211 views

How do you disable rel='noreferrer' for external links?

Our ProtectExternalLinksWithBlankTarget is set to true so all our external links have the rel='noopener noreferrer' attribute, but we need to be able to allow some external links to be recognized as ...
1 vote
1 answer
392 views

How to cache bust CSS and JS assets in Sitecore Helix

I want to be able to loop through my views, particularly my main layout and apply a query string cache buster to our CSS and JS calls as follows: <link rel="stylesheet" href="/assets/css/style.css?...
1 vote
1 answer
780 views

Redirect url with Trailing slash in the end of every url

I have a requirement where I need to redirect every URL and add trailing / in the end. Example : www.site1.com/abc should redirect to www.site1.com/abc/. Forward slash "/" should be added to ...
1 vote
2 answers
303 views

Link Database - rebuild specific items instead of whole database

Anyone know if there is a way to rebuild specific items in link database through a custom script targeting specific items to rebuild links to? OOB Sitecore only supports rebuilding the whole link ...
1 vote
1 answer
289 views

How can I get link fields content copied to another language version using Sitecore PowerShell Module?

when I create new language version item of content using: Add-ItemLanguage -Item $imageItem -Language $baseLang -TargetLanguage $targetLang -IfExist OverwriteLatest content page link field ...
0 votes
1 answer
474 views

Sitecore 9 CMS - Add an Image to a Link in the Footer

A client is using Sitecore 9 - we are not Sitecore developers. We've been asked a simple thing: add social media links to the Footer of their Sitecore site. Its proving more difficult than expected. I'...
1 vote
1 answer
114 views

Remapping links to a new page

We're wanting to replace an existing item/page in the content tree with another that uses a new template design but will have the same item name (there's a reason we can't use the template change ...
1 vote
1 answer
2k views

Append query string to url

I have a page lets say Page1. Page1 will have a button called GoToPage2. In the GoToPage2 button, I need to read the querystring and append its value to the url For example: The GoToPage2 link is /...
2 votes
1 answer
1k views

How to get URLS added in the Rich Text field and Link Manager Fields?

I want to redirect my urls added in the Rich Text Editor,General Links to custom urls on page load. To get the URLS which exist in the General Link field and in the Rich Text Editor, I am using the ...
1 vote
1 answer
256 views

Is there a way to automatically include link querystrings when dynamically rendering Sitecore links?

I have a number of places in my code where I render links from templates like so: <a href="@(Model.Link == null ? string.Empty : Model.Link.Url)">@Model.Link.Text</a> However I'...
2 votes
1 answer
1k views

Render a link field that has a url with query params as a query param (version 7.2)

I'm trying to render a link like the following as an external link - however it's cutting off part of the query parameter. So when I try to render this: https://www.example.com?url=http://www....
1 vote
1 answer
100 views

Save multi values to image library with link reference

My question might be a little complex, but I appreciate any help: I am using SitecoreFieldSuite by Velir, in my Sitecore 8 solution. Officially, SitecoreFieldSuite isn't supported in Sitecore 8, but ...
1 vote
1 answer
291 views

Enforce Site-Wide Alternate Text Validation On General Link Fields

I am working on Sitecore version 9.1. When attempting to insert a link using the general link field, the user is prompted to enter the following information: In an effort to enforce accessibility on ...
0 votes
1 answer
219 views

Update Sitecore rendered links for a specific page

We are using Sitecore 9.0.2 & SXA 1.7.1 and we need to update all links to be absolute only in a specific page as by default all the links are relative for example this is the default link <a ...
5 votes
1 answer
405 views

Hostname not resolving

I have issues with Sitecore Azure PaaS from Sitecore Managed Cloud as below. We have red-shield which is security shielding for request where we have configured prod domain which is like prd.xyz.com ...
0 votes
0 answers
534 views

Insert Media link not working

I have an item that has two language versions - en & jp For a General Link field in this item, I have used insert media link for both en & jp, & pointed to a pdf file in the media library....
1 vote
1 answer
340 views

Sitecore item API for shell site not returning the content

When I click on the "insert link" of the general link field, then the complete tree is not opened (as shown in the screenshot below), due to which I am not able to select the item. When I checked the ...
0 votes
2 answers
2k views

Richtextbox (RTE) link.aspx custom link provider/pipeline

so far I understand the richtextbox, when I insert a Internal sitecore link a href is created with link.aspx?_id=siteguid which is replaced in preview or published mode with the right url. <a href=...
6 votes
2 answers
1k views

How to deep link into Experience Editor so that user is redirected after login?

We have a case where we need to notify approvers when a page is sent for approval. In the notification email, I want to include a link so that the approvers can go directly to the page in the ...
2 votes
1 answer
38 views

Additional links next to Field name?

I am new to develop using Sitecore and have a question I saw in some tutorial website there are addition links next to the field name, like [Go to field] [Reset Field] [Go to datasource] Is this ...
0 votes
2 answers
4k views

Retrieving url from general link field in rendering parameter

I'm trying to grab the id and/or url attribute of a general link rendering parameter in the view, but I can't seem to make it work. I can't cast it to a Linkfield (it says it can't cast a string to a ...
3 votes
1 answer
3k views

retrieving the url from a link field in a view

I'm trying to retrieve just the url attribute of a link field for an item in a view. The view is just using the item as it's model so just retrieving the link field value, which is producing the ...
0 votes
2 answers
2k views

How to insert an internal path in Sitecore General Link field?

I have a template which contains a General Link field. If a new item is created of that template, then the link field should be populated with the item's current path. Suppose, template A have a ...
0 votes
1 answer
75 views

Cache of links - error

I have a strange problem with links. On the website I have many components added (one have one link and the other many links). In Experience Editor everything works correctly in Edit mode. After ...
1 vote
1 answer
773 views

Is there a way to use the Sitecore MVC Field helpers and render a General Link with stuff appended to the query string?

I have an item with a General Link field named "MyLinkField". In my view I have the following: @Sitecore.Html().Field("MyLinkField") That works great to output the link. Now I have added a ...
1 vote
1 answer
311 views

Droplink value is always returning null in post action

I am trying to build a form which contains state as droplink and given datasource as states . here's the snippets of my employee model and state. i am getting all the states in the get action of ...
0 votes
0 answers
240 views

Insert javascript to link not working as expected [duplicate]

Using insert javascript on link field, adds javascript code to a tag in href with return false which is added automatically and because of it mistake appears and if manually delete return false ...
1 vote
1 answer
1k views

Equals sign (=) added after valueless query string parameters

When rendering an external link from a General Link field using the Glass Mapper BeginRenderLink helper, any query string parameters without values are getting an equals sign (=) added after them. An ...
5 votes
2 answers
4k views

Sitecore multisite cross links not resolved with proper hostname

I've multisite solution setup, and sites config looks like below: <sites> <site name="localhost" hostName="local.com" scheme="http" notFoundItem="not-found" enableTracking="true" ...
2 votes
1 answer
530 views

How to configure sitecore rich text editor not to replace url to relative.

I have strange behavior at Rich Text editor (I heard that everyone had it), when user add some Absolute url for example, https://www.example.com/mypage/someextra, after save Sitecore replace it to ...
1 vote
0 answers
1k views

Download Sitecore Media file from UI

In our application we have an excel (xlsx/xls) file in medial library. We are trying to create a functionality to be able to download this excel using an html anchor or button. But when we click on ...
5 votes
1 answer
995 views

How can I append HTML within and before the text of a rendered Link Field?

I have a General Link field in Sitecore that I would like to append some HTML to. I know that I can create a custom extension method and put what I want after the link's text by doing the following: ...
1 vote
1 answer
770 views

How to change name of external link when viewing in its rendering variant?

I'm using Sitecore 9 and SXA 1.7. I have a template with a "General link with search" field, and I created several items of that template where I need to "insert external link", after that I set the ...