Questions tagged [links]

For questions related to links and link field-types within Sitecore, including rendering, setting, references, etc.

18 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3 votes
0 answers
2k views

How to set default language for the website

We have a website with two languages - en & jp. When the URL mysite.com is browsed, it should load jp content. Just like browsing mysite.com/jp, but the URL should be mysite.com The Site ...
sukesh's user avatar
  • 3,129
2 votes
1 answer
35 views

Links table on multiple publishing targets out of sync

We have set up 2 publishing targets (web and web2). The web items tables are in sync with the same number of items and the items match when comparing. The problem is we are seeing the links tables ...
Richard Banks's user avatar
2 votes
3 answers
624 views

Calling ItemUrlBuilder method in Sitecore 10.1

We have upgraded to Sitecore 10.1 from Sitecore 8.7. In Sitecore 8.7 We used MultisiteItemLinkProvider which derives from LinkProvider and its obsolete in Sitecore 10.1. In Sitecore 8.7 we use the ...
Owais Ahmed's user avatar
2 votes
0 answers
210 views

How do you disable rel='noreferrer' for external links?

Our ProtectExternalLinksWithBlankTarget is set to true so all our external links have the rel='noopener noreferrer' attribute, but we need to be able to allow some external links to be recognized as ...
221BakerSt's user avatar
2 votes
0 answers
102 views

How can I place internal links into WFFM

How can I insert internal links into these WFFM places: WFFM Introduction and Footer text Text of a checkbox field I would like to give the chance to the content editor to edit these links with the ...
Imre Németh's user avatar
2 votes
0 answers
574 views

Link 'title' attribute not mapping correctly in Glass Mapper

I am using Glass.Mapper.Sc 4.3.4.197 and for some reason the "title" attribute ("Alternative Text" property of the link field in Sitecore; Link.Title property in Glass.Mapper) appears to not be ...
Zachary Kniebel's user avatar
2 votes
0 answers
2k views

Make RTE output media item links with a path instead of ID

In Sitecore 8.1, I would like to align the download links to media items (files), as links can be outputted in two different ways for the same item: Links with an ID my.site.com/_/media/...
ChristianH's user avatar
2 votes
0 answers
836 views

General Link - Raw Value inside but not editable in Field

I have a general link field where the value is still inside when I look at the raw value but the field seems to be empty and has to be cleared before it is editable again. How do I fix that and what ...
Kodachi's user avatar
  • 193
1 vote
1 answer
156 views

Creating Internal Links in General Link Fields is Failing in Sitecore 8.2 Environments

We have a few templates in our project which use the General Link field type. We're finding them unpredictable. In our Staging environment, by clicking the Insert Link field to create a link to ...
Ron Ritchie's user avatar
1 vote
1 answer
402 views

How do I force the Sitecore FieldRenderer or Glass.Mapper, when rendering rich text fields, to always render absolute urls for my API?

I have an API in Sitecore that takes content from Sitecore and provides it to an external non-Sitecore site. While retrieving content, the API renders a rich text field using a glass mapper. This rich ...
TxRegex's user avatar
  • 141
1 vote
2 answers
798 views

How Does One Create a Download Link to Media Library Content in Rich Text Editor

A page on the site contains rich text, part of which is a series of links to PDF documents the user can download. Clicking on these, however, results in a 404 error. I've tried several RTE editing ...
Ron Ritchie's user avatar
1 vote
0 answers
1k views

Download Sitecore Media file from UI

In our application we have an excel (xlsx/xls) file in medial library. We are trying to create a functionality to be able to download this excel using an html anchor or button. But when we click on ...
Praveen K Dubey's user avatar
0 votes
0 answers
46 views

Duplicate related items in Links under Navigate after Sitecore upgrade to 10.2

Upgraded an application on Sitecore XM from version 9 to 10.2.1. I installed Sitecore CM\CD via SIF and performed the clean-up of databases as per the SC-XP-10.2.0-Upgrade-Guide-en under section 3.1.3....
Siddhi Kamat's user avatar
0 votes
0 answers
53 views

Error message in EXM when using the external image hosting link

I have created an Email campaign via Sitecore, and in my HTML code for the E-mail I used an external link for the image (from the media hosting). When I wanted to send it out via list delivery, I got ...
Lizaveta Andryukhina's user avatar
0 votes
1 answer
141 views

Issue with links for a SXA Multisite when a site definition has multiple hostnames

I've got this odd issue with our Sitecore 10.2 with SXA implementation. I have a site definition that has multiple host names associated with it. On occasion, the links on the site will include the ...
soze's user avatar
  • 93
0 votes
1 answer
190 views

Javascript link rendered without onclick attribute in preview

When using javascript link the edit mode renders the target script in onClick attribute <a href="#" onclick="javascript:void(0);onclick=javascript:openOverlay('test-overlay',event);...
nari447's user avatar
  • 407
0 votes
0 answers
534 views

Insert Media link not working

I have an item that has two language versions - en & jp For a General Link field in this item, I have used insert media link for both en & jp, & pointed to a pdf file in the media library....
sukesh's user avatar
  • 3,129
0 votes
1 answer
75 views

Cache of links - error

I have a strange problem with links. On the website I have many components added (one have one link and the other many links). In Experience Editor everything works correctly in Edit mode. After ...
Jan Nowak's user avatar
  • 311